Editing twonkyvision-mediaserver.ini

Discussion in 'Cisco/Linksys Network Storage Devices' started by lingenfr, Dec 26, 2010.

  1. lingenfr

    lingenfr Networkin' Nut Member

    I am trying to enable web access. However, when I ssh in with either terminal or a graphical terminal, vi produces uneditable garbage. If I more the file it is readable, but not to vi. I don't use vi often. Am I missing a necessary command-line option? Thanks.
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    That file is in Unicode if I recall correctly. Try copying it to an area that's accessible over the network and then using an editor hat understands Unicode like Notepad++ to edit it.

  3. lingenfr

    lingenfr Networkin' Nut Member

    This is pretty ridiculous. Not sure why anyone would mess with Twonky based on this experience. Linux SCP GUI apps don't really exist. I tried everything in the ubuntu repository. I finally downloaded WinSCP and ran it under wine and it worked fine. I copied the twonkyvision-mediaserver.ini to my PC and tried a wide variety of editors. The file says it is UTF-16. Only a very few editors claim to be able to edit UTF-16. yudit under linux looked promising, but it still gave me garbage. I tried Notepad++ and it did not work. If you review their website, they tell you it doesn't work. I went to windows and tried SuperEdi and it also gave me garbage. Having spent several hours simply trying to edit a text file, I am done with twonky. I really don't get it. I assume that they put Twonky on the NAS200 for UPnP since they have hobbled the other functions such that it would discourage me from EVER using it. I am not sure why it would be worth upgrading. I'm sure I am missing the point.
  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I'm working on a package to update the Twonky server in an easier way, as we speak. Hang in there!
  5. lingenfr

    lingenfr Networkin' Nut Member

    Thanks Jac. As part of that, it would be most helpful if you would enable web in the twonkyvision-mediaserver.ini file. I can't see why anyone who would enable twonky wouldn't want web access to be available (whether they use it or not). Also, contacted the twits at twonky, here is how that went:

    Your request (#3130) has been updated.

    Ekta, Dec-26 22:13 (PST):

    Our apologies but the NAS builds are provided "as is" for advanced users who wish to install them at their own risk. We do not provide technical support for INSTALLATION and CONFIGURATION of these versions.


    Lingenfr, Dec-26 18:02 (PST):
    Customer Name: Rusty Lingenfelter

    I have the Linksys NAS200. I would like to enable the Twonky web interface. Unfortunately, the twonkyvision-mediaserver.ini has some type of unusual unicode format. While it says UTF-16, I have tried several UTF-16 formats with no luck. How can one edit that file? Thanks.
  6. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    It looks like I have Twonky 6.0.28 running with web server and everything, but only if I use my own INI file instead of the one that the NAS200 software generates. I agree, if the web service is not enabled it will be a show stopper so I'm working on getting that problem sorted out.

    Meanwhile if you want to do your own editing here's an easy way: just edit the file /etc/media.conf and then enable the media server from the web gui. When you switch the media server on, the web server apparently converts the (ASCII) file /etc/media.conf to (Unicode/UTF16) file /etc/twonkyvision-mediaserver.ini.

    I'm not sure yet how the Linksys/Sercomm software makes the media server files survive a reboot; I think both files probably get regenerated on startup. I'll figure it out.

    If you want to try and play around with Twonky 6.0.28 yourself, here's a quick hacking hint:
    1. The file you need to download is here
    2. You will also need the following files from a Linux distro that's compiled for i386 (not x64 or i686): ld-linux.so.2 libbz2.so.1 libc.so.1 libpthread.so.0 libstdc++.so.6
    3. The twonkymedia.sh file won't run because the NAS uses Busybox. You can read it for inspiration though. The version of this file that's started by the web server is in the /etc/rc.d directory. It has a bit of code that I wrote to look for an updated version under .../rc.d/twonky* but apparently it doesn't work if you run a RAID configuration unless you change /etc/scriptdirs.txt.
    4. The magic command to run any stubborn executable that requires new libraries is /path/to/ld-linux.so.2 --library-path /path/to/updated/lib /path/to/stubborn/exe --parameters --for --stubborn --exe
    5. The program that you will want to start is twonkymedia (not twonkymediaserver). If you rename twonkymedia to something else e.g. because you're putting a script in its place, you must rename twonkymediaserver too: apparently twonkymedia starts twonkymediaserver by adding the word "server" to its own name. For example I renamed twonkymedia to org.twonkymedia and wrote a script called twonkymedia, so I had to rename twonkymediaserver to org.twonkymediaserver too.

    If you can find a way to make it show the configuration page (not the famous Red Page or a 401 Access Denied error) before I do, let me know :cool:

  7. lingenfr

    lingenfr Networkin' Nut Member

    Jac, your suggestion on editing /etc/media.conf worked. However, I still can't bring up a webpage. What is the default address for Twonky? I've tried everything I could find on the web.
  8. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The default port is 9000.

  9. lingenfr

    lingenfr Networkin' Nut Member

    Yes, I tried 9000, ie but no joy. I tried 9050 and a couple of combinations up folders.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice