EFG80 - unable to access the Web Interface

Discussion in 'Cisco/Linksys Network Storage Devices' started by wency, Aug 29, 2007.

  1. wency

    wency Network Guru Member

    Hello guys, i decided to put this thread here because EFG80 ans NSLU2 are very similar devices. Hope it is not a problem.
    What happened with my EFG80:

    It worked just fine for about 4 years from now without any problems.
    But 3 days ago it stopped to allow me to access the web interface. All other stuff is working - samba, ftp and so on. All my data is here on the disks untouched. But when i try to access the web-based interface i end up with a blank page (tried with IE/FF/Safari/Lynx/Links and from many computers). I tried to reset the device and now it is back to the original IP address. One strange thing is that when i try to ping the device - it responds with TTL of 255.

    The Linksys setup utility is unable to to find the device.
    I contacted Linksys support and they advised me to use the EraseAll utility to reflash the firmware (it is for EFG120). But this tool is also unable to find the device. The same results with the Update Utility for NSLU2. Even both tools are unable to recognize the BIN file with the firmware.

    Then i extracted the CF card from the device and put it into a standard computer with the CF->IDE adapter. It booted successfully and i was able to see that thttpd also started successfully. The port scan of the device shows that port 80 is open, but the web interface is still unavailable. I reached the login prompt but i do not know (and also Linksys support) the root password.

    Finally, i decided to recompile the firmware using the GPL code from Linksys.
    Within the zip file there are instructions for how to do that.
    Well - these instructions and the code are prepared for RedHat 7.1 or 7.2 and i tried using RH9, Fedora 1, 4, 6 and 7, CentOS 5.0, Debian with different results.

    It seems to me that RH9 (2.4.20) is the most close choice, but even then the compile process ends with error like that showed in the attached image.

    And now i give up waiting for your opinion.
    Any ideas how to re-flash my EFG80?
    Thanks in advance.

    Attached Files:

    • rh9.jpg
      File size:
      48.8 KB
  2. wency

    wency Network Guru Member

    SOLVED: Inaccessible Web Interface, EFG80

    Well friends.
    Finally, i solved the problem.
    It seems to me that there were a compiler-related issues when trying to compile under the distros i mentioned in my original post.

    When i left without any other choice - i installed Red Hat 7.2 (under VmWare) and the compilation procedure went without any errors.

    Then i burned the ISO image, started the machine and installed the firmware back on the CF card.

    Now my EFG80 is back in business.

    If you need the ISO image, you can download it directly from here:

    Hope this will help someone.

  3. finjohansson

    finjohansson LI Guru Member


    i am an idiot when it comes to this stuff, can you explain to me what it is that you said in your posts. my EFG80 also died. you said you took the flash card out of your EFG80 and was able to boot from it in your PC? also, how do i install the stuff on the ISO to the flash card? i am at a loss here. thanks.

  4. finjohansson

    finjohansson LI Guru Member

    OK, i downloaded the stinking ISO image and booted to it as Wency suggested. thanks for that ISO by the way.

    now just for fun i have booted the PC from the CF card and have made it to a console login. does anybody happen to know what the default login and password are? i would really like to poke around in there to see whats what.

    i have found nothing searching google about default passwords or logins for this device. neither for the console or for the web admin.

    Wency, maybe durring your compiling of the OS you noticed something where the default username and password went by? maybe?

    i wonder if the OS is upgradeable to another version, such as redhat 8 or suse or another distro? it seems if the CF card was big enough and the base system were included, the rest of the OS could be modded to do other things as well? i would guess that the processor power of these things is probably LOW so modding it to do things should likely be kept to a minimum, but still i would like to poke around in there a bit.

    any info on this area would be greately appreciated.


  5. Toxic

    Toxic Administrator Staff Member

    I dont think there is a default pwd on the drive, you add a username/password to the device using the Instant GigaDrive utility. check the user manual. have you used the eraseall utility?
  6. Niwla

    Niwla LI Guru Member

    My problems with my EFG120 are identical to your problems. I have also read a lot about the eraseall-utility. For now I am looking for this tool. Can't find it anywhere on the linksys-website. Can anybody here provide me (direction to) the file ?

    Is it hard to use the eraseall-utility and upgrade/downgrade the firmware ?

    Edit: Found the tool and a small tutorial here :biggrin:
  7. Same problem here with my efg80. I removed the flashcard, downloaded the GPL-package and then I'm lost: I put the 'boot' - files (similar files as on the flashcard) on the flashcard but no effect.

    Is there something that needs to be compiled or is there a standard package wich can be copied to the flashcard of my efg80?
  8. Niwla

    Niwla LI Guru Member

    Damn, how could I have missed this topic. I even replied in this one :eek:

    At the moment my efg120 is bricked because of a failed flash when my webserver was corrupt for a second time. Perhaps all the things you have told and the ISO can bring my NAS back to business :biggrin:
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice