Endless Loop - can't get firmware upgrade into WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by mset, Feb 25, 2006.

  1. mset

    mset Network Guru Member

    I am editing the first post because this thread has become a tech assistance thread. Please scroll down to see my questions regarding getting my 'new' (used) WRt54G V 1.0 up and running. DIAG is blinking, so I must upgrade formware. I can't connect to the net through the router. Downloaded the upgrade but can't get it 'into' the router - all procedured for upgrading the router seem to involve connecting to the net through it!!

    See below, please. Any help is appreciated. As you will see, I have been trying on my own, not just asking someone to solve my problem for me, and I am not a computer guy at all.

    Please scroll down to the 10th post in this thread, it's where the trouble starts.
  2. mset

    mset Network Guru Member

    Re: WRT54G Version 1.0 - link to a n00b tutorial?

    Just found the users manual on the Linksys site and it will take me a while to digest it. It says the unit has 'NAT technology to protect against Internet intruders' but I will have to figure out if that means a firewall.

    I had a private correspondence with a member here who mentioned that I should not use third-party firmware, although he didn't elaborate as to why. Any comment from anyone else? Is this because he knows I'm a n00b?

    Also, I saw at the website that drivers are not available for this unit - the 'drivers' option is 'greyed out'. Is that a problem for me? I guess it may be!!

  3. RcNorth

    RcNorth Network Guru Member

    I would also suggest that you don't try a 3rd party firmware. At least not yet. If you flash the firmware incorrectly you could end up "bricking" your router and making it basically useless. There are ways to de-brick it, but those involve opening the case and shorting the main board. Do lots of reading first especially read about the problems that others have had in flashing the firmware and what steps they say you should take so that the same problem doesn't happen to you.

    When I first found out that the Wrt65g could be flashed with a different firmware, I read up on it for close to 7-10 months before I decided that it was something that I wanted to try. I'll be buying a 2nd router soon so that I have one to play with, without risking taking down the wife's wireless access. Seeing what the router can do has turned into a hobby for me, and has little to do with finding a new feature that I need to have on my home network with only 3 computers.

    There are a lot of different firmwares available for your router (which is the same one that I have). It is difficult to recommend which version you should run until you know what you want to do with it. Each of the major firmwares have a section to themselves in this forum. In those sections you will find links to the firmware's home page and other useful links.

    At this point I would start by reading the various messages on this board to see what others are doing with their equipment and determine if you need that feature or not. It will require some research. Especially when you find terms that you haven't heard before like bridging, QoS, VPN, etc.

    A good link to start is the firmware comparison. This will tell you most of the features that the router can do.

    The modding forum talks about what hardware mods you can make to the router such as adding SD card readers, LCD screens, com ports etc.

    other links

    Basically though, the router is capable of just about anything that a Linux PC can do. Including running as a web Server, and FTP server, a VOIP server, firewall etc.

    Hope this helps you getting started.
  4. mset

    mset Network Guru Member

    Hi Rc

    That was very helpful, thanks, and I will definitely avoid flashing this thing until I know what I am doing. I don't want to 'brick' it.

    I appreciated what you wrote above in the quoted section. Sometimes when I ask for tech help, pros can forget that we don't automatically know what some of this stuff means. I love learning about it. I have read up on the basic steps for getting the router hooked up and connected to the Internet. My ISP tells me I am connecting through a dynamic IP address. I am going to try to get the unit up and running.

    One thing I am wondering about is the whole driver thing but I guess I will find out soon enough. You haven't said that this older version 1.0 router is obsolete or useless so that is a good thing. Seeing the option to download drivers 'greyed out' at the website was a bit unsettling.

    I will check out the links you provided later tonight.

    btw... I grew up in Grande Prairie - nice to see a helpful Calgarian on these boards :)
  5. mset

    mset Network Guru Member

    btw... on this site, the pages are 'too wide' - the reply boxes run off the right edge of the screen and a scroll bar appears at the bottom of the screen; I have to scroll left to right in order to read the posts. I haven't experienced this on any of the other forums I have signed up at to get help with my n00b build. I have tried to play with the setting available under the 'View' drop down menu on my browser (Firefox) but I can't get the page to display 'normally'. Any ideas?
  6. RcNorth

    RcNorth Network Guru Member

    I'm experencing the same problem using Firefox. How did you create the first post? Was it possible that you pasted the text in from notepad or something similar?

    Maybe try to edit the first post to see if there are extra characters or something like that in the post.

    I had a summer job in GP when I was going to school. It was a nice place then, but haven't been back in a long time.

    Where are you located now?
  7. RcNorth

    RcNorth Network Guru Member

    In my opinion you definately want to use the router over zone alarm. Since zone alarm is a program running on your computer it is going to be taking up resources that could be used by other apps that you want to run.

    Also, I've never liked software firewalls, since the app, code, etc. that you are trying to stop from getting to your computer is already in your computer in order for Zone Alarm to stop it. I much prefer stopping things as soon as possible, and the first line of defense is the router.
  8. mset

    mset Network Guru Member

    Hi Rc

    Yes, this is one of the big reasons I wanted one of these - I had heard a lot of people referring to 'hardware based firewall'.

    Unfortunately... I tried to hook the unit up but no go. Solid lights on the Internet light but DIAG light is flashing, can't connect via the router. The Linksys Easy Connect Help Wizard at the site strangely tells me that I need Win XP to run it - I run Win 2000 Pro.


    The manual says that if the DIAG light keeps blinking, I need to flash the unit with the latest firmware. Problem is... how do I flash it if I can't get it to connect to the internet??

    I tried resetting the unit, both powered up and powered down, but that didn't seem to help.

    Anyway, the answer is either here or in the manual or on the net somewhere, just have to find it. This is how we learn, right? :)
  9. mset

    mset Network Guru Member

  10. mset

    mset Network Guru Member

    Well... almost

    I followed the long explanation by toxic about how to solve the flashing DIAG light. I downloaded the firmware upgrade in ZIP format, then configured my computer and did the command prompt test to see if my compter saw the router. All fine, although the ping times were more like 500ms and not <10 as toxic said they should be. Then the last line in this long tutorial is this

    6. You may now proceed to upgrade the router’s firmware with the files that were downloaded.

    Ummm... ok, but how do I do that?? There is an other explanation by toxic in a sticky that says how to do this, but it involves processes with which I am unfamiliar, so I decide to check the Read Me that came with the .bin file that is the firmware upgrade. Aha!!It says this, which sounds pretty straight ahead.
    1) Before you start, be sure you are using a PC that is connected to the WRT54G
    via a wired (Ethernet) connection.
    2) Open your web browser (e.g., Internet Explorer, Netscape, etc.)
    3) In the Address bar, type in the IP address of your router. The default IP
    address is
    4) Leave the username blank and enter your password. The default password is "admin",
    all lower case.
    5) Click on the Administration tab.
    6) Click on Firmware Upgrade.
    7) Browse for the firmware file that you have just extracted. The file name should end
    in .bin
    8) Click the Upgrade button.
    9) The router will begin its upgrade routine. Do not power off or unplug the router until
    the process is completed. This process may take up to 5 minutes to complete.


    Ok.. now, am I supposed to enter this IP address into my browser while connected to the internet? Because if I am, the same problem still exists!! I can't connect to the internet and have my computer connected to the router at the same time, because obviously the ethernet cable from my computer has to run to the router and right now I need to run the ethernet cable from my computrer into a modem to connect.

    And anyway, I tried entering that into a browser window while connected to the internet and while the router was connected to my ethernet port on my computer (remember, I cannot do these two things at the same time yet!!!) 0 and I got nothing. I can't get a browser to react to either or just

    in order to get the firmware upgrade process to start.

    Any help is appreciated - I feel like I am so close here.
  11. mset

    mset Network Guru Member


    So I decided to try the tftp route outlined by toxic


    But again - all of these solutions assume that I can connect to the internet through the router!! But the whole point of the whole thing is that I am trying to get the blinking DIAG light to go away by updating the firmware so that I can get the router connected to the internet!

    Even this tftp system needs a connection to the net, for some reason. I don't get it because in the instructions it says the tftp program must be directed to the 'folder where the firmware upgrade was stored on your computer'. What is there to log into. The upgrade is sitting on my computer. My computer can see the router when I plug directly from the ethernet out of my computer to the #1 input port of the router. What more is necessary? Why do I need to be connected to the internet for this??

    I cannot connect my computer to the internet and simultaneously connect the computer to the router, because there is only one ethernet port on my computer.
  12. mset

    mset Network Guru Member

  13. howardp6

    howardp6 Network Guru Member

    I have a WRT54G V1.0 and I am using firmware version 4.20.7. If you are using the tftp technique, you have to do a manual reseof the router to factory defaults by pressing the reset button for at least thirty seconds. If you are using the tftp you ahte going to have to get one of the older versions, since the tftp approach requires you to use one of the smaller versions of the firmware. I believe it has to be less than 3.0MB. If it is a zip version you have to unzip it. You only have about thirty seconds to power cycle your router and start the tftp process. You have to be connected by a wired connection and the router has to be pingable at the default address of
  14. mset

    mset Network Guru Member

    Hi howard

    Thanks for replying, I appreciate it. So I guess that the firmware version available at the website is not the one I need... even though it's th eone you get if you specify that your router is v 1.0.

    I can check which version I have - I think it's in the pathname or filename of the download I did.

    Sounds to me like the best thing to do would be to get a working router. Whatever I do, I can't ping my router at, and I have tried a bunch of things. Linksys support tried too and they told me that they wouldn't do any more to try and fix it, and if I could return it to the seller, he could try to RMA it (however, I am pretty sure it's out of warranty). Will the RMA any unit? Because if there is no 'out of warranty' period, then I may be able to get the receipt or proof of purchase from the seller then RMA it myself.
  15. bluebox

    bluebox Network Guru Member

    Hey, give this a try - I think it will work for you:

    Scroll down to my last post in the thread here:

    forum post for flashing a partly-bricked router

    I've used that method at least half a dozen times on a v1 router.

    Let me know how that works!
  16. mset

    mset Network Guru Member

    Excellent, blue - thanks for this. I may not have time in the next 48 hours but I will be trying both methods outlined in the last two posts and I will report back here.

  17. t4thfavor

    t4thfavor Network Guru Member

    im not sure but doesnt the config utility that ships with the router perform a flash when you first start it up?

    i thought it did...
  18. mset

    mset Network Guru Member

    Not sure... I have power cycled it a few times and done the hard reset a few times, but no luck yet. I will have some time to try the latest suggestions in a day or two.

    I did find out that the last thing the previous owner did was attempt to flash it, but he didn't specify if it was with 3rd-party firmware. I have a feeling it may have been...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice