Entware on sd-card

Discussion in 'Tomato Firmware' started by ulyan, Aug 23, 2012.

  1. ulyan

    ulyan Networkin' Nut Member

    Hi I added an sd-card on my asus rt-n66u (internally) but I have some strange errors trying to install it.

    My sd-card label is 'opt', I added this script to init : echo "LABEL=opt /opt ext2 defaults 1 1" >> /etc/fstab

    But when I execute the install script (after reboot and sucessfull mount) I get this error message:

    root@BRAIN:/opt# ./entware_install.sh
    mkdir: can't create directory '/opt/bin': Input/output error
    ./entware_install.sh: cd: line 19: can't cd to /opt/bin
    Connecting to wl500g-repo.googlecode.com (
    opkg 100% |*******************************| 456k 00:00:00 ETA
    chmod: /opt/bin/opkg: Permission denied
    Connecting to wl500g-repo.googlecode.com (
    opkg.conf 100% |*******************************| 112 --:--:-- ETA
    ./entware_install.sh: line 26: /opt/bin/opkg: Permission denied
    ./entware_install.sh: line 27: /opt/bin/opkg: Permission denied
    Info: Congratulations! The Entware successfully initialized.
    Info: Use it wisely :)
    Info: Found a Bug? Please report at wl500g-repo.googlecode.com

    Is this telling me that my sd-card does not work ?

    Thank you.

    ------------- SOLVED ---------
    I think my sd card had some sort of problem. I reformatted it internally and now it works.

    I use shibby's latest build.
  2. ryzhov_al

    ryzhov_al Addicted to LI Member

    Looks like /opt folder still not mounted properly.
    $ mount
  3. ulyan

    ulyan Networkin' Nut Member

    root@BRAIN:/tmp/home/root# mount
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    proc on /proc type proc (rw)
    tmpfs on /tmp type tmpfs (rw)
    devfs on /dev type tmpfs (rw,noatime)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/sda1 on /opt type ext2 (rw)
    /dev/sdb1 on /tmp/mnt/NAS type ext3 (rw,nodev,noatime,data=ordered)

    Can you advice me on a proper way to mount after boot ? Thanks.
  4. ulyan

    ulyan Networkin' Nut Member

    When I don't bind it to opt I get this message :

    root@BRAIN:/tmp/home/root# ls /tmp/mnt/opt
    ls: /tmp/mnt/opt/bin: Input/output error

    I think there is something wrong with it ?!
  5. ulyan

    ulyan Networkin' Nut Member

    I reformatted the card internally using terminal and ssh connection. What is the difference between using this:
    echo "LABEL=optware /opt ext3 defaults 1 1" >> /etc/fstab
    or this
    mount -o bind /mnt/Optware /opt
    Is it better to add on init or use as a run after mount ?

    PD: I'll post later on if I solved my problem.
  6. leandroong

    leandroong LI Guru Member

    do this and forget about echo and mount:
    1. telnet
    2. cd /tmp/etc
    3. vi fstab
    LABEL=swap none swap sw 0 0
    LABEL=optware /opt ext3 rw,noatime 1 1
    4. after saving, nvram commit
    5. reboot and wait
    Note: you can remove swap if you dont use it
    ulyan likes this.
  7. pzlmg

    pzlmg Network Guru Member

    ulyan likes this.
  8. ulyan

    ulyan Networkin' Nut Member

    Thank you guys.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice