Excellent Signal - 1Mbps g speed

Discussion in 'Networking Issues' started by TheBashar, Apr 21, 2007.

  1. TheBashar

    TheBashar LI Guru Member

    Can some one please help me before I pull the last of my hair out?

    I moved into a new apt, and I can't get a stable wifi network to save my life.

    To rule out most hardware problems, I experience the following issues with a WRT54GL or a WHR-54GS connecting with either a Dell WLAN 1350 or a WG511T. I experience the same problems using stock firmware, dd-wrt 23sp2, 23sp3, 24, and tomato 1.06.

    My laptop is the only client connecting to the AP. My microwave is not plugged in. My cordless phone is 900Mhz.

    I connect at 54Mbps and within minutes is degrades down to 1Mbps. The AP is 10ft away with line-of-sight unblocked access. I have 9Dbi high-gain antennas installed (on the WRT54GL).

    My dell connection manager shows a signal of -47dBm and interference of -90dBm. This happens on channels 1, 6, 11, and 8.

    Can somebody at least help me understand what could be causing this?

    Screenshot to illustrate attached.

    Attached Files:

  2. pablito

    pablito Network Guru Member

    Did you try other encryption methods and with no encryption to rule that out? Your signal while very good is noisier than I would expect. I'm getting -95 noise with a so-so signal of -60 in a much tougher environment. I use normal antennas and never see less than a 54M connection.

    A high gain antenna isn't helping at such close distances. If you're cranking the signal strength up that too isn't helping. With short distances I would use a normal antenna and turn down the signal strength.
  3. TheBashar

    TheBashar LI Guru Member

    Thanks for the ideas, though sadly the symptoms are the same for no encryption, wep, and wpa. I've tried more and less signal as well as the original antennas. No observable effect.

    The only thing I've found is sometimes using the tomato firmware, if I leave the "device list" page open on auto-refresh, I will get a 48-54Mbps signal locked in for about 5 minutes. I'm not sure why. Perhaps it's related to the br0 interface changing to permiscous mode?

    I'm really at a loss as to what to do about this. Any other ideas floating around out there?

  4. TheBashar

    TheBashar LI Guru Member


    Okay, I may have found out the problem. A week or so ago I read that someone found there problems were caused by 802.1x being enabled in WinXP. I found similar settings on my laptop and uninstalled the 802.1x service (the example I read had an option to disable - I didn't).

    Unfortunately, that didn't help me at all. Today I spent hours trying to isolate the problem to laptop power saving mode, fan speed, router settings. At one point, I decided to go back to DD-WRT because the Tomato firmware doesn't have an option to overclock. Well, I never got to trying to overclock.

    While reconfiguring the dd-wrt settings, I noticed there was a setting to enable or disable 802.1x! So I disabled it. Now, I'm bouncing between 36-54Mbps instead of 1-5.5Mbps.

    Truth be told, this wasn't the only change, I'm also using the newest v24 beta build. But after having spent literally 4 whole 8 hour days battling this, I'm sure not changing any settings back to isolate what exactly fixed it. But my gut says it was that 802.1x.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice