Experiences with Thibor 14 + WRT54G

Discussion in 'HyperWRT Firmware' started by exnetgear, Mar 20, 2006.

  1. exnetgear

    exnetgear Network Guru Member


    I seem to be one of the unlucky ones that cannot get Thibor 14 to work properly on my WRT54G V3.0. Tofu 13c works flawlessly, but the upgrade to Thibor 14 only works until the router is reset to defaults. Once it is reset (by clear NVRAM or "reset to factory defaults) it will not connect as a WET or client to my other WRT54G AP. As a wired router it works normally.

    My question to those who have successfully upgraded their "G" v.3.0 to Thibor 14 is: does your Thibor 14 upgraded WRT54G continue to function wirelessly even after a Clear NVRAM reset? If you have upgraded from Tofu 13c, you will know you need a reset if your Router Name is still WRT54GL. It should be WRT54GS

  2. RTSAnime

    RTSAnime Network Guru Member

    It works fine on my 54Gv3. I upgraded from 13d though. It is connecting to a 54Gv1 running ddwrt v23.
  3. Sparcle

    Sparcle Network Guru Member

    I flashed mine WRT54G first with DD-WRT Mini and then with Thibor.
    It's now running fine.
  4. NateHoy

    NateHoy Network Guru Member

    Here are the upgrades I have done to my WRT54G V4:

    - Stock -> Tofu (starting with 11, then various versions over several months, ending in 13c) -> Thibor 14 "standard" build
    - Stock -> Thibor 14 "G" build (testing the direct upgrade for Thibor)

    Both upgrades worked flawlessly after selecting the "ERASE NVRAM" version of the supplied factory reset. Things were a little funky before I did the Factory Reset with Erase NVRAM option on both upgrades, but I expected that.

    I do not use mine as a client, however. Mine is purely configured as a "standard" wired/wireless (WPA TKIP/AES) router.
  5. mystikalprince

    mystikalprince Network Guru Member

    I have a WRT54GS v4, but when i try to upgrade using Thibor's hyperwrt 1.4 firmware for the wrt54gs v4, it says that the upgrade failed. whay should i do? i already tried a hard reset and everything else. thanks for any help in advance
  6. berndstein

    berndstein Network Guru Member

    I have a WRT54GS v4, too. Before Thibor14, i had upgraded my WRT54GS with the current DD-WRT (23, i think).

    I could upgrade without problems from DD-WRT to Thibor14.

    What i have discovered, is: It is absolutely neccessary to "ERASE NVRAM", as NateHoy has mentioned before in this thread.

    I performed the following steps to upgrade:

    1. I started with DD-WRT (the upgrade to this firmware is another thing ...)
    2. hard reset (using reset button)
    3. "Erase nvram" (somewhere in the menu of the web interface)
    4. Uploading the "Thibor14.bin" (worked without errros)
    5. hard reset (using reset button)
    6. "Erase nvram" (somewhere in the menu of the web interface)

    This is, how i did it - and it just works fine. :thumbup:

    I didn't work, until i performed exactly these steps above, especially it won't work without the steps 2 and 3, before uploading the "Thibor14.bin"!

  7. NateHoy

    NateHoy Network Guru Member

    mystikalprince -

    I'm assuming you are currently running stock firmware.

    You might want to try upgrading to the latest stock firmware before trying Thibor again. Remember that an "upgrade failed" message means you NEED to reboot the router before trying again. You may also want to download the firmware again to make absolutely sure you don't have a corrupted file.

    As berndstein said, though, a factory reset before attempting to do the upgrade is a Really Good Idea, whether it be from stock firmware or aftermarket. The cleaner you can get memory, the better.
  8. exnetgear

    exnetgear Network Guru Member


    Thanks for the replies!!

    WRT54G - > Tofu 13c - > Thibor 14

    I have tried starting with DDWRT mini and Tofu 13c. My procedure has been:

    erase NVRAM reboot
    load FW through GUI
    erase NVRAM reboot

    What I have found is that if I start with a working Tofu 13c and upgrade to Thibor 14 everything appears loaded and working - although my router name is still WRT54GL. When I do an erase NVRAM and reboot, Thibor 14 is correctly loaded (router name is WRT54GS) but I cannot connect wirelessly to my other 54G (which is running stock FW.) I've made sure that I re-entered the settings exactly as I had with Tofu 13c. It does operate fine as a wired router. If I then flash back to Tofu 13c everything runs perfectly with no setting changes or NVRAM erase. When I do erase NVRAM and re-enter my settings, everything still works fine. I was wondering if someone with a 54G v3.0 running Thibor 14 can test this out for me:

    - Check to see what your router name is.
    - Erase NVRAM - reset defaults
    - Check to see if WRT54GS is the router name.
    - Test router in Client Mode and Wireless Ethernet Bridge Mode

    Thanks again for all of your help!!
  9. mystikalprince

    mystikalprince Network Guru Member

    Thank you for the advice, i will definately try it as soon as i get home this weekend. i am currently away at school right now. i will let you guys know how everything went and i appreciate all the help.
  10. berndstein

    berndstein Network Guru Member


    Did you reset your hardware, using the reset button at the back of the router chassis?

    I remember another post in another forum, that it is absolutly necessary to do this hard reset.

    You did this steps:

    1) erase NVRAM reboot
    2) load FW through GUI
    3) reboot
    4) erase NVRAM reboot

    I think, you must additionally do a hard reset before step 1) and a hard reset before step 4).

    After this (now) 6 steps (and, of course, after correct configuring) your router should work correctly.

  11. exnetgear

    exnetgear Network Guru Member


    Thanks for the help!! I tried your suggestion, but still the same problem. I also tried no wireless security, wep, wpa, changing ssid, firewall off. I guess at this point I am just curious what the problem might be.

    Thanks again!
  12. berndstein

    berndstein Network Guru Member


    at this point, i don't have any further ideas ... because the described way works fine for me.

    The only diffrence, i can think of, is our diffrent hardware: I use a WRT54GS-DE v4.0...

    I hope, you will find another user with exactly the same hardware as you and a working Thibor14! :thumb:

    So long,
  13. exnetgear

    exnetgear Network Guru Member

    Hello and thanks,

    I have tried every option and suggestion without success (including upgrading from Linksys original FW) and I am concluding that Thibor 14 will not work on at least one WRT54G v3.0 in Client mode or Wireless Ethernet Bridge mode. I do wish that Tofu would continue with 13c and up, but such is life.

    Thanks again
  14. mystikalprince

    mystikalprince Network Guru Member

    thanks every1 for your help. i just was able to upgrade the firmware. i hope that it runs smoothly.
  15. Sjowhan

    Sjowhan Network Guru Member

    I've upgraded the Thibor14 firmware on saturday on my WRT54G-v2.2 from linksys 4.20.8, it's running like a charm. Much better than the dd-wrt firmware i've had on my router earlier (disconnects every 3-4 hours).

    (and another thing; it's upgraded to a GS-version in stead of G 8O )
  16. exnetgear

    exnetgear Network Guru Member


    54g v3.0 Tofu 13c Client --> 54g v3.0 Factory FW AP = OK
    54g v3.0 Tofu 13c Client --> 54g v3.0 Thibor 14 AP = OK
    54g v3.0 Thibor 14 Client --> 54g v3.0 Factory FW AP = No Wireless
    54g v3.0 Thibor 14 Client --> 54g v3.0 Thibor 14 AP = OK

    I tried everything (three times) to get the Thibor14 g v3.0 to connect to the Factory FW g v3.0, but no luck. I did notice that some wireless setting changes on the Thibor 14 AP required me to power off/power on the unit to restore wireless connection.

  17. Thibor

    Thibor Super Moderator Staff Member Member

    exnetgear, i'm at a loss to explain why your scenario isn't working, the wireless code is 99.9% identical to tofu's. Pehaps it's something at your end causing your incompatibility. in any case, i don't have "G" routers, so i'm unable to test this, but can state that i have received many many reports of flawless operation.
  18. exnetgear

    exnetgear Network Guru Member


    Thanks for your great work on the FW!! Putting Thibor 14 on both of my 54g v3.0s has everything working perfectly. I was planning on leaving my "mission critical" router with factory firmware, but Thibor 14 seems to be very stable on both routers.

    Thanks again!!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice