extending airport express base station range with wrt54g?

Discussion in 'Networking Issues' started by wildfire, Apr 3, 2005.

  1. wildfire

    wildfire Network Guru Member

    Hi all,

    I've been poring over this forum as well as other results from Google but have not been able to find a solution after two days of experimentation. There're quite a number of tutorials out there for:

    internet == WRT54GS (or other non-Apple base station) == WDS+WEP== AEBS
    internet == WRT54G == WDS+WEP== WRT54G
    internet == AEBS == WDS+WEP== Belkin 54g (F5D7230-4)
    internet == AEBS == WDS+WEP== Buffalo WLA-G54

    but none for

    internet == AEBS == WDS+WEP== WRT54G

    I've tried to set up my AEBS and WRT54G v2.2 (flashed with Hyperwrt) by "combining" some of the tutorials but they're refusing to talk to each other.

    My setup:

    1. Basically, I have both AEBS and WRT54G on the same mode, channel, SSID, WEP key.

    2. On the WRT54G I've changed the default local IP to, turned off DHCP server, entered wl lazywds 0 and wl wds AA:AA:AA:AA:AA:AA (wireless MAC address of the AEBS) in the startup panel.

    3. On the AEBS I'm Connecting using Ethernet, using DHCP, sharing a single IP address using DHCP and NAT for client computers, enabling the AEBS as a WDS main base station and allowing wireless clients on it.

    4. On the AEBS, after doing the stuff in #3, I can actually see my WRT54G when I scan for base stations which I can use as WDS remote base stations, but I can only add it and not auto configure it as a remote base station. The AEBS tells me I have to manually do the configuration, at which point everything fails 'cos it asks me for the AEBS password but is then unable to read the AEBS configuration when trying to authenticate. -- am wondering if this is because (possibly *very* newbie error here) I didn't connect the AEBS to the WRT54G with an ethernet cable (as instructed in some of the tutorials for extending WRT54G with AEBS). But I tried this as well and it didn't work either -- my AEBS kept flashing its orange light...

    So... Has anyone tried this successfully before? Can any of you experts out there spot anything I'm doing wrong? Do I need to be looking at another firmware (sveasoft's?) for it to work? Or... Am I attempting the impossible in the first place? I'd really prefer to have the WRT54G extending AEBS instead of the other way round, as I want to keep the AEBS near to my printer in order to use the remote printing feature of the AEBS.

    Thanks in advance for any pointers.

  2. wildfire

    wildfire Network Guru Member

    Just an update to say I managed to get it working.

  3. wildfire

    wildfire Network Guru Member

    For anyone interested, I've listed the steps I took at http://miscellany.interaktive8.com/guide_aebs_wrt54g.html -- I didn't take any screenshots or notes as I experimented (and I haven't tried resetting and re-doing since I got it working) so this is entirely based on memory. Hope I didn't miss anything and may this simple guide be of use to others.

  4. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Just wanted to say thanks KT. Though you didn't get any immediate replies you kept plugging away at it and were nice enough to share your findings with all of us.

    Exactly the spirit that has make linksysinfo.org a great place for information.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice