Extending capacity of NAS200

Discussion in 'Cisco/Linksys Network Storage Devices' started by Guillaume, Aug 28, 2012.

  1. Guillaume

    Guillaume Serious Server Member


    I was wondering : with default fireware (V3.4R79), my two 3To HDD (WD caviar green) are not detected.
    I found someone saying it was a limitation of the kernel.

    Would the Jac4 kernel solve this problem ?
    If not, do you think there is any solution (or am I screwed ?)

    Thanks a lot for your time
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    No. It's a limitation of the hardware as far as I know.

  3. Guillaume

    Guillaume Serious Server Member

    Thank you so much :)

    Do you think I would be able to bypass this limitation by plugging my drive via USB ? (It seems to be recognised, but maybe as a smaller disk, do you think it is once more a hardware limitation or maybe only a limitation of the interface ?)

    I've got another (stupid) question : (sorry)
    As I messed aroud with my disks, I was able to have one of the 3TB disk recognized (but not formated and it was buggy and strange). Thus, the firmware turned to "two separate disks".
    Now, whan I plug back my old RAID1 disks, they are recognised, but as two separate disks (one formated and working, the other one as "not formated") and the disk configuration is still on "two separate disks"
    I am pretty confident that the second drive is still a RAID1 disk with all data backed up on it. And I'm very sure that the disk1 is RAID1 with all data. Though, when I want to turn the disk configuration to RAID1 he warns me that he is going to format both disks !
    Is there a way on JAC4 to turn back to RAID1 configuration "by force" ? Is it just a matter of mounting the disks as such or maybe I could just change a parameter ?

    Thank you very much for your help :)
  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Sorry for the late reply, I don't monitor these forums every day anymore.

    Good question! It may be possible to see larger devices through USB because it uses a totally different data path which is not related to the hardware that has the 2TiB limitation, so it might work. I don't have a way to test this though, and it would probably be very slow. Either way, if the USB drive is formatted in NTFS, the NAS200 can't write to it, it will be mounted read-only. This is because Linksys used a non-write-capable version of the NTFS file system.

    Another good question. There certainly isn't an easy "click here" answer. But using the mdadm command you may be able to recover from the command line via SSH. Unfortunately I don't know exactly how to do this, and I don't know if the NAS is smart enough to "just recognize" that the disk is supposed to be mounted in RAID mode next time. Maybe the smartest option is to:
    1. Download SystemRescueCD and burn it to a CD-ROM
    2. Shut down the NAS200 and take disk 1 out
    3. Connect disk 1 to a PC that has enough disk space on another hard disk to copy all the files from disk 1, and boot the PC with SystemRescueCD. I'm pretty sure SystemRescueCD will automatically see the partitions and will mount the NAS disk automatically, otherwise you'll have to use mdadm and mount on the command line to mount it yourself.
    4. Copy all the files from partition 1 of the NAS drive to a folder on your PC's hard disk. You don't have to copy partition 2 (configuration data) or partition 3 (swap partition)
    5. Shut the PC down and put disk 1 back into the NAS200. Turn the NAS back on and let it format the drives in whatever mode you like
    6. When the format is complete and the RAIDed drives are empty and working normally, shut the NAS down again, and connect both disk 1 and disk 2 to the PC. Boot the PC with SystemRescueCD again. It should automatically recognize the RAID array and mount the drives correctly.
    7. Copy the files from the PC's hard disk to the RAID array.
    8. Shut the PC down and put the drives back in the NAS (make sure disk 1 is on top and disk 2 is on the bottom so the software doesn't get confused). Once it's running, you should have all your files available on the network again.
    Good luck!

  5. Guillaume

    Guillaume Serious Server Member

    Thank you very much !

    I solved my first problem by building a very cheap server on Linux, which will share my files in samba. Made it for half the price of the NAS200, by the way. It's bigger, but can help for other things than filesharing ! A solution to consider, from time to time, I think.

    Though, I did'nt solved my second problem yet and your suggestion will do fine using this new fileserver for my backup.
    It's too bad native software is so eager to switch automatically from RAID to separate with no easy way back, though.

    Thank you so much for your time :)
  6. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Your Linux server is probably also a lot faster than the NAS200, and more reliable in case your hard disks run hot...

    Good luck!

  7. Flaya

    Flaya Network Newbie Member

    where do i find firmware V3.4R79 for my nas200? On linksys page it says no firmware available..

    My firmware is currently V3.4R75.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice