Failed disk/unit recovery for NAS200?

Discussion in 'Cisco/Linksys Network Storage Devices' started by xb307, Jun 26, 2008.

  1. xb307

    xb307 Addicted to LI Member

    I guess fundamental questions relevant to any sort of disk array:

    1) How to re-mirror NAS200 in case of a single disk failure?
    2) How to recover data from the HDDs if the plastic-fantastic disk enclosure or quality made chinese electronics fark up? I presume buying an empty NAS200
    enclosure in a couple of years time will be mission impossible, being such a speedy and bug-free product (not), the NAS200 is likely to be dropped before than

  2. Mercjoe

    Mercjoe Network Guru Member

    The first thing I do with ANY backup device is test the failsafes. If they don't work then you have a false sense of security.

    Well, in an experiment here on my just purchased NAS200, I formatted as a RAID 1 then pulled the #2 drive and powered it back up.

    I got an e-mail notifing me that a HD had failed.

    I dropped the drive back into slot 2 and powered it back up. I logged onto the router and got a status that drive 2 was being rebuilt. Next morning I checked it and all was normal. Seemed fairly easy to me. It even allowed me to access the drive in slot 1 while the rebuild was going on. It required NO user actions other than dropping a drive in the housing and turning it on.

    All in all, I think the NAS200 was designed to be a network enabled BACKUP device, not a server like the name says. It may be slow, but it does an admirable job of keeping your data safe.

    Check out:

    Here is a cut and paste:

    My NAS is broken (all Leds green). This page explains how to recover a NAS200-disk on a liunx.

    Take one disk out and connect it to a linux-box. Boot linux and run the following commands:

    mdadm -A --run /dev/md0 /dev/sdb1

    mkdir /mnt/sdb1
    mount -r /dev/md0 /mnt/sdb1
    Now, the files may be accessed (read only) under /mnt/sdb1

    I hope this helps
  3. 5circles

    5circles Network Guru Member

    I'm trying to do something similar, but my NAS200 hasn't exactly failed. I can access the files. Linksys wants me to reformat on another system - shows they don't trust their own firmware.

    I'm trying to access the files in my Ubuntu 8.04 system to do a faster copy than I was able to do over the network. I don't know if I'll be able to copy back, but I think I can read.

    I installed the drive into the Ubuntu system. Then I tried to check it out with the partition editor (Gparted). This showed that the drive had 3 partitions, 2 formatted as xfs, and one as linux swap. Unfortunately it also said that the 2 xfs partitions were not accessible.

    I thought at first that this was something to do with the Raid on the NAS200 - even though I hadn't set up as raid. So I tried installing the mdadm package and following the instructions referred to in the previous post. mdadm didn't think the device was setup for raid - at least it errors about no recognizable superblock.

    So then I went back to the simpler possibility, and just mounted the device on /media/sdb1. Now I can read the files. So perhaps the drive was just formatted correctly by the wonderful V75 firmware.

    Linksys says that I'll be able to use the drive if I format it elsewhere, but that wasn't the case with the USB drive.

    The copy from the disk is working (using cp -dpRuv) and the problem with special characters isn't happening - which means there was something about going through the network - Samba?. And the copy is going fast.

    I wonder if I'll be able to copy back this way? Still, first things first.

  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The NAS200 will automatically rebuild the array once you replace the failed disk. It will take a while though...

    The NAS200 uses standard tools to store the data. Any decent Linux distro should be able to recover the data if your electronics should ever go bad (unless the bad electronics are on the disk drive itself of course). You can use ext2ifs to access non-journalled drives directly from Windows, and you can use a Linux live boot CD with VMWare Server to access journalled drives. If you don't have a free SATA or eSATA port in your system, you can use a USB to SATA adapter; they're about $20.

    Of course, if you make backups, you don't have to worry about all that. At least not as much...


  5. That worked for me except that the email never was sent. But the "test" emails did fine. Mine did not indicate the drive had failed but only that it had been removed. Perhaps that is why there was no email.

    The rest worked as you indicated however it only works if the failed drive is drive #2. If the failure is Drive #1 the the RAID1 is "not ready" and you go nowhere. Ifd you move Drive #2 up to the first slot so it become Drive #1 the device declares the Drive as "changed" and the RAID1 is "not ready". If you then add a new Drive #2 it will then declare that both Drives are "changed" and the RAID1 is "not ready",...but it gives you the addional option of "Reset Volume" which reformats the volume and defeats the whole purpose of having a Mirror. So,..if the Drive #1 fails you are just simply screwed unless the remaining drive can be moved to another machine (Windows, Linux,...whatever it takes) to copy the data to a safe place,...then Reset the Volume and start over.

    But if the failure is Drive#2 then replace the drive with another drive of the same size or larger and everything seems hunky-dork aft the very slow rebuild period.
  6. alejandro_liu

    alejandro_liu Addicted to LI Member

    So the other option is to get a firmware with a command line and do it manually.
  7. alejandro_liu

    alejandro_liu Addicted to LI Member

    With md RAID1 arrays you don't really need to recreate the array but just mount it directly:

    [CODE}mount -t /dev/sdb1 /mnt/sdb1[/CODE]

    This is a feature of md RAID1 arrays used to allow you to boot from a MD1 array. Obviously a boot loader won't know about RAID1, so it is made transparent to them.
  8. ryanbaxter

    ryanbaxter LI Guru Member

    I finished mirroring last night after a single disk failure in my NAS200. I used an Eagle Consus USB drive enclosure to backup my data before attempting to recover my failed drive. I wrote about it here.
  9. sblalock

    sblalock Networkin' Nut Member

    Thank You Very Much!!!!

    Thank you, Thank you, Thank you.

    I wanted to thank this thread for your help. I think my solution was originally posted by Mercjoe, but forgive me if I am wrong.

    I get so tired as an IT Professional of 18 years (Microsoft Technologies and Digital VAX Technologies mainly) of going on forums and having some jerk respond with 1). RTFM or 2). you SHOULD be able to do this... however I do not know what I am talking about because I am just a college student currently taking C++, or 3). I use this product and what you want to do is not in the manual and therefore you can not do it.

    My NAS200 crashed and I was unable to get to my data. I purchased a cable to connect the drives directly to my PC via USB. I was able to see the devices under Win 7 and Vista but I could not get to the mount the partitions as they are part of a Raid Array. So I decided to build a linux box using a spare laptop and knowing that the NAS200 uses Linux internally. Well I went into Unbuntu's Disk Utility (actually, I tried about 4), and while I could see the Device, It still would not let me mount the partition, and would not let me start the RAID Array as I only had the one drive.

    At this point I was at my wits end, until I found this thread and read the following

    mdadm -A --run /dev/md0 /dev/sdb1

    mkdir /mnt/sdb1
    mount -r /dev/md0 /mnt/sdb1

    I tried this, however being new to linux, I did not understand the error - unknown command on the mdadm command. I went online, found and install for the command and installed it on my machine. I then successfully issued the commands and then BINGO, the drive mounted and I am now copying the data to my external backup.

    Thank you for the great advice! I do appreciate it.
  10. kallsncvc

    kallsncvc Networkin' Nut Member

    great advice, guys. i got an error with the mdadm command (as i'm new to it) - with this command above i managed to get my data back from the disk. just look out that you use the right disk ( sudo fdisk -l will list you all drives - the one with "linux raid autodetect" filesystem is the right one - in my case it was sdd1, because there are a few drives in my linux machine).
    many thanks!
  11. rmcinnes

    rmcinnes Network Guru Member

    Mercjoe, I hope you and other enthusiasts are "still out there"...
    I have three Seagate Barracuda ES.2 500GB HD I use with my NAS200.
    HD03, was previously installed in my NAS200 as Disk 2 and paired with HD01 as Disk 1.
    A few years ago, I removed HD03, and replaced it with HD02, and as expected, upon installation NAS200 rebuilt the RAID 1 structure.

    Yesterday, I decided I should replace HD02 with HD03 as Disk 2.
    When I do so, NAS200 declares Disk 2, HD03, Changed and Idle, and Disk 1, HD01, as Used by RAID 1.
    NAS200 does not attempt to rebuild the RAID 1 from HD01 source to HD03 Target, why?
    When I removed HD01, and installed HD03 as either Disk 1 or Disk 2, NAS200 continues to declare it Idle.
    No files listed in My Files, and there is no connection from Windows or macOS to NAS200.
    S.M.A.R.T indicates HD03 is OK.
    But ScanDisk does not run, I assume because HD03 is Idle and not part of RAID 1.

    I could not find a way to reformat HD03 with NAS200, installed as Disk 1 or 2.

    How do I go from here? I simply want to swap HD02 for HD03 as Disk 2.

    Like you, I find this "little box" a cute piece of technology, which in conjunction with NTI Shadow, has served me well for over 12 years.
    The first NAS200 failed after (5) years (Power On did nothing).
    The replacement NAS200 is still going strong.
    When new, I did enlarge (drill out a little) all the small vent holes in the case, and do not feel the HD's are getting as hot as they used to...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice