File Transfer Hitting Limit? Tomato ND USB Mod

Discussion in 'Tomato Firmware' started by ahngau, Apr 18, 2010.

  1. ahngau

    ahngau Networkin' Nut Member

    Hi all, a Belkin 4231-4p (BCM 4712) running teddy bear's wonderful Tomato ND USB Mod, a 20G harddisk (soon to be 500G) is attached to the USB 1.1 port.

    Main purpose of the harddisk is to store media files but when ever I copy file to/from the USB harddisk, performance is very slow.

    I first suspected a samba problem. After installing samba3 and tuning it to no avail, I tried different file transfer protocols.

    During the trial, the router was running with transmissiond, and other PC clients doing Voip, streaming media and stuffs.

    Here is the bandwidth monitor watching an upload via samba3 of a 240MB file:-
    - The transfer is from a PC attached on wifi (802.11g WAP2-AES).
    - The peak transfer rate was 13,000kbit/s.
    - Note 1 the on again off again pattern, it seems like for every 30MB of file transferred, it hit a brick wall and stop, then resumed and did it again.
    - Note 2, during the on period, the CPU was max out with smbd drawing 60~70%. During the off period, the CPU was 40~60% idle.

    Now, when we switched to ftp and upload the same file:-
    - The pattern was the same! It stopped every 30MB!
    - The peak transfer rate was much higher (17,000kbit/s), leading to a narrower peak, yet the off period was the same as the samba.
    - Again, CPU max out during the on period but idling during off.

    Finally, I tried to really challenge the CPU - scp the file.
    - Well, it's only a router, encryption turned out to be a tough job. The peak transfer rate was a mere 1900kbit/s. The CPU max out all the time and of course, dropbear was using the most.
    - The on/off pattern went away, suggesting the CPU was the bottle neck.
    - This little home grade router with Tomato is really tough. I could still make an excellent VoIP call during the CPU max out, so QoS was still working beautifully. Other PC clients doing their normal stuffs didn't even know I was trying to trash the router!

    Now guys, any idea on what gives? It seems like some kind of buffer was full when the transfer rate was high. And it's not CPU related.

    Oh oh, by the way, the router has 64M ram and the swap on disk is 128M.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice