Filesystem lost after firmware upgrade

Discussion in 'Cisco/Linksys Network Storage Devices' started by matsimoto, Mar 29, 2008.

  1. matsimoto

    matsimoto LI Guru Member


    after a firmware upgrade I get:
    BusyBox v1.00-rc2 (2008.03.03-16:02+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.
    $ fdisk -l
    Disk /dev/sda: 255 heads, 63 sectors, 60801 cylinders
    Units = cylinders of 16065 * 512 bytes
    Disk /dev/sda doesn't contain a valid partition table
    Disk /dev/sdc: 16 heads, 32 sectors, 979 cylinders
    Units = cylinders of 512 * 512 bytes
       Device Boot    Start       End    Blocks   Id  System
    /dev/sdc1             1       917    234736    b  Win95 FAT32
    /dev/sdc2           918       979     15872   82  Linux swap
    I only modified the startscript rc.1 and added some processes to start on bootup.
    Happens this often or do I had bad luck ?
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    You didn't tell us which firmware you're using and what changes you made to rc.1.

    As far as I can think of, there's nothing in the firmware (neither Linksys nor mine) that makes a partition table disappear.

    If you tried to run programs before rc.bootbin starts, you should know that the harddisks aren't mounted yet until rc.bootbin runs. I don't know exactly how rc.bootbin would react to unexpected situations (e.g. files in the filesystem before a disk is mounted), but I recommend not running anything before rc.bootbin unless there's no other way. And if you do run something before rc.bootbin, make sure all partitions you mounted are unmounted again. In other words: You should always let rc.bootbin do its work before you do anything that's different from the original firmware.

    As for the missing partition table: one of my harddisks happens to have 60801 total cylinders too (like yours). I will send you a PM with my partition table so you can write it to yours.

    Normally, the NAS200 partitions the disks somewhat like this:
    - partition 1: data partition, type 83, start at cylinder 1, size equals total capacity minus 45 cylinders
    - partition 2: config partition, type 83, start at end of partition 1, size 30 cylinders
    - partition 3: swap partition, type 82, start at end of partition 2, size 15 cylinders

  3. matsimoto

    matsimoto LI Guru Member

    Hi Jac,

    after running xfs_repair which worked for more than 5h, and only gives me a "no valid secondary super block found" I decided to reformat the disk.

    After all I think it could be that some processes that were started in my chroot environment had disc activities during the firmware upgrade.

    Maybe this could cause the problem. What do you think ?

    Every activity I do begins after rc.bootbin. I inserted my backup disk and it worked fine without any problems what means to me that the image should not be the problem.

    BTW, I noticed that my USB-Stick was not mounted after rc.bootbin. I would like to activate the telnet daemon with a file placed on the USB-Stick but the file cannot be found after rc.bootbin has run.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice