Finally! WRT350N-v1 new f/w v1.03.6 (Aug 10)

Discussion in 'Cisco/Linksys Wireless Routers' started by Toink, Aug 24, 2007.

  1. Toink

    Toink Network Guru Member

    Download HERE
    GPL Code HERE

    Looking forward for Thibor's Firmware :) :)
  2. Thibor

    Thibor Super Moderator Staff Member Member

    downloading the sources now, thanks for letting me know mate. btw, your GPL link is for 1.03.2
  3. Toink

    Toink Network Guru Member

    Whoopsies! GPL link corrected :) Thanks for the correction Thibor! :)

    I have yet to flash my router though... I may have to wait for your version :)

    [Edit:] I couldn't bear the urge not to upgrade... so I tried.... Is it just me or is anyone else also having a problem to go to other settings? As soon as I hard reset, upgarded, hard reset, save the BASIC SETUP. I couldn't go on and change the other settings in the tabs. Whenever I tried to click on any of the tabs I either get gibberish characters or am faced by a "cannot find page error".

    I tried to re-flash doing the hard reset process and all.... same thing.... I went back to my stock firmware which is 1.03.2... everything is back to normal.... Oh well I guess I will have to skip this version first until a working one comes out....
  4. Thibor

    Thibor Super Moderator Staff Member Member

    i'll look into that when i start working on it, which will be in aprox. 1 week. i have a crazy final week at my job and then a couple of weeks off before i start my new job so i should get some major time to put it out, along with the SL too i very much hope.
  5. mlai

    mlai Network Guru Member

    Sorry to barge in.... Thanks for the info. I am currently on 1.05.8 beta (which has been out there for ages.....). Will this 1.03.6 be newer than the 1.05.8 beta? I am a bit reluctant to install the 1.03.6 to overwrite the 1.05.8 beta if it is actually older than the beta.....

    Many thanks.
  6. Thibor

    Thibor Super Moderator Staff Member Member

    a little update. i was actually using 1.05.9beta2 when i installed the 1.03.6 version. after flashing it was good, but i reset it to defaults and the router turned into a silver brick. needless to say i am less than impressed at the destruction of my router simply by resetting it to factory defaults. it is (or was) my only 350N and it doesn't want to be revived as i can't ping it, and the switch ports are all screwed up now also. i have spent a lot of time trying to debrick it without any success and i'm quite frankly disgusted that this would happen simply from resetting it.
  7. Toink

    Toink Network Guru Member

    Wow! What a way to go indeed! :(

    I have a feeling that something may be wrong with the firmware compilation (?) or the hardware itself....

    I tried some 3 more times upgrading... What I notice is that during the upgrading process it would always show as far as 78% done, then it will show update success - All 3 times!

    I got cold feet and re-flashed with the old .exe v1.03.2. Only until then would it work normally.

    I got to talk to a Linksys Tech Support (via chat) and I was advised to have my router replaced (RMA'ed). Just got it last Feb '07 so it's still under warranty.

    As far as I remember, Thibor, you purchased your WRT350N from the US, correct? They will honor international warranty - you just have to shoulder the shipping cost. Delivery is free...

    Too bad we may have to wait a little longer for a really working firmware version...
  8. bchumina

    bchumina LI Guru Member

    Thibor - Try this.

    Completely unhook everything from your router... All cables etc. Then disconnect the power. While everything is unhooked press and hold the reset button for ~10 seconds. Then Connect the power back to the router still nothing hooked into it. Wait for it to completely power on - you will know when it is completely on because you should see the security light as being active. Then plug in your computer connection.

    See if that works - I had the same issue you described multiple times when flashing with the older firmwares. These are the steps I had to take.

  9. Gripweed

    Gripweed LI Guru Member

    If I'm not mistaken it looks like Linksys pulled the updated firmware. The link given in this message thread leads to version 1.03.2 again.
  10. Toink

    Toink Network Guru Member

    Yeah it appears like it... I guess something's really wrong with the firmware. I tried to be objective in my posts in the official Linksys forum but the mods there locked my thread...

    Anyways I'm really disappointed at how this firmware was not thoroughly tested before it was officially released to the public :thumbdown:
  11. dgwawrzy

    dgwawrzy Guest

    Should I be concerned?

    I downloaded and installed 1.03.6 and had a couple of weird things happen.

    Installing the firmware there was no clear indication when it was finished. I wasn't pressed for time so I waited an hour for something to tell me it was done.

    After restarting/rebooting there was no way to get to it. I ended up having to power down everything attached to it and powering everything back up again to make things work. Never had to do that before.

    I've been using this firmware for a few days without any apparent problems. I mean if you do a reset it might turn it into a doorstop which is very scary. Should install the older version and just wait or just sit still?
  12. Mick Mickle

    Mick Mickle LI Guru Member

    Recovering from Failed Firmware Flash

    I flashed to 1.03.6 using the router's web page and at about 75% got a "failed." After several hours of trying to reflash with that version and the previous one using the TFTP utility and chasing down Internet leads to unbrick the router and get a solid power LED, this is what I found worked: Using the latest Linksys tftp.exe v. 1.255, and the 1.03.6 bin file, I followed these directions from an OpenWRT web page --

    (Added 8/31/07: Before steps below will work, you will probably need to set your TCP/IP options to assign your computer the address of, subnet mask of (probably defaults to that), and gateway of your router's address After all your router is probably not working to assign your computer an IP address.)

    1. Open two command windows side-by-side in the folder where the firmware file and tftp.exe are located ("Open Command Prompt Here" or Start-Run-Enter "cmd")
    2. In one window, type "ping -t -w 10" and press enter. is the router IP.
    3. Ping will continuously try to contact the wrt with 10 ms timeout instead of default 4000 ms. Keep this running
    4. In the other window, prepare the tftp command "tftp -i PUT OpenWrt-gs-code.bin". Do not press enter yet! (Substitute the actual firmware filename for "OpenWrt-gs-code.bin" - The result is that this command starts the tftp program, so as an alternative, you might as well just execute tftp.exe and have it cued with the blanks filled with the correct info and ready to press enter.)
    5. Now you may plug in the router (unplug it first if it was plugged).
    6. In the ping window it will start saying "Hardware Error"
    7. Return to the tftp window. As soon as the ping window starts to answer again, press enter in the tftp window.
    8. The image should now be flashed without multiple tries.
    9. If ping starts with "Hardware Error", then starts to answer, and then returns to "Hardware Error" again for a short moment, you waited too long.

    Success for me. After resetting and powering off and on it worked okay. But this firmware version doesn't boot properly when I power down and up my entire cable modem and routers circuit, which I do every few months with one switch to fix the seemingly inevitable glitches that develop in my Internet or wireless connectivity. Instead, I have to unplug and replug the WRT350N by itself several times before all lights are on. Once that's done, it seems fairly stable except for the inexplicable orange security light (which is sometimes green).

    So far, I don't see a need to revert to the earlier firmware version while this one's working okay.

    Hope this helps someone who's pulling their hair out over this new firmware that wasn't quite ready for prime time. The same process can be used to flash back a stubborn router to the previous firmware version.
  13. Gripweed

    Gripweed LI Guru Member

    And what do you do if your bricked 350N router won't even answer a ping?
  14. drutort

    drutort Network Guru Member

    im using DD-WRT v24 RC-1 (08/22/07) std on my wrt350n v1 which i got about 1 week ago, works great with my wrt54gs's both runing same firmware

    im just looking into the usb support which a few people have been working on, and even opened up the 2nd usb port with hardware mod

    there is special info and ways to talk and try to get to flash your router when its bricked, req a hardware made cable i believe, i think it works on all devices? not sure, you will have to look at the faq's
  15. Linkyguy

    Linkyguy Network Guru Member

    I upgraded from the beta to the v1.03.6 Aug. 10, 2007 version with absolutely no problems. Didn't even need to reboot it but I did anyway. However, I have to say I am continually amazed at the moron-ness (is that a valid word?) of Linksys. They take over 8 months to post an upgrade, then pull it after a week or so. I asked on the live chat and some robot said "it was only a test version". Why not post a reason for this? Why not post a semi-literate explanation? Most folks who upgrade are savvy - why treat us like morons? I think there is a higher power that is testing our loyalty to Linksys - what other explanation could there be?
  16. Toxic

    Toxic Administrator Staff Member

    My guess is it obviously was not tested to the full. It should have spent more time in an Alpha testing phase before being released to a Beta testing phase.
  17. Linkyguy

    Linkyguy Network Guru Member

    but it was not a beta! it was a full official release: v1.03.6 Aug. 10, 2007
  18. Rekoil

    Rekoil LI Guru Member

    It'll take a miracle from Linksys for me to install Linksys firmware on mine :p
  19. Neoistheone2000

    Neoistheone2000 LI Guru Member

    1.03.7 available.........

    1.03.7 Sep 14, 2007 1. Disabled SIP/ALG internally
    2. Fixed inability to add or delete DHCP reservation with apostrophy "'"
    3. Removed QoS Ethernet in the help file
    4. Fixed Internet access to FTP server by default is disabled.
    5. Fixed typo in some error messages.
    6. Fixed instability with some cable modem connections.

    Wonder if there is any fixes that are not listed...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice