FiOS TV - On Demand

Discussion in 'General Discussion' started by rybakt, Aug 8, 2006.

  1. rybakt

    rybakt Guest

    This morning I got FiOS TV installed. Everything was going smooth until the tech asked to see the free wireless D-Link router I got during the initial FiOS internet installation. I told him that I got rid of it as it was a piece of junk and my Linksys SRX WAP54GX is better. He told me he could not continue the installation because he needed the D-Link (he offered to sell me some Actiontec router but did not know how much Verizon would charge me). I told him that I was not going to buy another router when the Linksys works just fine. At that point he told me that he needs the D-Link because there is a firmware flash he needs to perform. This new firmware fixes an issue with the On Demand function. I told him that I really don't care about On Demand and asked if he could work with the Linksys, but he refused. To get him to work on it I went to my neighbours house and borrowed his D-Link router. The tech performed the firmware flash and completed the final setup. He did not make any changes to the configuration of the router. Right after he left I connected back my Linksys and it all seems to work fine. However I did not have a change to try the On Demand function.

    Does anyone have FiOS TV On Demand work properly on their Linksys SRX WAP54GX? Is there any firmware that addresses this issue?
  2. dblamp

    dblamp LI Guru Member

    I have a RV042 that works fine with the Fios TV on demand. I just got the RVS4000 and I am having problems with it and the on demand. The picture is al pixilated and there is no sound. Anyone have any suggestions?
  3. Linkyguy

    Linkyguy Network Guru Member

    FIOS TV with non-Verizon router

    Getting FIOS TV and in same boat- disconnected the actiontec router supplied for internet and put my WRT350N in. But have heard ActionTec router needed for on demand and program that true? If so, is there a workaround? eg can I WDS my WRT350N from the ActionTec?

  4. z28man

    z28man LI Guru Member

    WRT54G v5 Linksys router working with Fios On Demand

    I had Fios internet installed a year ago. I wanted a wireless router, but was told by their tech that the linksys router was better then the dlink wireless router and that either would work (the non-wireless dlink was free, the wireless one was extra cost). Anyway, I got a linksys WRT54G v5 and hooked it up (and after getting some firmware patches... 1.00.4 to be exact), everything worked fine.

    Last night I had Fios TV installed (no more TW!). The tech hooked the Motorola NIM up to port 1 of the linksys router, although he seemed a little freaked about it not being an actiontech or dlink. Everything seemed to work fine... menus, guides and everything came up. This morning I tried On Demand and it did not work. I got the ERR-1 message and a phone number. After a long time on the phone, the guy finally asked about the router and I told him I had a linksys, which made him put in a ticket to send out a tech to check the splicers and "possibly" replace the linksys with an actiontech router. In the meantime, I started poking around and found this site with this trail.

    One guy mentions "QOS support" is needed, so I poked on the linksys router and found QOS under "Applications and Gaming -> QOS". It was disabled. I enabled it, left upstream bandwidth at AUTO, and changed the "Ethernet Port Priority" for port 1 to HIGH, flow control left to ENABLE (no change). I hit Save, then tried the On Demand thing and it still failed. I then started poking around on the linksys site looking for newer firmware updates.

    I found 1.01.1 (again, this is a WRT54G v5) and installed it, leaving the QOS settings as I set them before (enabled, HIGH priority on port 1), checked the On Demand, and it works. I have 5 STBs, so I went to all 5 and picked some On Demand thing and ran internet connections at the same time and all STBs picked up On Demand and showed whatever I poked at and the internet stuff was working fine.

    So, bottom line is I know WRT54G v5 with the 1.01.1 firmware and QOS turned on as I mentioned above does work with Fios TV and On Demand. I don't know if it was just the firmware or if I still needed to have the QOS settings turned on, but I know this works. Other linksys routers should have QOS settings similar to this, so I would try messing with that as I mentioned above (port 1 on the back of the router is where they hooked their Motorola "big black box").
  5. z28man

    z28man LI Guru Member

  6. Linkyguy

    Linkyguy Network Guru Member

    I figured it out - using both supplied DLINK from FIOS and my WRT350N (or any other Linky will do).
    Set up the FIOS router per Verizon's specs. Plug in your Linky into port 1 of DLINK using the internet port on Linky. This is a "wired bridge" or whatever the correct terminology is. If you specify DHle CP the DLINK will give the Linky an IP, but I hard coded it static to be It needed the Verizon DNS 's on the linky setup page for static.
    This way I preserved all my original network settings with a different subnet and I get N speeds in that network. The FIOS router acts as the gateway only andI don't use their DHCP or anything. I open the ports on the DLINK and pass them to the Linky. One problem, port 80 and FTP is blocked in Maryland. I plan to redirect port 80 using's instructions for my webpage.
  7. Linkyguy

    Linkyguy Network Guru Member

    correction - it was FIOS' new ActionTec router, not a DLINK they gave me.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice