Firmware 2.3R73

Discussion in 'Cisco/Linksys Network Storage Devices' started by ReLLiK75, Jan 15, 2007.

  1. ReLLiK75

    ReLLiK75 Guest

    NSLU with Firmware 2.3R73!!??

    I just purchased an NSLU2 that has firmware 2.3R73. I've called linksys to get information regarding the firmware, but no one was able to help me. Does anyone here have any info on it?

    Somethings I've noticed about this firmware vs what I've read this device is supposed to be capable of:

    Flash drives work in either port 1 or port 2
    RAID (but only at designed time via a scheduler)

  2. aximbigfan

    aximbigfan LI Guru Member

    ....this might have made my day. can you take a screen shot of the admin page where it says the f/w version?

  3. gwbaker

    gwbaker Guest

    So I wonder when Linksys plans to add the new firmware to their support/downloads pages. I want to get rid of this damnned write protect error in the previous verson and hope the new one will. Any guesses?
  4. LordFlux

    LordFlux Network Guru Member

    That's awesome. I hope Linksys puts this up on their page.
  5. Syncer

    Syncer LI Guru Member

    I'd love to see a screen shot too ... as I don't know that I believe it. There has been no mention of any update or beta beyond 72, so I'll be very curious to see the 73 revision.

    As for the two items mentioned,
    Flash drives work in either port 1 or port 2
    RAID (but only at designed time via a scheduler)

    I'm pretty sure these are already implmented in revision 63.
  6. 123Piet

    123Piet Guest

    Firmware V2.3R73

    I got my NSLU2 a couple of days ago. It had R73 on, here's the screenshot.

    Attached Files:

  7. Syncer

    Syncer LI Guru Member

    Thanks for posting the screen shot! Indeed, it will be interesting to eventually learn what may/may not be updated in this release verses the current R63.
  8. aximbigfan

    aximbigfan LI Guru Member

    well il be a monkey on crack smoking a pipe, it really is r73.

  9. Koala_b

    Koala_b LI Guru Member

    The screenshot could be a fake.

    Under R72 (and I presume, since the R63 version), the upgrade screen has a special button on the bottom list of blue buttons: between the button 'Start Upgrade' and the button 'Help' must be proposed the button 'Upgrade of the UI' permitting to load one of the 3 supplied languages for the HTML User Interface of the NSLU2.

    This button is missing on the provided screenshot, and I see no reason to have it no more in R73 (BTW, this realease is still officially an internal beta release)...
  10. Goanna

    Goanna LI Guru Member

    I just purchased a NSLU2 from newegg and I also have this firmware installed on mine.

    What I am wondering though, if it is still worth it for me to upgrade to Unslung, or if I should stick with the stock firmware? I wish there was a feature list or some screenshots of unslung but so far I havent found any.
  11. smanders

    smanders LI Guru Member

    Yeah mine just came in the mail today loaded with R73. Still no specs on the release? The quick start guide still has it in bold that you can only put flash drives in disk2, but more than likely quick start guide probably has not been updated since the original release :rolleyes:

    I want to make this thing a print server in addition to the NAS features, but I wanna know what I'm screwing up first :confused:

    Anyone have any more info?
  12. smanders

    smanders LI Guru Member

    So NOBODY knows anything about a shipping release? :confused: Somebody has to know something?

  13. LordFlux

    LordFlux Network Guru Member

    I've contacted Linksys Support about the new firmware and they don't know anything about it. According to them, it doesn't even exist. So who knows when it will be available to download on their website.
  14. Koala_b

    Koala_b LI Guru Member

    have contacted the support too.

    Same answer: they only know taht the last final firmware is the R63 and that the last available Beta is R72...
  15. LordFlux

    LordFlux Network Guru Member

    I spoke with a lady name Shiela on Live Support. She received approval from her superior to send me 2.3R73 over e-mail. She copy and pasted the firmware details and from what I remember, the 73 update from 72 only fixes a problem when changing the port number on the 72 firmware... something like if you change the port number to 1024, it makes the unit's web interface inaccessable.

    She said I should receive an e-mail with the firmware within 24 hours.

    Oh, and one more thing... she said that according to her notes, 2.3R73 was still a beta build and was only for internal testing (which is why she had to receive approval). I asked why a beta build was being installed on retail units. She didn't answer my question.
  16. LordFlux

    LordFlux Network Guru Member

    Here are the fixes -- I got an e-mail with my chat transcript:

    Shiela A. (22690): Here are the fixes for the beta firmware 2.3 R73.
    Shiela A. (22690): "The web interface of NSLU2 becomes inaccessible once you changed the Port number for HTTP (Web Browser) connection to 1024. Accessing the storage link by typing http://IP_Address: Port (e.g. on the Address Bar will yield Page Cannot be Displayed once you click on the different tabs. You would have to reset the unit in order to access it again. When the HTTP Connection Port was set to other values like 1025 and 1050, the problem doesn’t occur.

    The problem was encountered with firmware 2.3R63 and beta 2.3R72."

    Shiela A. (22690): When you rename a folder or file on the NSLU2 with a filename that starts with a dollar sign (e.g. $pki_folder), the file or folder disappears. The problem was encountered with firmware 2.3R72 but not with beta 2.3R66. When you downgrade the firmware to 2.3R66, the files and folders that were created or renamed with a dollar sign will become visible and accessible.
  17. ytsejam

    ytsejam Network Guru Member


    Can you post the 2.3R73 firmware they emailed to you?
  18. LordFlux

    LordFlux Network Guru Member

    I kept checking my e-mail on Monday, waiting for it to come in -- nothing. So I got on Live Chat again late Monday night and asked another representative to send it to me. He read my previous transcript and understood what I wanted. Not only did he e-mail the support team, but also e-mailed his supervisor, requesting that the latest firmware revision be e-mailed to me.

    And yet....... nothing is still in my e-mail. As soon as I hear or receive something, I'll post.
  19. bripab007

    bripab007 Network Guru Member

    I, too, bought a slug from Newegg recently that came with the R73 (and was also de-clocked to 133mhz), but, I was silly enough to think this was the latest version avail. on Linksys' website and proceeded to Unslung the router. Now that I've learned more, I want to revert to the Linksys R73 software and un-Unsling the router.

    I chatted with Jerald at tech support this afternoon, and, in theory, he, too put in a request to have the R73 firmware e-mailed to me. He even asked if I had an alternate e-mail account than my Gmail, as they'll often block file attachments deemed dangerous. We'll see!

    On a related note: have people had luck simply using Sercomm utility to flash directly from Unslung firmware back to a Linksys firmware?
  20. LordFlux

    LordFlux Network Guru Member

  21. bripab007

    bripab007 Network Guru Member

    Yes, I went ahead and used the Sercomm method yesterday, and it worked like a champ. I first flashed to the stock Linksys R63 firmware, as that's what the Unslung 6.8 is based off of, and I figured it would lessen the chance of causing further problems. Also made sure to connect the external drive to my PC and reformat it to NTFS in order to clear off any Unslung remnants. Worked great.

    Checked my e-mail a little later and, lo and behold, I had R73 waiting for me in the inbox. So now I'm running back where I was three days ago before I loaded Unslung (except now I'm de-underclocked as well ;) ). I would post the R73 up for download, but there was a lengthy bit of Lawyer-speak™ in the e-mail about how it's an internal beta, not intended for public distribution and how they'll press criminal charges if they catch you giving it out publicly.

    Not exactly sure why they're loading it on Slugs from the factory then.
  22. LordFlux

    LordFlux Network Guru Member

    I just got the e-mail with the firmware as well. Like bripa said, it says they'll file charges if the firmware is shared... so sorry everyone... I had planned to post it up for download.
  23. Toxic

    Toxic Administrator Staff Member

    I have emailed a linksys about this and asked them to explain why they have not released this as official firmware if production units are already in distribution

    If users need this firmware then I would suggest contacting Linksys Tech Support for it.
  24. Meistergeek

    Meistergeek Network Guru Member

    Linksys: Post R73 NOW!

    Once again Linksys shows total lack of touch with basic customer service! If you release product to retail with the R73 firmware, that firmware is no longer beta, but part of the public domain, it is that simple!

    They did the same run around with the Wireless-G VPN Broadband Router WRV54G, where it took almost 2 years to get an update posted.

    So I urge Linksys to make the R73 firmware available sooner rather than later!

  25. Toxic

    Toxic Administrator Staff Member

    I have raised this issue with Linksys. am waiting to here back from them.
  26. jksmurf

    jksmurf Network Guru Member

    Or even hear back from them... :)

  27. Toxic

    Toxic Administrator Staff Member

    i have already but they are awaiting response from other sources, be patient my friend.... Rome wasn't built in a day ;)
  28. mikehunt

    mikehunt Guest

    I just got mine and am setting up the drives. I saw the firmware version and thought it was wierd since I only saw 60 something on their website and on the discussions on the linux site to hack the firmware
    google search turned up this thread so I thought I'd register and see what all I can learn here.
    I think it's funny it has a firmware version linksys support apparently knows nothing about and is a version newer than one they claim is still beta

    Although I don't like the idea of it potentially running a pre-beta firmware

    here's proof of the firmware version
  29. Igor33

    Igor33 LI Guru Member

    where I can download firmware 2.3R73?
    Now I use 2.3 R72, with 2.5 HDD 80Gb Ext3, but NSLU2 have problems with big files on FTP (above 4Gb).
  30. jksmurf

    jksmurf Network Guru Member

    I believe if you read through this thread, you'll see it can not be downloaded, due to its current beta status.

    Those who do not get it with their new SLUG, but have got hold a copy, have all spent some time on Linksys Live Chat (and I can now count myself amongst this group, having finally gotten Live Chat working - thanks to bripab007) and explained that they can't access their slug via the http://address via port 1024 with 2.3vR63 and that they understand there is a new beta f/w which will allow them to do this. Linksys will email you a copy for YOU only (which is why no-one can give them out).

    btw Linksys normal flash method (from R72) failed leaving me with an alternating blinking red / green light. I had to use the Sercomm utility (don't use Linksys Eraseall!!) to upload the R73 f/w. It worked fine after that, even kept the settings, but I was uttering a few choice words ther for a while ...

  31. Igor33

    Igor33 LI Guru Member

    Thanks for reply. I will wait official release.
  32. Abandonflip

    Abandonflip LI Guru Member

    Would anybody with a copy of R73 be willing to share it with me - Linksys have tried, and failed, on several occassions to send me the zip file, and I have all the relevant emails to prove it. It just seems that I am destined never to receive the file from them, and they have now stopped responding to requests.
  33. kandreas

    kandreas LI Guru Member

    Can you please share your copy of Firmware 2.3R73 with me.
  34. kandreas

    kandreas LI Guru Member

    Can you please share your Firmware 2.3R73 with me?
  35. Abandonflip

    Abandonflip LI Guru Member

    Hi kandreas, as you may have gathered from some previous posts in this thread, there is a bit of a legal problem with the re-distribution of this firmware, and I don't think anybody wants to take the chance of getting their wrist slapped by Linksys.

    I would suggest you do as I did, which is to make a request direct with Linksys customer service. Other than the problems I had receiving the file, they were very helpful.
  36. Melvin Ganik

    Melvin Ganik LI Guru Member

    I recently received two NSLU2 units from newegg (about 2 weeks ago). Both have V2.3R63, just in case anyone is thinking to purchase a new unit to get the 2.3R73 release. I guess you might get lucky, but it seems to me that Linksys "accidently" released Beta 2.3R73 out of the factory, and has since corrected the mistake.
  37. d__l

    d__l Network Guru Member

    You would think newegg would have lots of inventory turn over, but there still is a possiblity that they are older units that have been sitting around for a while on the backshelf at a warehouse.
  38. rwhitby

    rwhitby Network Guru Member

    What we need is someone who got R73 already installed on a unit, and who has JTAG capability, so that they can read it off the unit and therefore distribute it.

    -- Rod
  39. Coopsterman321

    Coopsterman321 LI Guru Member

    Any new news on when Linksys might officially leak the R73 'beta'?
  40. computeguy

    computeguy Network Guru Member

    NSLU firmware upgrade

    I got my 73 firmware from emailing Linksys Tech support after 2 days
    they sent it to me

    anybody needs it.. just email me
  41. tcchan

    tcchan Guest

    Can you please share your copy of Firmware 2.3R73 to me.
  42. Dr.K

    Dr.K LI Guru Member

    Download link for Beta Firmware NSLU2_V23R73

    Just got my copy of this release today (2007/07/09), I'm still waiting for release notes. I've had the unit for some time now constantly having problems with it locking up while copying files to or from. Additionally the performance would significantly degrade after the unit was running for some time. I've been checking Linksys website once or twice a month hoping that some update would be released to resolve those issues, and with the last official firmware having a release date of 2005 I thought they forgot about it (and so did I... barely using the thing because of its poor reliability). I have LaCie (Seagate inside) 250GB drive attached to it formatted in NTFS. I bought the unit due to the fact that it would read/write to NTFS drives. I have not tested the firmware yet, but below is the download link. File came from Linksys and has been tested for viruses with NAVCORP 10 definition file 2007/07/08 rev 7 by me.

    Download link for Beta Firmware NSLU2_V23R73 (5,717KB)

    Link to picture of the email from (30KB)

    I have renamed the "zip" file from to to maintain the naming convention, but left the "bin" file inside untouched. The last modified date of the file is 2006/06/13 (June 13) so it's been around for over a year, but it's a BETA release.


    I will try to update everyone if it resolves my issues and will post release notes once or if I get them.

    I'm a Cisco guy and now that they own Linksys someone has to watch out for them and to make sure they perform somewhat to Cisco's standards :)

    Hope this helps!

  43. grumpa

    grumpa Network Guru Member

    So .... ? .... is there any compelling reason to upgrade to R73? Any significant difference from R72 or RA5? Any Forum preference of the three versions?
  44. d__l

    d__l Network Guru Member

    You can fix that by having your NSLU2 auto restart itself once a week or every day, if necessary, in the early morning hours.
  45. mstombs

    mstombs Network Guru Member

    Thanks -have downloaded for potential future use, my NSLU2 is 'unslung' at the moment.

    I don't think it is very professional to distribute even beta firmware without release notes or readme - do you?
  46. Dr.K

    Dr.K LI Guru Member

    R73 update

    I still didn't get release notes from Linksys... This version seems to work ok, the unit has not locked up since I upgraded it. Once i lost a connection to it whlile copying large amount of data (multiple files) but the unit didn't lock up :) the perfrmance seem to slightly improve as well. If I get the release notes fro Linksys I'll post them here...


  47. rich

    rich Network Guru Member

    link down?

    Dr. K...that link to get the FW does not work for it still up?

  48. mstombs

    mstombs Network Guru Member

    Its still there, but for some reason the link won't open in Firefox, does in IE7, filename capitalization is different, but that's not the problem as far as I can tell

    use an ftp client and browse to the directory, still works for me
  49. rich

    rich Network Guru Member

    mstombs...Thank you! I did not think of that...yes I'm using firefox on a Linux machine!

    Again, Thank you!
  50. ChiefZeke

    ChiefZeke LI Guru Member

    Upgarde installed just fine

    Thought I'd say thanks for the posting of R73 and mention that I installed it this morning on my NSLU2 - with no problems.

    Would be nice, though, if Linksys posted a final as opposed to beta.
  51. rich

    rich Network Guru Member

    I've had 73 running since 7/ problems....

    Thank you!
  52. Ropey

    Ropey Guest

  53. rich

    rich Network Guru Member

    It's still up there and working although it doesn't want to work with firefox...I used a standalone ftp program to get it down.
  54. Linkiboy

    Linkiboy LI Guru Member

  55. Toxic

    Toxic Administrator Staff Member

  56. Talisker

    Talisker LI Guru Member

    How to flash an uNSLUng 6.8 ?


    I'm using a NSLU2 with a V2.3R63 Firmware and uNSLUng-6.8-beta. My slug fails when I copy larges files (>2Go) from XP or Vista. I would like to try the R73.
    I already download the bin file, but what is the procedure to flash the slug with my configuration ?
    Can I use the regular Web interface ? Do I need to de-connect the drives before flashing the slug ?

  57. gimi

    gimi Guest

    Ok so someone told me that the NSLU2_V23RA5_fw.bin release available under is newer than 2.3R73. Can anyone confirm this. What's with the RA5 anyway.

    Found the release notes for it. Seems to be an International release of some sorts....

    Linksys, A division of Cisco Systems, Inc.
    Product: NSLU2
    Classification: History of microcode release.
    release Date: September, 26th, 2005
    Version: V23RA5 (ETSI)
    - Initial multilingual (EN-FR-DE) release with FAT32
    and NTFS support.
    - Web user interface language can be changed using
    the Setup Wizard after microcode has been upgraded.
  58. danix71

    danix71 LI Guru Member

    Who could attach the vers. 23v73 or could indicate a precise location. Thank you!
  59. mstombs

    mstombs Network Guru Member

  60. danix71

    danix71 LI Guru Member

    No, no, I was looking after the exact v.73 not any other...
    Anyway one question: installing Debian onto the Slug doesn't alter/change in any way the RedBoot, is that right ? Anytime after I can change back (install) my old firmware ?
  61. ddesjard

    ddesjard Guest

    NSLU2 - v2.3R73

    Got mine from Amazon and it also has this "beta" release.
  62. danix71

    danix71 LI Guru Member

    Once again, please an answer. Debian installed. RedBoot oke, APEX oke. How can I reverse to the original firmware or another (unslung, operwrt) ?
  63. u3gyxap

    u3gyxap Network Guru Member

    You probably could, but... why would you?
  64. danix71

    danix71 LI Guru Member

    Oke. It's a fair question.
    I've installed Debian following the well known steps. Didn't know before that but only that the original firmware (v.63) wasn't good for me.
    But didn't know either that Debian on Slug is only a console, accesible through ssh (installed on a Corsair 2 GB flash).
    I want a web gui not just a console, so...I'll choose another firmware.
  65. cip1959

    cip1959 Guest

    can you mail me the beta nslu2 file (latest upgrade..) thanks very much for your help
  66. danix71

    danix71 LI Guru Member

    It supposed to be accesible to anyone here. I didn't succed to download it 'cause of a crapy message ''you do not have permission to access this page. This could be due to one of several reasons''. Toxic, what the crap is that ? Can I and can I not download it, me or anybody else on this forum ?
  67. Toxic

    Toxic Administrator Staff Member

    Beta Firmwares have been removed due to the fact that firmwares are not allowed to be downloaded by anyone without the source code being made available as well. Since has not been given the source code or a link to it for each individual firmware, we are therfore unable to allow downloads of Beta Firmware anymore.

    If you need to contact anyone about this, please visit first of all. Then contact one of the departments here:

    You may only want the firmware, but without source code, we are not allowed to issue it to you. Sorry but thats not my decision :(
  68. danix71

    danix71 LI Guru Member

  69. anyheck

    anyheck Addicted to LI Member

    I know this thread is old...

    but linksys has made the R73 source available (R76 is there too):

    Unfortunately, the binary still isn't shown for download.

    Can someone now, allowably, post the binary build?

    I just got into this NSLU2 thing and would like to have a backup copy of my firmware just in case.

  70. mstombs

    mstombs Network Guru Member

    R76 is still available in the downloads section on this site.
  71. anyheck

    anyheck Addicted to LI Member

    Thanks, I went and found that one now.

    What are the differences between 73 and 76?

    I guess I'm just paranoid :-/
  72. anyheck

    anyheck Addicted to LI Member

    Looks like the NSLU2-General Yahoo Group has it.

    I had to use WINZIP to get it to de-segment the zip properly.
  73. Steve71169

    Steve71169 Serious Server Member

    Is it possible someone could send me the latest firmware for my NSLU2 please, I'm tearing my hair out trying to find it and Cisco tech support deny it exists!
    My email is swebb711 @
  74. mstombs

    mstombs Network Guru Member

    I used to have the binary and the source-code (c.f, if found will post it somewhere - never used it mind you - still have an nslu2 in use running unslung 6.10 (now on its 3rd 5V 2A psu!) - have another with a useful version of OpenWRT.

    What I had on a backup drive uploaded here:-
    Do check the files/dates (5 years old) and use at your own risk!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice