Firmware compiled from source bricked my RVS4000

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by robertwojo, Jul 23, 2007.

  1. robertwojo

    robertwojo Guest


    I tried to follow the instructions in the rvs4000 tarball exactly (which says run ./, add it to your path and 'make') but it seemed to have bricked my RVS4000.

    I used the following package:

    # md5sum RVS4000_v1.1.09.tar.gz
    f7d471fd9e3b82b5d5f373c18e90d272 RVS4000_v1.1.09.tar.gz

    and flashed the resulting rvs4000.img file out of this bunch:

    8389120 Jul 23 07:50 rvs4000_a.img
    8388608 Jul 23 07:50 rvs4000.bin
    8389120 Jul 23 07:50 rvs4000.img

    Any ideas? Did I burn using the wrong image file? Right now all I get is a solid power and diag LED. I tried the layer 2 recovery tool to no avail.

    And if you're curious I did this, it was to upgrade openswan 2.4.4 to support NAT-T with aggressive mode, something fixed in the later versions but I just applied the patches here: Something else that would work well for me is certificate support for IPSEC tunnels :wink:


    -- Robert
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice