Firmware upgrade continuously failing

Discussion in 'Cisco/Linksys Wireless Routers' started by Mindfreak7, Jan 30, 2009.

  1. Mindfreak7

    Mindfreak7 Guest

    Okay so I have an old WRT54G v2.2 and I figured it was about time to try some 3rd party firmware on it. After attempting a firmware upgrade with Tomato I received the message, "Upgrade are failed." At first everything worked fine, but after attempting a reset to factory defaults it was suddenly "bricked."

    Now after tons of research, I successfully loaded the newest Linksys firmware onto it using tftp and everything seemed to work fine at first, but I still have two problems:

    1. Anytime I try to load ANY firmware onto it now it comes to a page saying, "Connection has been reset," and if I go back it looks like it's working and then finally comes up with "Upgrade are failed" again.

    2. I'd be fine with the current Linksys firmware at least, but everytime I try to make changes in it it goes to a blank white page where "apply.cgi" should be and I can't actually apply the change, so essentially it's useless.

    Does anybody have any ideas?
  2. irootsk

    irootsk Addicted to LI Member

    Try to install DD-WRT firmware. It's supported for your router.
    Here is little HowTo.
    Also here you can find different DD-WRT firmware packages for you router. Just type in linksys and click on to your router.
  3. pharma

    pharma Network Guru Member

    I have the latest version of Tomato running on my WRT54G v1.1 . :)

    Try doing a search for "tftp2.exe" ... works wonders helping to load on older models, or download it here.

  4. badassz34

    badassz34 LI Guru Member

    I had a bum firmware update on my wrt54g v2 and had good results from the WRT54Gv2 FW3.01.3 updater (from linksys ftp site). It's executable, so you don't have to fool with tftp, which I never could get to work with mine, by the way. I had erroneously thrown v7 fw on my v2, and after it took a crap I tried to roll back to fw4.21, which was built for the v1-v4 models IIRC. It worked wonders in short order, just took me a couple fo weeks to stumble upon it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice