firmware upgrade failed on NLU2 now it will not startup

Discussion in 'Cisco/Linksys Network Storage Devices' started by michael_e6, Aug 14, 2005.

  1. michael_e6

    michael_e6 Guest

    hi can someone help
    i tried to upgrade the firmware to r63 on the NSLU2 after over an hour of the led flickering red , i did something maybe i should not have done, powered off the nslu2. now it will not startup, is there anyway i can fix this ????????

    many thanks
  2. beatgr

    beatgr Network Guru Member

    Powering OFF during a firmware upgrade!

    Michael -

    That is the reason that Linksys/Cisco issues a SPECIFIC warning to users NOT to power off the NSLU2 when performing a firmware upgrade. Same problem can happen when you do a BIOS (Basic I/O System firmware) for a personal computer and turn the computer off before it is finished.

    For your retrievable question, send the question to this group:

    Jim Buzbee

  3. roule

    roule Network Guru Member

    This is fine. but at some point, I too will have to give up. This is a 5MB or so firmware image, yet it's been loading for something like 6 hours now (Firefox is still patiently waiting for it to end!). The LED keeps flickering red/green. Ethereal traces in the last few minutes showed nothing other than TCP keep-alive packets. Why is this not flowing any faster? Where is the holdup?
  4. techmanblues

    techmanblues Network Guru Member

    Well, if the upgrade has not completed in 6 hours, it's a brick. has a link to a ultility that I used to downgrade from R63 to R29. It worked. The file is called Upgrade_207_XP.exe.

    You can also use a tftp utility from linksys. I got it from a LiveChat with the Linksys tech. I think both of these upgrading helper programs are tftp type.

    When you upgrade the firmware, always be aware that there is a chance that you will make the device useless. Firmware is like the BIOS on your motherboard. I only upgrade the BIOS or any firware when something is wrong or I must have some new features in the new firmware. The general rule of thumb is do not upgrade the firmware unless you absolutely have to. Good luck.
  5. roule

    roule Network Guru Member

    The funny thing is that I've tried upgrading and had similar results many times (ie. essentially hung upgrade). Between each time, I manage to get the NSLU2 back into a healthy state, at least to the point where the admin web i/f works and lets me try again. Usually this requires two power cycles (after the first, nothing but eth green LED). I am about to try one of these radically-different approaches. So if it's a brick, it's been a smart brick so far...

    My home LAN is 192.168.7.*, maybe this has something to do with my problem?


    P.S. why is it called a "slug"?

    P.P.S. I have also not been able to see the unit's shares from the other PCs on the LAN. Again, maybe that's an issue with IP address? Or with my home LAN design?
  6. techmanblues

    techmanblues Network Guru Member

    Well, it does not matter what the LAN IP is as long as all the machines belong to the same subnet as specified by the subnet mask.

    I have flashed and reflashed my NSLU2 many times over and yes, if it is a brick, it's a pretty smart brick. Basically at this point, I am convinced that this is a product that is not ready for primetime. I am convinced that is because the hardware is version 1.

    As to why it is called a Slug? Isn't it obvious? NSLU2 = SLUG. It's just an easier way to call it. Also from the fact that in its previous versions of the firmware, it's really slow. And Linksys for some odd reason, under-clock the chip in the NSLU2 at 50%. You can "over-clock" it if you want. The unslung website has a tip on how to do it.
  7. roule

    roule Network Guru Member

    I decided to live a bit dangerously. The top LED was still flashing red and green, so I assumed that meant it was in upgrade mode. I zapped the Firefox window that was still waiting (after 8 hours) for the download to complete, then installed Upgrade_207_XP.exe and used that to do the upgrade. A few minutes later, the slug was rebooting.

    After the reboot, it rejected connection attempts from the browser. So I pulled the plug and restarted it later. Now seems to be back in good health, with the more recent F/W (V23R63 -- is there a V25? I seem to have read about that at some point). This will be my upgrade path from now on!

    As for "slug", I thought maybe there was a more exotic explanation. No problem.

    Thanks! Pierre
  8. techmanblues

    techmanblues Network Guru Member

    Glad it worked out -- for now.

    There was a bunch of Releases between R29 and R63. The LiveChat Linksys tech admitted that, but they were never made public because I assume they were so buggy. If R63 is so buggy already, imagine what these unreleased versions would have done!

    Even though my NSLU2 is working fine now (with a few minor bugs), I am reluctant to buy a second one for my friends and clients. I am waiting for version 2 of the hardware to come out before that happens.

    Even the rock solid WRT54G was buggy when the first version came out. I think it's version 4 now.
  9. roule

    roule Network Guru Member

    Are there lists of known bugs with R63, either official or non-official? I'd like to know what kind of troubles to expect. The original version on the unit I bought (~R24) didn't keep time which would have been an issue. Now I'm on to the next problem (where my own LAN is the more likely culprit). The PCs don't see the slug, and it' s not IP connectivity since the browser i/f works (probably some firewall thing somewhere). Anyway, lots of interesting experiments if nothing else...
  10. techmanblues

    techmanblues Network Guru Member

    I have never had a problem with my PCs seeing the NSLU2. My problem has always been able to access the various folders using Windows sharing. It sometimes says that I have no permission to open these folders. A restart of the PCs has always solved this problem.

    Remember that the NSLU2 is basically a SAMBA server. Therefore any problems with accessing the NSLU2 have their basis in the interoperability between SAMBA and Windows networking protocols.
  11. roule

    roule Network Guru Member

    OK, I've been warned. Actually, my "home" directory at work is on Samba (has been for years), and that is working fine as a rule, so I might be OK. But Windows networking is really a big mystery. I still can't see the shares from the slug from either of two PCs on the home LAN, altho HTTP and (now with R63) FTP work fine (so IP is OK). R63 also supposedly supports NTFS (on USB 1), which would be a real plus.

    Anyway, a bit of a fun challenge to get this thing working. Maybe I'll have to learn a bit more on samba and windows protocols...
  12. beatgr

    beatgr Network Guru Member

    Windows issue

    Most likely a Windows network issue. I am having NO problems with WinXP SP 2. I will try it in a week or so with my Win2K workstation - with the current MS security hole & eventual patch!

  13. roule

    roule Network Guru Member

    I got it working by putting explicit entries in the router's host file (DNS). It would probably also work with LMHOSTS. For some reason, it seems that the broadcast mechanism for NetBios (NBT) name resolution is broken in my LAN. I'm probably guilty.

    I've also uNSLUng'ed my firmware. Seems much more stable, and the clock now keeps correct time. Still, I read thru a lot of comments here, and I'm wondering if I can really trust my data on this device. Time will tell I suppose.
  14. Mic-Re

    Mic-Re Network Guru Member

    Hi roule,

    in case you still haven't solved this problem under Windows:

    I think its just a question of the propper user rights on your NSLU!
    The NSLU will only show the shares allowed to the user (PC) logging in to the NSLU.

    1) Make sure the NSLU and the PC's are in the same network group.
    2) create the same useraccounts and passwords on the NSLU as the users on the PC already have and don't forget the rights of the shares!

    The shares in question should now show up under NETWORKPLACES in Windows. Easiest way to acces them is to map them as network drives under windows.

    Open the windows browser... klick EXTRAS... klick 'Connect to a Network drive' ... assign a drive letter... search for the sharefolder in your network ... than klick on ' connect to it under a different username' (just to make it waterproofed)

    Voila! You should now have mapped a new drive and the share is accessible as any other drive on your PC.

    (I hope that I translated it right to english since I use a german windows :D )

  15. huntertan

    huntertan Guest

    Upgrade and cannot find the NSLU2

    HI Folks!
    Need help , after flashing the firmware, it seems to boot up nicely, the LED seems to indicate not major problem. But I cannot locate it on, my network is , and I really don't know what IP address it is using now, I tried direct cable connect to my pc and access for Redboot I still cannot find it !!!
    It is so frustrating !! Anyone have a tool to find out what IP this fellow is now sitting on??

  16. Mic-Re

    Mic-Re Network Guru Member

    Hi Huntertan,

    It looks like it doesn't boot up right or at least not completely.
    Here is what a support tech told me when I lost control and response of my NSLU:

    1) Press the reset button at the backside of the case for more than 10 or better 20 seconds with a small pin or a needle.

    2) power it down and up again.

    3) All settings should now be back to absolute default! Admin-password, IP and so on. User passwords and shares are still stored on the discs (format ext3).

    If you can't contact it now and it is still not responding to the set up utility from the CD than power it down, pull the power cable and open the case to take out the eprom-battery. The case is made up of two shell parts snapped one into the other. You have to slightly dent one of them near the seam with your fingers and pull the other part away.

    As with all electronic circuitry be carefull not the accidentially shortcut any solder pins!!!! No wet hands, no woolen clothing (static charge), no metal in its vicinity... etc! Take the battery out for half an hour (fingers or tooth pick).

    All former settings are now deleted and the NSLU should start up clean with the default settings.

    It worked with me!

    OR if you don't want to take the risk of breaking it, call the support team first and ask for other options

    Good Luck
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice