Firmware upgrade problems.

Discussion in 'General Discussion' started by sonarogre, Oct 24, 2006.

  1. sonarogre

    sonarogre LI Guru Member

    Heya, sorry to bother.

    Here's the deal. I've got a WRT54G router running (according to it) 1.00.00 firmware. This is a WRT54G v5 according to the serial number.

    I've manually tried to upgrade the firmware and it didn't work.
    I've tried the auto updater and it also failed. (This didn't detect any firmware version and upon upgrade gave the error "Invalid code pattern".

    This was the WRT54G Linksys Furmware Upgrade Utility downloaded from this site.

    I've been having a lot of problems with this router, unable to DMZ, and generally sluggish response when editing the menus. I've also had a lot of problems connecting to people to play games, though this seems to be a specific person when it occurs and not a general problem. But it is the reason I want to upgrade.

    Any advice would be appreciated. Thanks!
  2. grcore

    grcore Network Guru Member

    return the v5 and buy a WRT54GL, or a WRTSL54GS
  3. NateHoy

    NateHoy Network Guru Member

    What error message did you get when you tried the manual upgrade? Did you download the official Linksys firmware from their web site, and are you sure you got the correct version?

    Here is a link to version 1.01.0 of the Linksys firmware:


    I'd start with a complete factory reset (either go into the Administration menu and select "Factory Defaults" or press and hold the reset button for 30 seconds while the unit is plugged in). From there, try the upgrade using the web GUI again.

    The original firmware for the V5 units had a LOT of problems, and you really need to get it upgraded.
  4. sonarogre

    sonarogre LI Guru Member

    The manual upgrade gave an immediate error message "upgrade are failed". Yes, that is the exact message. It then proceeded to show a progress bar that went along until 75% and hung for over 2 hours before I closed the browser. Yes, I know thats a bad thing to do.

    I'll try the 1.01.00 firmware. Thanks.

    If it's a no go I'll consider an upgrade, I'm afraid its way too late for a return.
  5. sonarogre

    sonarogre LI Guru Member

    Ok, the 1.01 firmware update worked. Is there anything beyond that?

    Thanks for the help guys.
  6. bluej100

    bluej100 LI Guru Member

    I am in the same position. 1.01 worked, but 4.30.5 and dd-wrt v.23sp2 still give "Upgrade are failed" after two seconds.
  7. Toxic

    Toxic Administrator Staff Member

    I guess no one sees the description and the first 2 lines. I make them BIGGER

    WRT54G v1.x-v4.0 and WRT54GL v1.x ONLY

    WRT54G v5v6v7 NOT SUPPORTED!!!!
  8. bluej100

    bluej100 LI Guru Member

    Sorry to be a dumb n00b.

    I realized I'm running a v6. That would explain why only 1.01 firmware update worked. Thanks for the link, Natheoy.

    Does anyone know--does dd-wrt not support v5+ either?
  9. bluej100

    bluej100 LI Guru Member

    The Bitsum Technologies WRT54G DD-WRT upgrade wiki was extremely helpful. I now have DD-WRT running beautifully.

    By way of warning, midway through the process, your router will lose almost all functionality. If you're running a dual-boot system, as I am, the instructions are slightly easier to follow in Windows.
  10. Toxic

    Toxic Administrator Staff Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice