Fixing WRT54G 1.0

Discussion in 'Cisco/Linksys Wireless Routers' started by ixirockx, Nov 7, 2005.

  1. ixirockx

    ixirockx Network Guru Member

    can you debrick a wrt54g 1.0? i was gonna short the pins i found the flash chip and they are not numbered though so i dont know which one is 15. can anyone help me? all it is is my power and diag light are on constantly and nothing else is on. thanks for the help!
  2. Toxic

    Toxic Administrator Staff Member

    can you ping the router at all?

    if you look at the flash chip it will be numbered


    Top right of chip is 1
    Top left of chip is 24


    revival guide is here:

    WRT54G revival guide
  3. ixirockx

    ixirockx Network Guru Member

    no i found the flash chip its called like AMD385793DS or something its AMD but its not nubmered and i need to know what the numbers are so i get the right pins its a wrt54g 1.0
  4. Toxic

    Toxic Administrator Staff Member

    there should be a 1 somewhere in the corner of the flash chip on the PCB. the flash chip is under the radio card on the v1.0

    if you look at the image agin i have highlighted the 1 on the PCB
  5. ixirockx

    ixirockx Network Guru Member

    cool thanks for all the help but i dont see a 1 all i see is an arrow (circled in the pictures)




    does that mean 1 i'm assuming? and then everything to the left of that is through 24? and the bottom row starts 25 on the right side and 48 ends on the left side? thanks for all your help i really appreciate it!
  6. Toxic

    Toxic Administrator Staff Member

    Then that is pin 1 next is pin2 etc etc

    i used to have a v1.0 many moons ago...
  7. ixirockx

    ixirockx Network Guru Member

    thanks i got it into failsafe mode and now i cant tftp an image to it. it keeps pinging......pinging.......pinging successfully and when i go to tftp it says timeout occured. teh networking lights are now working and the diag light is blinking instead of solid so i need some help. thanks :D

    EDIT: ok the commands im putting into CMD are as follows:

    cd C:\ (yes firmware.bin is in C:\)
    tftp -i PUT firmware.bin .bin

    what am i doing wrong?
  8. tunne

    tunne Network Guru Member



    Have a similar problem as ixirockx. I flashed my WRT54G V1.0 (approx. 2,5 years old) two weeks ago with the Alchemy V1.0 (downloaded from

    Worked really well for a week but since this thuesday my Linksys is dead.

    First I had a green power led and a red diag led, both constantly on. After resetting the WRT54G I only had a power led.

    Tried using the Revival Guide as explained in this topic but nothing works. Can't ping, can't get the device in failsafe mode, ...

    Also tried the suggestions here but no luck.

    Lost case or do you guys have any suggestions for me?


  9. cgondo

    cgondo Network Guru Member

    Have you tried JTAG?
  10. tunne

    tunne Network Guru Member

    Haven't tried JTAG since I don't have the material to build the adaptor...
  11. tunne

    tunne Network Guru Member

    In case I'd buy a new Linksys what should I buy?

    In case of a WRT54G I shouldn't take the V5 device (no Linux firmware). Is this right?

    And what about the WRT54GS, do all versions have Linux firmware?

    Thx in advance,

  12. boomhaueruk

    boomhaueruk LI Guru Member

    Solid red light - WRT54G v1.0

    Is that it then?
    If you do all this stuff and it doens't ping:
    Same thing.
    Got a Wrt54g v1.0 (no intel chip).
    Have tried the powering on with pins 5 and 6 bridged (apparently the flash chip is under the pcmcia card and you count from the white triangle).
    Tried 15 and 16.
    Tried the bridging to the antenna.
    Spent ages doing stuff from forums and the like..nada.

    Some people mention using copper wire rather than a screwdriver, I'm going to try that next.

    Anyone got this working or would like to give more detailed information of how they did it if it did work?

    Best I could find on the web was:
    "Ok, now for the nitty gritty fun part. Locate pin 15 (third white mark starting from pin 1). Take your jewelers screwdriver
    (philips head is what I used, nice and pointy) and stick the point between pins 15 and 16 (see 1. NOTE1). While holding
    the screwdriver there, plug in the power and watch your ping screen. Hopefully you will be amazed at seeing the pings
    starting to succeed. Don't be so happy that you drop the screwdriver on the board and start sparks flying. Remove the screwdriver
    and the pings should continue.."

    Which they didn't...not for me.
    It just sat there saying "cable unplugged" in windows.
    I found:
    "I recently bricked my WRT54G v1.0 and tried the PIN jump, too, and it worked for me.

    The 1.0 flash chip is (unlabeled!) under a mini card and you need to brick pin 5-6 when counting from the side with the white triangle, I don't know about v1.1, I read I need to jump 15-16 and white triangle is PIN 1, but actually it was 5-6, although I read 15-16 is with older models and 5-6 with newer ones only...anyway, worked for me.

    connect it to your box and start an infinite ping, then get the jewelers screwdriver on those pins and power it on, after 2 seconds or so it started responding (you can take off the screwdriver once it responds)."

    "I used a piece of duct tape to hold the wire to ground while I touched 16 and powered on and a magnifying glass . The magnifying glass is a must. You have to do a sherlock holmes with it, that is hold it right up to your eye and move your face right up to the pins. Old tech and new nose to nose."

    "Jumping pin 16 to the antenna works!"

    Except, it doesn't.
    Not for me. Same thing, windows never sees a signal.
    Tried 2 network cables.

    Anyone? Any ideas?
    Any more detailed explanation?
    Have I just got to buy some odd JTAG cable and gamble against the cost of a new router?????
  13. boomhaueruk

    boomhaueruk LI Guru Member

    Incidentally I have solid red diag light and solid amber power lights only.
  14. boomhaueruk

    boomhaueruk LI Guru Member

    No replies

    No one?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice