Flaky behavior on WRT54Gv2

Discussion in 'Tomato Firmware' started by garyfritz, Jun 4, 2011.

  1. garyfritz

    garyfritz Addicted to LI Member

    I've been running 1.23 on a WRT54G2 for several years. It's always been a bit flaky but it provided the wifi for my kids so it wasn't a real high priority.

    Well it's been getting flakier, they're getting more sophisticated, and it's becoming more of an issue. I'm sick of fighting with the @^#!! thing.

    It's never been much good at holding a connection. This is for all devices: their computers, their iPods, etc. Often it would drop the connection and I'd just tell them to re-connect to the wifi, and that would work.

    I boosted the power to 150 mW and that didn't help much.

    I finally got a wifi repeater so they'd at least have a strong signal in the basement, where they usually use it (and where the signal was weaker). That didn't help much.

    I thought maybe a more recent release might help. This morning I updated it to 1.28. Twice since then the router has "disappeared" -- no visible SSID broadcast. Sometimes I could get at the web interface, sometimes not. So I just downgraded to 1.27.

    Any suggestions what might be wrong? Should I give up on Tomato and go to another firmware? Or does this indicate the hardware itself is flaky?

  2. ntest7

    ntest7 Network Guru Member


    First thing to try after unexpected behavior is to do Administration/Configuration/Restore Default Configuration (thorough), and then setup the router by hand -- don't restore a backup.

    Try the ND version of tomato if your router supports it (see the download page for details).

    There have been reports of Intel wifi cards interacting badly with broadcom-based routers in general. If any of your laptops have Intel wifi, see if there is a newer driver for the laptop.

    There have been reports of some Apple products interacting badly with wifi. Make sure your i-whatever has the most recent software installed.

    It's worthwhile to turn off one device for a period of time to see if maybe that one device is causing problems.

    Try repositioning your antennas. Sometimes I've found that putting one up and one out -- like [ | _ ] -- helps with different floors.

    Finally, after you eliminate those things, consider flaky hardware.

    It's possible that some other software will tickle the flaky hardware in different ways, so at that point it's reasonable to try something else. But don't expect too much.
    You might also consider some of the enhanced tomato builds, such as Victek or Toastman.

    I believe Tomato 1.28 (& 1.27) to be very stable and reliable when run on good hardware. I have several routers running those versions with no trouble, with a wide variety of devices including Apple and Intel.
  3. TexasFlood

    TexasFlood Network Guru Member

    I mostly agree with ntest7.

    I'd do is a thorough NVRAM reset. And yes reloading a configuration backup essentially negates the benefit of this.

    In the old days I'd write down my settings or capture them with something like scrapbook for firefox, then re-enter them all manually.

    But Toastman showed a better way in posts like this one and this one.

    You CAN manually re-enter settings if you like. But I'd use Toastmans method to backing up and restoring any settings that might be too painful to manually re-enter.

    Also with my WRT54G v2 router I found, in MY tests, that 42mW TX power was the best setting for me. Much more than that and it got flaky. IIRC this was before Tomato started using this number as the default setting, but obviously I agreed with it since I'd come up with it independently with my own testing.

    To quote Jeff Boomhauer: "Tell you what, man. Talkin' 'bout ol' meanin' of life, man. Go read that ol' Hitchhiker's Guide, man. You know, talk - talkin' 'bout ol' four -- 42, man." I don't have a store of memorized King of the Hill quotes memorized, but the episode with that quote (The Passion of Dauterive) was just on so stuck in my mind.

    Ever since I've been pretty conservative with TX power settings and had good luck. I pay more attention to positioning the router and measuring the results until everything looks best than pushing the TX power. I know there are reports of using much higher settings without problems, just reporting what I observed. Also on my newer N routers I did some speed tests and found increasing TX power much slowed file transfers, just further confirmation of what I already believe.

    If 1.23 is working for you, fine but I'd consider upgrading it for security and perhaps improved compatibility.
  4. garyfritz

    garyfritz Addicted to LI Member

    Thanks guys. I'll work on trying those things.

    That's why I suspected the hardware. I upgraded to 1.28 and it started hanging and/or the wifi disappearing. Sometimes I can reboot it from the web UI, sometimes I have to go upstairs and pull the plug. So if 1.28 is reliable, that suggests that maybe my hardware isn't. Odd though that 1.23 didn't do this...
  5. TexasFlood

    TexasFlood Network Guru Member

    Or perhaps your NVRAM is full or corrupt which is why we were suggesting to try and clear it.
  6. garyfritz

    garyfritz Addicted to LI Member

    Ah, I see. OK, I'll give it a try. First I have to kick my kids off. :)
  7. Toastman

    Toastman Super Moderator Staff Member Member

    You might also find this link interesting. It will be difficult to isolate the source of any problems, but usually it's a client that causes the hassle. As you can see, it's a common enough problem!


    As ntest7 said, it's absolutely essential to use an ND version (the newer drivers) if you aren't already. Since you are using 1.23, then you probably aren't.

    A version that was known to be very stable is Victek's 8515.2, which you can get here:


    Or there are newer versions to look at. But I'd try that one first, as it's kind of a "reference" standard as far as I am concerned. I still run it on around 400 WRT54GL's, and they are usually up for several months at a time.

    [As an additional teaser, and speaking as an engineer, I would never use wifi to connect to a computer at all, given the choice. The whole technology is a can of worms, buggy, top-heavy total POS in my opinion. Why not run some cable around the house ? Try one at first and see what you think. You'll probably be grateful you did. It isn't practical to do it in 350 room apt. blocks, the cost is just too high, too many expensive switches needed, and the cables and sockets keep getting damaged by users - or I would go start cabling every room right now.]
  8. garyfritz

    garyfritz Addicted to LI Member

    Thanks, after I reset the NVRAM I'll try 8515.2. But it contains a .trx file instead of a .bin file. Can the WRT54Gv2 (*NOT* GL) load that OK? Sure don't want to brick my router by feeding it the wrong format data.

    Re: wifi: I use a cabled connection to my office. The Tomato router is for my kids, and a significant part of their usage is for their iPods. Cables don't work too well for that. Plus we don't have any cables running to where their computers are, and wifi is a whole lot less headache (even with these reliability problems) than running cables through the house...
  9. Toastman

    Toastman Super Moderator Staff Member Member

    Just change the extension to .bin
  10. jed_99

    jed_99 LI Guru Member

    One thing I've had happen to me this past year, with a few different brands, was dodgy power supplies. My last one to give me grief was an Asus WL-500gP. It had started giving me wireless dropouts, then wouldn't grab an IP from my ISP, and then no boot. Replaced the brick and its back in use, stable as ever.

    Food for thought.
  11. garyfritz

    garyfritz Addicted to LI Member

    OK, I've done the thorough NVRAM reset, flashed it with Tomato_RAF_1.25.8515.2-ND.trx/bin, and repositioned the antennae. I left everything at the defaults except the basics like IP, Wifi encryption, etc. We'll see if that helps any.

    One question: how can I set the WAN address? It's getting set by DHCP on its upstream router. I used to have a fixed IP address on the external port but I can't see how to set it now. Can't seem to set the DHCP assignment on the upstream router either.
  12. garyfritz

    garyfritz Addicted to LI Member

    Hrm. I set it up and tested it (from my W7 laptop) and everything was fine. One son got up this morning, deleted his memory of the wifi connection in W7, and was back on the air in no time. Other son is still running on XP, and we can't get his wifi to connect. I specified WEP2-PSK (TKIP) in Tomato, and I specified that in XP, and it won't connect. It doesn't say the key is bad, it just tries and tries and gives up. !?!??

    I can't remember how XP handles this stuff. I tried to delete the wifi stored config but I can't find out how. All I can do is remove it from the "preferred networks" list. That doesn't work because it doesn't prompt me for a wifi keyword when I try to connect.

  13. ntest7

    ntest7 Network Guru Member

    (I assume you mean WPA2 rather than the non-existent WEP2.)

    Depending on how your XP has been patched up, you might have better luck starting with "WPA Personal" and "TKIP"

    After that works, you can try the newer WPA2 Personal, or the combo settings such as "AES/TKIP" or "WPA/WPA2 Personal".
  14. TexasFlood

    TexasFlood Network Guru Member

    TKIP is the devil, AES is the way to go, :wink:
  15. ntest7

    ntest7 Network Guru Member

    Depending on what patches/updates are applied, XP may have trouble with AES, and may not be able to use WPA2 at all. Start with WPA/TKIP.
  16. TexasFlood

    TexasFlood Network Guru Member

    ntest7, you may be right but I have two XP boxes, one pretty back level, that work fine with WPA/AES. I use WPA, not WPA2, but it seems to work fine with AES. I think AES, or CCMP, is the biggest difference between the two anyway, so not sure it makes all that much difference as long as you're using AES.
  17. ntest7

    ntest7 Network Guru Member

    Old versions of XP had trouble with AES, and couldn't do WPA2 at all. This may be aggravated by what kind of wifi card you have and if you use built-in windows wifi management or the card's bundled software to manage the connection, resulting in a bizillion variables of what works and what won't. Even Vista is better... or at least more consistent.

    Patched up XP-sp3 using the Windows wifi management should work fine with WPA/WPA2 AES.

    For older devices, first try WPA/AES. If that doesn't work, you'll probably need to use TKIP or find updates for the old device.
  18. garyfritz

    garyfritz Addicted to LI Member

    Yup, you guys nailed it. XP SP2 couldn't do WPA2 so I backed off to WPA/TKIP and updated it to XP SP3. Haven't had a chance to update to WPA2/AES yet (better than WPA2/TKIP?) but I suspect it will work fine. Then hopefully the reset router with the good software will improve our results.

    Thanks for all the help!
  19. ntest7

    ntest7 Network Guru Member

    AES is the preferred encryption as it's faster and more secure than TKIP. TKIP is an older standard and more likely to be supported by old clients, but use AES if you can.

    WPA2 is the newer standard and preferred, but there's not much practical difference between WPA/AES vs. WPA2/AES.

    more secure/newer << ------ >> more compatible/older
    WPA2/AES -> WPA/AES -> WPA/TKIP -> WEP -> Open
  20. TexasFlood

    TexasFlood Network Guru Member

    TKIP worked but I had stability issues with it. I have had great success with WPA/AES even on older versions of XP.
  21. garyfritz

    garyfritz Addicted to LI Member

    BTW I'm still wondering -- is there any way to set a fixed IP on the WAN address? I can't find it in the Tomato software, and I can't seem to control it in the upstream router that's handing out the DHCP assignments...
  22. Toastman

    Toastman Super Moderator Staff Member Member

    Do you mean Basic/Network/Static ?
  23. garyfritz

    garyfritz Addicted to LI Member

    Under Basic/Network I don't see a "Static." There's a Static DNS entry but that's not what I want. "Router IP Address" sets the address *inside* the subnet. I want to set the address on the *outside* port, the one that plugs into the upstream network.

    Status/Overview shows the "WAN IP Address" but doesn't let you change it. It's set by the upstream DHCP server. How can I set it to a fixed IP?
  24. TexasFlood

    TexasFlood Network Guru Member

    You can set your WAN port IP under Basic->Network->WAN/Internet section. If your ISP provides a static address like some folks I know then you should set this info statically. If your ISP provides dynamic addresses, I would not recommend trying to set a static address in this way. First of all the ISP equipment might not even allow it and even if they do, you'll quite likely end up with a conflict at some point when the IP gets allocated to someone else.
  25. Toastman

    Toastman Super Moderator Staff Member Member

    Excuse me, all versions I have ever seen have a static entry for WAN. It may not be what you want, but it's there. That is why I asked the question, are you missing it?
  26. garyfritz

    garyfritz Addicted to LI Member

    D'oh!!! Thanks TF, I just needed somebody to rub my nose in it. The dropdown was set to DHCP so of COURSE it wouldn't let me set the IP. *DUH*.

    Not to worry about the IP. This router doesn't connect to my ISP. :) I have a rather complex network in my home, with THREE routers. One is a "gateway" that hooks to the ISP. The two others connect into the gateway to provide two independent and isolated subnetworks. One of those is my & my wife's work network, with all of our business data on it. The other one (the Tomato browser) is for my kids. This means the boys with their less-than-sterling web-browsing habits are isolated from our business-critical data. It also means Tomato can kill their net access at 10:30pm. (sinister dad chuckle :)
  27. TexasFlood

    TexasFlood Network Guru Member

    OK, just checking, wasn't clear from your post that you understood the potential risks of setting a static iP as you obviously do. So sounds like you have some double NATs doing there. I've done that myself in the past and was always warned of the problems with doing so such as VPN not working. The only really problem I had was PCs not seeing each other on the subnet making file sharing and such difficult. Of course if that's your GOAL then it's all good, hah. As for as controlling access you can also do that with Tomato by MAC or IP in a flat network, six of one, 1/2 dozen of the other I guess.
  28. garyfritz

    garyfritz Addicted to LI Member

    Not sure what you mean by double NATs. I have each router in a separate subnet: 10.1.1.* on the gateway, with 10.1.2.* and 10.1.3.* plugged into the gateway, all /24. Yes, the GOAL is for business-subnet and kid-subnet to be unable to see each other. I want that isolation to protect us from any potential virii they pick up.

    You can control access by MAC/IP, but AFAIK that's always-on or always-off. The nice thing about having the kids on their own subnet (besides the isolation) is that I can shut down the subnet on a schedule. Don't think you can do that by MAC.
  29. TexasFlood

    TexasFlood Network Guru Member

    Well, I mean if you create your subnet by connecting the WAN port of one router to a LAN port of another router, that WAN->LAN connected router communication is via a NAT table. And if the primary router is already NATing to the ISP network, you have yourself a double NAT for clients hanging off the secondary router. I'm not saying it's a bad thing, just that it exists. Well, if you're doing it that way. The way I read your post I thought you were but perhaps I mis-read. I did it that way for a while, it was just the simplest way to add wireless routers to my original wired router when I first got some. But later I went back and flattened my network out to ease file sharing and such.

    You can apply access restriction rules by times, and even select certain days of the week,for any MAC or IP or group of them, I've done this and it works better than my kids wish it did.
  30. Toastman

    Toastman Super Moderator Staff Member Member

  31. garyfritz

    garyfritz Addicted to LI Member

    Aha. I hadn't noticed that restrictions could apply to IPs/MACs. Useful to know, but for now the 3-router solution is working fine. Especially since we *want* the isolation.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice