Flashed with tomato , wireless problems now :(

Discussion in 'Tomato Firmware' started by Anax, Aug 10, 2008.

  1. Anax

    Anax Addicted to LI Member

    First off , Hi everyone sorry for making this my first post .. I looked through the wireless connection thread which is posted in the sticky but it wasnt very helpful . I am not sure if this gets asked a fair amount but here I go.

    I was having odd issues with my connection dropping , turns out it was my linksys router so I had upgraded to tomato ( im hardwired to the router ) and horray I have no dropped from ventrilo nor any games this morning unfortunately another problem arose .

    I hear someone screaming downstairs while I have my head phones on , Turns out now my fathers business computer ( Cannot configure the card as there is no admin access to it . Information : It's using ThinkVantage Access Connections , which I am guessing is IBM's little wireless program , The card is an intel 3945ABG ) is not connecting as it is not authenticating .

    Now when i test for networks via windows detect nothing shows up , Yet in this ThinkVantage it does show up . ( Thats what it is trying to connect through and yes the name is broadcasted )

    I didnt notice the problem at first as I was trying to enter WPA keys etc and figured that was the issue.. So I reverted back to No security , Turned the Afterburner off , Changed the channel back to 6 and still nothing . Yet the computer across from me using a linksys card ( with the linksys software ) finds the network on this and is able to use it.

    I am not very good at this stuff so you will probably have to talk in simpleton terms and for that I am really sorry but when people say change this and that I need to know exactly how to do it .

    Linksys WRT54G / CDF7 router . Signal strength is 100 to the card in the laptop .

    Can I revert back to a linksys firmware if I want without bricking the router? nvramw as cleared after I flashed the firmware.

    Wireless Mode Access Point
    B/G Mode Mixed B+G
    Radio Enabled
    SSID Loomis
    Security -
    Channel 6 - 2.437 GHz

    Afterburner Disable
    AP Isolation Disable
    Authentication Type Auto
    Basic Rate Default
    Beacon Interval 100
    CTS Protection Mode Disable
    Distance / ACK Timing 0
    DTIM Interval 1
    Fragmentation Threshold 2346
    Frame Burst Disable
    Maximum Clients 128
    Multicast Rate Auto
    Preamble Long
    RTS Threshold 2347
    Receive Antenna Auto
    Transmit Antenna Auto
    Transmit Power 42
    Transmission Rate Auto
    WMM Disable
    No ACK Disable
  2. gregg098

    gregg098 LI Guru Member

    Did you clear the NVRAM after you upgraded? Sometimes a weird value can stick in there from the other firmware and throw things off. If you didnt do this, goto ADMIN->CONFIGURATION->RESTORE DEFAULT CONFIURATION and choose ERASE ALL DATA IN NVRAM.

    Then redo your settings and see if this helps.

    Also, another thing to try is to go into the laptops settings for the wireless connection, and find out where the wireless program stores all of the access points it has connected to. On my work laptop (Dell), there's a tab that lists everything I have connected to at one point and you can order them in the priority you want it to try to connect. Delete all of the connections (or at least the SSID from your house), then try again.
  3. Anax

    Anax Addicted to LI Member

    Yeah I have cleared it several times , still no go. As for the access points no idea where to look I saw prefered ones ( using mac id's but none were actually set )

    I have been googling up a storm and all i am finding is turning off afterburner but thats not my solution unfortunately.

    I guess all I can hope is someone else had this issue , If i put the linksys firmware back on should I be ok? ( not connection wise , i just mean not bricking my router )
  4. Anax

    Anax Addicted to LI Member

    Eh I give up , Flashed back to linksys's firmware and everything seems ok .. Guess I have to deal with the drops in connection ( even hardwired ) and no mass network bandwidth monitors .

    maybe one day i will get the problem solved.
  5. rhester72

    rhester72 Network Guru Member

    Did you flash with Tomato or Tomato ND? The latter is not a good choice for your device.

  6. TexasFlood

    TexasFlood Network Guru Member

    I have a WRT54G v2.0 (CDF5) and Motorola WR850G, have no problems with Tomato and Intel 3945ABG on a Dell laptop. Have a thinkpad but it doesn't have the 3945ABF, but a non-specific Atheros ABG. Works fine.

    With access connections, my experience has been that it's best to delete old profiles and recreate them if anything changes. If that's not possible then make sure the hew router settings exactly match the old. The problem with that is...

    My thinkpad often won't "see" a router with different firmware intially. Seems like there is some configuration or cache that needs to be cleared. It doesn't happen real often, usually when I've had the laptop connected wirelessly for some days. Connecting to another wireless network then back sometimes clear this issue. Powering off the wireless card for a bit also often does the trick. A laptop reboot is the next step that is sometimes reqiured to fix this. I can't tell you why it happens, it's black magic to me, just telling you what I observed & what has worked for me.

    Also noot a bad idea to remove power from the router and Internet modem for a bit when something like this happens. A reboot or a good fresh cold boot might be crude but it's amazing what problems can be solved this way sometimes. At the very least you know you have a good clean slate to start diagnosing from.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice