Folders missing when connected to NSLU2 - HELP!

Discussion in 'Cisco/Linksys Network Storage Devices' started by georgep7, Nov 24, 2005.

  1. georgep7

    georgep7 Network Guru Member

    Hi everyone, what I've done:

    1. Purchased Lacie 160GB external USB2 drive
    2. Formatted it on my laptop using NTFS
    3. Copied my files over to it.
    4. Connect it to port 1 on my NSLU2 (IP address which has the latest firmware that supports NTFS drives

    Ok, drive appears in the network, I can map it, and open it in explorer. HOWEVER, some folders are missing! I can't see them at all. When I try and create those folders on the drive I get an error:

    "Cannot rename New Folder: Access is denied. Make sure the disk is not full or write-protected and that the file is not currently in use."

    I can create other files/folders ok, so it got me thinking that maybe the folders are actually there, but just can't be "seen" by the NSLU. So, connected the USB drive drive back to my laptop, and yes, the folders are actually there!

    The linksys people have recommended I reformat the drive in NTFS and try again - I am happy to try this, but as there is 100GB of info on there and it will take me a while, I'd rather not if there is an obvious solution.

    Can anyone help? Thanks!
  2. georgep7

    georgep7 Network Guru Member

    Here is an update - I have done some investigation on which folders do not show up and they are folders with quite a few files in them (>1000). So anyone else see this problem? I was under the impression that with NTFS there wouldn't be any limitation on size of disk, size of file or number of files per folder. I am assuming that the linksys has a problem with seeing folders with large numbers of files in them. I am currently getting this verified with Linksys.
  3. georgep7

    georgep7 Network Guru Member


    That is the answer from Linksys - they have run some tests in their lab and have identified that folders with more than a few HUNDRED files will NOT be seen by the linksus NSLU2 - it has a memory limitation.

    Absolutely pathetic......
  4. Doug_B

    Doug_B Network Guru Member

    Is this limitation specific to NTFS-formatted drives attached to the unit or is it more ubiquitous.


  5. d__l

    d__l Network Guru Member

    This would be specific to a NTFS-formatted drive as I have folders on ext3- and FAT32-formatted drives with nearly several thousand files in each folder with no problems.
  6. custk9

    custk9 Network Guru Member

    Been using Maxtor in Icy Box casing, 3 partitions, 2FAT32, 1 NTFS. Lots of troubles (files apparently missing, long transfer times, even lock-ups with the need to hard-reset the slug).

    Changed to 4 partitions, all FAT32. Worked like a charm. After that, added another HD (EXT3), worked even better.

    IMHO NTFS and Linux aren't friends. There have been a few attempts to write NTFS drivers for Linux, all with issues. So add one more to the list.

    So, if possible, stick to FAT32 (<4Gb files) and/or EXT3.

  7. maunakai

    maunakai Guest

    Sorry for my english. Could be your problem, may be you tweak Windows XP with "disable 8.3 filename creation"? Then you have to enable and it will be ok.
    Me i have a 200Go Ext3 on port 1 and a 250Go Ntfs on port 2 and it's working pretty well.
    I also try with a hub usb2 on port 2 and then two ntfs disk and still working good.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice