[Fork] FreshTomato-ARM

Discussion in 'Tomato Firmware' started by kille72, Apr 15, 2018.

  1. txnative

    txnative Addicted to LI Member

    There is a commit about the way nvram space is limited on this model. https://bitbucket.org/kille72/freshtomato-arm/commits/4a0b09ad7609aa46eec7ec2df934d7939cca3279 someone my have to build a special image with openvpn, pptpd but that would mean to remove something in order to make it fit to limited space.

    (edited)
    kille72 would it possible to build the dir-868l to nvram_64K instead of the 32 bit size or is there something else that is missing for this model that isn't written about changing it? Regards
     
    Last edited: Dec 28, 2018
  2. Wizardknight

    Wizardknight Serious Server Member

    Yes. It supports VPN client and server settings.There is a known issue when trying to have more than 1 VPN client settings stored at the same time, but it works fine if you have just 1 client info entered.
    Well at least it does for the 6300v2 units I use.
     
  3. wolfwolf

    wolfwolf New Member Member

    Hello im new to all this, i have sucessfully flashed newest Fresh Tomato firmware to my Xiaomi R1D.
    How can i usb tether my Mobile Phones Internet Connection to the Router now?
    I have plugged in a USB Charging Cable from my Mobile (Xiaomi Redmi Note 5 Pro) to the USB Port on the Back of my Router and enabled USB Tethering in the Phone.
    On the Router side i have switched the WAN Setting to 4G.
    Yet it shows connecting and my ip adress shows 0.0.0.0
    Can someone help me, what do i need to do to share my phones unlimited Plan with the Router
    Also my router CPU gets very hot, like CPU Temperature91°C / 196°F.
    Should i be worried?

    thank you
    wolf
     
    Last edited: Dec 29, 2018
  4. cloneman

    cloneman LI Guru Member

    Yes, it does.

    Perhaps someone should upload a Freshtomato WebUI simulator demo?
     
  5. Sean B.

    Sean B. LI Guru Member

    The 4G option is meant for cellular modem dongles an the like, not USB tethering. The thread here , while old, does have a script that can be inserted in the hotplug custom config box under the USB section in the GUI and is designed to configure the interfaces/routes etc needed for the connection to function. It may or may not work with current firmware.

    While "normal" temp ranges differ between make/model of router, in my opinion 91C is excessive. I'd suggest, if you feel capable of doing so without causing damage, disassembling the router casing and clean the PCB + any heat sinks with compressed air. If there's a decent amount of dust/lint buildup it will increase temps dramatically.
     
    Techie007 and kille72 like this.
  6. PeterPann

    PeterPann New Member Member

    Hello, I have also the same router but Im a newbee in all of this. Coud you please help me by telling the procedure of flashing the xiaomi rom with this one? Is everything working fine with this rom,like nas, vpn...? Also would it be possible to flash back to xiaomi rom if needed? Thank you for your time
     
  7. wolfwolf

    wolfwolf New Member Member

    Yes of course but i cannot post links, no permission, search google for
    "adslzone exclamation sort of review mi nuevo router xiaomi r1d.423586"
    you can translate with google translate
    all went well following this guide, but i will flash back to stock, this thing turned into an oven, very hot
    you have been warned
    it was cool on stock
    i do not understand why another firmware makes it run so hot
    the heat it produces is enormous
     
    Last edited: Dec 29, 2018
  8. PeterPann

    PeterPann New Member Member

    Ok,thank you, please let me know if you succeeded with the backflash to stock rom. Will you try the only english firmware or the last chinese version? Also you could consider to flash older tomato firmware,maybe older version would be colder :) Im running the only english version and was looking for something up-to-date...as you...I believe
     
  9. P2q000

    P2q000 Network Newbie Member

    Hello

    I am newbie. I understand nothing from this thread.

    My ex-bf installed on my Netgear R7000 Advanced Tomato (
    Tomato Firmware 1.28.0000 -3.5-140 K26ARM USB AIO-64K)

    I need now go to 192.168.1.1/#admin-upgrade.asp and upgrade? All settings won't be lost?

    Screenshot 2018-12-29 at 20.37.27.png

    I don't know which file to download from exotic.se/freshtomato-arm/ . Sorry.
     
  10. pomidor1

    pomidor1 Networkin' Nut Member

    unzip and flash from gui 192.168.1.1/#admin-upgrade.asp
    https://exotic.se/freshtomato-arm/v2018/2018.5/freshtomato-R7000-ARM-2018.5-AIO-64K.zip

    you can try without cleaning nvram, but on 90% the router will work badly with the wrong settings, try it, and if it's wrong then clear the nvram using the reset button or http://192.168.1.1/admin-config.asp erase all data ... .
    of course you need to clear the browser cache (after flash) is very important when switching from adwanced toamto

    known error when switching from adawanced toamto to freshtoamto without cleaning nvram is an error in downloading skins from the internet database
     
  11. digixmax

    digixmax Addicted to LI Member

    I just upgraded my R6300v2 FW from Shibby build R6300v2-ARM--132-AIO-64K to FreshTomato build
    R6300v2-ARM-2018.5-VPN (with manual reconfiguration from fresh default settings at first boot), and now the router failed to obtain a WAN IP address (via DHCP) from my Cable ISP (CableVision).

    Any pointer/suggestion -- including the most recent FreshTomato build version that works on a R6300v2 as a home gateway router -- would be greatly appreciated.

    TIA.
     
  12. digixmax

    digixmax Addicted to LI Member

    I tried power-cycling the cable modem before connecting and powering up the R6300v2, and that fixed my WAN IP address acquisition issue :) although I can't think of an explanation for why that worked as that it had never been necessary previously.

    Update
    From having swapping in/out different routers running different builds for comparison purpose, it seems that Cablevision DHCP process recognizes only the last two routers authenticated through an embedded authentication process triggered by a power-recycling of the cable-modem. Swapping in a 3rd router would require power-recycling the cable-modem.
     
    Last edited: Dec 31, 2018
  13. wolfwolf

    wolfwolf New Member Member

    i dont know english router version, i had this version before brcm4709_all_46327_2.25.213, its dev fw from mi wifi
    i cleaned the router now with compressed air and placed it upside down as the heat comes out from the button, seems to hover now at around 80°C, i will watch it now a little but 90°C was too much, not sure if 80°C CPU is ok..
     
  14. wolfwolf

    wolfwolf New Member Member

    how do i flash back to stock?
    i just tried with with the stock firmware and ssh file on flashdisk pressing down reset while plugging in power but it didnt work, the same way i flashed to the rom but now i landed back at the Broadcom web Interface, also the orange light never flashed
    i flashed the fresh tomato.trx file again and im back again on tomato
    can someone help me, how to flash back to stock?
    or any way how i could reduce temperature, is it possible to make the fan spin faster with tomato?
    thank you
     
  15. digixmax

    digixmax Addicted to LI Member

    In troubleshooting the problem "router time is not available" I discovered that my Netgear R6300v2 router which I configured to run as a Wireless Ethernet Bridge (WEB) using build FreshTomato R6300v2-ARM-2018.5-VPN is not able to get to the Internet: it can ping the statically configured default gateway 192.168.1.1, but it does not appear to recognize it as a default gateway to the Internet (ping to Internet IP addresses does not work). My PC which is attached to the R6300v2 WEB can get to the Internet just fine.

    The issue goes away when I reverted the firmware back to an older, non-MultiWAN Shibby build (R6300v2-ARM—136-AIO-64K). As such I am guessing that I might have missed some WAN-related configuration steps when using the later MultiWAN version. Any pointer on what I might have missed would be greatly appreciated.
     
    Last edited: Dec 30, 2018
  16. wolfwolf

    wolfwolf New Member Member

    After Clearing NVRam (Configuration..) in fresh tomato my Xiaomi R1d seems to be bricked.
    Continous Orange light and cant flash anything, Ethernet connects and disconnects, lights blink
    i did the Clearing because the behaviour was odd, when i had DHCP on i would get an 192.168.137.1 ip adress
    also Wlan Survey showed nothing and the Wifi Signal Quality was 0
    i used ICS before so it had still the old values i guess, thats why i choosed Clear Nvram, obviously now a bad choice
     
  17. Sean B.

    Sean B. LI Guru Member

    80C is fine. My RT-AC68P idles at 73C. Remember, these routers were designed knowing they will not have active cooling ( fans ) like computers do. The chips are rated for continuous operation at higher temps then most are used to from their experience with computer CPU's.
     
  18. Sean B.

    Sean B. LI Guru Member

    There should be a reset button somewhere on the router. Often it's a pin-hole that you need to use something like a paper clip to push the button. Try a reset by either ways:

    A.) While the router is powered on, press and hold the reset button for 30 seconds or until you see an obvious change in the status LEDs.

    B.) With the router powered off, press and hold the reset button, while still holding the reset button turn the router on. Continue holding the reset button until status lights blink, reboot router.

    See if that gets you anywhere.
     
  19. PeterPann

    PeterPann New Member Member

    Sorry to hear that you are in trouble :-( On this link the dude put an external fan on the router,maybe there will be an explanation why and how. https://blog.icece.tw/Xiaomi-R1D-1TB-Flash-Tomato

    The only english version was 2.6.103...thats from the international version which I have. And unfortunately I can not check the temperature and its not stated anywhere in the gui.
     
  20. Pasha_ZZZ

    Pasha_ZZZ Serious Server Member

    Is there any way to start Tor without ports/users redirection? Only SOCKS proxy.
     
  21. digixmax

    digixmax Addicted to LI Member

    I added a static default route:

    0.0.0.0 192.168.1.1 0.0.0.0 0 LAN

    and the WEB router can now ping destinations on the Internet.

    But my problem "router time is not available" remains unsolved :(.

    I have the Default Gateway and Static DNS entries on the WEB router set to 192.168.1.1 (the IP address of my home gateway router). (FWIW, on the old Shibby pre-MultiWAN builds both of these two entries would show under LAN section of the Overview tab, whereas now only the DNS entry would show under the WAN section of the Overview tab).

    As a shot in the dark I also tried setting the DNS entry to the address of some external public DNS servers, but to no avail.
     
    Last edited: Dec 30, 2018
  22. Tomato Mike

    Tomato Mike Connected Client Member

    2018.5 has been working beautifully! Thank you to everyone involved. I do have a question, though:

    What option would I enable in Stubby, to allow for my VPN to use its DNS server (enabling EXCLUSIVE under my VPN's DNS options), but use Stubby when my VPN is off? The only way I can seem to use my VPN's DNS server, while using Stubby, is to set Stubby's priority to "none" - which makes me think it may not be the first/only thing used, when I turn my VPN off. Any suggestions?

    It it better/safer to just use Stubby, even when using my VPN?

    Thanks
     
  23. yxo-6o6uka

    yxo-6o6uka New Member Member

    Many thanks to the crew for keeping this Tomato fresh on the vine!

    Netgear R6300v2, switching from the latest Adv tomtato 3.5-140 to the latest Fresh tomato 2018.5.
    Cleared nvram. Using this approach tailored to my setup to transfer settings values between firmwares.
    Verified the imported settings in FreshT match those in AdvancedT

    No wifi interference from neighbors.
    5G speed is at parity, no issues
    However 2.4G speed in FreshT is ~3 times lower vs AdvT (with all related settings believed/double checked to be same). Using iperf3 from Android tab on wifi to laptop on a wired link to router. Tab is in the exact same position 6ft line-of-sight from router.

    Wondering:
    - Anyone with R6300v2 experienced 2.4G performance issues on 2018.5 FreshT? What 2.4 speed do you observe?
    - Ideas to try?

    Thx in advance
     
  24. wolfwolf

    wolfwolf New Member Member

    Well tried that many times, it isnt booting anymore, only flashing lights and connects/disconnects in windows, seems dead cant flash anything aswell
     
    Last edited: Dec 30, 2018
  25. Sean B.

    Sean B. LI Guru Member

    While the article here is about the Xiaomi Mi router rather than your R1d, it explains a recovery procedure for when a system error ( steady orange LED ) occurs. It may cross directly over to your model, but if not I would search for the user manual or check the manufactures support page and see if there's a similar process for the R1d.
     
  26. digixmax

    digixmax Addicted to LI Member

    Have you tried this ROM flashing process for the R1D http://en.miui.com/thread-137281-1-1.html
     
    Last edited: Dec 30, 2018
  27. digixmax

    digixmax Addicted to LI Member

    On my Asus RT-N16 I can see all currently active TCP/UDP connections (typically numbered in the hundreds of connections on my home gateway router) in QoS->View Details tab.

    For the same build version on my Netgear R6300v2 I only see a handful of ICMP/IGMP connections listed in QoS->View Details tab.

    Why is there a a different behavior?
     
    Last edited: Dec 31, 2018
  28. seashell

    seashell Network Newbie Member

    I'm having trouble getting this to work on a new Asus RT-AC3200.

    Tried the last few 2018 builds including the latest (AIO and VPN) as well as the last Shibby Tomato version (AIO only). All place the router in an endless boot loop. Fortunately I can recover by resetting then NVRAM (power on holding WPS for a while) and then going into the built in CFE (power on holding reset) and then flash either Merlin or DD-WRT firmware using either the webpage or the Asus firmware tool.

    I've tried loading the FreshTomato firmwares using DD-WRT, the built in CFE (and either the webpage or the Asus firmware tool), and by scping the firmware to the router then loading it with the command "mtd-write2 /tmp/filename.trx linux" (after which I've tried rebooting using the Merlin reboot button or just powering on and off the router).

    Is there something obvious I'm missing? Are there known versions of this router that do not work with FreshTomato?
     
  29. bd0426

    bd0426 Networkin' Nut Member

    My experience mirrors that of yours with 2018.4 or later. I have 4 multi-generational RT-AC3200s in various locations (128K CFE) that exhibit this same behavior. However - Asus, Merlin, Toastman, Shibby and a 2018.4 pre-release (the first one with the 10+ device 2.4GHz fix) have all been successfully flashed to mine at some point or another. Toastman's very last release was the longest tenured version I ran and the others were only used for troubleshooting purposes when I tried to stay with Fresh Tomato and ran into problems.

    I always clear NVRAM via the WPS button power-on method before and after (successful) flashing. Once the boot loop starts, I have to use recovery mode and the CFE FTP or the Asus recovery tool to load something else. I have left a couple routers for 24+ hours to see if the image would eventually boot with no luck.

    Currently I keep one RT-AC3200 idle to test each new Fresh Tomato release in the hopes one day a build might be released that is stable on this unit and allow me to move back. But, unfortunately, I don't have anything constructive to add to the conversation. I ended up with DD-WRT on my units due to the '10 device bug' back when that was a problem and an issue I seem to have on any Tomato release with remote https management becoming unresponsive over time and not being able to track down exactly why or come up with a work-around.
     
    Last edited: Jan 2, 2019
  30. ras07

    ras07 Network Guru Member

    I'm having trouble with uPNP after upgrading to 2018.5 (from 2018.2). Before the upgrade I think it was working fine; now, I never see anything in the "Forwarded Ports" list on the uPNP/NAT-PMP page, and traffic isn't getting forwarded to my uPNP apps. AFAICT all the uPNP-related settings are exactly the same as they were under 2018.2.

    When I save the uPNP settings, I get the following in the log:

    Dec 30 21:25:49 Router daemon.notice miniupnpd[32712]: shutting down MiniUPnPd
    Dec 30 21:25:50 Router daemon.notice miniupnpd[477]: version 2.1 started
    Dec 30 21:25:50 Router daemon.notice miniupnpd[477]: HTTP listening on port 19937
    Dec 30 21:25:50 Router daemon.warn miniupnpd[477]: no HTTP IPv6 address, disabling IPv6
    Dec 30 21:25:50 Router daemon.notice miniupnpd[477]: Listening for NAT-PMP/PCP traffic on port 5351
    Dec 30 21:25:50 Router daemon.err miniupnpd[477]: PCPSendUnsolicitedAnnounce() IPv6 sendto(): Bad file descriptor
    Dec 30 21:34:24 Router daemon.notice miniupnpd[477]: shutting down MiniUPnPd
    Dec 30 21:34:25 Router daemon.notice miniupnpd[670]: version 2.1 started
    Dec 30 21:34:25 Router daemon.notice miniupnpd[670]: HTTP listening on port 21314
    Dec 30 21:34:25 Router daemon.warn miniupnpd[670]: no HTTP IPv6 address, disabling IPv6
    Dec 30 21:34:25 Router daemon.notice miniupnpd[670]: Listening for NAT-PMP/PCP traffic on port 5351
    Dec 30 21:34:25 Router daemon.err miniupnpd[670]: PCPSendUnsolicitedAnnounce() IPv6 sendto(): Bad file descriptor
    Dec 30 21:34:39 Router daemon.notice miniupnpd[670]: shutting down MiniUPnPd
    Dec 30 21:34:40 Router daemon.notice miniupnpd[728]: version 2.1 started
    Dec 30 21:34:40 Router daemon.notice miniupnpd[728]: HTTP listening on port 22213
    Dec 30 21:34:40 Router daemon.warn miniupnpd[728]: no HTTP IPv6 address, disabling IPv6
    Dec 30 21:34:40 Router daemon.notice miniupnpd[728]: Listening for NAT-PMP/PCP traffic on port 5351
    Dec 30 21:34:40 Router daemon.err miniupnpd[728]: PCPSendUnsolicitedAnnounce() IPv6 sendto(): Bad file descriptor
    (I don't know if that's normal or not.) Any thoughts? TIA
     
  31. wolfwolf

    wolfwolf New Member Member

    i have seen this page, the reset button is non functional at this state, no matter how long i press nothing changes,
    the flashing is that kind of indicating failure after nvram reset in fresh tomato, why offer this option when it bricks devices to non functional state? atleast put a warning to xiaomi r1d devices...jesus
    i have extracted the hdd now for future use
     
  32. rs232

    rs232 Network Guru Member

    Can anybody provide this please? it would save a huge amount of time to lots of people.

    Thanks
     
  33. Justio

    Justio Networkin' Nut Member

    I'll try..though will take me some time.
    Also take into account that i'm not a big expert...anyway my VM seems to work and correctly compile the thing.
     
    rs232 likes this.
  34. rs232

    rs232 Network Guru Member

    Great that's what we need really. Also if something doesn't work this forum is the place where to ask to try to fix. Did anybody say collaboration...? :)
     
  35. Sean B.

    Sean B. LI Guru Member

    You mean something like this? Of which is in the very first post of this thread:

    You aren't the first person to screw something up trying to flash their router, and you certainly wont be the last. What's also for certain, with an attitude like that, is you'll be figuring it out and/or crying about it on your own.
     
    kille72 likes this.
  36. seashell

    seashell Network Newbie Member

    Thanks for the reply. While it's good to know it's not just me it's a bummer it doesn't seem to work on this router.

    Devs: Maybe it should be removed from the list of compatible routers in the first post.
     
  37. wolfwolf

    wolfwolf New Member Member

    i fully knew that, i havent had much use of the router anyway with the chinese interface and nothing to route as i only have a 4g unlimited plan, so yeah i knew i could brick the device, with temps running high as 92°C it wasnt really usuable aswell with tomato anyway,i dont need another oven here in the caribbean, so yeah i was experimenting, and yeah violently disassembling the device like others did before me and installing custom fan mods im not sure if thats the way to go, its not a big loss for me
    im certainly not new to all this, having owned linksys router before and flashed to dd-wrt succesfully
     
  38. digixmax

    digixmax Addicted to LI Member

    I also experienced uPnP failure on my R6300v2 and RT-N16 routers after upgrading from Shibby build 132 to FreshTomato 2018.5, so I have decided to revert to the Shibby build for now.

    Any recommendation on which Tomato recent and stable build to try on these two router models would be greatly appreciated.
     
  39. PeterPann

    PeterPann New Member Member

    Sorry you had no luck with restoring and also you had no chance to try the english firmware,its a great device for that money and also the design is another level. But at least you have the hdd from it ...;-)
     
  40. wolfwolf

    wolfwolf New Member Member

    yeah the device is cool if you can put use to it,
    hdd is still going strong, after 5 years all my other HDD from Seagate or WD died already
     
  41. AlterEgo

    AlterEgo LI Guru Member

    Just got to know about FreshTomato. I am running Advanced Tomato Firmware 1.28.0000 -3.5-140 K26ARM USB AIO-64K on Asus RT AC68U. For my use I am content with current setup. I am not utilizing full of some part of all the features and functionalities (Captive Portal/VLAN/USB etc).

    Can someone please explain the basic difference and value addition which can be derived if I plan to move from AdvancedTomato to freshtomato.

    Thanks.
     
  42. Mercjoe

    Mercjoe Network Guru Member


    After several redownloads and reflashes the problem stopped. Each time I had the problem I flashed BACK to 2018.4 and it worked normally.

    Each time I flashed I cleared NVRAM and configured from scratch. I have no idea what the problem was.

    Anyway, now that I have had a while to play with the new version I found an intermittent bug. This time in the USB and NAS section. Specifically with the Samba File sharing

    I have a 2TB USB3.0 drive on the router that is used for long term storage non critical storage. Normally I have it shared with no authentication and it has worked great for many years now.

    With the 2018.5 update I suddenly could no longer access the share without authentication. If I go back 2018.4 it worked as before.

    Here is the strange thing I found:

    If I set it up for access 'Yes, authentication required' and access it ONE time from any machine and then immediately go back and change to 'Yes, NO Authentication' and all machines can access it normal as before but only for a while. So far the longest time has been about 30 hours and then it becomes inaccessible again.

    Everything else is working great. Thank you for all the hard work.

    Further update:

    If you turn on 'Yes, Authentication required' then the CIFS shares will not mount. Once you go back to 'Yes, No authentication' the CIFS shares mount.
     
    Last edited: Jan 2, 2019
  43. txnative

    txnative Addicted to LI Member

    Are you having issues with the current build and are you erasing nvram? Are there particular devices that should be opening up with upnp? I have a R6300v2 charter build but I haven't compiled for it since Nov'2018, but no real issues as when i was using it a few months back, i have been using my openwrt linksys ea3500 as my router since placing it Nov i like to rotate different models month to month updating as needed for my routers. I'll check it out a run the same setups as you have done to see if there some problems with wireless ethernet bridge, time zone, dns upnp issues, but maybe look into how to set up the wireless ethernet bridge properly first, do a google search or use the linksysinfo search here.

    Edited: I've built from source for my r6300v2CH and so far so good no problems with it, I'll do have to setup a vlan later for a guest network, as well a few other tasks but for now everything is stable, except for me I'm going to sleep.
     
    Last edited: Jan 2, 2019
  44. digixmax

    digixmax Addicted to LI Member

    I did the clear nvram whenever flashing a older or newer build (even with the same mod branch). Until this past weekend I have been using Shibby pre multiWAN builds on my RT-N16's and R6300v2's acting as gateway router and as wireless ethernet bridges (WEBs). The only Freshtomato builds I have tried are of the 2015.5 release.

    Summary of the 3 problems I am having:

    1. uPnP stopped working on Gateway router: affects both RT-N16 and R6300v2 running FreshTomato 2018.5 builds

    2. no listing of active TCP/UDP connections under "Qos->View Details": affects only R6300v2 (as gateway router or as WEB) running either FreshTomato 2018.5 build or any Shibby build. This appears to be a router-model specific problem.

    3. no NTP time sync on WEB: affects both RT-N16 and R6300v2, running either FreshTomato build or Shibby multi-WAN builds. The problem does not occur on any of my WEB routers running some pre multi-WAN build (Shibby 132 or earlier), hence I think this is a bug that was introduced with the multi-WAN feature introduction into Tomato.

    Problem #1 (lack of working uPnP) is a show-stopper for me, fix for #2 is highly desirable, #3 is something I can live with. I'd love to know if earlier FreshTomato builds do not have uPnP problem in which case I'll will try them out.
     
  45. Shahnewaz

    Shahnewaz Network Newbie Member

    So I've just flashed the initial firmware on my R7000 from the stock 1.0.9.60 firmware. After reboot, I can't seem to login to the router anymore, the default passwords don't seem to work (401 Unauthorized).

    My router still transmits the previous SSIDs, but there is no internet connection (DHCP disabled).

    Holding the reset button does nothing, same for holding the WPS button. I've tried telnet, but facing the same problem. I think I'm out of options now. :(

    Is my router bricked?
     
  46. txnative

    txnative Addicted to LI Member

    Ok, there are 1 through 5, 2018 builds if you'd like to try but I don't recall all of them being any problems on my router, as I compile from those sources.
     
  47. txnative

    txnative Addicted to LI Member

    Have you tried clear your brower cache? unplug the power, hold the reset, plug in the power hold reset for 10 and release you should notice the indicator light turn orange while you are holding the reset button this should reset the router to defaults. User: admin Pass: admin. Try that
     
  48. Shahnewaz

    Shahnewaz Network Newbie Member

    Tried that with cache cleared. The indicator light does turn orange, but it boots back to the same configuration as before. admin/admin doesn't work.
     
  49. usergay

    usergay Connected Client Member

    Hold the reset button with the power on for 10 seconds, then while still holding the reset, unplug the router for 10 seconds. Plug the router back in while still holding the reset for another 10 seconds. Let go of reset and power off and back on the router. It should reset back to admin/admin or admin/password as the login credentials
     
  50. Shahnewaz

    Shahnewaz Network Newbie Member

    No success. It still boots back to the same state. :(
     
  51. Shahnewaz

    Shahnewaz Network Newbie Member

    Some additional info: If the router is pinged while booting, it responds with TTL=100. That is only when the reset button works. When it has finished booting, none of the buttons on the device work.
     
  52. digixmax

    digixmax Addicted to LI Member

    Did you try pointing your browser at http://192.168.1.1 (the default address of the router at first boot)?
     
  53. txnative

    txnative Addicted to LI Member

    Ok, you telling us that you receive a ping on what ip address?
    What previous configuration are you referring to? Could you post a screen shot of what you are telling us, also it does ask for a user/pass then? Did something happen while flashing the initial R7000 freshtomato?
     
  54. digixmax

    digixmax Addicted to LI Member

    Assuming your router is bricked, you might consider trying a recovery process using tftp as described at https://community.netgear.com/t5/Ni...ck-unresponsive-R7000-softbricked/td-p/414034 or https://community.netgear.com/t5/Ni...uring-firmware-update-to-1-0-9-18/m-p/1500305.
     
    Last edited: Jan 2, 2019
  55. JPJazz

    JPJazz Reformed Router Member

    This happened to me once, turned out I forgot to clear the cache when I reverted. I panicked a bit and out of desperation tried my previous password (the one that I had used for Tomato) and it let me in! I hope that's the scenario in your case...

    EDIT: After reading your post a bit more closely, I may have misunderstood the situation. Leaving here anyway in case someone else can't log in after reverting to stock.
     
  56. Shahnewaz

    Shahnewaz Network Newbie Member

    Yes.

    Nothing unusual happened before or after flashing. I just uploaded the initial .chk file to the router and updated it. It flashed as normal and rebooted. Then I was greeted with Tomato's login screen which I can't seem to get past with any password. The router does respond to pings and telnet login requests. And from the screenshots you can see "Netgear 121" which the router is transmitting.

    tftp always results in "Connect request failed". I don't know what I'm doing wrong there.
     

    Attached Files:

  57. M_ars

    M_ars Network Guru Member

    What password and logins have you tried? Can you login via telnet? (User: root)
     
  58. txnative

    txnative Addicted to LI Member

    Thank you for posting those. Normally performing the power off, holding the reset pin hole button, plugging the power back in does the trick. There is no root for "user" for tomato just admin/admin as you may know now. What ip are you receiving a response from 192.168.1.1 or ?
     
  59. pedro311

    pedro311 Networkin' Nut Member

    RT-AC3200 is now my main router, and I have no single problem with it...
     
    M_ars and kille72 like this.
  60. seashell

    seashell Network Newbie Member

    Well I purchased the router from Amazon via the link on the first page and all I get is the boot loop I described. I'm open to any advice on how to correctly install FreshTomato.
     
  61. Shahnewaz

    Shahnewaz Network Newbie Member

    No, I've tried all combinations of admin, password, root, user, empty and my last password used on the stock firmware. Nothing seems to do the trick.

    Since DHCP is disabled I have to set my computer's IP to 192.168.1.2 to get a response from the router and access its login screen.
     
  62. pedro311

    pedro311 Networkin' Nut Member

    OK, so first try this actual beta version "freshtomato-RT-AC3200-ARM-2019.1.008-beta-AIO-64K" located in "tests" folder on mega upload, and tell what's going on.
     
    kille72 likes this.
  63. Bird333

    Bird333 Network Guru Member


    Is this going to be added?
     
  64. digixmax

    digixmax Addicted to LI Member

    For tomato, by default "root" is also accepted as a valid login ID.

    My question: at first reboot following the flashing of the initial build firmware file (e.g., tomato-R7000-initial.chk), without resorting to the reset button, what should be the expected login id and password -- tomato's login/password or netgear oem firmware's login/password? (It's been a long while since I first flashed my R6300v2 routers and forgot how that played out).
     
    Last edited: Jan 2, 2019
    M_ars likes this.
  65. txnative

    txnative Addicted to LI Member

    Only time "root" is used, is in telnet, I've never used root on tomato builds to login. On first boot after flashing the initial freshtomato-arm image, of course. What should be expected is to wait up to 5mins. Make sure to create static ip, open a console if in linux to run ping, in windows use the command prompt as do the same run a ping on 192.168.1.1, shibby done a video of this procedure, take look at the video for better illustration from youtube. Regards.
     
  66. ras07

    ras07 Network Guru Member

    I'm using 2018.5 on an RT-AC68R/U. I upgraded from 2018.2 and erased nvram. I'm not well-versed in uPNP, but it seemed to be working fine on 2018.2, and now it's not. (I could certainly have something messed up but I don't think so.)

    I've tried with a couple different applications including qbittorrent, with no success.

    If anybody knows of a simple way to definitively test uPNP I'll try it out.
     
  67. pedro311

    pedro311 Networkin' Nut Member

    The problem is already located, and will be fixed (in one or other way) in next release.
     
  68. usergay

    usergay Connected Client Member

    Do this:
    1) run router and wait 2-3
    2) push and hold wifi on/off button for 25 secs - this will enable a "backdoor" access to the router.
    3) use putty and connect via telnet on port 233 and log in to router without password
    4) run command: nvram get http_password (login`s value: nvram get http_username)
    5) use result as password
    6) when you log in to tomato remember to erase nvram
     
    Shahnewaz likes this.
  69. txnative

    txnative Addicted to LI Member

    My consoles(xbox/ps) doesn't seem to be affected by this, and I know it should since it is from the same source, which is odd? Great that a fix will be implemented, as I don't use bittorrents.
     
  70. bd0426

    bd0426 Networkin' Nut Member

    Still boot-looping.
    Curious... @pedro311, Does your unit have a 64K or 128K CFE? In my initial reply to @seashell I incorrectly indicted that I had both 64K and 128K units. I went to grab what I thought was the remaining 64K unit to try with the beta, but found it to also have been upgraded to 128K (by flashing the latest Asus firmware at some point in the not-so-distant past).
     
  71. pedro311

    pedro311 Networkin' Nut Member

    Well, maybe try some of the older Asus FW (ie: 3.0.0.4.382.50624 or older?), and then beta FT with nvram cleaning?
     
  72. Mel Zape

    Mel Zape New Member Member

    I am getting this error message when trying to Tomato my brand new Netgear R7000, version 1.0.9.60. I tried using different chk files but nothing seems to work.

    Error:
    The firmware is not compatible with your router. Error code -1.

    I had a chat session with a Netgear rep. telling him that I wanted to download from above version and this is what he told me.
    Kean P
    They are locking down some firmware since those firmware have too much bugs that can make the router defective.

    Please, if anyone has a solution, let me know. If not, I am return router back to Amazon.
    Note: I also tried telnet, ttl, etc. nothing works.
     
  73. digixmax

    digixmax Addicted to LI Member

    I did a Google search on "R7000 tomatousb flashing can't login" and it turned up quite a few reports by others of this problem of "can't login" after flashing the initial build and for which the solution posted herein has been the only solution (hard reset just doesn't work).

    Is this experience the norm for R7000? Or are there other folks who have recently succeeded in smoothly upgrading from Netgear stock firmware (in particular the current version 1.0.9.60) to TomatoUsb (either FreshTomato or Shibby build), and if so which stock firmware version was on the router before the upgrade?
     
    Last edited: Jan 3, 2019
  74. digixmax

    digixmax Addicted to LI Member

    A potential solution is to try to find and downgrade to a sufficiently dated version of stock firmware (see https://www.netgear.com/support/product/r7000.aspx#download) that hopefully does not check and lock out non-stock firmware.

    Please report back when you find a stock firmware version that works, as there are others who would be in the same boat (included myself who have a R7000 on its way with 1.0.9.60 on it) & TIA.
     
    Last edited: Jan 3, 2019
  75. Windows98

    Windows98 Network Newbie Member

    I was (re)researching this issue tonight. About six months ago I had the same problem and I think the culprit is the newer Asus firmware:

    Between ASUS builds 380.xx and 382.xx, they implemented a change to the nvram size. Once you take the plunge on a 382.xx build, the nvram size changes and you can't go back. I found out the hard way.

    My router ran tomato completely fine and then one day I got it in my brilliant mind to try Merlin's firmware and I've been unable to go back to tomato ever since. As soon as I setup my router with tomato and hit apply, it reboots and gets stuck in a boot loop.

    I ultimately got annoyed and bought a different router entirely.
     
  76. digixmax

    digixmax Addicted to LI Member

    Just found this dated Wired article re: FCC mandate for router manufacturers to lock out non-oem firmware:
    https://www.wired.com/2016/03/way-go-fcc-now-manufacturers-locking-routers/.
     
    Last edited: Jan 3, 2019
  77. buggage

    buggage Network Guru Member

    Just had the same exact experience with a brand new off-the-shelf R7000 from Best Buy. I was finally able to flash the firmware after finding reference to a software called nmrpflash here: https://github.com/jclehner/nmrpflash (if running Windows, you'll need WinPcap installed also). I had tried other TFTP programs, only this one worked for me. I did have to play around with it for a while until I got the proper command figured out (had to add flags to overwrite the default router/interface IP's used) and timing right. Took a few tries, but you'll be able to tell when it's uploading. When everything was finished it got into a boot-loop after restarting and I had to use the reset button on the back. After that, it's been fine ever since. I'd say don't give up too soon. I was about to myself, but you can get it with a little work.
     
    digixmax and Mel Zape like this.
  78. seashell

    seashell Network Newbie Member

    @pedro311 I went down to the oldest firmware available on the Asus site, 3.0.0.4_382_50470 and reset the NVRAM. As @Windows98 said the nvram was still 128K in size. (I used "nvram show" after sshing into the router to get the size.)

    I didn't see the beta firmware in the tests folder at https://exotic.se/freshtomato-arm/. Is there a link to the folder on mega upload?

    Can a 128K nvram version be made for the 3200?
     
  79. kille72

    kille72 LI Guru Member

    Last edited: Jan 3, 2019
  80. pedro311

    pedro311 Networkin' Nut Member

  81. Larry SSSS

    Larry SSSS Network Newbie Member

    Hi Kille72.

    Question for you - I have noticed lately since installing your latest build that my internet now- shuts off for about a minute and then re-connects? referring to Nighthawk R7000 Nighthawk - Your latest build.

    This happens on my desktop, laptop and streaming devices - basically the entire internet in my home.

    Never did that with any of your other builds?

    Not sure if there is a bug in the latest build update or something that needs to be further tweaked in my router?
    Please advise and if I can be a help in this by having you log into my router for review - we can arrange a time for that as well.

    PS: Hard for me to follow this feed all day due to work schedule and so if anyone has any suggestions please email me directly at justicesl AT hotmail com - PLEASE PUT THE EMAIL TOGETHER AS THIS POST WON'T LET ME POST OTHERWISE

    Thank you again for all your dedication to these builds.
    Larry
     
  82. digixmax

    digixmax Addicted to LI Member

    Did you just start the router normally or with reset button?

    Also what values did you use for the timeout t and T parameters?

    TIA.
     
  83. pedro311

    pedro311 Networkin' Nut Member

    kille72 likes this.
  84. Larry SSSS

    Larry SSSS Network Newbie Member

    Hi Kille72.

    Any word on my post above?
    Thank you
    Larry
     
  85. seashell

    seashell Network Newbie Member

    @pedro311 I tried loading the Asus 380 (4180) FW and it has the same boot loop problem as FreshTomato. It seems @Windows98 is correct and you can't go back to 64K NVRAM once it's been set to 128K. Newer routers like mine are going to come with it already set to 128K.

    Also the Merlin firmware upgrade rejected loading both versions of the 380 firmware you uploaded. I had to do it via the CFE and firmware recovery tool. The Merlin firmware upgrade is happy to load a 382 version of the Asus bios.
     
  86. Shahnewaz

    Shahnewaz Network Newbie Member

    This worked! If anyone else is stuck in this situation after flashing, try the password: "@newdig" (without quotes)

    Holding the wifi on/off button successfully enabled backdoor access, and I was able to telnet via PuTTY without requiring any login info.

    I ran nvram get http_username and it returned "admin" as you expect. But when I run nvram get http_password, it returns nothing. Strange, so I tried admin and blank on the login screen.
    No success. Weird. But since I have nvram access to the router, I was very tempted to run nvram erase. Instead I looked up what command parameters are available with nvram, and I ran nvram show.

    That returned over 2,000 lines of code, and the first line being http_username=admin. So I copied it all to a text file, and searched for the likes of "http_pass".

    Interestingly, there was no http_password entry. There was only http_passwd, which was set to @newdig for who knows why, and http_passwd_digest. So tried admin/@newdig and BAM! I was instantly logged in.

    The initial firmware seems to have flashed just fine, and the UI seems unharmed, so I promptly flashed the actual firmware and cleared NVRAM.

    Thanks a lot! I can't really explain why the reset was not working or why the password was randomly set to @newdig. Netgear's latest firmware requires you to have security questions set in case you forget your router password, so that might be an issue? I can't tell. I've saved a copy of nvram show output if anyone wants to take a look for debugging purposes.
     
  87. seashell

    seashell Network Newbie Member

    @pedro311 would making a 128K NVRAM version involve anything more than changing the NVRAM_64K=y to NVRAM_128K=y in the makefile?
     
  88. cloneman

    cloneman LI Guru Member

    I just noticed today -- the QoS "Rule" information is not showing under "View Details". Rule 255 is I think"no match" -- which works. , if there's a match it's just blank, instead of showing which classifier rule # was being used.

    Not an overly disturbing problem , probably has been there for a while.
     
  89. pedro311

    pedro311 Networkin' Nut Member

    OK, I've just uploaded "freshtomato-RT-AC3200-ARM-2019.1.015-beta-nvram128-test-AIO-128K" on mega upload in "tests" folder.
    Please, let me know.
     
  90. seashell

    seashell Network Newbie Member

    @pedro311 unfortunately I'm still getting the same boot loop behavior. Tried flashing through the Asus firmware tool and through DD-WRT but neither worked. I let it loop for a few minutes to see if it would come out but it didn't.

    Thank you for making that test for me. At this point I have to concede I don't know what else to suggest. Merlin and DD-WRT do both set NVRAM to 128K for the RT-AC3200 but I guess they do something else as well.

    Perhaps @bd0426 could give this one a try as well to verify I didn't do something stupid.
     
  91. seashell

    seashell Network Newbie Member

    In case this helps show what's changed, here's the MTD layout from Merlin 384.6 on my RT-AC3200.

    Code:
    cat /proc/mtd
    dev:    size   erasesize  name
    mtd0: 00080000 00020000 "boot"
    mtd1: 00180000 00020000 "nvram"
    mtd2: 03e00000 00020000 "linux"
    mtd3: 03c4d170 00020000 "rootfs"
    mtd4: 04000000 00020000 "brcmnand"
    
     
  92. Twincam

    Twincam Networkin' Nut Member

    That's almost the same as FT 2018.4 on my AC-RT3200 with 64K of nvram:

    dev: size erasesize name
    mtd0: 00080000 00020000 "boot"
    mtd1: 00180000 00020000 "nvram"
    mtd2: 03e00000 00020000 "linux"
    mtd3: 03c4af70 00020000 "rootfs"
    mtd4: 04000000 00020000 "brcmnand"
     
    Last edited: Jan 4, 2019
  93. buggage

    buggage Network Guru Member

    This is what Idid:

    Connected router directly to PC
    Set static IP on PC to 192.168.1.2

    Then used the following command. I added the -a (router IP) and -A (interface (PC) IP) because the default command uses 10.64.x.x network addresses, so those override that with my own network IP's. The other thing I changed was the eth0 to net0 when I ran the nmrpflash -L command to find the interface type.

    nmrpflash -a 192.168.1.1 -A 192.168.1.2 -i net0 -f firmware.chk

    Then I just used the power button to start the router while trying to run the command at same time. That was the trickier piece. If you run a continuous ping against the router IP, you'll see shortly after the beginning of boot where the TTL=100 fora short while (Reply from 192.168.1.1: bytes=32 time=3ms TTL=100) and apparently that's the window where the bootloader will respond to TFTP requests. So I tried to either run, or have the command running, when I saw that window. After a few attempts it took, and then I saw the file being uploaded and received message to reboot after it was completed. That's when I rebooted the router and the boot loop occurred. Then I used the reset button, and after that it came up normally and I was able to access it, and conifigure. Good luck!
     
    digixmax likes this.
  94. usergay

    usergay Connected Client Member

    Glad I could help! :)
     
  95. seashell

    seashell Network Newbie Member

    One thing I noticed in comparing Merlin 380 vs Merlin 382/384 baselines is that the trx_asus binary changed in the src-rt-7.x.main area which is what builds the RT-AC3200 version.

    It's just a binary in the Merlin repos though so I don't know what changed. It could be nothing more than a different compiler was used to compile the same code but I figured I'd point it out in case Asus did indeed change their trx format for their newer BIOS. Maybe not likely, but the new firmware does refuse to flash the old firmware. I don't know if it just in general refuses to flash older versions though.
     
    maurer likes this.
  96. maurer

    maurer Network Guru Member

    try to flash via mtd-write (first upload the trx file to /tmp via scp)
    Code:
    mtd-write2 /tmp/freshtomato-RT-AC3200-ARM-2019.1.015-beta-nvram128-test-AIO-128K.trx linux && reboot
    of course - i'm not responsible if it gets bricked :) - although it shouldn't or should be fixable
     
  97. copyfile

    copyfile New Member Member

    Just started installing the latest tomato on my brand new R7000. After the initial file was installed I'm unable to login again, the router is online and when I go to the Ip it asked for a username and password. I tried a lot of combinations (admin/admin, admin/password, root/admin, etc.) also the password I choose when installing the router the first time. Someone any idea what I have to do now? Thanks!
     
  98. ras07

    ras07 Network Guru Member

    I need to configure FreshTomato such that it tells DHCP clients to use one set of DNS servers, but it uses a different DNS server for its own purposes. Will configuring the DHCP clients' servers in Basic/Network/WAN Settings (with DNS Server set to Manual) and then putting
    Code:
    echo nameserver 1.2.3.4 > /etc/resolv.conf
    in the Init script do the job? Is there a better way?
     
  99. Sean B.

    Sean B. LI Guru Member

    Place this in the Advanced->DHCP/dns custom config box:

    Code:
    dhcp-option=tag:br0,option:dns-server,X.X.X.X
    Where X.X.X.X is the IP of the DNS server you want your DHCP clients to use. If you wish to send a secondary DNS server as well, simply add another comma separated IP address, like so:

    Code:
    dhcp-option=tag:br0,option:dns-server,X.X.X.X,Y.Y.Y.Y
    If you have more than one LAN, add an additional line for each LAN, changing the br0 tag accordingly.

    Under the Basic->Network WAN section put the DNS servers you want used by the router.
     
    Last edited: Jan 5, 2019
    Techie007 likes this.
  100. ras07

    ras07 Network Guru Member

    Perfect - thanks!
    Is the syntax for having multiple DNS servers just to append them, comma separated?, i.e.:
    Code:
    dhcp-option=tag:br0,option:dns-server,X.X.X.X,Y.Y.Y.Y
     
    Last edited: Jan 5, 2019
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice