[Fork] FreshTomato-ARM

Discussion in 'Tomato Firmware' started by kille72, Apr 15, 2018.

  1. Mercjoe

    Mercjoe Network Guru Member

    Signal strength has nothing to do with data rate.

    Even sitting right next to the radio antenna does not guarantee you a max data rate as there may be other interference to the signal.
  2. edud2k

    edud2k Network Newbie Member

    I agree with you. but I have another router of another brand and in placing it in the same position as the tenda ac15 is, I have the 433Mb in my mobile phone.

    I am just trying to understand, because an AC1900 router and that has 1300mb in 5Ghz can not deliver even 10% of that to 2 meters away.

    I'm expressing what happens to me, because other users may face the same difficulty as me

    it is a reality then that the band of 5Ghz on this router with Broadcom has a signal below the desired minimum.
  3. usergay

    usergay Network Newbie Member

    Did you try these that I posted previously?

    1. Make sure country setting is set as Singapore.
    2. Enable Frame Burst only for 5ghz network
    3. Set Encryption to WPA2 + AES only
    4. Set Wireless mode to AUTO
    5. Set transmit power to 0 (Hardware default)
    6. For maximum speed use 80mhz

    Could be defective hardware or loose internal / external antenna if you've tried all of our suggestions and it still doesn't work properly.
    Last edited: Jun 19, 2018
  4. usergay

    usergay Network Newbie Member

    Try updating or downgrading your client's (intel ac7260) wireless drivers. I had a similar issue with a laptop until I changed the drivers and tweaked the card's properties / settings. Should look like this if you're on windows

    10752iACC1A6B7D3E06B99.png ...

    These are my settings...
    1. Chan Width for 2.4 = 20mhz
    2. Chan Width for 5.2 = Auto
    3. ARP Offload = Enabled
    4. Bluetooth Amp = Disabled
    5. Fat Channel = Disabled
    6. HT MODE = VHT Mode
    7. Mixed mode = RTS / CTS Enabled
    8. NS Offload = Enabled
    9. Packet Coalescing = DISABLED
    10. Throughout Booster = DISABLED
    11. Transmit power = Highest
    12. U-APSD Support = DISABLED
    13. Wireless Mode = 802.11a/b/g
    14. Mimo power Save Mode (You may not have this option) = Auto SMPS

    Let me know if this helps!
  5. user17600

    user17600 Reformed Router Member

    Logically it could - e.g., if the device was indexing or if it was issuing other calls for network information. I suppose you could see if that device also had a large amount of network traffic (e.g., data transfer) as confirmation, but your testing seems to confirm the issue with that device.
  6. edud2k

    edud2k Network Newbie Member

    Yes @usergay i Tried and same resut, not great speeds on 5Ghz.

    Enviado de meu Mi Max Prime usando Tapatalk
  7. usergay

    usergay Network Newbie Member

    Maybe your router is bad and may need to be replaced.
  8. rgnldo

    rgnldo Networkin' Nut Member


    Attached Files:

  9. eangulus

    eangulus Network Guru Member

    Just wanted to report that twice in 3 weeks now I have this error in my logs.

    kern.warn kernel: nf_conntrack: table full, dropping packet.

    My Maximum Connections setting is: 15956 and active connections is 115. Stopping remote access to servers and such and only just managed to get these readings out of the router before a reboot.

    RT-AC3200 running 2018.3.018 -beta
  10. edud2k

    edud2k Network Newbie Member

    my router is AC15 tenda, yours is Netgear, there is no way to make comparisons, yours is much better.
  11. sstacks

    sstacks Reformed Router Member

    Thanks. Googling confirms that a bad device can bring down a network. In my case, it doesn't bring it down immediately, but instead whacks it in the knees over and over until it occasionally gives way. It made it identification of the problem difficult.

    I have removed the device, and all has been stable for two days now.
  12. usergay

    usergay Network Newbie Member

    This may not have anything to do with your issue but I experienced a similar "flooding" issue with one of my windows PCs... It turned out that the antivirus software (BITDEFENDER) that I was using was the culprit. After I uninstalled it, the router was no longer complaining. For some reason the software kept doing something to manipulate network packets causing all kinds of chaos / havoc.
  13. Justio

    Justio Networkin' Nut Member

    You have filled almost two pages of kille72 specific Fork with replies that got lost among other users replies (instead of opening a new thread / maybe use google search or alternatives / or read kille72 & pedro311 request - first post). Beside that has nothing to do with nor with a bug related to this Fork nor with an issue of the said.

    Apologies! in advance kille72 for the off topic
    Techie007, kille72 and pedro311 like this.
  14. maurer

    maurer Network Guru Member

    yes !
    that got me to 702mbps tomato reported and about 400mbps TCP throughput !
  15. edud2k

    edud2k Network Newbie Member


    Sorry but your opinion does not interest me.
    exchange words with another person

    thanks @usergay and others for help me with my doubts

    thanks @kille72 for your hard work with this fork.
    Last edited: Jun 20, 2018
    kille72 likes this.
  16. usergay

    usergay Network Newbie Member

    Glad it worked out for ya! :)
  17. attip90

    attip90 New Member Member

    Please have a look also in this thread, especially the last part: https://www.linksysinfo.org/index.php?threads/tenda-ac15-ac1900-tomato-firmware-support.71709/page-2

    It seems that Tomato is somehow not able to use the 5G radio in AC15 with it's full capabilities. There is no hardware problem, as someone suggested, since it's working normally with the tenda firmware (moreover it has an exceptionally good 5G signal...)
    Techie007 and Justio like this.
  18. WildFireSG

    WildFireSG Addicted to LI Member

    Again, I would highly recommend setting Wireless Mode to N-Only if you do not have any wireless-A clients.

    Also, a few more questions/considerations:

    1. What version of FreshTomato are you running?
    2. What cell phone do you have and what software version?
    3. Try setting country to Singapore and turn off Bluetooth Coexistence if it is on.
    4. Last but not least, keep in mind not all router/client combinations are 100% compatible and able to reach expected maximums. There are many variables that contribute to link negotiation speeds and it simply could just be the hardware combination. Have you tried a laptop or any other wireless client besides your cell phone?

    Screenshot of my Advanced Wireless Settings for both 2.4GHz and 5Ghz (practically everything is set to default values as I have experienced negative results when tinkering with them):

  19. edud2k

    edud2k Network Newbie Member


    Thank you for sharing this information.
  20. edud2k

    edud2k Network Newbie Member

    1. What version of FreshTomato are you running? 2018.3.018-beta
    2. What cell phone do you have and what software version? Xiaomi Mi Max Prime / LineageOS
    3. Try setting country to Singapore and turn off Bluetooth Coexistence if it is on. Yes, I did as you instructed.
    4. Last but not least, keep in mind not all router/client combinations are 100% compatible and able to reach expected maximums. There are many variables that contribute to link negotiation speeds and it simply could just be the hardware combination. Have you tried a laptop or any other wireless client besides your cell phone? yes, I have other devices that are connected in the wireless network, and all with the same speed limit or signal range. I have a wifi A / C adapter that I will test on my notebook to see at what speed it works.

    Once again, thank you for your attention and support.

    you and the other users have my respect and admiration
  21. TH1324

    TH1324 New Member Member

    First of all, thank for your work kille72 and pedro311.

    I'd like to ask what hardware is best supported by the FreshTomato firmware for the moment, and will be supported in the near future? Are you planning to abandon any vendors from the list?

    If forums members could share their experience with FreshTomato and their routers, I'd be very grateful. I'm just trying to make a decision about which device should I buy.

    I've been doing some projects with PC Engines WRAP/ALIX/APU, but I'm new to the Tomato firmware.

    Thanks in advance.

  22. usergay

    usergay Network Newbie Member

    For me, the r7000 has been stable thus far.
  23. pedro311

    pedro311 Networkin' Nut Member

    rt-ac3200, rt-n18u if you don't need 5GHz wifi.
  24. pedro311

    pedro311 Networkin' Nut Member

    Everything's fine here, both on FF Nightly and latest Chrome.
  25. RunningRoach

    RunningRoach New Member Member

    Oki... So I flashed the R8000 AIO to my R8000 (previously had ddwrt) .... I checked the nvram reset.... It flashed successfully, all the lights come up as normal BUT here is the problem:

    1. I don't think the nvram reset worked
    2. A dhcp address is not assigned (dhcp was off in ddwrt)
    3. I manage to go in using static IP assignment to what the router was (
    4. I get the username and password screen, no matter what default passwords I try (I've tried close to 30 combinations of admin/root/blank/user/password) I can't authenticate to the gui.
    5. I tried same steps as item 4 for ssh login.
    6. Failing miserably I have 3x30 reset about 10 times in an attempt to get nvram reset to kick in, but it doesn't

    Anyone have any suggestions other than the USB to serial option?
  26. partypop69

    partypop69 New Member Member

    I have:
    Router1- R7000 for network
    Router2- R7000 for network
    Both routers have VLAN and isolated guest networks.
    Both used Shibby's latest and worked fine to isolate the guest networks, but once I upgraded to
    Freshtomato guest network SSID broadcast fine, IP address received from br1 on the guest network scheme,
    but no internet connectivity. I removed the firewall script and that didn't help. Switched back to Shibby and walla it all works fine.
    Any ideas? BTW, Router1 works fine with Freshtomato with the guest network, its only the 2nd router is having the issue. Tried 2018.2 and 2018.3.018 beta
  27. usergay

    usergay Network Newbie Member

    Try doing the nvram reset using the WPS button instead of reset, this helped bring back my router when it was stuck in this stage. Also I believe you can do the telnet trick by using the wireless on/off button to log in to the terminal.
  28. hkdrj01

    hkdrj01 Network Newbie Member

    I´m using the latest beta (2018.3.018) but this happened on previous beta too on an ASUS AC3200. I have 3 LANs:

    br0 Disabled Enabled - 150 1440
    br1 Disabled Enabled - 150 1440
    br2 Disabled Enabled - 150 1440

    ASUS AC3200 has two 5GHZ and one 2.4GHZ wireless interfaces, and the three are configured. I need two more Wifi on the 2.4GHZ one for each LAN, so I setup Virtual Wireless.

    When I create wl0.1 everything works fine, but at the moment I create the wl0.2, I start having authentication problems on all the 2.4GHZ, virtual or not. On the iPhone I get "incorrect password" message, on Windows 10 it doesn´t connect and in the log I see "Dynamic key exchange did not succeed within configured time". At the moment I remove wlan0.2 and reboot the router, everything works again.

    So, does anyone have any tip on what I can do to solve this ? Maybe I´m doing something wrong, but I can´t tell what.
  29. bd0426

    bd0426 Networkin' Nut Member

    I'm not sure it's related and could possibly be deemed OT, but...

    I'd be curious to know how many wireless devices you are attaching total to the 2.4GHz WiFi across all 3 (main plus 2 virtual) interfaces.

    See my previous inquiry here that could be similar -> http://www.linksysinfo.org/index.php?threads/fork-freshtomato-arm.74117/page-3#post-296718

    I have been keeping an eye on this thread for posts from other RT-AC3200 owners possibly having the same problem and I'm surprised how many folks seem to be using this unit with no issue. Perhaps they are not using the wireless capability at all and are solely using the router to route (imagine that) or perhaps using so few wireless devices that they never notice.

    Maybe try troubleshooting by clearing NVRAM and setting up only the main interface (with no virtual interfaces) and attaching all of your 2.4GHz devices to it temporarily to be sure they will all connect simultaneously on a single interface before you go down the multi-virtual-interface rabbit hole.

    I'd like to hear from other RT-AC3200 owners that are using Fresh Tomato and have successfully attached 11 devices to the 2.4GHz WiFi simultaneously.

    I ended up using DD-WRT on the (7) 3200s I own to work around the 10+ device problem they all seem to have under Fresh Tomato. I can with certainty say that I can get at least 19 devices (all I have) attached to 2.4GHz across multiple virtual interfaces under DD-WRT. The advanced wireless config on DD-WRT also allows a max of 80 vs the 32 Tomato (all flavors) seems locked to on my units (which is still less than the 255 I'm accustomed to typing in that field over the years).

    That is not to be read as an endorsement of DD-WRT nor a condemnation of Tomato, just a chronicling of my troubleshooting and experiences with the RT-AC3200 and various Tomato flavors.
  30. SNR

    SNR Addicted to LI Member

    @pedro311 - the [Downloads] link from your sig and profile here points to a MEGA page for FreshTomato-MIPS. Ditto for the Downloads link on your Bitbucket page for FreshTomato-ARM - that link points to the same MEGA page for FreshTomato-MIPS.

    Apologies for not keeping up, but are you also providing pre-built images for FreshTomato-ARM? If so, where? Thanks...
  31. kille72

    kille72 LI Guru Member

  32. hkdrj01

    hkdrj01 Network Newbie Member

    I read your post, and that´s exactly what happens to me. I was under the impression that it happened when I connected the 7th device to one of the virtual Wifi, but now that you mention the total number of clients on all 2.4GHz, the problem it´s exactly the same. Only 9 clients allowed. The 10th can´t connect until other client disconnects.

    I do cleared NVRAM and tested only without virtual interfaces, and no OpenVPN, VLAN, etc, but connected only 7 clients an thought that the problem was solved, since I was thinking the limit was 6 clients on that interface, which is the one with most clients in my case. Now that I now it´s 9 for all of then, I´d have to repeat the test, but I don´t have that many devices to test. The problem showed when I had guests at home thus reaching the 10th client.

    Anyway, true it´s I need 2 virtual Wifi, so even if it works without then , that won´t cut it for me. Maybe I´ll give a chance to DDWRT too when I have the time and if the problem get´s solved in Fresh Tomato I´ll gladly come back.

    Thanks a lot for your thoughts on the matter.
    Last edited: Jun 22, 2018
  33. SNR

    SNR Addicted to LI Member

  34. RunningRoach

    RunningRoach New Member Member

    Thanks, but that didn't work....>HOWEVER< searching for that solution guided me to a page that told me that Broadcom routers don't work that great with 30-30-30 reset, and instead i should try a 30 second single reset followed by another 30 second single reset......Worked like a charm.

    1. Power on ROUTER till all lights are on
    2. press the reset key for 30 seconds until all lights go orange
    3. once orange lights go off, let go of reset button.

    This will start the reset sequence which takes about 2 minutes to complete....then the lights will flash, Power will turn Orange, then white....then it will start its boot.....in 45 seconds all the wifi lights come on and VIOLA!
  35. travism

    travism New Member Member

    I have the R7000 with a recent install of Fresh Tomato that's reporting a CPU Temp of 67°C in a room that is proably 22°C. But it's also mostly idle because I haven't really set it up yet.

    From the stats page:
    Current Version: 2018.3.018 -beta K26ARM USB AIO-64K
    Uptime 0 days, 08:27:27
    CPU Usage 1.77%
    CPU Load (1 / 5 / 15 mins) 0.02 / 0.03 / 0.05
    CPU Temperature 67°C
    Wireless Temperature
    eth1: 2.4G - 49°C eth2: 5G - 50°C

    If we assume it would go up +5°C when doing "real work" that would support the +50°C over ambient estimate. I wonder how much a cooling mat would bring that down. I also wonder how much it matters. How hot is "too" hot?
  36. usergay

    usergay Network Newbie Member

    :) Glad you got it up and running again!
  37. kille72

    kille72 LI Guru Member

    No. FreshTomato team has split up the work, I compile ARM, @pedro311 compiles MIPS. Our ARM repo's are identical. The idea is that everything will move to freshtomato.org later this year. Is there a problem?
    Last edited: Jun 23, 2018
    SNR and The Master like this.
  38. kille72

    kille72 LI Guru Member

    FreshTomato 2018.3-ARM is ready for download. More info in first post.

    The implementation of DNSoTLS will begin in the next beta 2018.4.x.
    Last edited: Jun 23, 2018
  39. user17600

    user17600 Reformed Router Member

    While peak temperature obviously has some significant downside (melting, or fire as an extreme), it's actually the heating/cooling cycles that are killers for any PCB. Thermal expansion and contraction weakens the soldering and connections on the board. The more extreme the temperature swing, the more likely for damage.

    Is it happening overnight? No. It's a cumulative thing. Heat>cool, Heat>cool.

    Is it worth extending the life of a $150 router, since it's likely the technology improves during it's lifespan? That's a personal decision, but I'd much rather replace a piece of tech on *my* schedule than to deal with an untimely failure (which is how these things seem to happen)... and keeping the temp closer to 20F over room temp is worth the price of an inexpensive USB cooling mat.

    And the R7000 is set up nearly perfectly for a cooling mat, pulling air from the bottom through the side vents.
    travism likes this.
  40. The Master

    The Master Network Guru Member

    kille72 likes this.
  41. Severus

    Severus Connected Client Member

    Works for me on FF 60.0.2 and Chrome 67.0.3396.87 (both 64 bit).
  42. monoton

    monoton Serious Server Member

    http://freshtomato.org/ doesn't work for me either.
    Firefox 60.0.2 (64-bit)
    Chrome 67.0.3396.87(64-bit)

    Edit: The site only works when third party cookies are enabled.
    Last edited: Jun 23, 2018
    kille72 likes this.
  43. GhaladReam

    GhaladReam Network Guru Member

    I'm still having this issue in 2018.3 final (Released June 22). Perhaps try adding some virtual wireless interfaces to each 2.4 and 5 Ghz? "Ethernet Ports State" still disappears for me..
  44. kille72

    kille72 LI Guru Member

    The Master likes this.
  45. gs44

    gs44 Addicted to LI Member

    Latest ARM Beta still running rock solid since flashing on my R7000, Thanks FreshTomato Team!!!

    For those discussing R7000 Temperatures, a cooling pad works obviously, but All I did was add 1/2 inch thick feet on the 4 bottom corners to lift the bottom up so air could actually get to the bottom air vents, no fan or cooling pad needed.

    It has been running non stop and over clocked for 3-4 years without issue, average cpu temp is 60-73 C depending on room temperature. All wireless radios and QOS is on and it is the main brain of a rather large home network.
    travism likes this.
  46. sszpila

    sszpila Serious Server Member

    I use ipv6 by hurricane electric tunnel, and have this in logs :

    miniupnpd[3682]: Failed to convert hostname '2001:xxx:70:1ae::xxxx:xxxx ' to ip address
    Wysłane z mojego Redmi 4X przy użyciu Tapatalka
  47. Jose C

    Jose C Serious Server Member


    In previous versions you needed to put this into firewall script in order to the router (being an AP) be able to resolve dns, in the newest version just released is this still needed?

    if [ "$(cat /etc/resolv.conf | grep" ]
        rm /etc/resolv.conf
        echo "nameserver" > /etc/resolv.conf
        logger "Resolv.conf server IP corrected."
  48. ShrekSWFL

    ShrekSWFL New Member Member

    @ Devs- First, thanks for continuing the Tomato work! Now, on to my silly question.

    I had to buy a new r8000 router last week, as my old one died. Upon trying to flash the firmware, I get a Firmware not compatible message. Tried other firmwares, researched the web, and Presto! Netgear looks to have put a minimum firmware block into the (at least ) R16 and R17 revisions. (My old one was an R13) .
    Someone did get around it and successfully install DD-WRT, But it required cracking the router and a serial cable.

    (and the site won't let me post the link to that forum or picture of the cfe console and version error because I am a newbie, thanks spammers)

    SO here is my question, can I, through altering the source and recompiling, "fool" the version number? Trying to find where that is set in the sources (and reading the last 3 stock sources to make sure it isn't a setting put in by and FW)
    I CAN downgrade to, but not stock versions.
    Error is same for Adv Tomato initial .chk, Freshtomato .chk, ddwrt, etc...

    Yes I factory reset, 30/30/30 reset, 30 reset/ boot 2 minutes/ 30 reset. Have tried to tftp both lower firmware and customs during the ttl=100 time at boot, and stood on my head while drinking a glass of sand.

    Any ideas or suggestions would be appreciated, as I am at my wits end (especially with netgear and their "support"), and I am stuck with this router or out the $300.
  49. R7000user

    R7000user Network Newbie Member

    Summer here in Tokyo and its 32°C outside. My R7000 was showing 69°C as the CPU temperature this morning, so I raised it 10 mm on rubber feet and positioned a room fan to blow over it. After 10 minutes it has dropped by 20°C to 49°C, or 17°C over ambient.

    travism likes this.
  50. ShrekSWFL

    ShrekSWFL New Member Member

    I found ambitCfg.h in the /ap/acos/include directory of the stock sources, as well as ambitCfg.h and abbitCfg_WW_R8000.h in the /project/acos/include of stock source. These seem to set the version numbers. Two oddities I noticed.
    (1) In the stock sources for 4.12 and 4.18, the line defines AMBIT_UI_VERSION as "10.1.49", yet in 4.4 it defines it "1.1.42". Might this line be the delimiter (1 vs 10) for the newer revisions inability to do older stock firmware?
    (2) In the /ap/acos/include directory of both 4.12 and 4.18, the files are identical, claiming to both be "". (The file in the project directory is the correct version number, I just found it amusing and thought I would share)

    So, can I just take and alter the ambitCfg-R8000.h from the arm7 fork and recompile? Do I just change the versions to match one that works?
    I notice the differences between 4.4 and 4.12, other than the software, ui, and tbl string versions, are the addition of defining another product name tri-band and model url tri-band, as well as defining some generic and specific HW IDs for the dual band and tri-band classes, and even one that claims to be for the r8000p. Do I need to add these as well?

    I'm kinda fumbling in the dark here, just using logic and lots of comparisons.

    Thoughts are appreciated.
  51. Twincam

    Twincam Networkin' Nut Member

    Thanks for this - cured! On my RT-AC3200 the messages would only appear in syslog when the WiFi devices were all switched *OFF and I was displaying the main "Overview" ["Status"] page. If I wasn't viewing the page, the messages did not appear.
  52. rs232

    rs232 Network Guru Member

    I have been trying to set up the 5GHz interface for sometime now. It seems to be broken. Did anybody have any success forcing A Vs N (5GHz) and setting up a channel other than 36?
  53. pomidor1

    pomidor1 Networkin' Nut Member

    I have channels 40 @Botswana and 136 @Liberia set on R8000 and what's the problem?

    And I understand, if you force it, for example, A does not display the Wireless Network Mode in the overview
    I have the same

    but I did not clean the nvram
  54. rs232

    rs232 Network Guru Member

    This is after a 30/30/30 reset.
    Hum I did switch to Botswana and I can see some results now... still not perfect but at least I can change channel.
    I get few interface errors (like pop ups with undefined items).

    Is perhaps the case to change the wifi default country to Botswana for the Freshtomato releases?
  55. sszpila

    sszpila Serious Server Member

    I have Botswana as my country setting on my Ac56u. It worked on freshtomato 2017.3, 2018.2 and it works on 2018.3 with no problems.

    And rs232, p2partisan still work great with newest freshtomato-arm.

    Wysłane z mojego Redmi 4X przy użyciu Tapatalka
  56. pomidor1

    pomidor1 Networkin' Nut Member

    He may be right, change the auto mode to A, then he does not display well in the overview tab
  57. apreslin

    apreslin Connected Client Member


    I have a RT-AC3200, and have the exact same issue with a 10 device limit. It has become frustrating because most smarthome devices such as smartplugs and bulbs don't do 5GHz so I have to put them on 2.4GHz, and I have apparently maxed out because of this.

    You can change the max clients value in terminal via SSH in NVRAM, but you would need to do a script on each boot. Nonetheless, it didn't have an effect. You can see the variables and other ones with something like "nvram show | grep max" or "nvram show | grep wl0" and change it with "nvram set wl0_maxassoc=255". If you change it there, it will be reflected in the Tomato GUI and not revert back to 32 immediately if you hit save in the GUI.

    That doesn't fix the issue anyway, which makes sense since the magic limiting number seems to be 10 and not 32. I looked for any variables set to 10 and couldn't find any that seemed to be related.

    As you pointed out in the log in your previous post, the messages "wlc_userscb_alloc: no SCBs available to reclaim" along with “wlc_ap_auth resp: out of scbs for xx:xx:xx:xx:xx:xx” are present with the mac address of the device that can't connect at that point when 10 devices are already connected. I googled for awhile, but haven't come into anything relevant to what exactly "SCB" or "scbs" is. I tried a text string search within all files of /, but wasn't able to come up with anything there either.
    Last edited: Jul 3, 2018
  58. M_ars

    M_ars Network Guru Member

    thx for the update

    right now everything i use does work :)
    - OpenVPN
    - vlan
    - IPv6 (Dual stack, DHCPv6 with PD)
    - NTP Time Server
    - samba
    - portforward
    - and and and
    Joe A and kille72 like this.
  59. Joe A

    Joe A Serious Server Member

    Yep. Everything I use seems to be working as expected as well.
    Same as above , except no OpenVPN in use.
    Last edited: Jun 26, 2018
    kille72 likes this.
  60. rgnldo

    rgnldo Networkin' Nut Member

    Please, the option DNS server with Unbound as option.
  61. davis bacon

    davis bacon New Member Member

    Hi, just finished installing the 2018.3 version of firmware, now my SNMP graphing software is not functioning.
    I reset the router to factory defaults with no improvement. I am running on a Netgear R7000 using Windows 10 and perfgraph software.

    Thanks for any help you can provide.
  62. sszpila

    sszpila Serious Server Member

    I. Can't confirm. Snmp still working on my Ac56u. [​IMG]

    Wysłane z mojego Redmi 4X przy użyciu Tapatalka
    pedro311 and kille72 like this.
  63. WildFireSG

    WildFireSG Addicted to LI Member

    @kille72 @pedro311

    Thank you for the very stable 2018.3 release. I'm running on an RT-AC68U and have done a complete NVRAM clear and a manual resetup by hand. 5 VLANs working without issue as well as 4 wireless segments (wl0, wl0.1, wl1, wl1.1).

    I'd like to give a bit of feedback on a potential issue.

    The only issue I appear to may have discovered thus far is with the Bandwidth and IP Traffic monitors. The router was set to automatically add clients which seemed to work, but tracking the actual bandwidth and IP traffic stats didn't seem to register very much. So I specifically added my IP to the IP Traffic monitoring. After downloading over 1GB of data from the Internet (to register traffic on LAN and WAN), the IP Traffic for my IP shows a total of 156KB of transfer...71KB Download and 85KB Upload. Obviously this is incorrect. Both of these worked fine in 2017.2 release.

    Any ideas?
    Techie007 likes this.
  64. davis bacon

    davis bacon New Member Member

    I can get the SNMP walk OIDs as well, but for some reason, no matter which graphing software I use, it's not working.
  65. sszpila

    sszpila Serious Server Member

    I use librenms to gather and graph snmp data. Still working. [​IMG]

    Wysłane z mojego Redmi 4X przy użyciu Tapatalka
  66. Haldi4803

    Haldi4803 Reformed Router Member

    I Don't see a R6400 Build in your downloads. does that have any specific reason? Or do you simply not build for systems not used.

    Using a R6400 OC to 1000MHz with 30°C Room temperature is currently 70°C CPU and 47°C 2.4ghz / 53°C 5ghz
    But i read somewhere that the Broadcom chip used in this Router is rated up to 125°C so fuck it ^^ not gonna actively cool that and add another noise source.
  67. koitsu

    koitsu Network Guru Member

    Sadly, many of the different Broadcom SoCs used in routers don't have public datasheets. I went looking for several last week and found none, not even on Mandarin-centric sites. :/ I get the impression Broadcom's legal staff tracks down leaks and gets the documents removed.

    That said: I've never been under the impression operating temperature range (in a data sheet, ex. -40C to 125C) represent 24x7x365 operation. I imagine temperature stress testing can last several weeks on a product, but much like MTBF, it always seems like a measurement intended representing "worst-case environment". Like: "yeah, this IC should run fine at -30C {cough cough but will probably fail much sooner than if it was operating at 20C cough cough}". I think this forum has some folks who work/worked in the industrial industry so maybe they could disclose some details on that. Occasionally I'll find a spec sheet for something that discloses what the duration of the operating temperature tests was.

    As for OCing routers: don't do it. The information contained within that link should be sufficient evidence for what completely bizarre/weird real-world scenarios happen as a result of OCing. If you're OCing your router, much like with a desktop PC, it's your choice and if it's working for you, great, but all bets are off when it comes to any kind of support (publicly or with your vendor) -- and unlike desktop PCs, embedded devices are even less intended for it. The biggest concern stems from what it does to underlying clock frequency timing; I've seen massive (as in several full seconds) clock drift happen within several minutes even on heavily OC'd-yet-stable desktop PCs. This isn't entirely about "accurate time" (as in a wall clock), it's about consistency/stability of intervals of time (e.g. interrupt N that should fire at 1000 times a second now happens only 989 times a second). I'm not aware of any SoC manufacturer who is intentionally testing their chips OC'd; if there are some, it'd be great to know who!
    Haldi4803 likes this.
  68. boooya

    boooya Network Newbie Member

    Are there any updates on support for RT-AC66U_B1?
  69. davis bacon

    davis bacon New Member Member

    Nice graphs, I tried without any success, went back to 2018.2 and SNMP is now working again
  70. Techie007

    Techie007 Serious Server Member

    Yes, this bug still remains. I think they expect me to submit a patch. I know enough about C coding to be dangerous, but have no idea where to start in the code with this issue or how to set up a compiling/debugging environment in Windows to test my attempts at patching. It's gotta be a trivial issue to fix, however.

    I am confirming this new bug. While everything in Bandwidth seems to be working fine for me, the only thing under IP Traffic that's working correctly is Transfer Rates. Everything else is reporting numbers that are an order of several magnitude too small, and the graph isn't working correctly. It worked in the last build...
    WildFireSG and Jose C like this.
  71. AndreDVJ

    AndreDVJ LI Guru Member

    I simply never tried to compile r6400z target.

    I made my R8000 a completely dumb Access Point (Almost dumb, still has an IP address to be manageable) as I don't need this unit to resolve DNS. Wireless clients connect and browse internet just fine.

    Why would an Access Point resolve DNS?
  72. sstacks

    sstacks Reformed Router Member

    I'm the guy who recently posted about router instability that I thought I had traced to a rogue ethernet-to-USB adapter. I had stability after disconnecting that device, but now I have had two router freak-outs in the past 12 hours. I would appreciate any help in troubleshooting and identifying the cause.

    I use a R7000 with an attached USB3 drive, with Samba file sharing and Transmission functionality enabled.

    I had TOP running when the last freakout happened, and I could see unusually high CPU usage from [mtdblock3] at 25.5%. I have seen similar instances of freezes with unusually high [mtdblock3] CPU usage.

    When this happens, the router is unresponsive (other than pings) but video streams in progress continue but web pages won't load. Occasionally the router has recovered on its own, but it typically requires a physical turning off/on to recover.

    Can anyone advise what [mtdblock3] does? Googling found little.
  73. SNR

    SNR Addicted to LI Member

    No problem at all, and thanks for clearing that up.

    Thanks also to you and pedro for both the ARM and MIPS images. Pizza and beer in the fridge! ;)

    rgnldo and kille72 like this.
  74. pedro311

    pedro311 Networkin' Nut Member

    Really? I can't see it on my PP account... :p
    rgnldo likes this.
  75. SNR

    SNR Addicted to LI Member

    Well that's because both the ARM and MIPS FreshTomato pages here were started by kille, so they have his signature with his Donate links, not yours. :rolleyes:

    I tried, I swear I did... but I am easily confused.

    How about now? :cool:

    Edit: Yeah, it's in there now. Check your p.dro inbox. Behind the spoiled milk. :)
    Last edited: Jun 27, 2018
    rgnldo likes this.
  76. pedro311

    pedro311 Networkin' Nut Member

    Better! :D
    SNR likes this.
  77. WillyTP

    WillyTP Connected Client Member

    Hello everybody!
    In this latest 2018.3, are Asus RT-AC68U Rev C1/E1 supported?

    If not, any plan for the next release?

    Klauss likes this.
  78. Jose C

    Jose C Serious Server Member

    Well in my case, the router could not resolve the ntp server so time was off, also, I wanted to ping some servers from the router ( i had my reason) and couldn't resolve
    Techie007 likes this.
  79. AndreDVJ

    AndreDVJ LI Guru Member

    Is an IP address, a gateway, and a static DNS server set up in your Access Point? This is the bare minimum for any computer to be able to locate resources in the internet, and applies to an Access Point.
    NotVeryClever likes this.
  80. rgnldo

    rgnldo Networkin' Nut Member

  81. pedro311

    pedro311 Networkin' Nut Member

  82. rgnldo

    rgnldo Networkin' Nut Member

  83. tripper22

    tripper22 Serious Server Member

    I installed Fresh Tomato on my Netgear R7000 a few days ago. For me everything works great with lot's of features and a strong 2.4 GHz signal. I have a lot of congestion from AP's in my neighborhood so I enabled Interference Mitigation under advanced settings in the 2.4 GHz section and set it to Wlan Auto. My 2.4 GHz wireless has never been faster or more stable. I can't say thank you enough to @kille72 and @pedro311 for all the work they do and keeping Tomato alive. :D
  84. usergay

    usergay Network Newbie Member

    If you are experiencing too much congestion on the 2.4 band, then yes "interference mitigation" will help as well as dropping the width down from 40mhz to 20mhz.
  85. tripper22

    tripper22 Serious Server Member

    Really? Because I connect at 150 Mbps and at 20 Mhz I only connect at 72 Mbps. And I am getting double the speeds over 20 Mhz.
  86. usergay

    usergay Network Newbie Member

    What's you ISP's speed?

    For me, even though my connection shows 150mbps @ 40mhz, my actual speeds are faster on 72mbps @ 20mhz.

    Using one channel (20mhz) in my area is more stable than using two (40mhz) regardless of the channel combination I select.
  87. tripper22

    tripper22 Serious Server Member

    270 Mbps up and down. I understand that everybody's situation is going to be different. I tested all kinds of configurations including yours. The configuration I listed above is give or take twice the speeds (throughput) of the 20 MHz configuration for my situation.
  88. usergay

    usergay Network Newbie Member

    Cool Thanks for your updates!
  89. apreslin

    apreslin Connected Client Member

    Still researching the heck out of the RT-AC3200 2.4GHz 10 device connection limit issue...

    I found this thread in the Asuswrt-Merlin forum https://www.snbforums.com/threads/rt-ac3200-limit-on-the-number-of-2-4gb-clients.47019/ which is showing this isn't just a Tomato problem, and apparently caused by the dhd (Dongle Host Driver). Someone was able to fix the limit by recompiling with an old version of the driver, check out the thread.
    Last edited: Jul 3, 2018
  90. cobrax2

    cobrax2 Serious Server Member

  91. kille72

    kille72 LI Guru Member

    Can you please try this new test version?
  92. gffmac

    gffmac Networkin' Nut Member

    I use tunnelbroker.net for ipv6, and have setup the 6in4 static tunnel. All works well but I would only like to use iv6 on one pc, previously on merlinwrt and I think tomato had the option in the past to announce on lan which I would disable and manually setup the ipv6 details on said pc which would do what I wanted. The option doesnt seem to be available on freshtomato arm. AC68U. Can I disable announce on lan some other way?
  93. Jens Preikschat

    Jens Preikschat Reformed Router Member

    Unable to edit field "Included IPs" located under web page: 'Administration' / 'IP Traffic Monitoring'.

    Symptom: Cannot get focus onto the field. Workaround is to set the 'Included IPs Values' through NVRAM set command. Once set through NVRAM, the values are correctly displayed in the 'Included IPs' field, however the field remains locked / inability to edited.

    Router: Netgear R7000, ARMv7 Processor rev 0 (v7l)
    Firmware: FreshTomato Firmware 2018.3 K26ARM USB AIO-64K
    NVRAM Free: 28%

    'Included IPs Values' Field was previously accessible using Shibby build: 1.28.0000 - 138 K26ARM USB AIO-64K
    Router firmware was upgraded to FreshTomato, after flashing, all data was erased in NVRAM memory to provide a clean upgrade path.
  94. UserDirk

    UserDirk New Member Member

    Thank you for your work. I've the Cisco E3000 and the 2018.1 work, but not the 2018.3 and 2018.3.011-beta (K26 only - smaller size) all are too great. Message: File is too big to fit in MTD. Must be 8MB and all greater than 8MB.
    Windows filesize infos: 2018.1 7,55MB (work) and the same 2018.3 7,91MB (too great)
  95. kille72

    kille72 LI Guru Member

    Wrong thread...
    Last edited: Jul 1, 2018
  96. pedro311

    pedro311 Networkin' Nut Member

    You need to uncheck "Enable Auto-Discovery" first...
  97. apreslin

    apreslin Connected Client Member

    Last edited: Jul 3, 2018
    Techie007, travism, M_ars and 2 others like this.
  98. someburner

    someburner New Member Member

    Thanks for x-posting over here! I had actually suspected something might be wrong with the dhd.o file since it looked like Merlin had a newer .o, but I left it at the 2015 version since I really just needed >10 clients and it seemed to work. Of course, that version is missing krack fix and who knows what other fixes- I will say it was pretty unstable even though 10+ clients worked.

    I recompiled my tomato with the dhd.o (May 2018) and things are looking much better over here as well.
    apreslin likes this.
  99. apreslin

    apreslin Connected Client Member

    No problem! I'm happy that bug has been quashed and now am finally running Tomato on the RT-AC3200 without any known issues in my setup. I really didn't want to change hardware or jump off Tomato and wasn't sure that was a bug that would ever be figured out. Glad I was able to google and come across your post on the Asuswrt-Merlin forum. I spent many hours messing with NVRAM variables and dhd command parameters hoping to find something that would change the connection limit behavior. I'm not a developer and probably wouldn't have gone to the extent of recompiling it myself.

    Thanks again to you, kille72, and pedro311!

    Last edited: Jul 3, 2018
    kille72 likes this.
  100. Twincam

    Twincam Networkin' Nut Member

    RT-AC3200 & freshtomato-RT-AC3200-ARM-2018.3-AIO-64K.trx

    Working very well via PPPoE. Has been running smoothly for a few days supporting 2x vLAN, 2x vWLAN, 2x DDNS, 2x OpenVPN servers [TAP & TUN], remote syslog etc. ....

    M_ars and kille72 like this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice