[Fork] FreshTomato-MIPS - development thread


rs232

Super Moderator
Staff member
It seems like @pedro311 did it again ;-)

I can see MIPS1 builds under 4MB with VPN and VPN2

1581584880515.png

Before I try, what are the differences between the two builds and does any of the these include tinc by any chance?

Thanks!
 

FredericM

Connected Client
Member
2019.2 running on a RT-N16

I noticed a device in VLAN2 with an IP out of my local LAN

It turned out to be the IP for the gateway for the WAN interface. The MAC corresponds to a cable access network solutions OEM.

If you really want to find out, start unplugging until the device dissapears. The non-listed MAC can be spoofed, and the IP out of your range can be the static IP that the interface had when connected to your network
I tested a bit further and was able to narrow it down to my home server which hosts a VPN server. Apparently, it generates a random MAC and uses the 172.31 range to do it's magic (didn't pay attention to what it exactly does).
Thank for your suggestions!
 

spread48

New Member
Registered
Hi. I had recently upgraded my e3200 but I have two issues: cannot update my DDNS IP (Unknown libcurl error 60 with response code 0). Also, it seems that after a reboot my 2.4ghz becames open (the shared key is gone) - although I had to unset the empty vars at some point to get more free NVRAM space and that could be related.
 

WildFireSG

LI Guru
Member
Hi. I had recently upgraded my e3200 but I have two issues: cannot update my DDNS IP (Unknown libcurl error 60 with response code 0). Also, it seems that after a reboot my 2.4ghz becames open (the shared key is gone) - although I had to unset the empty vars at some point to get more free NVRAM space and that could be related.
Hi new member @spread48. Please review page 1 of this thread, section "How to report a bug or problem"
 

kernel-panic69

Serious Server
Member
Hi. I had recently upgraded my e3200 but I have two issues: cannot update my DDNS IP (Unknown libcurl error 60 with response code 0). Also, it seems that after a reboot my 2.4ghz becames open (the shared key is gone) - although I had to unset the empty vars at some point to get more free NVRAM space and that could be related.
Check force renewal.

@kernel-panic69 how’s the dnsmasq update coming along?

I remember you were mentioning back in November I believe that ARM was running fine for you as well.

Maybe best next step is to PR into main branch so wider audience can test and help debug boundary case issues?
Just now seeing this. I have nothing to do with dnsmasq. I have been working on busybox. I have other things on my plate, but I have been trying to keep up with development and how it may affect things. I am likely going to have to merge upstream on one file in particular in the MIPS branch, regardless of kernel version because making that a reverse patch is too cumbersome. I still have to look at kernel patches from RHEL and others that I want to test as well.
 

Edrikk

Forum Guru
Member
Sorry yes my typo. Did mean busybox.
Ok got it. Was thinking that based on your posts things seem to be generally functioning. Given how difficult a task it is to get to where you got, it probably makes sense to merge, so more people can then take it to the end.
 

fiwiman

Reformed Router
Member
Hi, I just upgraded to 2020.1 (freshtomato-RT-N66U_RT-AC6x-2020.1-AIO-64K.trx) trying the AC6x version this time and restored my config from the MIPSR2 version (it has 3 tagged VLANs on br1/2/3 on a single port) and untagged trafiic across all ports. The minute I restore my configure I lose complete access to it on my untagged LAN. Normally, an upgrade from the MIPSR2 is simply a restore of config and I'm good to go.

To troubleshoot, I figure to try to rebuild by config my hand and I noticed the minute that I configure a VLAN (basically check Tagged to "On"), I am unable to ping the router anymore on the untagged LAN.

Went back to MIPSR2 and no problem...
 
Last edited:

danielhaden

Forum Guru
Member
Hi, I just upgraded to 2020.1 (freshtomato-RT-N66U_RT-AC6x-2020.1-AIO-64K.trx) trying the AC6x version this time and restored my config from the MIPSR2 version (it has 3 tagged VLANs on br1/2/3 on a single port) and untagged trafiic across all ports. The minute I restore my configure I lose complete access to it on my untagged LAN. Normally, an upgrade from the MIPSR2 is simply a restore of config and I'm good to go.

To troubleshoot, I figure to try to rebuild by config my hand and I noticed the minute that I configure a VLAN (basically check Tagged to "On"), I am unable to ping the router anymore on the untagged LAN...
Maybe it is possible to figure out what happend to RT-AC?

Fortunately, there are RT-N versions for n66u: https://exotic.se/freshtomato-mips/v2020/2020.1/K26RT-N/Asus RT-N66u 64k/
 

Top