[Fork] FreshTomato-MIPS

Discussion in 'Tomato Firmware' started by kille72, Apr 26, 2018.

  1. candycrush

    candycrush Serious Server Member

    I appreciate what you're saying but I have many legacy devices that I just can't do that with so I thought it would be easier to update the router. Would the authors consider an option in this firmware so that I could use the new driver with the hack that stops KRACK, even if it false positives?

    Is there another significant vulnerability affecting WPA after KRACK?
  2. pedro311

    pedro311 Networkin' Nut Member

    I recommend clean install, as stated in OP.
    MongooseProXC likes this.
  3. pedro311

    pedro311 Networkin' Nut Member

    Could someone with WRT54* (4MB) check if new build of "freshtomato-K26_RT-MIPSR1-2018.3.038-beta-Mini" with various size optimizations from the test directory on FreshTomato-MIPS download, fits into it?
  4. pedro311

    pedro311 Networkin' Nut Member

    ad1. Good ;)
    ad2. Probably. Did you try adblock with lower number of lists?
    ad3. Fixed: https://bitbucket.org/pedro311/freshtomato-mips/commits/db9689e40ea4bf3dd2e7fd37890ddeff08f7b1d4
    ad4. I tried to find the cause, but I didn't manage (maybe later)
    ad5. Fixed: https://bitbucket.org/pedro311/freshtomato-mips/commits/fbe792aaea1bde6f8c59534635d137bf0ffeb3b7
    ad6. Good ;)
    ad7. :D

    ad a/b. Adblock is just a tiny script, so we will not gain much by removing it, unfortunatelly...
    K3rm1t4 likes this.
  5. Pomodoro

    Pomodoro New Member Member

    Attempting an update from 2018.3.006 MIPSR1-beta K26 MiniIPv6 to .038-beta-Mini showed a "MTD too large" error message during the update attempt. The same was true when I previously tried the .011-beta-Mini version. Tested with a WRT54GL / 4mb.
  6. pedro311

    pedro311 Networkin' Nut Member

    OK thanks.
    Will try to lower size more...
  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    If you care about KRACK you should either update (if possible) or retire (if not) the device.

    It's not a matter of the authors being unwilling, its a matter of the wireless driver being closed source. Such a feature would have to be integrated into the wireless driver, which is a binary blob written by Broadcom. You can try yelling at them to include mitigations in their driver but I suspect the most they'll do is forward information about the existence of Tomato to their legal department for a terminate the use of our IP nastygram. Though I wish them luck trying to figure out where to deliver it (I don't know). At best MIPS is a legacy platform for them and they're only maintaining their existing source, not developing new features.

    You think the only vulnerabilities you have on legacy devices are WPA related? The applications you run on those devices are fully up to date? The OS on those devices are fully up to date?

    This is the last I'll write on this, sorry for taking the thread off track.
    pedro311 and kille72 like this.
  8. Pomodoro

    Pomodoro New Member Member

    FYI, I also gave .044-beta-Mini a try - same result. Thank you for your efforts on this front!
  9. K3rm1t4

    K3rm1t4 Network Newbie Member

    Just in case you're not already aware of this:
    The max image size for 4 MB flash router models like WRT54GL is 3801088 bytes (3712 KB), acccording to DD-WRT Wiki and other sources.
  10. Pomodoro

    Pomodoro New Member Member

    The .044-beta-Mini image is 3883008 (3792 KB), so we're only 81920 (80 KB) off the mark. If compression has been utilized to its fullest extent, perhaps the removal of one item which is already missing from MiniIPv6 would do the trick (such at https admin logon). This would effectively create a "MiniIPv6 plus" version which would be the go to 4mb firmware version.

    Unless I'm missing something, I don't see the need for multiple 4mb firmware versions. One version that is relatively easy to maintain for pedro311 and the others would be ideal. To me it is more important to have a firmware with updated core components than to have multiple variants trying to squeeze every last feature into the image size. To that end, the firmware will need to be somewhat smaller than 3712 KB to allow some "wiggle room" for changing core component sizes down the road.
  11. Pomodoro

    Pomodoro New Member Member

    .054-beta-Mini successfully flashed to my WRT54GL. So far, so good. Thank you!

    If you need any specific feedback, just let me know.
  12. koitsu

    koitsu Network Guru Member

  13. Justio

    Justio Networkin' Nut Member

    Last edited: Jun 24, 2018
  14. K3rm1t4

    K3rm1t4 Network Newbie Member

    That makes perfect sense ... Unfortunately, checking the make file didn't come to my mind initially which would have saved me quite some time.
    @Justio, thanks very much for pointing me to this and also checking the possibility to build an image with HTTPS support for 4 MB flash routers.

    @pedro311, thanks very much for the HTTPS GUI fixes.
    I'd appreciate though if integrating HTTPS admin access in Mini builds could be revisited later on. I still think this would be a nice feature to have, but I understand the challenges due to the image size constraints.
    Last edited: Jun 24, 2018
    Justio likes this.
  15. Twincam

    Twincam Networkin' Nut Member

    WRT54Gv1.1 & small builds ["test" folder]

    I have now retrieved a mate's WRT54Gv1.1 [it used to be my router!] and can provide some feedback .... so far, not positive.

    The only FreshTomato image I have successfully flashed is "freshtomato-K26_RT-MIPSR1-2018.3.054-beta-Mini.trx". However, it does not run; no WebUI or Telnet access is possible. After flashing, the router remains in "recovery" mode and I can immediately recover it by TFTPing the original Tomato ["WRT54G_WRT54GL.bin"] to it without a power-cycle. Previous "test" versions left the router in an unpingable state.

    My experience is almost exactly what @Pomodoro reports above [much more succinctly - thanks!]. Unlike Pomodoro, I was unable to flash freshtomato-K26_RT-MIPSR1-2018.3.011-beta-Mini.trx to my WRT54GL [although I will try this again and update here if neccessary].

    I will do more detailed "AdBlock" tests "sometime" very soon.

    Unlike Pomodoro, I'd suggest that the builds tailed "-beta-MiniIPv6" are, potentially, a better starting point for WRT54G* devices because they are significantly smaller to start with [and @pedro311 has already provided some fixes above]. However, I don't know the functional difference between "MiniIPv6" & "Mini" builds - and, of course, that could be critical.

    I can provide NVRAM dumps for WRT54Gv1.1 [under Tomato - retrieved via CIFs] or WRT54GL [via the "System Commands" menu] if required.

    One thing is for certain. Toggling between original Tomato & FreshTomato versions so rapidly underlines the enormous amount of work that has been undertaken in the past 9 years. Awesome! :cool:
  16. pedro311

    pedro311 Networkin' Nut Member

    Just flashed "freshtomato-K26_RT-MIPSR1-2018.3.061-beta-Mini" from "tests" folder to my WRT-54G v3.1 - it fits.

    Everything's fine here (however, i suggest clean install).
    Even Wireless Client mode works, but need special procedure.
    Adblock works just with 1 - 2 medium lists, otherwise it hangs router (to little memory, to parse lists).

    I think, I'll build betas for all routers, next week.
    M_ars likes this.
  17. Twincam

    Twincam Networkin' Nut Member

    Very strange; I have just tested freshtomato-K26_RT-MIPSR1-2018.3.061-beta-Mini.trx. You have obviously successfully flashed and booted whereas my WRT54Gv1.1 will flash .... but not boot [a useful visual indicator is that the WLAN LED never lights]. Maybe the hardware is just sufficiently different between v1.1 & v3.1 to stop it.

    Below are the "board*" type NVRAM values for my router as reported under "Tomato" [the original JZ version].


    It should also be noted that this device has only a 125Mhz CPU [NVRAM: clkfreq=125].
  18. RMerlin

    RMerlin Network Guru Member

    kille72 likes this.
  19. Edrikk

    Edrikk Network Guru Member

    I think Koitsu is volunteering
  20. koitsu

    koitsu Network Guru Member

    The only one I can think of off the top of my head is wl. Are you aware of others?

    If that's the only binary: would wlc not be an option? It uses the proprietary Broadcom API for both older SSB as well as BCMA interfaces. It doesn't have all the arguments that Broadcom's wl binary supports, but it supports a good base set.
  21. LastSilmaril

    LastSilmaril Addicted to LI Member

    First of all, thanks pedro for taking up the baton.
    Couple regressions I noticed since 2018.1. (Testing K26 AIO on RT-N16.)
    • Ntpd does not work when more than one VLAN. (It would be nice to bring back the options to specify how often, specifically, to scrape the time. I guess that these could be related to the switch from ntpclient/ntpc to ntpd?)
    • Ping command to outside the network likewise does not work (quits right away) with more than one VLAN when pinging somewhere outside the local network. Not sure what's going on, it's like DNS resolving is just not happening.
    Couple quick questions:
    • I've been using K26 until now, but is there any advantage of running K26_RT-N builds instead?
    • Before switching over from shibby, I noticed that shibby build I was using was an NVRAM-64k build. That was a mistake for the RT-N16, right, and I'm lucky that it worked at all?
  22. pedro311

    pedro311 Networkin' Nut Member

    Did you make a clean install (clear nvram)?
  23. RMerlin

    RMerlin Network Guru Member

    Acsd in SDK 6.37 handles automatic channel selection (can't remember if it was there in 6.34). et, the Ethernet userspace tool.

    If Tomato supports it, then both emf and igs.
  24. MongooseProXC

    MongooseProXC Connected Client Member

    The other day, I jumped into the FreshTomato pool with my E3200. I flashed to version 2018.3.006-beta-Mega-VPN from Shibby's on the update page without checking the Erase NVRAM option. I let it go for about ten minutes but it kinda hung up. I power cycled it and it wouldn't boot, so I tried a 30-30-30 reset. That got it going! I erased the NVRAM afterwards.

    My first impression is that it works great! Very zippy and no real issues to speak of. I am curious about the 32k version vs the 60k for Shibby, though. So, I guess the limit was put in place because if you go over, the 5ghz radio disappears? What happens if you go over 32k with FreshTomato? Will the router brick or something or will the settings just not save?

    Lastly, I did notice a problem with Shibby's TomatoAnon reporting system. When first enabled, my router showed the correct information on TomatoAnon. After a while, all the information gets messed up. It reports weird router models and different countries like China and Costa Rica. It would be nice to get this fixed so we can see some FreshTomato routers show up.

    All in all, keep up the great work!
    Last edited: Jun 27, 2018
  25. pedro311

    pedro311 Networkin' Nut Member

  26. EpsilonX

    EpsilonX Network Guru Member

    Follow up to the QoS problem (DSL)...

    Case A :


    Running torrent with default class of P2P/Bulk (Lowest)...
    No specified class, whatever connection not classified, goes here...

    Case B :


    ISO Download
    with class HTTPS...

    Case C :


    Running torrent with default class Download...

    It seems like the lowest class is not classified properly...
  27. GhaladReam

    GhaladReam Network Guru Member


    I'm curious about freshtomato-RT-N66U_RT-AC6x-2018.3.063-beta-AIO-64K.trx in the 'tests' folder. I have this router and am currently running 2018.3.006. Is this one safe to flash?
  28. UserDirk

    UserDirk New Member Member

    I've the Cisco E3000 and the 2018.1 work, but neither the 2018.3 nor 2018.3.011-beta (K26 only - smaller size) can't flash all are too great.
    Message: File is too big to fit in MTD. Must be 8MB and all greater than 8MB.
    Windows filesize infos: 2018.1 7,55MB (work) and the same 2018.3 7,91MB (too great)
  29. pedro311

    pedro311 Networkin' Nut Member

    Yes, it is.
    It's my own test build for N66U.
    pharma likes this.
  30. pedro311

    pedro311 Networkin' Nut Member

    Next betas will be smaller due code optimization.
    pharma, rs232 and Justio like this.
  31. Twincam

    Twincam Networkin' Nut Member


    Apologies for the delayed reply. I did [clean install] but it didn't work [as I described previously]. Here's what I have just tried again this evening .... still "no go". :mad: Frustrating!

    Firstly, I can only flash from original Tomato [Tomato Firmware v1.28.1816 - WRT54G_WRT54GL.bin] or DD-WRT [dd-wrt.v24_mini_generic.bin]. Only DD-WRT offers the option to "erase NVRAM" from its WebUI during a flash operation, but Tomato offers that function as a menu option without flashing, and that was my starting point. I have tried to flash both freshtomato-K26_RT-MIPSR1-2018.3.011-beta-MiniIPv6.trx [which works well on the WRT54GL] and freshtomato-K26_RT-MIPSR1-2018.3.061-beta-Mini.trx.

    Both files report as flashed successfully but the router never boots up [Power light flashes continuously]. Continuous ping times fluctuate wildly afterwards [and the TTL value is 128 while that happens]. In fact, I know that the router is actually in "recovery mode" because I am immediately able to tftp WRT54G_WRT54GL.bin back on to it [using a Linksys tool], wait a couple of minutes whilst it reboots and then I can log in via the WebUI.

    [I even "bricked" the router a couple of times [where it became "unpingable"] but I found the TUMPA board I had previously bought [5 years ago?]. Anyway, that "saved my bacon" [after much reading] and means that I can, at least, safely test future versions. :D]

    I think it must be something to do with the WRT54Gv1.1 hardware as it is truly ancient. My guess is that it does not support the K26 kernel .... but it is a guess only. It would be interesting to hear if anyone else has successfully flashed this device with FreshTomato. WRT54Gv1.1 .... anyone?
  32. Twincam

    Twincam Networkin' Nut Member

    RT-N66U & freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.006-beta-AIO-64K.trx

    Works great! [2x vLAN; 2x vWLAN; SSHD; 2x DDNS; remote syslog; USB]

    This bug has resurfaced.

    Also, it would be great [& maybe only for routers with 8MB+ Flash] if there were more built-in "Color Schemes" [exactly like the new ARM builds]. If you are supporting many routers, colour is a great aid .... :)
  33. pedro311

    pedro311 Networkin' Nut Member

    It's because this build is before that fix ;)
  34. pedro311

    pedro311 Networkin' Nut Member

    Really don't know...
    I've just uploaded freshtomato-K26_RT-MIPSR1-2018.3.068-beta-Mini, it's even smaller.
    You can try it - but I don't think so if the size is the problem...
  35. rs232

    rs232 Network Guru Member

    My view on this is that MIPS1 devices are indeed very old but are just excellent to connect small sites via vpn.

    It would be really great to have an updated MIPS1 with nothing other than VPN (tinc included) that fits in a 4Mb device.

    The latest Shibby supporting VPN on MIPS1 was 124 but did not have tinc. I'm wondering if with the new code optimisation and removing some extras like CIFS/USB/IPv6/etc tinc could actually be squeezed in.

    my 2 cents
  36. Twincam

    Twincam Networkin' Nut Member

    Just tried [thanks!] but, sadly, with the same result. The router flashes OK but never fully boots [and is left in "recovery mode"].

    I absolutely concur with @rs232 [and a small VPN build is my goal too] except that I can't see how economical use of the limited NVRAM can be made without the CIFS client [for certificate storage].

    If the CIFS components remain in the build, could someone advise me of the correct command-line syntax to connect my ReadyNAS? I'm no expert!
  37. Twincam

    Twincam Networkin' Nut Member

    As Homer would say .... doh! :confused:
  38. maurer

    maurer Network Guru Member

    instead of CIFS mount you should consider small jffs partition to hold your certs
    rs232 likes this.
  39. LastSilmaril

    LastSilmaril Addicted to LI Member

    ...so is nobody else experiencing this? I tried it a couple of times now and settings that let these two things work with 2018.1 definitely do not work on 2018.3.
  40. jcpro101

    jcpro101 New Member Member

    What is the process to normally upgrade from Tomato Shibby build 1.40 to this beta build? Through the Web UI as per normal or are there any special install/upgrade considerations I need to keep in mind?

    I should probably just add here I have an Asus RT-N66U unit but it's running Shibby's 1.40 which hasn't been updated since mid 2017.
    Last edited: Jul 3, 2018
  41. Twincam

    Twincam Networkin' Nut Member

    There is no jffs option in this build for MIPSR1. And the overlaid "Properties" windows shows that my OpenVPN server certificates are ~20k which is too much for the available NVRAM. :(

    FT-No-JFFS.jpg FT-No-JFFS-2.jpg
  42. Monk E. Boy

    Monk E. Boy Network Guru Member

    As I recall, the WRT54G/GL had major performance issues on K26, which is why they were kept on K24 for the longest time. It worked 20 or 25% slower with some stability issues. Back when I was using one I just stayed on K24 builds to avoid them. Not sure if they were ever figured out, by the time I would've cared I had moved on.

    I'd just like to point out that a RT-N12D1 is usually around $15US refurbished, has a faster CPU, twice the RAM, twice the flash, runs K26 natively, and is 802.11n (2.4 only).
  43. maurer

    maurer Network Guru Member

    i could try to build one for you if you want me to - openvpn and jffs ONLY !
    or do you want a k24 build (although the kernel is quite vulnerable...)
  44. pedro311

    pedro311 Networkin' Nut Member

    I suggest through the GUI + clear nvram.
  45. Twincam

    Twincam Networkin' Nut Member

    That would be much-appreciated. I am particularly interested in a K26 microvpn build. So far, I have not succeeded in getting my WRT54Gv1.1 to boot after appearing to flash OK [as documented above]. I'd be very happy to test and, as I am begining to know the JTAG procedure "by heart" again, I know I can recover quickly :cool:

    As @Monk E. Boy points out, however, K26 may have an issue on WRT54Gv1.1 [but runs well on WRT54GL]. I am keenly waiting for v2018.4 ....
    Last edited: Jul 5, 2018
  46. HunterZ

    HunterZ Network Guru Member

    What is extras-mips.tar.gz for, and how do I use it? My firmwares need updating and it looks like FreshTomato is now the thing everyone is using. Thanks!

    Edit: Also, which version should I be installing at this time? Looks like the version listed as latest in the OP is not the latest on the file share, and both are marked as beta.

    Edit 2: Is there a feature table available for the different build flavors?
    Last edited: Jul 5, 2018
  47. Pomodoro

    Pomodoro New Member Member

    Just a heads up - there may be an issue with .068-beta-Mini; my WRT54GL was bricked (rapidly blinking power light, indicating bad bootloader) after attempting to flash it. Something else could have gone wrong, so emphasis on may.

    I'm taking the opportunity to take @Monk E. Boy 's advice and upgrade to an RT-N12D1. Thanks for the tip.

    Also, does anyone have any recommendations on a JTAG cable? It might be a fun soldering project to try to resurrect the 54GL, plus a JTAG is something I should probably have in my toolbox....
  48. HunterZ

    HunterZ Network Guru Member

    FYI, I flashed freshtomato-RT-N66U_RT-AC6x-2018.3.071-beta-AIO-64K.trx on my RT-N66U and it rebooted approximately every minute. Yes, I did an NVRAM clear. Tried all sorts of things to find the cause, and did manage to get it to stay up for a few minutes a couple of times, but ultimately was not able to find anything that would make it reliable.

    Flashed freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.006-beta-AIO-64K.trx instead and it seems to be working fine.
    pharma and dc361 like this.
  49. pedro311

    pedro311 Networkin' Nut Member

    No problem here even with freshtomato-RT-N66U_RT-AC6x-2018.3.081-beta-AIO-64K (check tests folder)...
    So probably it's on your side...

    Attached Files:

  50. Twincam

    Twincam Networkin' Nut Member

    Your experience mirrored mine. That build "bricked" my WRT54GL [flashing from a working freshtomato-K26_RT-MIPSR1-2018.3.011-beta-MiniIPv6.trx with NVRAM cleared]. I was able to use this to debrick it [for the first time ever]. I bought it a long time ago to debrick a WRT54Gv1.1 [used many times since ;)]. For anyone interested, I used the same commands
    zjtag -probeonly /noemw /verbose /L1:4
    zjtag -erase:nvram /noemw /verbose /L1:4
    zjtag -erase:kernel /noemw /verbose /L1:4
    for both WRT54Gv1.1 & WRT54GL routers. HTH.
  51. HunterZ

    HunterZ Network Guru Member

    Just tried 081 (without an NVRAM clear) and it reboots too. Guess I'm stuck on 006.

    Edit: Hold on, it happens early in the config process, so I'll try to narrow it down.

    Edit 2: It's the 5GHz wireless settings. If I set WPA2 Personal + AES it reboots every minute. If I set WPA/WPA2 Personal + TKIP/AES it works fine.

    I run my 2.4GHz in the latter mode because of older devices in my house, but I prefer to run the 5GHz as WPA2+AES only for higher security on that band.
    Last edited: Jul 6, 2018
    pharma likes this.
  52. HunterZ

    HunterZ Network Guru Member

    Update: Now it looks like having any encryption at all enabled on either band causes reboots.

    The overview page is also only reporting 20MHz channel width on 2.4GHz and 5GHz even though I have both configured for 40MHz. Is this a GUI issue or a functional one?

    Edit: OK, forget everything I've said so far. The issue appears to be that the router is rebooting every time a wireless client manages to connect when the WAN is up.

    I'm therefore stuck on 006 because nothing newer that I've tried is usable.
    Last edited: Jul 7, 2018
    pharma likes this.
  53. pedro311

    pedro311 Networkin' Nut Member


    On N66U, on 81-beta, WPA2 Personal, AES, 2.4GHz, 40MHz, Ch5, with all possible features switched on for tests; connected on wifi since 20 minutes...
    So I suggest clean install, probably best through CFE Miniweb - first clear nvram, and then upload image.

    Attached Files:

  54. HunterZ

    HunterZ Network Guru Member

    How do I get to CFE miniweb? I only see it for a split second when booting.
  55. pedro311

    pedro311 Networkin' Nut Member

    You really should use google for it, or even search that forum...
    Justio and kille72 like this.
  56. pomidor1

    pomidor1 Networkin' Nut Member

    HunterZ likes this.
  57. UserDirk

    UserDirk New Member Member

    I've the Cisco E3000 and the 2018.1 work and freshtomato-mips 2018.3.082-beta the same problem that all files are too big.
  58. pedro311

    pedro311 Networkin' Nut Member

    Almost all files in next beta are smaller than in V132 by shibby!
    So don't worry.
    firemax_, pharma, WildFireSG and 2 others like this.
  59. slobodan

    slobodan Reformed Router Member

    I have installed beta 81 on E4200 V1 and I had to do this to make it work (I only use it as AP):

    echo "nameserver">>/etc/resolv.dnsmasq
  60. WildFireSG

    WildFireSG Addicted to LI Member

    @pedro311 Thank you again on the continued updates. I have an Asus RT-N66 (keeping as a spare to my main RT-AC68U), a Linksys E4200 and a Linksys WRT160N that I will be upgrading.

    However, I'm a little confused on the latest release... CHANGELOG says version 2018.3.082 but the binaries in K26RT-AC and K26RT-N are 2018.3.081.
  61. Onee-chan

    Onee-chan Network Newbie Member

    Thank you!
  62. HunterZ

    HunterZ Network Guru Member

    @WildFireSG it looks like the files in the 082 folder have version numbers of 081 in their filenames. Maybe a typo in the build?

    Update on reboot thing: I noticed there are TWO different AIO trx images that *look* suitable for RT-N66U, so I tried them both:
    • freshtomato-mips 2018.3.082-beta/K26RT-AC/freshtomato-RT-N66U_RT-AC6x-2018.3.081-beta-AIO-64K.zip
      • Despite having "RT-N66U" in its filename, this one results in a reboot whenever a wireless client connects.
    • freshtomato-mips 2018.3.082-beta/K26RT-N/Asus RT-N66u 64k/freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.081-beta-AIO-64K.zip
      • This one works fine.

    I'm thinking the K26RT-AC wireless driver does NOT actually work properly on *my* RT-N66U, and that a K26RT-N firmware must therefore be used instead.

    If it helps, my RT-N66U says "H/W Ver: B1" on the bottom label.

    Someone else reported a similar experience with Shibby RT-AC on N66U:

    This person also saw the same issue of not being able to set 40MHz channel width on an RT-AC build:
  63. pedro311

    pedro311 Networkin' Nut Member

    Yes, my bad. They are all 2018.3.082.
    Onee-chan and WildFireSG like this.
  64. Onee-chan

    Onee-chan Network Newbie Member

    @pedro311 If possible, you can add CPU Usage and CPU Temperature as in the firmware FreshTomato-ARM, in the router Linksys E900.

    Last edited: Jul 9, 2018
  65. wh7qq

    wh7qq Networkin' Nut Member

    Long time Tomato-Shibby user, I decided it was way past time to upgrade the old N66U so the most conservative move was "John's fork" and I installed that. Any changes in the web pages resulted in demands for the new IP and password ??? via wireless in stentorian bold black letters so I reset the N66U with the button and tried to upgrade to freshtomato freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.081-beta-AIO-64K.trx. John's fork will not accept that: "freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.081-beta-AIO-64K.zip (unzipped to .trx file):"Firmware upgrade unsuccessfully. It may result from incorrect image or error transmission. Please check the version of firmware and try again."

    I even tried shortening the name, thinking it might be too long but no joy. The md5sum for the .zip is good so I am stuck. Can someone please tell me how I am screwing this up?
  66. koitsu

    koitsu Network Guru Member

    CPU usage should be possible (you can use CPU load in the meantime). Temperature may not be possible; the capability depends entirely upon model and revision of router, and many models do not have PHYs with temperature sensors in them (or if they do, the wireless driver does not export the capability); it's more commonly-implemented on ARM.
    Onee-chan likes this.
  67. RMerlin

    RMerlin Network Guru Member

    On the BCM470x platform, you can usually retrieve it this way:

    admin@Stargate88:/tmp/home/root# cat /proc/dmu/temperature 
    CPU temperature    : 87øC
    Provided Tomato's ARM kernel is closely based to Asus, this should work for all other BCM4708/BCM4709 variants.
    Onee-chan likes this.
  68. koitsu

    koitsu Network Guru Member

    I tried to keep it short, terse, clear, concise, and simple. Once again I'm called out and must deliver full verbose details with evidence.

    This thread is about MIPS. I will cover both MIPS and ARM because it apparently needs to be covered.

    /proc/dmu/temperature = CPU temperature
    Wireless PHY temperatures:
    - CLI: wl -i ethX phy_tempsense
    - C API: wl_ioctl(interfacename, WLC_GET_VAR, "phy_tempsense", buffer) (buffer needs to be 128 bytes or more)
    - Wireless temperature conversion: (value / 2)+20 to get temperature in Celsius

    FreshTomato MIPS code references for anything temperature-related:
    - There are none, hence there is no temperature support. Proof:
    - grep -ri temperature in router/ turns up nothing
    - grep -ri tempsense in router/ turns up nothing
    - grep -ri temperature in release/src-rt/linux/linux-2.6/arch/mips/ turns up nothing
    - Refer to below ARM references for why I'm looking for these strings
    - If this is available on Asus-based MIPS routers, then there is code that has not been imported into Tomato, or has been lost

    FreshTomato ARM code references for CPU temperature:
    - /proc/dmu/temperature driver: release/src-rt-6.x.4708/linux/linux-2.6.36/arch/arm/plat-brcm/bcm5301x_dmu.c function dmu_temperature_status()
    - router/others/sysinfo-helper : script in /usr/sbin that populates file /tmp/sysinfo-helper with data
    - Do not confuse others/sysinfo-helper with others/sysinfo which is different entirely different (and does exist on MIPS)
    - httpd/cpuinfo.c : function get_cpuinfo() executes /usr/sbin/sysinfo-helper command, then reads /tmp/sysinfo-helper, tries its best to parse the data, and returns the data in the pointers passed to get_cpuinfo()
    - httpd/misc.c : asp_sysinfo() calls get_cpuinfo() and then outputs JSON-formatted data containing said information
    - httpd/tomato.c : asp_sysinfo maps to pseudo-ASP function sysinfo() within aspapi struct
    - www/status-data.jsx : calls pseudo-ASP function sysinfo() -- this is the HTTP GET endpoint (but of course requires being provided a proper HTTP cookie TID, which I won't discuss here)

    FreshTomato ARM code references for wireless PHY temperature:
    - Wireless driver (wl.ko) itself provides the capability via WL_GET_VAR API call via wl_ioctl()
    - httpd/wl.c : function get_wl_tempsense() function calls wl_ioctl(WLC_GET_VAR) (described above), once per wireless interface, and fills the passed-in buffer with data (as well as some other wireless data, ex. band and other bits)
    - If the value returned by the API is <= 0 or >= 120, then "--" is used as the temperature
    - If the API function doesn't return 0, "--" is used as the temperature
    - If the temperature is "--" then no data is returned for this interface
    - httpd/misc.c : asp_sysinfo() calls get_wl_tempsense() and then outputs JSON-formatted data containing said information if available
    - httpd/tomato.c : asp_sysinfo maps to pseudo-ASP function sysinfo() within aspapi struct
    - www/status-data.jsx : calls pseudo-ASP function sysinfo() -- this is the HTTP GET endpoint (but of course requires being provided a proper HTTP cookie TID, which I won't discuss here)

    I think I'm missing one step in the ARM wireless PHY temperature description, but this so far has taken me over an hour to write and I can't be arsed to spend more time.

    And shame on you, Broadcom, for using a CP437 character 0xf8 in the kernel driver for the degree symbol. Tools have to filter this nonsense out when parsing. Because, you know, "%d C" would have certainly confused everyone who read it..... *sigh*
    Last edited: Jul 10, 2018
    Onee-chan, pharma, pedro311 and 2 others like this.
  69. pharma

    pharma Network Guru Member

    I had similar issues on my my*
    RT-N66U when using freshtomato-RT-N66U_RT-AC6x-2018.3.081-beta-AIO-64K. However flashing with freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.081-beta-AIO-64K worked perfectly with no reboots.
    HunterZ and pedro311 like this.
  70. Aardvark

    Aardvark Serious Server Member

    No such issue here. 2.4GHz and 5GHz clients connect fine and never had any reboots. I am using my N66U as an AP, however, if that has anything to do with it.
  71. pedro311

    pedro311 Networkin' Nut Member

    Added JFFS support to WNR3500Lv2: check "tests" folder ;)
    pharma and kille72 like this.
  72. AndreDVJ

    AndreDVJ LI Guru Member

    Simple question for MIPS users - Does Captive Portal feature work?
  73. M_ars

    M_ars Network Guru Member

    Hi pedro,

    i remember that commit, did you see

    last time Toastman added it --> 2 people reporting bricked routers :eek:
    and Toastman reverted that commit / release 511.1
    Did you optimize/change the original commit?

    you re-applied commit https://github.com/RMerl/asuswrt-merlin/commit/52ad1c0c333a64c7cd264c998553c2b52be47044


    mmh... maybe that could/should fix it
    Last edited: Jul 10, 2018
  74. Canopus

    Canopus New Member Member

    Hi guy,
    How did you manage to flash that image in to router? What method did you use? Could you provide detailed procedure? Thanks.
  75. pedro311

    pedro311 Networkin' Nut Member

    I hope so ;)
  76. GhaladReam

    GhaladReam Network Guru Member

    Did you also forget to update the build number in the about page within the firmware? It still shows 2018.3.81 on my RT-N66U using RT-AC6x AIO, but with a build date of Sat, 07 Jul 2018 16:05:32 +0200

    Is the version with that build date/time actually 2018.3.82?

    I just want to make sure I'm on the latest version, because one our of your previous "test" builds for RT-N66U (which I used) was also labelled 2018.3.81, but had a slightly earlier build date on the about page within the firwmare.
  77. pedro311

    pedro311 Networkin' Nut Member

    pharma, Onee-chan and kille72 like this.
  78. K3rm1t4

    K3rm1t4 Network Newbie Member

  79. MongooseProXC

    MongooseProXC Connected Client Member

    Upgraded to 2018.3.082-beta from 2018.3.006-beta on my E3200. Did not reset the NVRam. Works great just like it did before. TomatoAnon still reports my router's located in China, though. Any idea why?

    Attached Files:

  80. pedro311

    pedro311 Networkin' Nut Member

    You have to ask @shibby20 - it's his script on the site (probably didn't upgrade ip2country list or something).
  81. johmut

    johmut New Member Member

    Hi Everyone,

    I have been running Tomato 1.28 since I bought the router back in 2010. I believe a new build can bring me new features and more stability (I have to reset the router every couple of days as it stops responding, could IMHO very well be a firmware built-in quota that only my gaming/streaming teenager is able to reach after a couple of days ;-) ? What would be your recommendation for a build I can put on my vintage WRT54GL v1.1 ?

  82. Ansilent

    Ansilent New Member Member

    Hello guys!
    I success flashed Fresh-Tomato on my router Axesstel MV610VR.
    It`s works very stable with last beta 2018.3.082.
    But don`t work led indicators.
    Can you add led configuration for Axesstel MV610VR?
    gpio disable 3 -> pwr_led
    gpio disable 1 -> connect_led
    gpio disable 2 -> 3g_led
    and signal_led, but I can`t finde gpio
  83. geekjock

    geekjock Network Guru Member

    Same for my WRT54G v3.0. Hoping to have IPv6 enabled.
  84. johmut

    johmut New Member Member

    Gentle Bump anyone ?
  85. HunterZ

    HunterZ Network Guru Member

    You might try creating a new thread.
    pedro311, pharma and kille72 like this.
  86. bobbob

    bobbob New Member Member

    I seem to have a similar issue as others using an asus RT-AC66U, on both 2018.3-006 and 082, any time a wireless client connects i get disconnected. Did a firmware upgrade - reset NVRAM several times same issues :\ unfortunately its the only router i have in the house so i'm not able to dig into this anymore until i have more time.

    for when i do get some time is there anything in particular i can do to help troubleshoot this? I was able to snag a log just before the router rebooted, not sure if i was able to capture anything useful though.

    I'd post the log but i keep hitting the sneaky URL error despite removing urls and things that i saw that look like one. I can email/send the logs to anyone that's interested though.

    TIA -
    HunterZ likes this.
  87. calc66u

    calc66u New Member Member

    Hi, finally a follow up to my first post #178. Like bobbob I have RT-AC66U and it's my only router, so I have limited time to experiment.

    Since my previous post I have tried the 082 beta with same results.
    Initially I suspected the pppoe implementation, however now I'm not so sure. I found that if I disabled both 2.4 & 5 gHz radios everything was ok, but as soon as I enabled wifi, firefox says 'sorry were having trouble finding that site' - I think this caused by the wan connection going down (reboot) rather than a DNS failure. Curiously though, changing settings in the DNS admin page (eg 'Use internal DNS' or 'reduce packet size') had the same effect.

    Below a diff between a stable shibby nvram and a freshtomato nvram. I have done a bit of editing/anonymisation.
    Syslog output to follow (sneaky url issue)

    --- /run/media/toby/9FF7-04DE/nvram.txt    2018-07-14 12:49:32.000000000 +0100
    +++ /run/media/toby/9FF7-04DE/nvramshibby.txt    2018-07-14 13:22:58.000000000 +0100
    @@ -16,10 +16,15 @@
    @@ -36,7 +41,6 @@
     bt_binary_custom =/path/to/binaries/directory
    @@ -125,7 +129,7 @@
    @@ -151,8 +155,7 @@
    @@ -172,18 +175,12 @@
    -dr_lan_rx=1 2
    -dr_lan_tx=1 2
    -dr_wan_rx=1 2
    -dr_wan_tx=1 2
    @@ -211,12 +208,13 @@
    @@ -235,11 +233,9 @@
    @@ -251,7 +247,6 @@
    @@ -279,7 +274,7 @@
    @@ -344,7 +339,6 @@
    @@ -400,7 +394,7 @@
    @@ -424,12 +418,12 @@
    -os_date=Sat, 07 Jul 2018 08:21:48 +0200
    +os_date=pet, 17 nov 2017 17:28:05 +0100
    -os_version=2018.3.081 MIPSR2-beta K26AC USB AIO-64K
    +os_version=1.28.0000 MIPSR2-3.5-140 K26AC USB AIO-64K
    @@ -631,6 +625,7 @@
     pmon_ver=CFE (r338244)
     portforward=0<3<<1000:2000<<<ex: 1000 to 2000, restricted>0<2<<1000,2000<<<ex: 1000 and 2000>0<1<<1000<2000<<ex: different internal port>0<3<<1000:2000,3000<<<ex: 1000 to 2000, and 3000>
    @@ -646,7 +641,6 @@
    @@ -682,7 +676,6 @@
    @@ -746,11 +739,11 @@
    @@ -774,7 +767,6 @@
    @@ -848,7 +840,6 @@
    @@ -994,23 +970,19 @@
    @@ -1032,23 +1004,19 @@
    @@ -1070,23 +1038,19 @@
    @@ -1099,32 +1063,30 @@
    @@ -1133,22 +1095,21 @@
    @@ -1169,16 +1130,16 @@
    @@ -1195,7 +1156,7 @@
    +wl0_akm=psk psk2
     wl0_ampdu_rr_rtylimit_tid=2 2 2 2 2 2 2 2
     wl0_ampdu_rtylimit_tid=5 5 5 5 5 5 5 5
    @@ -1264,7 +1225,7 @@
     wl0_radarthrs=1 0x6c0 0x6e0 0x6bc 0x6e0 0x6ac 0x6cc 0x6bc 0x6e0
    @@ -1283,8 +1244,8 @@
    @@ -1321,7 +1282,7 @@
     wl0_wme_txp_vo=7 3 4 2 0
    @@ -1456,4 +1417,4 @@
    -1457 entries, 33167 bytes used, 32369 bytes free.
    +1418 entries, 32162 bytes used, 33374 bytes free.

    any insights from this?
    cheers, calc66u
  88. calc66u

    calc66u New Member Member


  89. HunterZ

    HunterZ Network Guru Member

    Yikes, I thought it was because I was using the RT-AC build on my RT-N66U, but if you guys with RT-AC66Us are having problems too, then I'm going to question the firmware builds.
  90. schnappi

    schnappi Networkin' Nut Member

    Hands down:

    Found here (sign-required):

    As far as know neither Shibby nor Toastman builds for WRT54GL have IPv6 capability.

    Great to see Tomato, even for MIPS devices, thriving.
  91. pedro311

    pedro311 Networkin' Nut Member

    @all with wifi and other problems:

    Please stick to the rules on OP: How to report a bug or problem
    Otherwise, I can't help you/find what problem is...

    //EDIT: as I said earlier, I have no problems on RT-N66U with freshtomato-RT-N66U_RT-AC6x-2018.3.08X-beta-AIO-64K
    My chipset revision is "BCM5300 chip rev 1 pkg 0"

    #nvram show|grep board
  92. bobbob

    bobbob New Member Member

    aaaah... sorry, i would've posted my nvram settings also if I had saved it, also, my NVRAM was at ~50%. I'll have some down time this weekend and i'll do what i can to gather some more info, besides capturing the log (if i can) and nvram settings, is there anything in particular i should grab also?

    I have a long shot idea so i'll give that a go, if not i'll use older firmwares until i can find one that works

    For now i'm on the latest version of Advanced Tomato 3.5-140-AIO-64K... also i found the upload a file button so log is attached

    Attached Files:

  93. geekjock

    geekjock Network Guru Member

    So I took the plunge and loaded freshtomato-K26_RT-MIPSR1-2018.3.082-beta-MiniIPv6.trx on my WRT54G v3.0. I flashed it directly from Toastman 1.25 after clearing the NVRAM. The flash was successful and the router seems to be working ok. I have not had much time to play with it, and have not configured IPv6, so cannot comment on its stability or capabilities. But initial impressions are good.

    I'll be traveling for the next two weeks, so it will be a while before I comment again.
    nisarg86 likes this.
  94. jmp68fr

    jmp68fr New Member Member


    I was able to upgrade my router (Netgear WNDR4500v2) with the 2018.3.082-beta release (2018-07-08).
    All is working well, but Wifi 2.4Ghz: when activated,whatever the settings,the router reboots endless.
    With the previous release,I did not have this problem.Wifi 5Ghz is working well.
    Any idea ?

    Thanks for your help.

    Thanks FreshTomato team and others for your work
  95. jenom

    jenom LI Guru Member

    I am looking for the latest FreshTomato for ASUS RT-N66U
    In 2018.3.082 folder there is a 64k section, but files are showing 2018.3.081

    Is there a newer/beta/test version for RT-N66U ?

    Can I flash a non 64k generic ASUS 2018.3.83 file......such as:
    freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.083-beta-AIO.zip ?

  96. pedro311

    pedro311 Networkin' Nut Member

  97. pedro311

    pedro311 Networkin' Nut Member

    Did you try clean install?
  98. jenom

    jenom LI Guru Member

    thanks pedro311
    currently using:
    FreshTomato Firmware 2018.3.081 MIPSR2-beta K26AC USB AIO-64K
    with ppp0e to a bridged ADSL modem

    last night experienced a random RESET, and all network setting is router went back to default
    I will try the other mentioned versions.
  99. jenom

    jenom LI Guru Member

    I am looking for a recommended freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.083-beta-AIO-64K file, however I can not find it in freshtomato-mips 2018.3.082-beta....K26RT-N....Asus RT-Nxx & CO (updated to 2018.3.083).........because there is no any -64K build there

    Any suggestion where to locate file?

  100. pedro311

    pedro311 Networkin' Nut Member

    It's in "Asus RT-N66u 64k" subfolder (2018.3.081 actually, but it is 082, because i named it wrong).
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice