[Fork] FreshTomato-MIPS

Discussion in 'Tomato Firmware' started by kille72, Apr 26, 2018.

  1. Beast

    Beast Network Guru Member

    Asus RT-Nxx & CO (updated to 2018.3.083) ---- Will there be any nvram32k veriants? And will there be a change log. ?
  2. pedro311

    pedro311 Networkin' Nut Member

  3. pedro311

    pedro311 Networkin' Nut Member

    Last edited: Jul 21, 2018
    kille72, M_ars and HunterZ like this.
  4. Beast

    Beast Network Guru Member

    Too late, upgraded to: FreshTomato Firmware 2018.3.083 MIPSR2-beta K26 USB Mega-VPN.

    Bricked my Asus RT-N16. But all is well, used Asus recovery tool and managed to get this
    version back on the router:


    I want to update my backup router Linksys WRTSL54GS. Which build is recomended for this router model ? Thinking of using this one freshtomato-K26USB_RT-MIPSR1-2018.3.082-beta-VPN.zip
    Last edited: Jul 21, 2018
    HunterZ likes this.
  5. UserDirk

    UserDirk New Member Member

    Next issue is the WNDR4500V1. Clean install, 2018.3.006-beta WLAN switch to Germany and configure, now WLAN connect from a smartphone the Router reboot automaticly. Next try: Retour to original, 20 sec reset=clear.
    Install 2018.3.006-beta switch to Germany manuell reboot, WLAN configure manuell reboot. PC connect (which is connect via lan) to Router seems to work, but connect from a smartphone the router automaticly reboot (every time)
  6. pedro311

    pedro311 Networkin' Nut Member

    Goggy, pharma, Monk E. Boy and 3 others like this.
  7. UserDirk

    UserDirk New Member Member

    I've the Cisco E3000 and the 2018.1 work, but neither the 2018.3 nor 2018.3.106-beta can't flash all are too great. Message: File is too big to fit in MTD. Must be 8MB and all bigger than 8MB.
    8.6MB 11.1MB 8.4MB and 8.3MB
    Last edited: Jul 24, 2018
  8. M_ars

    M_ars Network Guru Member

    @pedro311: E3000 has only 8 MByte flash, something needs to be removed,
    maybe remove minidlna and/or dnscrypt-proxy

    E2000 does have also only 8 MByte flash and no USB Port --> i think you can remove usb support and this will make the leaner/smaller builds make fit again

    E4200 does have 16 MByte flash, so there would be some space available for features

    I also wanted to ask about the Captive Portal commit
    from AndreDVJ

    Retiring Captive Portal for mips / ARM ? :)
  9. pharma

    pharma Network Guru Member

    Flashed freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.106-beta-AIO-64K on my RT-N66U and is working perfectly. Had problems with freshtomato-RT-N66U_RT-AC6x-2018.3.106-beta-AIO-64K which kept rebooting the router.
    geekjock, adv.oscar and HunterZ like this.
  10. WildFireSG

    WildFireSG Addicted to LI Member

    I'm a bit confused...what did you mean by no more 32k versions? I see this file out there "freshtomato-K26-NVRAM32K_RT-N5x-MIPSR2-2018.3.106-beta-MiniIPv6.zip" that I was planning on trying on a Linksys WRT160N.
  11. adv.oscar

    adv.oscar Serious Server Member

    Exactly the same behavior on my RT-N66U
    pharma, geekjock and HunterZ like this.
  12. WildFireSG

    WildFireSG Addicted to LI Member

    @pedro311 Are the contents of K26RT-AC and K26RT-N for "freshtomato-mips 2018.3.106-beta" reversed?
  13. pedro311

    pedro311 Networkin' Nut Member

    Just renamed folders ;)
    pharma and WildFireSG like this.
  14. Beast

    Beast Network Guru Member

    Why no nvram32k of this build "freshtomato-K26USB_RT-N5x-MIPSR2-2018.3.106-beta-Mega-VPN.zip"

    The 2018.3.081 had a 32k build and its working on my RT-N16. I just don't want to brick my router again.
  15. pharma

    pharma Network Guru Member

    Probably too much work supporting both, after all developers do have a life. See Pedro's post above.
  16. Beast

    Beast Network Guru Member

    The question was/and is for pedro311, he had already told me he would make no more 32k variants of any kind. But he did make some anyways, so i thinks is fair to just ask why of not that one. Also the last version bricked my router. He has since removed them as you can see, but i would like to know. Should he get a moment to answer, before i update again.
  17. pedro311

    pedro311 Networkin' Nut Member

    2018.3.106 version for K26 branch is ready for download - enjoy.

    I've just added it back.
    WildFireSG likes this.
  18. pedro311

    pedro311 Networkin' Nut Member

  19. UserDirk

    UserDirk New Member Member

    Thank you, for the cisco E3000 and 2018.3.106-beta image successfully flashed.
  20. kernel-panic69

    kernel-panic69 Connected Client Member

    E2500V3 build filenames still have NVRAM32K. I haven't flashed my only E2500V3, as I am testing this on one of my E4200V1s. Only thing I've noticed between freshtomato-E4200USB-NVRAM60K_RT-N5x-MIPSR2-2018.3.081-beta-Mega-VPN.bin and freshtomato-E4200USB-NVRAM60K_RT-N5x-MIPSR2-2018.3.106-beta-Mega-VPN.bin is that enabling everything in adblock crashes dnsmasq and it won't restart properly until you disable adblock. This is trivial for me, because I can adblock on attached clients just fine. 2018.3.081 flashed just fine from stock firmware and 2018.3.106 flashed just fine from 2018.3.081 with "erase nvram" checked.
    Last edited: Jul 26, 2018
  21. Elfew

    Elfew Network Guru Member

  22. Combat619

    Combat619 Reformed Router Member

    Guys let consider to buy a beer for all the developers a donations would be excellent for them even if we donate doesn't gonna pay for all their amazing job they do for US we all appreciate their fantastic work thanks y'all developers GOD BLESS Y'ALL

    Sent from my SAMSUNG-SM-G920AZ using Tapatalk
    M_ars, kille72 and pedro311 like this.
  23. pedro311

    pedro311 Networkin' Nut Member

    It's because of this: https://bitbucket.org/pedro311/freshtomato-mips/commits/17117ba66b5df6cd3ed3cfd1144754485e88f03a
    Probably when parsing blacklists, it uses too much memory - so use only default ones.

    Oh, yeah! ;)
  24. pedro311

    pedro311 Networkin' Nut Member

    Elfew, M_ars and kille72 like this.
  25. MongooseProXC

    MongooseProXC Connected Client Member

  26. kernel-panic69

    kernel-panic69 Connected Client Member

    Had the previous build configured the same way and it never crashed dnsmasq that I recall, but I will definitely keep that in mind, thanks! If you need syslogs, let me know. I don't have this particular one up all the time yet, but.
  27. kernel-panic69

    kernel-panic69 Connected Client Member

  28. rs232

    rs232 Network Guru Member

    quick question:why in the latest beta is the MIPS1 mini (3.6Mb) build larger than the MIPS1 miniIPV6 (3.4Mb)?
  29. WildFireSG

    WildFireSG Addicted to LI Member

    I just recently looked this up and saw an explanation about it regarding Shibby's releases. Most likely the same reason remains but @pedro311 can correct me if this is wrong: miniIPv6 does not have https: which apparently adds a decent amount.

    However, since the code has been optimized and binaries are smaller, I wonder if https: can be added to the miniIPv6 builds and still keep it under 4Mb.
    geekjock and rs232 like this.
  30. UserDirk

    UserDirk New Member Member

    There is an issue with the WNDR4500V1. 2,4 WLAN works but 5GHZ reboot when a client connected
  31. rs232

    rs232 Network Guru Member

    On this topic, I can see freshtomato-K26_RT-MIPSR1-2018.3.106-beta-MiniVPN.zip which unpacked appears to be just about 4096K in size. Trying to flash a 4Mb device though I still get the "File is too big to fit in MTD", so I guess it's still just a bit too large to fit.

    Can anybody confirm if this miniVPN includes tinc or not?

    Last edited: Jul 28, 2018
  32. pedro311

    pedro311 Networkin' Nut Member

    Exactly. Additionally, Mini has JFFS support.
    WildFireSG likes this.
  33. pedro311

    pedro311 Networkin' Nut Member

    Only "Mega-VPN" and "AIO" include tinc.
  34. pedro311

    pedro311 Networkin' Nut Member

    The problem is, that it also removes minidlna/whatever for E4200, so Makefile should be rewritten for this, unfortunately.
  35. Joseph Deck

    Joseph Deck Network Newbie Member

    Problem with resolv.conf initialization in Wireless Ethernet Bridge mode

    I have installed 2018.3.106 MIPSR2-beta K26 USB VPN on a Asus RT-N16 and I am trying to use this router in Wireless Ethernet Bridge mode - therefore, without running DHCP or dnsmasq.

    I have set up the gateway and manually entered a static DNS server in the Basic | Network configuration
    page. However, network name resolution does not work. For example:
    root@R5:/tmp/etc# nslookup google.com
    Address 1:
    This problem also prevents the NTP client from connecting using any of the pre-set choices in the time setup page, since any of them requires name resolution.

    The problem is that resolv.conf is a symlink to /etc/resolv.dnsmasq, which does not exist.

    rm the link and replace it with a valid resolv.conf:
    echo nameserver 192.168.abc.xyz > /tmp/etc/resolv.conf
    (where 192.168.abc.xyz is the nameserver that I have entered on the network setup page)
    and all is well.

    It looks like this file is not being initialized correctly when choosing Wireless Bridge mode.

    As a work-around, I can enter these commands in the Init script:
    logger Starting INIT script
    sleep 20
    rm /tmp/etc/resolv.conf
    echo nameserver `nvram get wan_dns` > /tmp/etc/resolv.conf
    logger Created resolv.conf
    This will create the file using the server entered on the network setup. It is only a quick and dirty fix because it will not work correctly if two static DNS servers are entered. (The sleep is necessary to allow time for the default, incorrect resolv.conf to be created before removing it and creating a valid one.)
    Techie007 and JoeDirte like this.
  36. M_ars

    M_ars Network Guru Member

    I like the retirement of Captive Portal :D


    like AndreDVJ is writing

  37. PascalJ

    PascalJ New Member Member

    I am currently running advancedtomato on my N66. Can I flash this firmware via the webinterface, or do I need to use the emergency restore firmware procedure?
  38. M_ars

    M_ars Network Guru Member

    you can flash via the webinterface AND do erase all data in NVRAM memory

    best regards
  39. pedro311

    pedro311 Networkin' Nut Member

    It's known issue, existed both in MIPS and ARM tomato (since one of @tsynik commit IIRC).
  40. pedro311

    pedro311 Networkin' Nut Member

    It was a clean install as stated in How to report a bug or problem?
  41. PascalJ

    PascalJ New Member Member

    thanks! works like a charm
    M_ars likes this.
  42. Pess0g

    Pess0g Networkin' Nut Member

    Could “Multiwan=y” be turned off to disable multiwan at make?
    Last edited: Aug 4, 2018
  43. webcrumb

    webcrumb New Member Member

    Which entware or optware versions are people using now? I've been using entware_zyxmon_org for many years now, but they've recently stopped updating packages for the MIPSEL kernel 2.6 (which is what my WNR3500L uses).

    (Also, thank you to @pedro311 for picking up this project - I've just spent two days trying to get OpenWRT 18.06.0 playing properly but couldn't stop it grinding to a halt with more than one client... then I found FreshTomato and I'm happy again. Any donation link?)
  44. Beast

    Beast Network Guru Member

    There is a donation button at the very end of the about page. (In the Firmware itself).
  45. M_ars

    M_ars Network Guru Member

    short version: no, but you can try
  46. pedro311

    pedro311 Networkin' Nut Member

    Or at my signature ;)
    Onee-chan, pharma and kille72 like this.
  47. DataSquid

    DataSquid New Member Member


    N66U user here with Shibby Tomato on it.

    Is Fresh Tomato what all the cool kids are replacing Shibby Tomato with? That seems to be what I've gathered from some searching.

    Any tips for success in making the switch? Any chance I can import my existing config exported from Shibby Tomato into Fresh Tomato?

  48. WildFireSG

    WildFireSG Addicted to LI Member

    Hi @DataSquid. FreshTomato is the actively updated fork of TomatoUSB, and yes, all the cool kids are here.

    There is a decent chance you can import your existing config; however, if you have *any* issues, there will be no sympathy :D Any chance of getting help/advice requires us to perform a full NVRAM reset and manual configuration after upgrading.
  49. DataSquid

    DataSquid New Member Member

    Great! Thanks! It's a holiday Monday here so I have time to put in to recovering if it goes sideways, but was hoping not to have to :) I usually save my full manual configurations for winter holidays.
  50. geekjock

    geekjock Network Guru Member

    I have the same experience with my RT-AC66U, used as a wired ethernet bridge. It functions as a WAP, with an ethernet port connected to the RT-AC68 router. It was working ok, but did not get the date/time. Using the work-around above solved this problem.

    BTW, my static DNS is an Orange One box running Armbian with Pi-hole installed - a worthwhile project!
  51. friedgreen

    friedgreen Networkin' Nut Member

    I've used configs from several v140 Shibby builds on RT-N16's with new Pedro builds. After import everything works as expected, but it seems to not want to restore from the config saved while in Pedro builds. I'm not sure why exactly it fails to restore, it might be the import of unnecessary entries introduced by the old config.
    Had to drop back to Shibby v140 as restoring is really important, so be warned.
    Wondering if anyone else is having any trouble restoring from a fresh install of Pedro on RT-N16.... this might be a bug, might be the import...
    DataSquid likes this.
  52. Yirkha

    Yirkha New Member Member

    Hi kille72 & pedro311, many thanks for keeping the firmware for these routers alive also in 2018! I've sent you both a little something for all the effort through PayPal.

    I'm running freshtomato-E3000USB-NVRAM60K_RT-MIPSR2-2018.3.106-beta-Nocat-VPN on my device and so far everything seems to be working great.

    Well, apart from one tiny thing - I love my (static) MOTD, but this version does not show it anymore after connecting through SSH.
    Turns out Dropbear changed the DO_MOTD default in its version 2018.76 (mkj/dropbear/32a28d0d*),
    but this was understandably missed when updating on our side (pedro311/freshtomato-mips/697c188c*).
    Would you mind adding that back in the Tomato-specific patch through localoptions.h?


    *) I'd provide direct links to the commits, but forum rules don't allow me to do that just yet, sorry.
    kille72 likes this.
  53. pedro311

    pedro311 Networkin' Nut Member

    What do you mean by "import"?
    Do not use old configs/backups on these new builds.
    All configuration must be entered manually (as stated on OP in How to report a bug or problem section).
  54. pedro311

    pedro311 Networkin' Nut Member

    Thank you! ;)
  55. friedgreen

    friedgreen Networkin' Nut Member

    First, thanks for keeping Tomato alive.

    Fresh RT-N16, load freshtomato firmware, load config from any previous v140 RT-N16, works.

    Transfer config from another router of the same kind:
    nvram backup configfilename
    use ssh/telnet/command window, change et0macaddr on new router
    nvram show | grep et0macaddr on both routers, or from config to use (change cfg to zip and search)
    nvram set et0macaddr="newmacaddress"
    nvram commit
    use web gui to restore config.
  56. Yim Sonny

    Yim Sonny Serious Server Member

    Thank you, Thank you, THANK YOU ! I wish to gawd that we could at least get a check box somewhere so I could "accept" the responsibility to allow this from the GUI. I order RT-N12's 5 and 10 at a time. Consume about 50 or 60 routers a year. Would save me a LOT of time if I could roll up to a job site with a new replacement router programmed and ready for the customer's setup. Not trying to initiate a preaching session about how bad I might fuck up my routers. I know where the reset button is and I know exactly how to use it. I've got a $250 dollar donation ready when I see that checkbox ( at least a MIPS version for the RT-N12 )

    Pedro, I have not said "Thank you" lately for all the work you have been doing, so Thank you ! 75 Euro Paypal # 09M60217RG708961N
    Last edited: Aug 8, 2018
    pedro311 likes this.
  57. pedro311

    pedro311 Networkin' Nut Member

    Thank you!
  58. ghoffman

    ghoffman Network Guru Member

    i think this could create havok for a lot of people. maybe that's ok though.

    there are a bunch of old threads about scripts to selectively export nvram variables, allowing transer of config settings excluding hardware-specific values. i had used these extensively during testing phases and router migrations.
    in the end, i found it more reliable to generate a file that had the releveant 'nvram set' lines in it, and to execute that from the command line. you probably know all this. i'd be interested in which solution you find easiest.
    pedro311 and kille72 like this.
  59. friedgreen

    friedgreen Networkin' Nut Member

    The freshtomato routers run fine after import of the shibby v140 config as stated, but again there's the nagging problem of restoring from a backup made by the freshtomato install afterwards as it hangs the router and subsequent return to shibby firmware.

    So again I'm wondering if others have had any issues restoring freshtomato after manual entry of multiple vlans with guest wireless(s) and faked mac addresses, bcm_nat, etc...

  60. pedro311

    pedro311 Networkin' Nut Member

    Did you compare both backups, from v140 and freshtomato?
  61. minos

    minos Networkin' Nut Member

    Thx for your work.

    Is there a tab with features comparative between builds/files available ?
  62. Joe A

    Joe A Networkin' Nut Member

  63. apvmtan

    apvmtan Serious Server Member

    What Kernel version?
  64. bobby8

    bobby8 New Member Member

    I think I may have found a minor bug, which wasn't present with Shibby v132 (and v140 I think)

    Belkin F7D4301
    2018.3.082 MIPSR2-beta K26 USB miniVPN
    2018.3.106 MIPSR2-beta K26 USB miniVPN

    When configured as a regular router, the Status -> Logs -> View All correctly shows current date and time stamp for log entries.

    However, when configured as a 'wireless bridge' with WAN disabled, and Basic -> Network -> LAN section is correctly populated with default gateway and static DNS IP addresses, the log entries don't show current date and time stamp.

    (I also note the change logs make no mention of KRACK fix, so I guess when FreshTomato is configured as a 'wireless bridge', it is vulnerable to KRACK)

    UPDATE: I just saw @deepjock solution to same clock problem posted further up this page. I can confirm it works on F7d4301.
    Last edited: Aug 13, 2018
  65. bobby8

    bobby8 New Member Member

    Also, I observe 472 bytes of free NVRAM has been lost when moving from shibby v140 to FreshTomato.

    Erase all data in NVRAM (thorough): 5876 (17.93%) Free NVRAM

    Shibby Tomato
    Erase all data in NVRAM (thorough): 6348 (19.37%) Free NVRAM
    Last edited: Aug 14, 2018
  66. Beast

    Beast Network Guru Member

    Follow the instructions in this thread Reducing NVRAM usage.
    You will recover those bytes or even more. ?The thread is still on the 1st page at the moment.
    bobby8 likes this.
  67. kernel-panic69

    kernel-panic69 Connected Client Member I'm personally planning on doing a test with on stock Linksys firmware eventually. There are actually conventions that support the 2.6.32 branch in the GPL, which kinda negates a lot of conversations I've had regarding kernel version limitations. The kernel is the last long-term upstream kernel that I'm aware of (2016).
  68. M_ars

    M_ars Network Guru Member

    Last edited: Aug 15, 2018
  69. kernel-panic69

    kernel-panic69 Connected Client Member

    M_ars likes this.
  70. M_ars

    M_ars Network Guru Member

    Basicly TomatoRAF and Shibby have the same Linux version and Broadcom driver - so i think it should be ok
    --> the same patch can also be found here
    It looks like the patch is ok/complete

    kernel-panic69 likes this.
  71. fiwiman

    fiwiman Connected Client Member

    Some help here please?

    Like another user above, I've just updated to 106 beta from shibby and notice that ping/wget results in "bad address" from SSH on the router. I don't need dns for my clients as dhcp is provided by the pfsense box.

    I imported my working config from shibby which was working well. Using router as a AP only. Static dns is set to my pfsense box as was the case before. WAN is disabled, "Use internal DNS" is UNchecked. "port=0" is set in Dnsmasq custom configuration.

    nslookup www.google.com
    Address 1:
    nslookup: can't resolve 'www.google.com'


    The option:

    Doesn't seem to work.

    I had to add my dns server like this:

    echo "nameserver" > /etc/resolv.conf
    Not sure why, seems to never create the resolv.conf file.

    I'm not sure what combination of options need to be set to get this to work when WAN is disabled or should I go with Joseph Deck's workaround here?
    Last edited: Aug 17, 2018
  72. UserDirk

    UserDirk New Member Member

    WLAN connection problem. 2018.3.106-beta tested with Netgear-WNDR4500V1 and Tenda W1800R. Stable version works.
    Clean install two times.
    Problem is the wlan: password testpassword 2,4 and 5ghz net. Works without any problem, client can connect. But if I use the random password or a manuell password max length. As soon as a client tries to connect the router reboot, Netgear and Tenda are the same result.
    All times clean install. I try a new clean install, the same result. Tenda back to stable, no problem.
  73. bobby8

    bobby8 New Member Member

    Just use the fix posted in message no. 350 by Joseph Deck for now until it is fixed in a future release.
  74. rs232

    rs232 Network Guru Member

    I have the same config (WAN disabled) and same issue. I can only add that in the logs I also spotted these 2 lines:
    Jan  1 03:07:29 tomato-ap1 daemon.info dnsmasq[12346]: using nameserver
    Jan  1 03:07:29 tomato-ap1 daemon.warn dnsmasq[12346]: no servers found in /etc/resolv.dnsmasq, will retry

    It seems like the "WAN disabled" creates some confusion/unwanted behaviour.
    First of all it's confusing to have both:

    - Bridge WAN port to primary LAN (br0) (which sets the variable wan_islan=1) under Basic/Network
    - Mode (Router/Gateway) (which sets wk_mode=router/gateway) under Advanced/Routing.

    I think they should be linked together or at least displayed one next to the other on the same page. On this very same topic another incongruence I have spotted is: you can't have the WAN removed from the VLAN config page when your Mode is set to Router (I'm ok for this to appear in gateway mode though)


    Perhaps a check on the variable wk_mode value before displaying the error on the VLAN page could be a good approach here?
  75. tvlz

    tvlz LI Guru Member

    Joe A likes this.
  76. jenom

    jenom LI Guru Member

    Installing Freshtomato on Asus RT-N66U-64k router.
    The 8 Mb VPN was to minimalistic for my use, and the AIO version kept refusing my root/admin logins after a few days both on webpage, or telnet or ssh
    After power off/power on login worked again.
    There was no Mega 64k version, so I installed a generic MIPSR2 Mega and so far everything works.
    However it has the Captive Portal, Torrent built in....I have no use for neither.
    Would be good to have a 64k Mega version without those, maybe even 7with Nginx webserver ?
  77. fafhrd

    fafhrd New Member Member

    Trying to upload and install the latest freshtomato-K26USB_RT-MIPSR2-2018.3.106-beta-miniVPN on my old Netgear router model WNR3500L/Uv1 which is currently running Tomato Firmware 1.28.0000 MIPSR2-140 K26 USB miniVPN. Unfortunately, this firmware file is too big and I need usb support in order to connect my shared laser printer and a usb flashdrive storing optware. Maybe am I choosing a wrong file ?
  78. jenom

    jenom LI Guru Member

    WNR3500L/Uv1 has only 8 Mb flash memory......
    if 3.106 file is too big, try an older version 1.066 file, which is a little bit smaller
    otherwise stay with Shibby's v140
  79. fafhrd

    fafhrd New Member Member

    3.106 size is already under 8 MB and 1.066 is about 280 KB smaller, but yes 1.066 worked. The upload seemed to stall forever (almost a 1 hour count until I closed the window in Firefox) while it was indeed successful and the router had rebooted with no error after about only 3 minutes as usual. I did not clear the nvram however, so maybe am I the only one to blame for this apparent stalling.

    These firmwares include a bitorrent client of no use for me. Also they still propose a PPTP VPN client/server, an obsolete-flawed-unsecure tunneling solution that could be removed or at least become optional, imho.
  80. jenom

    jenom LI Guru Member

    not 100% of the flash is available, already used by boot, reserved,etc...
    downloaded file also gets a little bit expanded....~10 %.....you can see actual file size in serial console when writing file to flash

    uploading file from PC to router goes in seconds, writing file to flash memory takes long time
    on my Asus Rt-N66U it took 15 minutes to write a 8 Mb file....watched it on serial terminal

    I personally have no use for bittorrent (Transmission) or Captive Portal
    they both should be only in AIO version , not in Mini, VPN or Mega
    However, if we want customized firmware for our needs, we need to compile our own....
  81. fafhrd

    fafhrd New Member Member

    What are the differences between 2018.3.106 located in the "K26" folder and the newer 2018.3.107 located in the "tests" folder ? The latter seems to be small enough to get a chance to work on my WNR 3500Lv1. Did anyone test this 2018.3.107 firmware ?
    Last edited: Aug 30, 2018
  82. kernel-panic69

    kernel-panic69 Connected Client Member

    I haven't read each letter of every reply since my last comment in the thread, but one other thing I noticed about 2018.3.106 is you pretty much have to enter the "route modem ip" (aka gateway) address on the Basic -> Network page, either using to disable or the actual ISP device lan IP address to get internet to work. This may be affecting some of the problems folks are having. I've noticed some activity (a month ago!) on bitbucket, but it seems 'public' development is kinda stagnant at the moment? Not sure about all devices, but I am probably going to be downloading the repository and committing the E4200 led fix to it and run a build to test. I guess that fix being part of DD-WRT seems to have spoiled me lol May also merge that patch that M_ars posted about for giggles. So far, outside of at least one, maybe two inadvertent power cycles, I'm at 15 days uptime, would've been closer to a month, but things seem to be running well with no issues in AP/Gateway mode.
  83. filipedonato

    filipedonato Connected Client Member

    2018.3.106 in Belkin N600 V3 - F9k1102
    It's getting better and better

    • Now it has stopped randomly restarting.
    • It still has the BUG of LAN 4 that if connected resets the settings.
    • The LEDs are the same, but that does not matter.
    • ADVANCED-WIRELESS tab- If you change any WIFI option 5GHZ the signal drops. However in 2.4 the changes work.
    Last edited: Sep 10, 2018
  84. Traace

    Traace New Member Member

    freshtomato-mips 2018.3.106-beta works for me on a belkin F9K1102v1 running as NAS-Server now (USB HDD 500gb ext3).

    Many thanks for this awesome work.

    I follow this thread now :)
    Last edited: Sep 10, 2018
  85. GhaladReam

    GhaladReam Network Guru Member

    1st post says 2018.4 came out 9-10-2018 but the download folders are all empty. Am I missing something?
  86. koitsu

    koitsu Network Guru Member

    Maybe the builds aren't finished yet? It can take quite a lot of time.
    pharma, pedro311 and kille72 like this.
  87. filipedonato

    filipedonato Connected Client Member

    Belkin N600 V3 - F9k1102
    I was wrong. Random restarts still occur. But with a lower frequency. Now it lasts 5 to 8 hours.
  88. GhaladReam

    GhaladReam Network Guru Member

    I get that - but why post the 'latest version' info in the original post with a release date from 2 days ago if...It's not released? Doesn't make sense other than to confuse people. Plus, I have to take the extra step of going to the download folder periodically to see if the files are there yet - rather than just looking at the first post.
    Last edited: Sep 13, 2018
  89. pedro311

    pedro311 Networkin' Nut Member

    All files (except extras) already uploaded: [Downloads]
    More info, CHANGELOG in the first post.
  90. kernel-panic69

    kernel-panic69 Connected Client Member

    Just finished flashing the upgrade, so far so good. I am curious as to why BusyBox has not been upgraded to 1.29.x / 1.30 yet, but I understand that it's still a work in progress. I was at close to a month uptime with 2018.3.106 with very little issue. I'm still comparing a few things before I try to implement a few things to suggest as future commits. Keep up the continued good work!
    M_ars likes this.
  91. ghoffman

    ghoffman Network Guru Member

    upgraded a belkin f7d7301 (sharemax) with freshtomato-K26USB_RT-MIPSR2-2018.4-MiniVPN.trx.
    no problem with upgrade, but wifi password (WPA2-personal-AES) was not carried forward. im not sure f this is a feature or a bug!
    thanks pedro and all contributors!
  92. Traace

    Traace New Member Member

    with a v1 its very stable for me, no crash since fresh install on last monday.
  93. kernel-panic69

    kernel-panic69 Connected Client Member

    Only thing I have noticed so far with 2018.4 Mega is it took a couple of hours for CPU load to settle out completely, but otherwise, no issues and pretty stable and no crashes on E4200v1. Still comparing multiple versions of roboswitch drivers to figure out what to commit to fix led operation - and whether or not that will affect ethernet ports state function in the webUI. Trivial 'cosmetic' issue IMHO, but. One thing I noted, in the downloads folders (K26), is there is an E4200-AIO build that is 22MB. Given that the E4200v1 has only 16MB of flash, that build should probably be removed so folks don't brick their devices by mistake.
    Traace likes this.
  94. filipedonato

    filipedonato Connected Client Member

    2018.4 in Belkin N600 V3 - F9K1102
    As for random restarts, I'll see if it gets more stable and then comment.
    Last edited: Sep 13, 2018
  95. ghoffman

    ghoffman Network Guru Member

    @Pedro -
    there is definitely a problem withi this build on this router.
    the device dropped wifi connections, and a reboot brought up wifi without the WPA2 password retained again.
    i'm wondering of there is a problem that is specific to the miniVPN build, since it is 800K smaller in 2018.4 than it is in 2018.3beta.
    i reverted to freshtomato-K26USB_RT-MIPSR2-2018.3.106-beta-MiniVPN.trx and things are ok.
    i'm hesitant to try the non-mini build because at this point i only have remote access!
    edit - i did try the non-mini freshtomato-K26USB_RT-MIPSR2-2018.4-VPN, but it is too big for MTD.
    thanks again - please take a look.
    Last edited: Sep 14, 2018
  96. UserDirk

    UserDirk New Member Member

    I've the Cisco E3000 Message: File is too big to fit in MTD. Must be 8MB and all bigger than 8MB.
  97. pedro311

    pedro311 Networkin' Nut Member

    Added extras in K26 for MIPSR1 and MIPSR2.
    pharma and kille72 like this.
  98. pedro311

    pedro311 Networkin' Nut Member

    You've right. Just added new images for E3000 in K26 folder without minidlna, so they will fit now in flash for that router.
  99. Onee-chan

    Onee-chan Network Newbie Member

    Last edited: Sep 17, 2018
  100. schnappi

    schnappi Networkin' Nut Member

    Looks like FreshTomato-MIPS is now out of beta. Awesome job.

    Has anyone been using the below yet (for RT-N66U)?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice