[Fork] FreshTomato-MIPS

Discussion in 'Tomato Firmware' started by kille72, Apr 26, 2018.

  1. pharma

    pharma Network Guru Member

    Just for reference I'm using the External Adblock with no issues. Firmware version is FreshTomato Firmware 2018.5.005 MIPSR2-beta K26 USB AIO-64K.
  2. txnative

    txnative Addicted to LI Member

    I had cleared nvram from previous tomato build(advancedtomato) flash the FreshTomato Firmware 2018.5.083 MIPSR2-beta K26 USB Mega-VPN, cleared the nvram once more, done my initial network settings manually. Somethings I noticed was the performance the internet connection wan to lan, as internet speed tests were not near 100 mbps incoming, outgoing wasn't any issue for 10 mbps, so i rebooted, tried the internet speed testing again, but same results up to 70 mbps, so I enabled nat_bcm things went further south, ping went to 60 ms, incoming bandwidth was around 26 mbps, did another reboot, enabled nat_bcm once more the bandwidth to 90 mbps ping went back to normal 10 ish, wireless wasn't too bad pretty stable on both radios, macaddrs are still not correct, wan,eth1,eth2 as they appear this way. wan: 00:16:B6:C4:71:B1, eth1: 00:16:B6:C4:71:B2, eth2: 00:16:B6:C4:71:B3
    In the past without having to enable nat_bcm throughput was up to around my present bandwidth just over 200 mbps. The wan to lan internet connection testing I didn't enable, use Qos or bandwidth limiter, since I am concerned about performance, stability on the get go wireless should work without issue with authentication performance, stability as well on the get go. Looking at cmd "top" didn't reveal an sirq usage that be any concern normal as observed while incoming and outgoing wan to lan and wireless performance was being tested. Regards

    Edited: The linksys is normally used as wap, I don't use it as my main router. As connecting to the modem I didn't have any issue with wan "DHCP" either, dns and all other time references to router time worked as normal.
  3. phuklok1

    phuklok1 Network Guru Member

    I am using external adblock and while it is functional, the section of the adblock script that inserts an access page into the GUI is no longer working (as Beast noted earlier). Something changed in 2018.5.083 MIPSR2-beta K26 USB AIO. I am also still seeing a problem transferring large files (few hundred MB+) to usb flash mounted via Samba share. Smaller files work fine. (This is on an RT-N16, non-overclocked)
  4. pedro311

    pedro311 Networkin' Nut Member

    It's because JS files are now compressed:

    rmtomatolink() {
    	if grep -q "/www/tomato.js" /proc/mounts ; then
    		if [ -f "$jsflag" ]; then
    			umount /www/tomato.js
    			elog "tomatos.js was mounted by something else"
    	rm -f "$jsfile"
    	rm -f "$jsflag"
    addtomatolink() {
    	if [ "$tomatolink" = "1" ]; then
    		if [ "$web_dir" != "" ] && [ "$web_dir" != "default" ]; then
    			elog "Skip adding tomato link, non default web_dir($web_dir)"
    		elif ! grep -q "\"log.asp\"]]]," /www/tomato.js ; then
    			elog "Skip adding tomato link, could not find insertion point in tomato.js"
    		if [ "$mountjs" = "1" ]; then
    			elog "Adding tomato menu item"
    			sed "s/\"log.asp\"]]],/&['Adblock','${weblink#*/www/}\" target=\"adblock\"'],/" /www/tomato.js > "$jsfile"
    			mount -o bind "$jsfile" /www/tomato.js
    			touch "$jsflag"
  5. Beast

    Beast Network Guru Member

    Copy and pasted the changes to the old script. Now getting this error:

    ADBLOCK[1336]: Web interface should be available at
    ADBLOCK[1336]: Adding tomato menu item
    sed: bad option in substitution expression <----------------------------ERROR-----<
    ADBLOCK[1336]: Config or script has changed - rebuilding list

    I will check again, to see if I made any mistakes in the copy process. Thanks again for the help.
    Last edited: Nov 29, 2018
  6. AsusN66U

    AsusN66U New Member Member

    How did you enable stubby, I couldn't find the option in Web GUI
  7. MongooseProXC

    MongooseProXC Connected Client Member

    It's under basic>network.
  8. AsusN66U

    AsusN66U New Member Member

    Thanks, I wasn't looking under basic>network,
    Thinking that it may have been present only in AIO releases, I switched from VPN to AIO version.
    Not sure if it was available in VPN release.
  9. ciaccom

    ciaccom Addicted to LI Member

    --- No local DNS service with MIPS firmware ----

    First, thanks for the FreshTomato firmware and your support, especially concerning that shibby tomato is no longer continued.

    I have exactly the same problem with two routers reported under the ARM fimrware thread - see here: https://www.linksysinfo.org/index.php?threads/fork-freshtomato-arm.74117/#post-296289

    My routers are one Linksys E3000 and one Asus RT-N66U. Firmware used on them is the latest stable 2018.4:

    ** freshtomato-K26USB_RT-N5x-MIPSR2-2018.4-AIO-64K.trx
    ** freshtomato-E3000USB-NVRAM60K_RT-MIPSR2-2018.4-Nocat-VPN-noMS.bin

    Both routers are used only internal and are configured as access points with WAN port bridged to LAN ports. The configured default gateway (as well as the DNS server) is my modem. But under /etc/resolv.conf appears the loopback / only. I used the workaround posted by user @Sean B. which works even after a reboot.

    It would be nice, if that "bug" will be resolved or a statement mentioned somewhere in the firmware opening thread, so that users instantly will see that problems with local DNS on the router could be "shipped around" by the workaround.

    Thank you & greets!
  10. danielhaden

    danielhaden Network Guru Member

    rm /etc/resolv.conf
    echo "nameserver" > /etc/resolv.conf
  11. Sean B.

    Sean B. Network Guru Member

    Whether putting it in init works or not will vary by user. Init timing is not set in stone, and will vary depending on what services/options have been configured or added. It may execute prior to /etc/resolv.conf existing, or more likely its change could be overwritten by a service that started or restarted after it executed.
    Last edited: Nov 29, 2018
  12. pedro311

    pedro311 Networkin' Nut Member

    It's fixed in last beta.
  13. pedro311

    pedro311 Networkin' Nut Member

    I've no problem with that piece of code on my AC3200 (everything works as expected, I mean link to adblock is added after link to log.
    Of course, you have an entry in the first line of this script: (/user/adblock.sh):
    I'll check also on N66U, to be sure.
  14. Beast

    Beast Network Guru Member

    View attachment 5880
    I keep the adblock script on a usb stick, i will check to see where the script actually places the link/shortcut in the router.

    But now i have another problem, that at the moment is related to Firefox, the home screen when login into the router now looks like this:

    With IE, in Win7 it looks normal. It did look normal right after flashing the firmware in Firefox. I assume this related to the browser cach beeing cleared, and Firefox has a problem with the compressed .js, or ???? some setting in Firefox that wasn't affected before the change in the firmware.

    CORRECTION ------ Logon page did look normal the first time i used IE, now on a second attempt it looks just like it does in firefox............?????

    What you see below is what i get when i log into the router's main menu.

    Last edited: Dec 1, 2018
  15. Beast

    Beast Network Guru Member

    Looks like the script places the link in /www/user/adblock.sh ! And it does point to my usb drive.
    insid the link -----> /tmp/mnt/USBDRIVE/adblock/adblock.sh

  16. pedro311

    pedro311 Networkin' Nut Member

    I didn't see the entire script, only those 2 functions which you've pasted here.
    In case it mount wrongly edited tomato.js (you said, it was error in sed, so probably this file is broken now), just unmount it now.
    Use "rmtomatolink" from that script.

    BTW: I checked on N66U, and the script I edited also works correctly on this router (no problem with sed).
    pharma likes this.
  17. Beast

    Beast Network Guru Member

    Thank you for helping.

    Router Asus RT-N16 -- Main computer running Win7 Pro with latest updates.

    On the router under Admin:Access - Local Access is set to use HTTP, would it help to set it to use HTTPS instead ???

    I have reverted back to .4 version. This has confirmed my problems with the weird login page not showing correctly and now the adblock script works again as well. After the restore Firefox showed the incorrect layout of the login page, did a refresh/clear cach and the correct/whole login page displayed properly. On .5 version no matter how many refresh/clear cach I did it was a no go, always refeshed with the partical login screen as shown in previous post.

    I am no coder, so I have no idea why the router web page won't display correctly. Unless it has something to do with the compressed java script. But I have seen no one else posting any such problem.

    Here is a link to the adblock script---- https://tomato-adblock.weebly.com/
    One change will be needed to make it work with up to date versions of Tomato pryer to .5!

    # write weblink
    if [ "$weblink" != "" ] && [ -x "$binprefix/$webscript" -o -x "$( which "$webscript" )" ]; then
    if ln -sf "$me" "$weblink" ; then
    local lanport=$(nvram get http_lanport) <------DELETE THE local from this line----<

    I will try the newer version, again later on. When I figure out why the router web page goes all crazy.
    It's impossible to config the router under these conditions.

    Maybe some one else using an Asus RT-N16 router can chime in.
    Last edited: Nov 30, 2018
  18. ciaccom

    ciaccom Addicted to LI Member

    Confirmed, tested on Linksys E3000.
  19. skoub

    skoub Network Guru Member

    Hi everyone,

    I have an Asus WL-520GU. Is it compatible with the FreshTomato firmware and if yes, which one i should get?
  20. pomidor1

    pomidor1 Networkin' Nut Member

  21. skoub

    skoub Network Guru Member

    Since that my WL-520GU is not listed in the first post as listed, is there any risk to flash this firmware? Or since that the WL-500 is supported, i can asume that it is supported?

    And which one between the two files?

  22. pomidor1

    pomidor1 Networkin' Nut Member

    freeshtoamto is a continuation of tomtato by Shibby I can not make an oath, but I am convinced that this first file will be ok

  23. aehimself

    aehimself New Member Member

    freshtomato-K26_RT-MIPSR1-2018.5.083-beta-Mini working flawless on two separate WRT54GLs (1.1 both).
  24. macster2075

    macster2075 Reformed Router Member

    I went to the download page under the Linksys E-Series, but I do not see the file for E2000.. it goes from e1550 to e2500 skipping the e2000. Is the e2000 not compatible?
  25. pomidor1

    pomidor1 Networkin' Nut Member

  26. macster2075

    macster2075 Reformed Router Member

    Thank you...

    I think I did something wrong.....
    I flashed the firmware on my E2500 and it went great.... BUT...

    When I tried to upgrade my Linksys WRT160n I am having an issue.. the installation said it was successful, but I cannot access the router at all and there is not even wifi broadcast... There are lights on the router as if everything is fine... I tried resetting it several times, even did the 30-30-30... and nothing.

    I first used freshtomato-K26_RT-MIPSR2-2018.3.011-beta-Mini - and it said it was too big.
    So then, I tried freshtomato-K26_RT-MIPSR1-2018.3.011-beta-MiniIPv6 - it was successful.

    any ideas?
  27. macster2075

    macster2075 Reformed Router Member

    Oh wow.. I just realized the second time I used MIPSR1 intead of MIPSR2... yikes...is there a way to get my router back?
  28. macster2075

    macster2075 Reformed Router Member

    Got it back!...
  29. macster2075

    macster2075 Reformed Router Member

    I notice that most versions say BETA.. does it mean they are not stable?
    Are there any stable versions?
  30. buggage

    buggage Network Guru Member

    Having similar issue except mine was coming up as Surfnet / 145.x.x.x every time. I see both are listed in the stubby.yml config. If I try to manually edit that file for say only Cloudflare, it doesn't seem to be working or if it does, only certain sites resolve, and others don't. I did see a few posts in the ARM thread where it looks like it's working correctly for someone there...wondering if something is off in the MIPS build, or maybe I just don't have something configured properly. Does anyone have stubby enabled and working correctly that could provide some tips? Seems like a good feature and would like to have it enabled, but so far it's just not working for me as far as I can tell.
  31. kernel-panic69

    kernel-panic69 Connected Client Member

    FreshTomato is a continuation of Shibby and others' work, and is a work in progress. It's more stable out of the box than other firmware on my E4200v1. Meaning, I don't have to monkey-f*ck around with a bunch of scripts and workarounds to get the same results.
    M_ars likes this.
  32. AsusN66U

    AsusN66U New Member Member

    I too tried Stubby and gave up. It was always connecting to Surfnet, which had the highest latency from my location.
    Tried to change it to Cloudflare-only by creating a stubby.yml with Cloudflare-only option, (found the ARM thread). and then adding a command in Admin->WanUp to move this stubby.yml to the stubby.yml default location, and then restarting dnsmasq.
    It didn't work.
    If someone who has Stubby working in mips firmware, please provide the steps involved.
  33. macster2075

    macster2075 Reformed Router Member

    Oh ok... I've been using Tomato firmware now for years and I've never had issues... I have also tried DDWRT firmware but every time I install it on any router I have, it cuts down my speeds by half.

    So glad to see the freshtomato team is taking over and updating this wonderful firmware!!
    The only thing It would be great to see on a future update is the ability to add guest networks (virtual wireless) a bit less complicated... not that is much of a hassle now because once you know how to do it, it's pretty easy...but for those who are new to the firmware, it is pretty complicated.

    This is the ONE thing I liked about DDWRT, they made it pretty easy when it came to adding guest networks.
  34. antonio carvalho

    antonio carvalho New Member Member

    I want to thank the devs for their work on this project.
    I'm testing on a Belkin Play N600 (F7D4302/F7D8302) v1 the latest beta 2018.5.083 MIPSR2-beta K26 USB IPv6-VPN with a 3g modem (ZTE MF192) but I can not get the modem to work when I try to save the configuration (WAN Settin--> Type: 3G modem ) give me this error
    The field "wan_modem_dev" is invalid. Please report this problem.
  35. pedro311

    pedro311 Networkin' Nut Member

    Already known issue for me, will be fixed in next release.
    Techie007 likes this.
  36. Chrushev

    Chrushev Network Newbie Member

    Can I make a suggestion to make the naming scheme year.month this is pretty commonly used and is more intuitive. As things are right now version number does not give any indication how old the build is. Its very confusing to see a year used but not the month, ala Build made in November 2018 is not being 2018.11 but instead is 2018.5

    The year.month naming scheme works very well for Ubuntu builds.
    Techie007 likes this.
  37. kernel-panic69

    kernel-panic69 Connected Client Member

    1. Speedtests on FT are a little slower than DD-WRT K3.x with SFE here, but FT has been pretty damn stable (and whatever benefits of porting a QCA kernel feature to Broadcom isn't a deal breaker).
    2. DD-WRTs Broadcom builds for WRT-N devices have a problem with the VLAN configs out of the box. N devices do NOT have vlan0. This is one of the crucial points that breaks sh*t in DD-WRT that has been ignored for years.
    3. Guest networks in DD-WRT are broken all to sh*t (#2 and #3 referring to the whole bunch of monkey f*cking around in previous post). :mad:
    4. Not sure how many commits to any 2.6+ kernel in the Linux-MIPS community (specifically) would improve performance or vulnerability issues, but I will reserve my thoughts on that for now.
    5. I test both firmwares side-by side, obviously. ;)
  38. olind

    olind Networkin' Nut Member

    Anyone actually using a new firmware for the WRT54GL? Mine is still ont the last Tomato firmware. Would there be any benefits on update?
  39. Señor Nimda

    Señor Nimda Network Newbie Member

    Yes, I am actually using it on a WRTGL54 - as an Access Point. As far as I can see, everything works properly.
    I am using 2018.04.

    The benefits are - at least - a newer version of OpenSSL, than the last Shibby had. Security first!
    pedro311 likes this.
  40. olind

    olind Networkin' Nut Member

    Thanks! I'll try then!
    What file is it that you used? And do you think I can just update it via the web updater from tomato?

    I tried to find the right file here: https://mega.nz/#F!QywknIpa!5JwWNIfEwCOKXqXG0AOh4w!8y4xjaRL but din't know wich one.
  41. Señor Nimda

    Señor Nimda Network Newbie Member

    Yes, that is the correct folder. There is only one file you can use on the WRT54GL, the smallest one:

    Freshtomato-K26_RT-MIPSR1-2018.4-Mini.zip # (3.6 MB)
    Kent_Diego likes this.
  42. pedro311

    pedro311 Networkin' Nut Member

    Better try last beta, with fixes and update ;)
    Señor Nimda likes this.
  43. Señor Nimda

    Señor Nimda Network Newbie Member

    It took me some time, to get to answer this. Today, I successfully de-bricked my other E2500 v3, through the correct serial connector (it has 2, LOL). And then uploaded the FreshTomato 2018.4 firmware, and it works immediately, the 2.4 and 5.0 networks are visible. (Did not yet do a config, will do so probably during the weekend).

    For the record: flashing FreshTomato2018.4 for a bricked router directly to the CFE prompt works, there is no need to upload older DD-WRT or original Linksys firmware.

    Big thanx for this great effort to the FreshTomato team. You guys are a bunch of geniuses, or what! :cool:
    pharma and kernel-panic69 like this.
  44. pedro311

    pedro311 Networkin' Nut Member

    Great, so you can use your PP account, to buy me a beer, right?
    pharma and Señor Nimda like this.
  45. Señor Nimda

    Señor Nimda Network Newbie Member

    You should add this DONATION button or link to the first page, so users can find it quickly!
  46. Espionage724

    Espionage724 New Member Member

    I have a Netgear R6260 which if WikiDev is correct, uses a MIPS CPU (MediaTek MT7621). I could donate and test any builds for it (it's not a primary router), but I'd really like to see FreshTomato built for it please.
  47. pedro311

    pedro311 Networkin' Nut Member

    Good point! :)
    pharma likes this.
  48. kernel-panic69

    kernel-panic69 Connected Client Member

    Adding support for a non-Broadcom device to a Broadcom-specific firmware would be kind of tedious. The wireless interfaces use different drivers, different wpa supplicant, etc. It's not entirely impossible, but it would be quite the undertaking. There are 3 similar D-Link devices supported by DD-WRT, currently, but your Netgear wouldn't be identified correctly and there is no 100% guarantee the firmware for those devices would work 100%. Just my thoughts.
    Espionage724 likes this.
  49. pharma

    pharma Network Guru Member

    I confirm the External adblock script is missing from Tomato GUI on RT-N66U. I just flashed to freshtomato-K26USB_RT-N5x-MIPSR2-2018.5.083-beta-AIO-64K and noticed the adblock script is no longer on the Tomato GUI page. It was fine with freshtomato 2018.5.005 MIPSR2-beta K26 USB AIO-64K.
    Use if you need External Adblock access.
  50. ThirdEyeCx

    ThirdEyeCx New Member Member

    Hey there! Just discovered FreshTomato after using TomatoUSB by Toastman for a while. My router information is as follows:
    Model Belkin Share Max N300 (F7D3301/F7D7301) v1
    Chipset Broadcom BCM4716 chip rev 1 pkg 10
    CPU Frequency 453MHz
    Flash Size 8MB

    This router's purpose is being used as a Wireless Client and an OpenVPN client. I have tried flashing "freshtomato-F7D3301USB_RT-N5x-MIPSR2-2018.4-IPv6-VPN" and "freshtomato-F7D3301USB_RT-N5x-MIPSR2-2018.5.083-beta-IPv6-VPN" but neither of these builds has the VPN Tunneling option. I have since switched to "freshtomato-K26USB_RT-MIPSR2-2018.5.083-beta-MiniVPN" and it has the option, but now I am facing another issue.

    When entering the Server Address/Port information, there is a limit of 17 text characters. For example, if I am trying to enter "usXXXXxnordvpnxcom" it will only allow "usXXXXxnordvpnxco" not letting me enter the full server address and thus not allowing me to connect to that server. There are no issues when trying to connect to a server that has 17 characters however. My recommended servers with NordVPN are always the 18-character servers so this is an issue for me. I will use the servers that have 17 characters or less for now but any help regarding this matter would be much appreciated. Also, huge thanks for keeping our routers supported!
  51. pedro311

    pedro311 Networkin' Nut Member

    It will be fixed in next relase.

    Did you try https://www.linksysinfo.org/index.php?threads/fork-freshtomato-mips.74145/page-7#post-300976 ?
    pharma and ThirdEyeCx like this.
  52. Beast

    Beast Network Guru Member

    I would like to know as well if that works for you, it did NOT work for me. I got a substitution error. Also after clearing the browser cach i could no longer get the gui to display correctly. Using RT-N16
  53. HXRoark

    HXRoark New Member Member

    Is this flashable via the typical method if you are coming from Tomato (Shibby); that is, use the GUI to flash and clear NVRAM, then 30-30-30?
  54. pedro311

    pedro311 Networkin' Nut Member

    Depends on what router?
    HXRoark likes this.
  55. HXRoark

    HXRoark New Member Member

    Glad I asked. It's a Netgear WNR3500L v1 running TomatoUSB Shibby. I was going to install freshtomato-K26USB_RT-MIPSR2-2018.4-MiniVPN.md5.

  56. pedro311

    pedro311 Networkin' Nut Member

    You should just update it in GUI, but remember to check "erase all data in NVRAM memory", and set the settings again manually.
    HXRoark likes this.
  57. pharma

    pharma Network Guru Member

    Thanks for your efforts Pedro311. I'm getting the error below after substituting the linked code:
    Don't spend time on this as the Adblock dev's will probably come out with a fix for this shortly. I can still access Adblock using my external favorite browser link so it's not crucial.
    Last edited: Dec 8, 2018
  58. Beast

    Beast Network Guru Member

    Same error I got. That leaves me wondering why my gui no longer works with the compressed .js file. Yet I assume your gui is okay. What operating system are you using? Im on win7 pro router=RT-N16. I reverted back to the .4 build, because there was no way i could get the gui to work correctly in version .5
  59. pharma

    pharma Network Guru Member

    I'm also on Win 7 using a RT-N66U and using FreshTomato Firmware 2018.5.083 MIPSR2-beta K26 USB AIO-64K. I did have one problem with the GUI (no menu items showed) when I left the "revised" Adblock script in. When I reverted to the original Adblock script the menu items showed up again after rebooting router to default settings and reading from configuration file.

    After upgrading the firmware are you restoring a configuration file or inputting manually? Does the GUI work right after you update but before you change menu settings? I noticed if restoring from config file some settings are not activated and need to be re-done.
    Last edited: Dec 10, 2018
  60. Beast

    Beast Network Guru Member

    I erased NVRAM after the upgrade, and did the config manualy. Than did a reboot. This is where the gui went south. I am talking about the normal gui you get when you login. This is what the login gui looked like after the reboot. login_gui.png
  61. pharma

    pharma Network Guru Member

    Yes, that's what happened with 2018.5 and think it might be an issue since the same blank screen happened during a visit to check logs a few hours later. I've gone back to freshtomato-K26USB_RT-N5x-MIPSR2-2018.5.005-beta-AIO-64K-RT-N66U which works fine.
  62. kernel-panic69

    kernel-panic69 Connected Client Member

    Which browser are y'all using? On (L)Ubuntu 16.04 LTS - PPC with Firefox ESR, I am having no issues (but I do not have adblock turned on). Also never had issue with Chrome, Firefox, or Safari on Mac OS X. I don't recall any issues on Win10 with Firefox or Chrome, either, but I have wireless WebUI access disabled ATM. I can test adblock on my E4200v1, but pretty much all my client devices have their own.

    Also, @pedro311, as per my message in PM, rp-pppoe 3.13 is out, which may fix some folks' PPPoE woes.
  63. pharma

    pharma Network Guru Member

    Using Chrome with Win 7 Ultimate. Not sure what changed between RT-N5x-MIPSR2-2018.5.005 and RT-N5x-MIPSR2-2018.5.083 but the issue has not appeared on the .005 firmware version.

    Edit: Just to confirm I do not think external Adblock is the cause since it's also running when using the .005 firmware with no issue. The external Adblock menu choice is missing from both firmware versions but this is a more cosmetic/convenience feature.
  64. kernel-panic69

    kernel-panic69 Connected Client Member

    There's around two months' worth of commits between the two. Package updates, code cleanups, a whole lot of things. Not sure if this is could also be related to dnsmasq, but I do know there have been commits to the dnsmasq repo since v2.80, which is what is in 2018.005.083. Unfortunately, git is a little temperamental when you tinker around with your local repo and it's not sync'd with the main repo, so I have no way to test merging those commits and compiling.
    pharma likes this.
  65. Magister

    Magister LI Guru Member

    Thanks people for the MIPS version! I took my old E3000 and installed 2018.4/clear NVRAM, setup as wireless ethernet bridge (minimalist setup: disable wan/dhcp, set IP to, default gateway to, radio as ethernet bridge with the credential of the main router).
    It works wonderfully. I just needed to put the nameserver in resolv.conf as noted before and that's it.
  66. Yhazarus

    Yhazarus Network Newbie Member

    jffs now works on wnr3500lv2 on this build? on shibby and previous versions of advanced jffs doesn't work on this router but then I saw this post

    Im running now shibby 140 last on this router its this fork (last beta for example) better on all, internal dnsmasq works without put anything about it in scripts?
    Sorry if my English is bad it's not my mother's tongue

    PD Can I just upgrade from my version?
    Last edited: Dec 14, 2018
  67. pomidor1

    pomidor1 Networkin' Nut Member

  68. Yhazarus

    Yhazarus Network Newbie Member

  69. pomidor1

    pomidor1 Networkin' Nut Member

    you asked if there is such a version - so I told you it is - I do not have this router, software packages are younger than shibbie140 by 1.5 years
  70. Yhazarus

    Yhazarus Network Newbie Member

    Thanks, Is this added in last beta,? I need that jffs to free nvram scripts because i have very interesting commands to improve online gaming on init, firewall and wan up boxes, but still i don't know how can I do de same with jffs because o my router on shibby hadn't it and then I didn't try it. You would tell or guide me about load scripts like on administration but jfffs
  71. kernel-panic69

    kernel-panic69 Connected Client Member

    Every build newer than that test build (2018.3.083) should have jffs support for the WNR3500Lv2. I can backtrack the commits and double-check, but I do not think it was removed.
  72. pomidor1

    pomidor1 Networkin' Nut Member

    maybe @pedro311 will say, because this image is a test folder, in the next versions this commit is present or not
  73. M_ars

    M_ars Network Guru Member

    kernel-panic69 likes this.
  74. pedro311

    pedro311 Networkin' Nut Member

    Exactly. That patch was removed and is only available in this special test build.
    kernel-panic69 likes this.
  75. Yhazarus

    Yhazarus Network Newbie Member

    BUGS I SAW on last beta build:
    Alright, I have just checked last build 2018.5.083, and I'm going to say wich bugs I saw:
    There is a problem with forms or boxes on for example qos-classify.asp with last shibby I can put in destination port or source port (or source/des) ranges and numbers like this qos-classify.asp 53-58,110-111 or 80-88,500,3074-3085,3544-52363,52364-65535, now in this build 2018.5.083 once you put -, you won´t be able to put a , or other range. (with shibby there was a limit by line but not like this), to gaming needs it´s very importante ranges like shibby
    If you change local port on admin access (I had my web router like this, to one that it isn't 80 or similar (indeed I tried several nad oneone works well, you'll have problems with qos classify (not shown) and with basic-network.asp boxes or forms)

    -The shibby's version that I refer is 1.28.0000 MIPSR2-140 K26 USB AIO
  76. Amuro

    Amuro LI Guru Member

    Testing stable version in a RT-N16. So far so good.

    Do the current MIPS and ARM versions of FreshTomato have the same kernel version?
  77. pedro311

    pedro311 Networkin' Nut Member


    No problem here, everything works as expected. Clear your browser cache.
  78. pena1348

    pena1348 Networkin' Nut Member

    @Señor Nimda Did you happen to take pictures of your hookup. I may want to do the same.

  79. Señor Nimda

    Señor Nimda Network Newbie Member

    Pena1248: yes, but I did not annotate them. If you have any problems, I will help if I can.
    IMPORTANT: This is ONLY for "Linksys e2500 v3".

    There are 2 serial connectors, the one on the LEFT is the proper one. It is next to the ON/OFF button, and a closeup is on the 2nd picture. You should use a 3.3V lever shifter in the 3rd link on eBay, to connect to this serial connector, interrupt the boot sequence and you're in!

    There are two 5-pin connectors, for two different chips. I did not know which one is the right one, so I first soldered a pin-header to the wrong one. :)

    IMAGE 2:
    The one you want is the one on the upper left. Soldering is done on the bottom side of the board.

    Voltage level-shifter for mini-USB, don't forget to move the jumper from 5V to 3.3V. Remember, all you need is TX, RX and GND.

    (If this does not belong in this thread, it can be moved to a new one.)
    pharma likes this.
  80. pena1348

    pena1348 Networkin' Nut Member

    Cheers Señor Nimda. That will get it done. I already have a serial adapter.
    Señor Nimda likes this.
  81. antonio carvalho

    antonio carvalho New Member Member

    router: F7D4302 v1
    firmware: freshtomato-F7D4302USB_RT-N5x-MIPSR2-2018.5.107-beta-IPv6-VPN

    crash the router (tried 3 times...), recovery only with usb serial adpater.... (no luck CFE without open case...)

    copy from console:

    Bootloader version 0.06e boot_version 0.06e
    Project name : WG8017F22 1-LF-AK
    Press space bar to cancel startup...
    Device eth0:  hwaddr 94-44-52-9E-9D-39, ipaddr, mask
            gateway not set, nameserver not set
    Startup canceled
    CFE> nvram erase
    *** command status = 0
    CFE> Decompressing...done
    Init Arena
    Init Devs.
    Boot partition size = 131072(0x20000)
    et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller
    CPU type 0x19740: 133MHz
    Tot mem: 65536 KBytes
    CFE mem:    0x80700000 - 0x8079A640 (632384)
    Data:       0x80731730 - 0x80733AF0 (9152)
    BSS:        0x80733AF0 - 0x80734640 (2896)
    Heap:       0x80734640 - 0x80798640 (409600)
    Stack:      0x80798640 - 0x8079A640 (8192)
    Text:       0x80700000 - 0x80731730 (202544)
    Copying boot params.....DONEDecompressing...done
    Init Arena
    Init Devs.
    Boot partition size = 131072(0x20000)
    et0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller
    CPU type 0x19740: 453MHz
    Tot mem: 65536 KBytes
    CFE mem:    0x80700000 - 0x8079A640 (632384)
    Data:       0x80731730 - 0x80733AF0 (9152)
    BSS:        0x80733AF0 - 0x80734640 (2896)
    Heap:       0x80734640 - 0x80798640 (409600)
    Stack:      0x80798640 - 0x8079A640 (8192)
    Text:       0x80700000 - 0x80731730 (202544)
    Copying boot params.....DONE
    Bootloader version 0.06e boot_version 0.06e
    Project name : WG8017F22 1-LF-AK
    Press space bar to cancel startup...
    Committing NVRAM...done
    Device eth0:  hwaddr 94-44-52-9E-9D-39, ipaddr, mask
            gateway not set, nameserver not set
    Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
    Loading: .. 5100 bytes read
    Entry at 0x80001000
    Closing network.
    Starting program at 0x80001000
  82. poiu12

    poiu12 Connected Client Member

  83. kernel-panic69

    kernel-panic69 Connected Client Member


    A person's personal builds isn't de-facto of the freshtomato-arm fork. Advanced is a fork of the original Tomato / shibby, etc. mods, and AFAIK, it is a UI-only enhancement and has had no specific software code updates applied. That being said, one might be able to import the Advanced UI improvements into FreshTomato and compile, but I am not sure that is what @AndreDVJ did....
    youmax likes this.
  84. Mr Dini

    Mr Dini Network Newbie Member


    I had a spare RT-N12D1 at home with some old Tomato Shibby v132 installed, so I quickly replaced that with the latest K26 Beta Max release and I since the house is big, I wanted to setup a LAN to Wireless network under the same SSID. I looked up the available modes, and found WDS to be promising. So firstly on the first router I enabled the mode WDB, gave MAC access to the other device and everything went fine. However on the second one, I chose the AP + WDB mode too but without DHCP. And changed its address to Now I cannot access that router, it just keeps connecting to my other network and makes my WiFi completely unusable (since it cannot serve IPs).

    I wanted to launch CFE and do an nvram reset, but that didn't work either using the common button press, power on, button releasing when the power led starts blinking... But the router is still unreachable.
  85. sebwifi

    sebwifi Network Guru Member

    I flashed 2018.5.083 on my N60 and it works great. Now, I want to add cdc_ether/usbnet/rndis_host for 4G modem but can't find the "extras-mips2-RT-N" package, can you help please?

    Thanks for your great work.
  86. pedro311

    pedro311 Networkin' Nut Member

    No such package, due too many differences between individual build kernels. Maybe in the future...
  87. ephantom

    ephantom New Member Member

    @pedro311, @kille72

    I think I found a bug in freshtomato-K26_RT-MIPSR1-2018.4-Mini.trx

    I have a WRT54G v3.1 and installed freshtomato-K26_RT-MIPSR1-2018.4-Mini.trx with "After flashing, erase all data in NVRAM memory".

    During setup I found in setting Advanced > MAC Address that the Wireless Interface field was setting WAN Port & Wireless Interface to the same MAC address, the WAN Port field entry was ignored.

    WAN Port: <ignored>
    Wireless Interface: <set the same for both WAN Port & Wireless Interface>


    As an extra note I had to move back to Shelby tomato-ND-1.28.5x-124-SD-VPN.trx because I couldn't get a WAN Port connection using the same manually entered configuration settings. I haven't tried any earlier versions of freshtomato to see if they work yet.
  88. danielhaden

    danielhaden Network Guru Member

    I would like an update to the default classifications, just 5, matching the 5 default rules, like this:
    1. 10%, 100% VOIP ports (including skype and magicjack)
    2. 10%, 100% less than 1k
    3. 3%, 100% less than 512k
    4. 1%, 100% less than 1MB
    5. 1%, 100% 1MB and more

    That will De-Bloat the QOS classifications, updating to modern fast paced responsiveness.
    This, or similar size-based method, is needed for the default.
    Last edited: Dec 20, 2018
  89. pedro311

    pedro311 Networkin' Nut Member

    No problems here. Clear your browser cache and/or use Ctrl+F5.
  90. zanykokoa

    zanykokoa New Member Member


    I have a Linksys WRT54G-TM and I tried 'freshtomato-K26_RT-MIPSR1-2018.5' (Both Max and IPv6-VPN version) from exotic.se.

    The 'Save' button doesn't work in the 'BASIC - Network' page.
    I tried the 'erase all data in NVRAM memory' for each install, but it didn't help.

    So I then tried 'freshtomato-K26_RT-MIPSR1-2018.4' (Max), and the 'Save' button worked fine in the 'BASIC - Network' page.
    Last edited: Dec 21, 2018
  91. kille72

    kille72 LI Guru Member

    Last edited: Dec 23, 2018
  92. pedro311

    pedro311 Networkin' Nut Member

    How many times I have to say it?
    Clear your browser cache and/or use Ctrl+F5 to refresh pages...
    pharma, kernel-panic69 and kille72 like this.
  93. kernel-panic69

    kernel-panic69 Connected Client Member

    ^-- from page 1 of this thread, regarding troubleshooting and reporting problems / bugs.

    In other news, I haven't quite yet added a dev branch to my working repository to see if I can help break ... er, fix some things yet, but soon enough.
    M_ars and kille72 like this.
  94. WaJoWi

    WaJoWi Serious Server Member

    Thank you so much for your hard work! I'll give you one or two beers for that. ;)
    kille72 likes this.
  95. txnative

    txnative Addicted to LI Member

    That is odd, normally you can recover without a serial and don't have to open the case. What happened? Do you have any activity from ping, led on or off? For the sake of replicating, I had pulled my F7D4302 out and installed the very same build using the GUI one can use the cfe mini either way the flash worked with no issues. Recovery on this model just works unless, something happened the power supply, power surge, the image erased the chip but tomato,dd-wrt always flashed and recovery isn't a problem.
  96. Kuthil

    Kuthil New Member Member

    I have an ASUS RT-AC66W (white instead of black like the RT-AC66U) and I tried freshtomato-RT-AC66U_RT-AC6x-2018.4-AIO-64K and freshtomato-RT-AC66U_RT-AC6x-2018.4-VPN-64K with a strange results. The router works fine until I plug in the WAN cable and then any connection to the wireless (2.4 GHz or 5 GHz) causes all of the port lights and wireless light to go off and back on and all connections are reset. Has anyone experienced anything like this? I went back to the latest Shibby build for now as I can't have a router without wifi.
    EasyIsEZ likes this.
  97. M_ars

    M_ars Network Guru Member

    Did you clear nvram? You can NOT use any backup. You have to start from scratch. Please try version 2018.5, lots of fixes and updates

    Please see also first page of this thread.
    pharma and kille72 like this.
  98. Señor Nimda

    Señor Nimda Network Newbie Member

    There's a way, you can fix this in the HTML template of the web-interface:

    #1) Add a version number to the names of all external JS, CSS, JSX references. When there's a new version of FreshTomato, rename all files and update all references to these files. For example:

    <link rel='stylesheet' type='text/css' href='tomato.css'>
    <script type='text/javascript' src='interfaces.js'></script>
    … BECOMES:
    <link rel='stylesheet' type='text/css' href='tomato-2018.7.css'>
    <script type='text/javascript' src='interfaces-2018.7.js'></script>
    All this fixates external dependencies to the version number, 2018.7.

    #2) Then, add two META "nocache" directives to the HEAD section of the HTML template (which is not HTML5). This will guarantee a roundtrip to the HTTP server, and enforce that proper external files are referenced & loaded.

    <meta http-equiv="Cache-Control" content="no-cache" />
    <meta http-equiv="Pragma" content="no-cache" />

    Using #1 + #2 will do the trick 100% of the time.
  99. pedro311

    pedro311 Networkin' Nut Member

    Yeap, but it will break also the whole cache httpd system implemented in the tomato...
    kernel-panic69 and kille72 like this.
  100. UserDirk

    UserDirk New Member Member

    Cisco E3000USB works. Thanks you
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice