Frequent, reproducable dropouts

Discussion in 'Other Linksys Equipment' started by Paul01, May 28, 2005.

  1. Paul01

    Paul01 Network Guru Member

    I have used the V1 WAG54G for months as an IPSEC VPN router, connecting to a Cisco 3725 back at the office and its worked fine.

    We have deployed 4 WAG54G's to sites where we have a single wireless PC and a couple of other insignificant bits of gear. However they are the V2 models with a new firmware build.

    All 4 sites are using the same ISP, which is the same ISP that has been rock solid on the V1. The configs are identical except for the PPPOE user account and the internal IP address range.

    Problem #1. The IPSEC parameters, although identical to the V1 setup, refused to work. An analysis of the logs showed IPSEC Phase II to be negotiating different parameters what I specified in the GUI. Where it should be ESP-SHA-HMAC it is uctually doing ESP-MD5-HMAC. That at least is easy enough to deal with on the Cisco end. But having said this, config on the Cisco end shouldn't have to change in between hardware models!

    Problem #2. Frequent disconnects. Seems that the connection to the ISP will drop off and not reconnect without a power cycle of the WAG54G. This has happened at all sites. I had confirmation from the ISP that the device was indeed no longer connected.

    Problem #3. Using remote management, the web based GUI crashes. I have had situations where suddenly remote management fails. Travelling onsite, local web mamanagement has also failed. However during this time, the VPN was still up as I was able to ping inside devices.

    So although I am plagued with problem #2, problem #3 is a separate issue that happens quite often

    The whole reason I chose the WAG54G was it performed admirably during all tests (but of course that was V1). My supplier didn't actually tell me there was a new hardware model (I found that out only when setting them up) and now the problems above have rendered them practically unusable.

    Now I'm in Australia and I am using the same ISP, although some Dslams are Telstra rebadged and others they have their own service. THis problem is happening no matter which site using 4 different WAG54G's.

    Any ideas?
  2. hijglander

    hijglander Network Guru Member

    Maybe you can exchange them for v1.0 models via Linksys RMA or your local supplier, there should be alot of them around... even new ones.

    There is a new beta firmware that might fix all your problems. Although I haven't seen any changelog for this version (1.00.47-004) it works great for me.

    PM me if you're interested in this version... or just google on it, I found it that way.
  3. Paul01

    Paul01 Network Guru Member

    Okay I solved the worst of the IPSEC problems with a firmware from Linksys. However at each site I have a single PC with a linksys WPC54G USB wireless adapter and pereodically I cannot ping the device over the VPN.

    It seems to go in and out. Not one missed ping in 4 or 5, but 10 minutes where all requests time out.. then it comes back again.

    I feel its also the WAG54G because if I force it to come back if I make some benign change to the wireless confg on the router like enable SSID broadcast (or visa versa). Performing that action must 'reset' the wireless subsystem I guess as it almost instantly replies to pings again..

    until it happens again later

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice