FTP Client behind RVS4000

Discussion in 'Networking Issues' started by donathome, Feb 17, 2008.

  1. donathome

    donathome LI Guru Member

    I went to the Linksys website to get the latest firmware for my RVS4000 and found that the only way to get the update is via FTP.

    However, the RVS4000 does not allow my FTP client to actually get the file. I can connect fine and list the folder about 50% of the time. However, I cannot download anything through the RVS4000. Tried both active and passive. No difference. I am using the Filezilla client if that makes any difference.

    As a side note, when I replace my RVS4000 with my old Dlink router, the FTP client works fine.

    Anybody know the secret of making the RVS4000 work? Thanks in advance
  2. Fast Eddie

    Fast Eddie Guest

    Try disabling DoS Protection under Firewall

    Try disabling DoS Protection under Firewall.

    Worked on the WRVS4400N to get FTP to function.

    Hopefully Linksys will release new firmware to fix this and many other issues with this series of routers.
  3. donathome

    donathome LI Guru Member

    >>>Try disabling DoS Protection under Firewall.
    I was not using Dos Protection. It has already been disabled.

    >>> Hopefully Linksys will release new firmware to fix this and many other issues with this series of routers.
    I have the 1.1.14 (latest released). It took about a year to get that release after the 1.1.09. I am not hopeful.

    I really need ideas of what to do. My really old DLink handles FTP w/o issues but cannot handle the data rate. I am tired of having to swap it out to send/receive files
  4. Toxic

    Toxic Administrator Staff Member

    do you have your the FTP setting in IPS enabled on the RVS4000?
  5. donathome

    donathome LI Guru Member

    >>> do you have your the FTP setting in IPS enabled on the RVS4000?
    I have tried it both ways, enabled and disabled. Neither works and I get the exact same symptopms. (My client can connect through the RVS4000 to the server, but I cannot transfer files.)

    I am currently running with IPS enabled and FTP disabled. If I try to disable IPS entirely, then my browser no longer functions.

    Thanks for any support/help.
  6. mleining

    mleining Network Guru Member

    Check the IPS Report -> go to the bottom and "View Log". If your IPS is blocking your local computers, you will see a log entry with the internal IP address that was blocked. Also, the attack categories in the IPS report might give you a clue as to why it is being blocked so you know what to turn off. If it is a P2P/IM signature, you might be able to just set one type to "non-block".

    I have to disable anomaly detection in order for some of my stuff to work since it seems to trigger on false positives too frequently. It interferes with my VNC between internal computers. I just disable all four types of anomaly detection. I'm using firmware V1.1.14 and I just downloaded all of the stuff from Linksys and some from here just fine using FireFox.

    Under the FireWall basic settings, I also do not turn on any "Block" boxes, but I do have the firewall and IPS turned on.

    You might try a different client. I downloaded everything fine with FireFox on Vista Ultimate. I don't use FileZilla. If you can get there with a different client, then the problem is probably the client.

    When you upgraded the router firmware, did you factory reset it? I can disable IPS and mine still works fine.
  7. dizman67

    dizman67 LI Guru Member

    I am having the same issue .. took me a while to toubleshoot the issue to the RVS4000, once I unplug the power and replug it back it .. wait forever to boot. I am able to download via FTP for about a day .. then it goes away again. I am running 1.1.14 firmware. Very Annoying issue.
  8. wireless-Bob

    wireless-Bob Addicted to LI Member

    I have had this same issue with FTP. In my case, the transfer would start to download from the server and then stop after only ~2-3k bytes. My ftp client (SecureFX) will automatically restart transfers when the connection times out. So, the estimated time to download about 2M bytes was on the order of 46 hours. :mad:

    I found that the RVS4000 apparently determined the local computer running the ftp client was attacking the LAN. The attack name was APP_ANOMALY_DETECTION_FTP. Changing the IPS and anomaly detection settings did not have any effect. After resetting the RVS4000, the ftp transfers proceeded without any further problems.

    I don't know how long the reset was effective, as an ftp test transfer froze in the same way as I was writing this post.

    I currently have both Firewall and DoS protection enabled. IPS is enabled, as is anomaly detection for HTTP, FTP, and Telnet. Firmware is 1.1.14.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice