FTP Passv and other several troubles

Discussion in 'Cisco/Linksys Network Storage Devices' started by costinr, Mar 4, 2007.

  1. costinr

    costinr Guest

    Everything started with my need to have nslu2 configured as a ftp server behind a nat/firewall machine, (so i needed passv capabilities) with ntfs disks on an usb hub.

    1. So I've started with unslung 6.8, unsling to external flash on port 2, tried vsftpd package - stuck. Don't know why but vsftpd refuses to start.
    Again, reset, reflash linksys 63 version, re-unslung 6.8, re-unsling on port 2 (re-unslang with my nerves :)). Tried with xinetd at first and vsftpd - stuck again.
    Again everything slung/slang, xinetd and this time tried proftpd - and again stuck.
    More than that, I've discovered that with unslung 6.8 I cannot see my ntfs disks anymore. There is a ufsd so called package, but it did not work for me (is very tricky to install it, but I've succeeded anyway - but even with ufsd completely installed, no ntfs disk recognized).

    (BTW - I'm not a linux user (for me linux means redhat fedora or mandrake on gnome or kde) because I really don't like the commands in prompter (telnet/msdos style) but i can live with that)

    Now the question - does anyone knows a verified method of using nslu2 as a ftp server with passv capabilities, with ntfs disks in a usb hub ? (And also, does he have the patience to give me step-by-step instructions ?)

    2. I've tried linksys v72 version, and another surprise: The first web page is incomplete (corrupted) but only when I have 2 or more ntfs disks in the usb hub...?! Look at the pictures below:

    V72 with no usb hub and 1 ntfs disk - everything fine

    as before, admin screen - again everything fine

    v72 with usb hub and 2 ntfs disks (corrupted page)

    as before, admin screen (FAT16/32 ??? - there are 2 ntfs disks in the hub !!!)

    Question is simpler this time: WTF ??

    With v63, the problem is the same, it shows FAT16/32 instead of NTFS when there are 2 disks in the usb hub, but at least the first web page is shown correctly.

    With both versions (v63 and v72) the ntfs disks plugged in the usb hub can be accessed well (but with v63 I've experienced several freezes from time to time and I needed to reboot nslu2).

    Thanks a lot for any help,

  2. Toxic

    Toxic Administrator Staff Member

    please resize your pictures
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice