FTP Problems

Discussion in 'Tomato Firmware' started by mnbowhunter77, Mar 24, 2011.

  1. mnbowhunter77

    mnbowhunter77 Networkin' Nut Member

    Hey all,

    I'm having some issues FTP'ing into my router from offsite...

    I have an RT-N16
    using Tomato Firmware v1.28.9054 MIPSR2-beta K26 USB vpn3.6
    I also have a cable connection from my isp.. there is no firewall on the modem
    I have the basic settings from the initial installation + dyndns setup and working from offsite via HTTP.
    I have the FTP Server setup as follows:
    yes, WAN & LAN
    port 21
    anonymous is disabled
    /mnt in both the public and private root directory
    more than 1 allowed user with 2 connections
    unlimited bandwidth
    i also have a login/pwd setup
    under port forwarding i have port 21 forwarded to the LAN router IP

    This is pretty much an identical setup to another router i help admin... and the FTP works perfectly on that one.. major difference is my system has a dynamic ip provided by the isp... and the other is static.

    In the case of the problem FTP.. my client just hangs and times out. I have tried an anonymous setup.. no change... It does resolve my dyndns to the WAN IP.. so i'm getting that far.. but it goes nowhere after that.

  2. rhester72

    rhester72 Network Guru Member

    Remove the port forward. It is done for you automatically when you select WAN or WAN & LAN.

  3. mnbowhunter77

    mnbowhunter77 Networkin' Nut Member

    K... .Port forwarding for port 21 removed..

    but no change... connection just times out

    could it be something wrong with the vpn version of the firmware.. i don't have vpn enabled .. but the other router i am working on is the ext version and it seems to work great??

    Any other ideas
  4. rhester72

    rhester72 Network Guru Member

    Does it time out post-connection or before you are prompted for login?

    Does a Shields Up! scan on port 21 of your IP (NOT your DNS name!) show the port as open, closed, or filtered?

  5. Toastman

    Toastman Super Moderator Staff Member Member

    Just in case it helps, as long as I have been using a flash drive here, I also had to forward the FTP port or it didn't work.
  6. rhester72

    rhester72 Network Guru Member


    I'm not doing a manual forward and using the builtin vsftpd now - can you tell me if you can reach my site?

  7. TT76

    TT76 Networkin' Nut Member

    I can access your ftp. Everything is ok.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, I can. But you remember I used to use ftp on my router, people couldn't access it without portforward. Or so I was told by everyone when I deleted the portforward last time this came up!
  9. dufoq3

    dufoq3 Addicted to LI Member


    I have ASUS RT-N16
    using tomato-K26USB-1.28.7497.1MIPSR2-Toastman-RT-VPN.trx
    On my primary router i have DMZ port forwarding to this ASUS.

    I have the FTP Server setup as follows:
    Enable FTP server: Yes, WAN and LAN
    ftp port: 5550
    Anonymous user access: Read only
    Anonymous root directory: /mnt/"myUSBdevice"/public

    with this open port chcecker tool: http://www.canyouseeme.org/
    my port 5550 is opened: "Success: I can see your service on "my ip" on port (5550)
    Your ISP is not blocking port 5550"

    The problem is ---> I can connect to my ftp only from LAN, but no from the internet.

    I'll be greatful for every help
  10. dufoq3

    dufoq3 Addicted to LI Member

    This is iteresting:

    I'can connect to my VPN over internet,
    If i send magic packet for Wake On Lan from internet - i received it on my PC.
    Som I'm really confused :(
  11. dufoq3

    dufoq3 Addicted to LI Member

    problem solved:

    It's only problem to connect to my xxxxxx.dyndns.org with any device in my home LAN.
    If i try to connect from everywhere else - everything is ok. - dunno why...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice