FULL OPTWARE Package for Tomato ND USB Firmware..

Discussion in 'Tomato Firmware' started by Lost_Animal, Mar 4, 2010.

  1. Lost_Animal

    Lost_Animal Addicted to LI Member

    UPDATE.. 05/04/10

    New Version of OPTWARE PACKAGE V.9.5 For Tomato is OUT !!!


    Just follow Instructions HERE....


    Ready to Download .....

    Now Script_init load is Working !

    BUG Fix Script coming soon ....



    First of all i want to Thanks teddy bear for his excellent Firmware Mod, OLEG for his Huge Knowledge and Optware Collection, DD-WRT community and Special frater for his Scripts,
    and Finnaly A BIG BIG Thanks to valerakvb for his EXCELLENT script which i corrected to run on Tomato Firmware...:biggrin:

    I must say also that this First Release may have some Bugs also and probably need some fixes to come later. But i am really sorry because i start using LINUX a month ago and don't know much yet.
    So don't shoot me if code inside the script is not so well written.:redface:

    Installation Procedure

    1) Take an empty USB Disk and FORMAT it or Delete any Partition Have on It.
    You not need to Prepare any Partitions because the Script will make them for you.
    The Script will create 3 Partitions.
    1st will have 256 MB size and will used as SWAP.
    2nd will have 1GB size and will used As /opt mounting for Optware Package.
    3rd will have all the remain space of your disk and will used as /tmp/harddisk mounting for DATA.
    So dont worry about partitions - format etc. etc.

    2) On your router remove any other USB device you have and connect you USB Disk.

    3) Make sure you will have Automount ON at USB and NAS => USB Support Page of your router.
    Then attach the New Optware Disk and REBOOT your Router...

    5) Wait 5 sec to automount the Disk.
    If your disk is Emprty of Partitions you will not see any Mounted Device appears on Attached Devices. This is Normal...
    If your Disk have Active Partitions on it, then on Attached Devices you will see a /tmp/****** mount.
    Now just Press Unmount on the Right.

    7) Write
    cd /tmp
    wget http://www.xtremecoders.org/optware/tomato_optware.sh
    sh tomato_optware.sh
    and the next screen will Appear.


    PLEASE DONT forget that after Install Completed, your router WEB PAGE will be ONLY accessible at 192.168.1.XXX:8080 and Username will be root...
    This is a must because from now on will used by PHPSqlCms..

    8) As you see at the Image you can USE a,b,c,d,e,f,g,h,i,j,k,m,n keys to Select or UnSelect Apps will Install.
    With (+) key we choose between Format Installation (New Installation) or Update Only..
    With (-) Key we choose between Transmission and rtorrent P2P app..
    With (^) Key we start a Check Error on your USB Disk
    With (%) Key we Reinstall main Program and Leave Data Disk (/tmp/harddisk) UNTOUCHED...

    And Finally with (!) Key we Start the Installation of our Choices... :biggrin:

    Please NOTE that SAMBA3 on OPTWARE is FULL working but if you allready have USE the Internal Samba on Tomato Firmware, Maybe will conflict with your Settings.

    Entire Installation may last 10 - 40 Minutes or more depending from what you select and how fast is your Disk.
    So be patient and watch the installation Procedure or Drink a Coffee...:biggrin:

    If all went OK the router will Reboot and PLEASE Wait at Least 5 Minutes Before try to ACCESS any Page on Your Router.

    Depending from want you installed, Scripts after the Boot are loading and may this time your router will LAG due to Heavy DUTTY.

    When all Scripts loaded and Running, Then you can TRY to ACCESS your APPS...


    BEFORE YOU DO ANYTHING First CHECK Init_Script Loaded ok
    If you dont see the next Picture filled with script then you must Write the following
    AND REBOOT the Router before Use Any Optware...

    Its a NVRAM set Failure and i will fixed soon.....


    chmod 777 /tmp
    mkdir -p /tmp/harddisk
    sleep 2
    swapon -a 
    for i in `awk '/ext3/{print($1)}' /etc/fstab` ; do 
    if [ -b $i ] ; then 
    grep -q $i /proc/mounts || e2fsck -p $i 2>&1 | logger -t e2fsck 
    logger -t fstab "$i is not attached" 

    Now Lets See WHAT INCLUDED and HOW CAN ACCESS IT via WEB page....

    I Hope you Like all of them and ENJOY your New Optware Package.

    PLEASE just select to Install ONLY those you Really you NEEDED because you waste alot of memory recources and CPU LOAD and Maybe your router become slow and HOT....

    If you want to ADD some More Optware on Script Just Let me Know...

    BTW. Not all Scripts TESTED full for BUGS. Please dont forget that i have NOT much time to work on it.
    So let me Know your comments...

    LOST_ANIMAL.... Greece.....

    PS.... Dont Forget to Visit my New Page sometimes.....
    I need some good guys for Moderators when Finish the Forum

    I am Here .... http://www.netcoure.com It will be soon (www.xtremecoders.com)
    darkknight93 likes this.
  2. EricCartman

    EricCartman LI Guru Member

    Can we someone share Files FROM NAS DNS-343 with the router?
    thank you guys I have bought today Asus NT-N16 :) and LOVE IT :)

    Thank you for making our live easier :)
  3. EricCartman

    EricCartman LI Guru Member

    Can you post the link?
  4. Toastman

    Toastman Super Moderator Staff Member Member

    Hey, LA. - thanks! This is a really nice way for people who are not technical to install optware packages. When I get some time I'm going to try some of these. I look forward to seeing the list expanded, and maybe I'll make a few suggestions! My initial thought was for a better traffic monitoring and analysis package, nice graphs etc. - something like Link Logger ..

    Well done!

    NB - to help out a little - a copy of this version of the script can be found at: http://firmware.mooo.com/Toastman Builds/MIPS32R2 Kernel 2.6 (RT-N16 etc) Builds/
  5. ladysman

    ladysman Network Guru Member

    Download limit reached on the first file. FYI.


    This file is neither allocated to a Premium Account, or a Collector's Account, and can therefore only be downloaded 10 times.

    This limit is reached.

    To download this file, the uploader either needs to transfer this file into his/her Collector's Account, or upload the file again. The file can later be moved to a Collector's Account. The uploader just needs to click the delete link of the file to get further information.
  6. EricCartman

    EricCartman LI Guru Member

    How do I transfer file to my router?
  7. amitava82

    amitava82 Addicted to LI Member

  8. EricCartman

    EricCartman LI Guru Member

    I have installed some things all I get is

    Unable to connect

    Firefox can't establish a connection to the server at

    * The site could be temporarily unavailable or too busy. Try again in a few

    * If you are unable to load any pages, check your computer's network

    * If your computer or network is protected by a firewall or proxy, make sure
    that Firefox is permitted to access the Web.
  9. Credo

    Credo Addicted to LI Member

    you have to transfer all the files are in the script to download and spread into the archive, because the site http://www.studionr.ru is a private, located on the router "valerakvb" http://wl500g.info/ which may lead to inaccessibility or modification of files without notice ....
    run a script to do with the router. ( wget
    and change the path the script.

    nvnStat PHP frontend
    Needs to be Fixed In English...
    Status RC
    Working OK but must Fix English Version...
    how to change
  10. 56kb

    56kb LI Guru Member

    I can't install package but thanks for your effort.
  11. Lost_Animal

    Lost_Animal Addicted to LI Member

    OMG Credo......

    I didnt knew that links targeting your router.....:biggrin:

    This makes the Script and files Unsable Until Find a Host for them.....
  12. shibby20

    shibby20 Network Guru Member

    for what all of this? anyone can install optware to router (ipkg) and install everything what he need.

    simple, true?
  13. Simbol84

    Simbol84 Addicted to LI Member

    Я думаю справедливо было упомянут изначального создателя скрипта "valerakvb" с русского форума http://wl500g.info. Ой не дочитал )))) Все есть.
    I think it was rightly mentioned by the original creator of the script "valerakvb" from Russian Forum http://wl500g.info. Oh I am sorry everything is not read.
  14. Lost_Animal

    Lost_Animal Addicted to LI Member

    Finnaly i ended with a New WebHost Subscription for a year....:biggrin:

    I will create a new HomePage and will Host all Files on my new WebPAGE.

    The Next 24 hours my WebHost will be active at http://www.netcoure.com :wink:

  15. soldier

    soldier LI Guru Member

    Cool. I will wait that you fix the script and then give it a try.

    P.S. Remove the winky (smiley) and a dot from the link :thumbup::thumbups::clap::rockon::clap2::bow:
  16. Lost_Animal

    Lost_Animal Addicted to LI Member

    The script you give above my friend is a clone of dd-wrt and is included on script i used allready.... :biggrin:

    Not every one here is know much linux to make correct fix the conf files needed per Deamon or apps which use..

    So a package is far more simply way to do things if you dont know what to do..

    So i think we need all those GUIDES and Packages.... :wink:
  17. prito

    prito Addicted to LI Member

    I don't want all the optware packages, just certain ones. I have an 8GB flash drive I want to use for Optware and extra data, maybe a user home. What partitions should I setup on this drive?

  18. soldier

    soldier LI Guru Member

    So this package is generally OK or you need to do some corrections in the script.

    read again the LA's tutorial on the first page
  19. aiwlove

    aiwlove Addicted to LI Member

    Thanks. I am waiting for your new link.
  20. Lost_Animal

    Lost_Animal Addicted to LI Member

    My New Site is UP and Running....


    Now its time to Upload some Files.... :biggrin:

    Thank you for your wait.....:wink:
  21. EricCartman

    EricCartman LI Guru Member

    I got this nice message lol

    You do not have permission to access this document.
  22. CBR900

    CBR900 Network Guru Member

    same problem here too
  23. Lost_Animal

    Lost_Animal Addicted to LI Member

    I was on Installation Procedure....:biggrin:

    Temporary the forum is Hosted at http://www.netcoure.com/httpdocs/

    I recreate the Forum from Start.:thumbup:

    Tommorow i will Upload the Files.

    Try now...
  24. belliash

    belliash Addicted to LI Member


    This are unnecessary:

    echo "export PATH=/opt/bin:/opt/sbin:$PATH" > /root/.profile
    echo "unset LD_LIBRARY_PATH" >> /root/.profile
  25. soldier

    soldier LI Guru Member

    I'm registered. If you need any assistance I would be glad to help you.
  26. Lost_Animal

    Lost_Animal Addicted to LI Member

    Help Needed..
    I spend 2 DAYS to try host Optware on my New Forum WebHost...

    Loading files was ok.....BUT !!!!!!

    When i download with wget files without extension then DOWNLOAD is Impossible.... :eek:

    Here are Files Hosted on My WebServer.....


    First try a file with .sh extension is OK....


    But Second File with no Extension is not Downloaded....


    Why all this ?

    I've try all possible combinations without success, even ftp has the same problem...


    BTW my Forum is on BUILD Process yet. http://www.netcoure.com

    CHRONOMASTER Addicted to LI Member

    It looks like your config has a white/black list of extensions. It's meant to protect your files. But in this case you want to change or disable it.
  28. Toastman

    Toastman Super Moderator Staff Member Member

    I notice in the webserver I use, the whitelist doesn't seem to allow the use of no extension at all. And I had to add .sh and some other typical linux extensions myself, they were not part of the default setup. You probably need to check this out with the host site's admin staff.
  29. Lost_Animal

    Lost_Animal Addicted to LI Member


    Found a fix to this mess.

    I packed on optware.tar all scripts and tar needed.
    Updated to gnutar to bypass tar invalid magic bug...
    Then made fix to Script that extract on new mount (/tmp/hardisk)
    And replaced all wget with copy command...

    Tested and worked,,,,, :biggrin:

    Now get ready to Take it....

    New Instructions Uploaded

  30. contrary

    contrary Addicted to LI Member

    Thanks, I tried this and it ran into a lot of confusion/hilarity starting with

    "tomato_optware.sh: line 680: gnutar: not found"

    and that's likely to be in more than one place... ;-)

    Using an N16 with beta07 and a 80G usb drive previously partitioned.
    I unmounted it, and also turned off FTP and Sharing before I started (as suggested elsewhere by Wengi). The repartitioning appeared to progress normally and it found ipkg.nslu2-linux.org fine, but couldn't unpack it.
  31. Lost_Animal

    Lost_Animal Addicted to LI Member

    Do it again.....

    Format the Disk, and reload.
    U took the wrong tomato_optware.sh before upload the new one.
  32. Lost_Animal

    Lost_Animal Addicted to LI Member


    I see some OLEG packets are removed from links....
    So Installation is not proceed well.

    OMFG.... from one problem to the other....:mad:

    Dont download until find what changed...
  33. 56kb

    56kb LI Guru Member

  34. Lost_Animal

    Lost_Animal Addicted to LI Member

    Script is working,
    I tryed and saw during installation procedure, that some wget files dont found. :wink:
  35. 56kb

    56kb LI Guru Member

    You were right some wget got time out but installation process until finish. I guess we can Reinstall again later.
  36. Lost_Animal

    Lost_Animal Addicted to LI Member

    maybe was a temporary problem .
    Try to install and see if all is ok now.
  37. 56kb

    56kb LI Guru Member

    Can you please link me with latest "tomato_opt.sh" so I can try with Tomato ND USB Firmware:biggrin:
  38. Lost_Animal

    Lost_Animal Addicted to LI Member

  39. 56kb

    56kb LI Guru Member

    Please enlighten me how to?
    6) Copy the downloaded tomato_pt.sh to your /tmp folder on your router.
  40. hapahopi

    hapahopi LI Guru Member

    i use winscp to do this.
  41. 56kb

    56kb LI Guru Member

    I have downloaded "winscp"
    Can you please show me step to use it.:confused:
  42. hamster22

    hamster22 Addicted to LI Member

    Why don't you wget it?

    Or if you really wan't to do it localy use a ftp server or something, and then wget it?
  43. 56kb

    56kb LI Guru Member

    I got it silly me:biggrin: at first I try wget didn't work.
    works now thanks
  44. hamster22

    hamster22 Addicted to LI Member

    Good you got it working. :D

    I have now tried it, but i have found a bug (i think) or it could be firmware bug.
    I tried only installing transmission via format. it formatted the drive (120gb hdd) like it should. :)
    but in the /opt folder there is no dir's at all its just empty, isn't the optware supposed to be there? (maybe i have to install another program with transmission and not only transmission by itself? :tongue:)
    Okay now to the bug, in the script "init" section I had to instert the code manualy which i expected :p but i noticed that the script doesn't execute by itself (reboot) i have to go to /tmp and lunch "scripts_init.sh" myself, when that is done the swap is located and mounted. :biggrin:

    If it isn't a bug and I just don't understand a thing(im fairly new too all this) please don't hate on me :thumbup:
  45. vasilsmeer

    vasilsmeer Addicted to LI Member

    Found in log During install
    Whats its mean ??

    After instaling all progs lighttpd dont starts :mad:
    in lighttpd server logs(/opt/var/log/lighttpd/error.log) i found
    When i try to startup
  46. Lost_Animal

    Lost_Animal Addicted to LI Member

    I think its a nvram problem with init - firewall etc.
    I will try nvram getfile method to see if is ok.

    Probably a new version of optware by Oleg is out and some files have corrupt wget source.
    Thats why some installation procedure fails.
    I will try to find what changed and i will include it on the script.:wink:

    But please just FOLLOW exactly the Guide for installation.
    Don't even forget any reboot.:biggrin:
  47. 56kb

    56kb LI Guru Member

    Ho well I tried installed 3 times nothing stucked. can't start any application all I got was white pages :mad:
    gave up for now
  48. teddy_bear

    teddy_bear Network Guru Member

    If this is the script from the 1st post in this thread, then it won't work in most cases - the script is wrong.

    Do not use "Init" script to access USB partitions and do actual mounts and activate swap. It runs too early in the initialization process, and the USB drives may not be ready yet.

    The Init script is not intended for that. If for any reason you don't want to store your /etc/fstab file in nvram, you can create /etc/fstab in the Init script using "echo" commands - but that's probably the only purpose this script is suitable for.

    You can specify swap partition(s) in fstab, and they will be activated automatically - no need to call "swapon -a" manually in the Init script. Calling e2fsck from the Init script won't work in most cases for the same reason - drives are not ready yet. Personally, I don't see a real need to call e2fsck on the router, not on every reboot anyway. It's better to take your drive(s) to the computer and run e2fsck there. Or do it manually on the router from time to time - stop all Optware apps, unmount the drive(s) and run e2fsck.

    If you feel like you absolutely want to run e2fsck on startup, the only way to do it cleanly is to turn auto-mount off, and execute e2fsck from the hotplug script (after no less than 5+ secs delay). You can then mount partitions from the same script via "mount -a" command (it will use your fstab specs) - just note that with auto-mount turned off the ".autorun" and post-mount scripts won't be executed.
  49. Lost_Animal

    Lost_Animal Addicted to LI Member

    Teddy thanks for reply...

    Original Script is for ASUS original Firmware with Oleg Mods and Patches.
    So there are Huge differences the way working both...

    Oleg& ASUS use the next Startup scenario..

    touch /usr/local/sbin/post-boot
    touch /usr/local/sbin/post-firewall 
    touch /usr/local/sbin/post-mount
    touch /usr/local/sbin/pre-mount
    touch /usr/local/sbin/pre-shutdown
    touch /usr/local/sbin/ez-setup
    echo "#!/bin/sh" > /tmp/local/sbin/post-boot
    echo -e "\033[1mWriting pre-mount\033[0m" 
    wget http://www.studionr.ru/wl500/_pre-mount -O /tmp/local/sbin/pre-mount
    echo -e "\033[1mWriting post-mount\033[0m" 
    wget http://www.studionr.ru/wl500/_post-mount -O /tmp/local/sbin/post-mount
    echo -e "\033[1mWriting pre-shutdown\033[0m" 
    wget http://www.studionr.ru/wl500/_pre-shutdown -O /tmp/local/sbin/pre-shutdown
    echo -e "\033[1mWriting post-firewall\033[0m"
    wget http://www.studionr.ru/wl500/_post-firewall -O /tmp/local/sbin/post-firewall
    echo -e "\033[1mWriting ez-setup\033[0m"
    wget http://www.studionr.ru/wl500/_ez-setup -O /tmp/local/sbin/ez-setup
    echo -e "\033[1mMaking start files executable ...\033[0m"
    chmod +x /tmp/local/sbin/*
    And ENDS with...

    flashfs save && flashfs commit && flashfs enable && reboot
    As you see i must find equal way to do the same on Tomato by using Nvram or what ever.

    I know that maybe some other guy with better knowledge on Linux will do it better because i am 3-4 weeks Study on Linux..... :biggrin:

    Need moooooore lessons and time ...... :thumbup:
    Just searching on 3470 lines of code (including all *.sh files) to make this script run better on tomato.... :thumbup:
  50. vasilsmeer

    vasilsmeer Addicted to LI Member

    Sorry for offtopic i have installed 1.27.9042 RTN16-beta02 ND USB Ext its right firmware to install this script ??
  51. Lost_Animal

    Lost_Animal Addicted to LI Member

    You can Install on any Tomato ND USB firmware..:biggrin:
  52. prince

    prince Addicted to LI Member

    lost animal r u done with this script ....i mean shud i install it now

    i saw ur msg

    I Think i found a solution to this problem my friends.
    I will try this night to see if working ok and i will upload the final script.

    Thank you for your waiting.

  53. soldier

    soldier LI Guru Member

    I installed it. For me only Samba works. The rest of apps, nada.
  54. vasilsmeer

    vasilsmeer Addicted to LI Member

    And begins work Web server on 80 port :)
    But other not working for me :cool:
  55. Lost_Animal

    Lost_Animal Addicted to LI Member

    Just try this...

    Set Automount off...

    Copy the next to Hotplug script

    /opt/etc/init.d/rc.unslung start
    rm /opt/var/run/*.pid
    Make sure that on INIT Script have the next commands...

    chmod 777 /tmp
    mkdir -p /tmp/harddisk
    sleep 2
    swapon -a 
    for i in `awk '/ext3/{print($1)}' /etc/fstab` ; do 
    if [ -b $i ] ; then 
    grep -q $i /proc/mounts || e2fsck -p $i 2>&1 | logger -t e2fsck 
    logger -t fstab "$i is not attached" 
    SAVE and REBOOT router...
  56. zsolt

    zsolt Guest

    Hi LA,

    I have installed all options. Almost everything is working. After installation I had to unplug the rooter because the reboot was not sufficient.

    Samba OK.
    TWONKY MEDIA OK but asking for an other key: "This key is already in use by another instance of the server" - I need an other Registration key: SDDS-HWAB-PTAW-XFFG-BSPT-EGMS-BALE-AWXB.
    TRANSMISSION - i have not installed first time, an now i am not able to install it.
    ImageView -ok
    PHPSqlCms -ok
    WEB rtorrent - installed but not functional.
    Download Engine -ok
    RRDTool - not functional (I don't need anyway)
    System Info -ok
    Web2ICQ v.1.0 -ok
    vnStat PHP frontend -ok but I cant read it.
    Privoxy - ok
    NOD32update -ok
    Status RC -ok but !!!
    MC -ok
    SMS WEB -ok but I can't test it.
    PHP cfi -ok.

    I would like to ask you how can I uninstall the sections that I am not using, without to reinstall all the software on the router?
    What I need to do to install correctly one of the torrent application.

    Other questions:
    There is a possibility, to format the HDD to NTFS not EXT3. I am using that HDD directly attached to the computer too. (The tomato is able to read NTFS too).

    Thank you for your work and help.

  57. Credo

    Credo Addicted to LI Member

  58. Lost_Animal

    Lost_Animal Addicted to LI Member

    So it works...:biggrin:

    Ok still need some fixes to be complete and full operational.
    I will proceed to new 9.1 version and make some later updates.:thumbup:

    Please note all bugs you see, to include future updates. :thumbup:

    Twonky media is not free anymore.
    I had to buy a key also... :frown:

    Russian text will be replaced by English on Next Update.

  59. Credo

    Credo Addicted to LI Member

    Often, failure is rrdrun.sh script in the folder / opt/etc/cron.5mins
    fails Line
    / opt / usr / bin / rrdtool.sh>> / opt / var / log / rrdtool.log 2> & 1
    perhaps not all peremnnoy PATH =
    why not working
    RRDTool - not functional (I don't need anyway)
    and does not appear in the chart Status RC

    add post-firewal
    ipaddr=$(nvram get wan0_ipaddr) # for the accuracy of the variable is not sure ask Lost_Animal
    iptables -I INPUT -s -d $ipaddr -j DROP
    iptables -I OUTPUT -s $ipaddr -d -j DROP
  60. Lost_Animal

    Lost_Animal Addicted to LI Member


    My forum will be DOWN for a few hours today due to movement on NEW LINUX SERVER and new URL.

    My new URL will be http://www.xtremecoders.org and old http://www.netcoure.com will used as Parked Domain which redirect to new one.

    So download will not be possible during this procedure.
    Also will update the scripts to targeting new URL...

    Thank you...

  61. soldier

    soldier LI Guru Member

    Jep, that fixed the problem. Everything works :thumbup: Thanks
  62. Lost_Animal

    Lost_Animal Addicted to LI Member

    Everything works ? :biggrin:

    Need some fixes before we can say Everything works, but this is a start... :biggrin:
  63. soldier

    soldier LI Guru Member

    OK don't kill me :wink:. It opens the apps in the browser. I didn't go through every program.
  64. Lost_Animal

    Lost_Animal Addicted to LI Member

    I will not kill you...:biggrin:

    BTW... You was too fast by register on xtremecoders.org and server was not ready yet.

    I will inform you when Finish the BUILD of it....:thumbup:
  65. Credo

    Credo Addicted to LI Member

    New version of the script ( Oleg Fimware !!! not work Tomato)
    Version 9.2 dated 12/03/2010
    - New version of the web interface ruTorrent v.3 with plug-ins (cookies, erasedata, search, trafic, scheduler)
    - New version Download Engine v.2.0-14
    - New version of the menu item [n] Sending SMS through web-interface
    - Fixed display of data in the status for RT-N16 (I hope - no possibility to verify)
    - New version of the script reinstall v.9.2 (the version number of this script will now assign as a basic script install software)
    - Fixes for receiving Klyuchikov in NOD32Update (exception obtaining TRIAL keys)

    CHRONOMASTER Addicted to LI Member

    Hello Lost_Animal,

    I tried your script and here are my results and questions.

    I had a problem with the programs not loading, I fixed it by enabling automount and adding "/opt/etc/init.d/rc.unslung start" to "Run after mounting", nothing else worked for me.

    After install when using telnet/web access I seem to be stuck in user mode and I can't run anything that requires superuser access. Do you know how to get superuser access back?

    The find command seems to have been replaced with one of no use. The new find command no longer searches recursively and only the folder specified. Is there a new find command somewhere in opt and will deleting that restore the original?

    Is twonkymediaserver running at ~90% cpu when it should be idle for you?
  67. Lost_Animal

    Lost_Animal Addicted to LI Member

    For some works on hotplug script with automount off, for others work on run aftermount script and automount on.:biggrin:

    It need some sleep 5 adding probably on usb scripts...:redface:

    Twonky is a cpu demanding app. Mine also running hot and ~80% but droped to ~40% after 20 minutes idling..
  68. DarinA

    DarinA Addicted to LI Member

    I was experiencing this problem while in telnet, the fix for me was to unmount the attached drive, do what you need to do as root, then mount the drive again or reboot. Hope that helps.

    Cheers ;o)
  69. Lost_Animal

    Lost_Animal Addicted to LI Member

    Sorry for the late reply but i was too buzzy with Building my new Site and Blog.
    I think at the end of Next week will be ready to upload a new Version of Optware Package and i hope without Bugs, and included all suggestions from teddy bear about mounting etc.

    Any help on this Project is welcome. :wink:

    CHRONOMASTER Addicted to LI Member

    I think I fixed the whole permission denied thing.

    By deleting or renaming '/opt/etc/profile' and rebooting I was left in superuser(#) instead of user($).

    Easy Access Tip:

    Share the /opt folder over the network. USB and NAS > File Sharing
    Then rename the file.

    Edit: Opps, I typed 'home' instead of 'etc' by mistake. :tongue: Sorry about that.
  71. peyton

    peyton Network Guru Member

    Any chance to make a manageable webproxy/adblocker more effective than just a dnscache/hosts tweak ? like squidguard can do ? (for kids..)

    I notice some websites issues with the dnscache/hosts tweak like search request not working well and it's not easy to modify lists.
  72. miodzicho

    miodzicho Guest

    I have made everything as described, step by step. Seems installed correctly, mounted correctly but when I´m trying open http://IP:901 shows nothing. But main page is on 8080
    Nothing seems working for me.

    RT-N16 with 07 beta and USB HDD 320GB

    Storage 0 Hitachi HTS545032B9A302
    Partition 'sda1' swap (250.98 MB) is active
    Partition 'sda2' ext3 (980.53 MB) is mounted on /opt
    Partition 'sda3' ext3 (296.89 GB) is mounted on /tmp/harddisk Yes
    [ Unmount ]
  73. Lost_Animal

    Lost_Animal Addicted to LI Member

    Try this...

    1) Do a Shutdown from Web Interface and wait to complete.
    2) Power Off the router
    3) Power ON router
    4) Wait 3 - 5 minutes
    5) Try again on http://

    is OK ?

    If not then redo the installation using the new Beta Script...

    wget http://www.xtremecoders.org/optware/tomato2.sh -O /tmp/tomato_optware2.sh
    sh tomato_optware2.sh
    Inform me !
  74. Lost_Animal

    Lost_Animal Addicted to LI Member

    New Version Of Tomato Optware is STILL on Progress.

    Will include new Apps like NZBGet - plowshare - vlighttpd - etc..

    Before Upload it must be sure is running without BUGS.

    Permission Denied is Fixed.
    Will remove some Useless apps from script to save time and Mem Usage. :biggrin:

    Just wait a litle more... :wink:




  75. Lost_Animal

    Lost_Animal Addicted to LI Member

    New Version of OPTWARE PACKAGE V.9.5 For Tomato is on BETA stage.
    Need some minor fixes but U CAN download and Install without Problems....

    Just follow Instructions HERE....

  76. Lost_Animal

    Lost_Animal Addicted to LI Member

    Tomato Full Optware Package ver.9.5 IS OUT !!!

    It's Over.
    It's Ready
    It's Working (i hope for all :biggrin:)


    • What Fixed.
    • 1.Permission Denied after installation
    • 2.Rtorrent not Loading as Daemon
    • 3.New mounting Procedure without corrupts
    • 4.New Installation Procedure for K2.4 & K2.6 Kernels
    • 5.Better Loading Routine
    • What Added ?
    • 1.Asterisk 1.6.2 with Addons & Sound Samples and Web Interface
    • 2.SABnzbd Plus & NZbGET with Web Interface
    • 3.Ushare Media Server
    • 4.TwonkyMedia Server v.5.o Beta 1
    • 5.Imagevue v.2 ( Flash Photo Gallery and Slide Show )
    • 6.Web2ICQ
    • 7.SMS Messages & SMS WEB
    • 8.Plowshare Commnand line Down/Uploader
    • 9.PHPSql CMS + eAccelerator
    • 10.Vlighttpd By frater ( DD-WRT )
    • 11.SAMBA 3 + Web Administration Tool
    • 12.Nod32 update Server
    • 13.Polipo and Privoxy (proxy and filters)
    • 14.Site Status Router
    • 15.WiMAX (modem Samsung SWC-U200 from Yota)
    • 16.Midnight Commander with UTF-8
    • 17.Install Transmission (BitTorrent client)
    • 18.Rtorrent (BitTorrent client)
    • 19.Download Engine v.2.0-13 (FTP)
    • 20.VnStat ( Traffic Statistics )

    So get ready For Download...
  77. deboyz1014

    deboyz1014 Addicted to LI Member

    Awesome job Lost Animal
  78. prito

    prito Addicted to LI Member

    So how do I use this to install standard optware like NMAP or Lynx?
  79. Luis

    Luis Guest

    Standard optware ipkg installation should work, no?
    "ipkg-opt install nmap" or "ipkg-opt install lynx"
  80. cyan

    cyan Addicted to LI Member

    is there a way to change router to 8080 (if I don't use SABnzbd) ?
  81. Lost_Animal

    Lost_Animal Addicted to LI Member

    Goto Administrator=>Admin Access
    On Web Admin Tab change Http Port to what Ever you Like.... !
  82. Elanzer

    Elanzer Addicted to LI Member

    I went with a very minimal optware installation (no to everything, I only want to use rtorrent and the miau IRC bouncer for now) I want to use the native tomato file sharing interface as well, so I didn't install the samba package.

    Now when I try to set /tmp/harddisk as a file share on the tomato web interface, the share will show up, but I get read-only access even if I set to read/write. I've tried setting chmod 666 on /tmp/harddisk to see if it would help and I get "chmod: /tmp/harddisk/: Read-only file system". Without using this optware package, everything works perfectly (file share shows up on workgroup, is username/password authenticated). I also cannot create new directories through putty on the router itself.

    What am I missing?
  83. Lost_Animal

    Lost_Animal Addicted to LI Member

    Most of the shares created by Packages are handled by Optware SAMBA.
    So probably you can't access them without Optware SAMBA.
    Using WINSCP navigate on folders and see the owner and access rules.



    I will replace Download Engine with ADOS in a short time .. :!: :!: :!:


    I've already installed and run smooth !
    I will give you an installation patch if you already installed the Full Package of ver.9.5
  84. kamatschka

    kamatschka Network Guru Member

    Does this script also work on Tomato ND routers with SD-Card Mod ??

    I have a WRT54GS v1.1 where I want to install optware . Can I go with your script?

    Greet kama
  85. Lost_Animal

    Lost_Animal Addicted to LI Member

    You have to TRY.
    Can't Answer !
  86. teddy_bear

    teddy_bear Network Guru Member

    If you only want one or two of the included packages and would like to stick with built-in Samba, I'd recommend you to just install Optware manually, using the instructions linked from the 1st post of USB mod thread - unless you're afraid of command line ;).

    The package Lost_Animal put together is great for people who would like to use several or all of the included applications, and/or who find the manual Optware installation process too difficult. However, it has a few drawbacks, such as using /tmp/harddisk mountpoint (a legacy of a script it was initially based on), using hardcoded partition names, disabling auto-share and auto-mount, and requirement for yet another Samba. These issues are definitely not show stoppers, but I believe the compatibility of the script with the built-in features can be improved a little. I was intended to take a look at the script, and possibly come up with some suggestions - but just didn't have time yet...
  87. Lost_Animal

    Lost_Animal Addicted to LI Member

    Hi teddy,
    The script don't Disable Automount or anything else.
    I recommend to disable Automount to ensure that Formating and Partitioning Procedure will be the without any issues, but when ends it sets Automount etc back to normal use (enabled).

    For users which not afraid to play with commands i DON't recommend to use the Script.
    But for people who don't have any experience on Linux environment its an easy way to get what they want.

    I will not stay here.
    I have to my "to do list" an other Project, better than Optware Package.
    An Integrated Environment for Optware through Firmware Web Pages...

    New Firmware will OFFER...

    1) User selection of Optware List
    2) Automatic Installation through Web Interface.
    3) Automatic Updates through WEB Interface.
    4) User Selection of Start / Stop – Load / Unload every Optware Service
    5) Optware Trace Window showing Service status of each Optware like CPU Load / Mem Used / PID etc.
    6) Debugger Window.
    7) Backup / Restore Optware Utility

    I will name this Firmware Tomato Xtreme !!! :lol:

    But for sure i will need Help from Gurus like you !!! :biggrin:

  88. cyan

    cyan Addicted to LI Member

    is that mean you will put some of the optware inside jffs (5MB tomato vs 32MB flash) ?
    are still going to release ADOS for 9.5 user ? :biggrin:
    thank you.
  89. redarray

    redarray Guest

    great job
    and this post should be a STICKY
  90. jnappert

    jnappert LI Guru Member

    Is there a way for those who already went "the classic optware way", to manually install parts of this package?
  91. qingz

    qingz Network Guru Member

  92. stotes

    stotes Addicted to LI Member

  93. Lost_Animal

    Lost_Animal Addicted to LI Member

    Our Server is Back Again...

    Sorry for this Malfunction, but Our Server Crashed Last Night.
    Btw 2 things happened the same Time.

    1) Massive attack by Spam Robots on our Blog.
    2) Hard Disks on Server Crashed.

    We Recover our Last Backup but also we lost some of the last Updates.

    I was forced to recover manually some of the latest data but not all.

    Sorry Again, and i Hope this was the last Problem for ever.

    Lost_Animal (Site Admin - Owner)
  94. flammenwurfer

    flammenwurfer Networkin' Nut Member

    Hi. I have an Asus 520gu and I have Tomato Tedd Bear installed on it and working great. I would like to install transmission. On the first post of teddy_bear's thread for his firmware it says to follow these instructions to install optware. That seems very complicated, but the post is from 2008.

    Will it work if I just telnet into my router and do...

    cd /tmp
    wget http://www.xtremecoders.org/optware/tomato_optware.sh
    sh tomato_optware.sh


    Or will I have to follow those complicated instructions in teddy_bear's post?
  95. EricCartman

    EricCartman LI Guru Member

    Is this new script or old one?
  96. centurion

    centurion Guest

    can you integrate DC++ hub&client and reTracker in this opt?
  97. Aquafire

    Aquafire LI Guru Member

    Hello Lost_Animal,

    Seems like you have done some great work to make the life easier for the non-techies to enjoy all the benefits of tomato with Optware packages.

    I just wanted to ask for a small assistance can you make a script which will only install Polipo as a proxy server on my router.

    I dont need to change or install any other applications nor do I want to change the default access port of the router settings from port 80 to 8082 (since other applications start running on 80).

    So just a script to install Polipo/Privoxy with all basic settings with web based configuration file in place and running.

    Thanks for your support in advance.
  98. Simbol84

    Simbol84 Addicted to LI Member

  99. EricCartman

    EricCartman LI Guru Member

    Simbol84 English PLS :) as we can't understand Russian
  100. Simbol84

    Simbol84 Addicted to LI Member

    В 53 строке файла /opt/bin/dlengine ошибка, строка должна выглядеть так:
    while /opt/bin/true; do
    Тогда Download Engine работает и качает файлы нормально.
    Как я понял в инструкции ошибка и при установке все таки монтирование нужно выключать, как написано тут http://www.xtremecoders.org/forum/viewtopic.php?f=75&t=42#p195. Так не кто и не поправил, все ушло на форум Lost_Animal.
    Рторрент не работает, просто не стартует и все.
    Для установки нормальной (Automatic DOwnload System (ADOS) by DINI) можно воспользоваться этим:
    echo -e "\033[1mInstall Automatic DOwnload System (ADOS) by DINI\033[0m"
    ipkg install libcurl
    ipkg install perl
    mkdir -p /opt/share/www/ados
    wget http://www.studionr.ru/wl500/ados.tar.gz -O ados.tar.gz
    tar -xzf ados.tar.gz -C /opt/share/www/
    sleep 10
    wget http://www.studionr.ru/wl500/axel.tgz -O axel.tgz
    tar -xzf axel.tgz -C /opt/bin/
    sleep 2
    chmod 0755 /opt/bin/axel
    mkdir -p /tmp/harddisk/ados
    mkdir -p /tmp/harddisk/ados/admin
    mkdir -p /tmp/harddisk/ados/admin/archives
    mkdir -p /tmp/harddisk/ados/admin/images
    mkdir -p /tmp/harddisk/ados/admin/music
    mkdir -p /tmp/harddisk/ados/admin/programs
    mkdir -p /tmp/harddisk/ados/admin/video
    mkdir -p /tmp/harddisk/ados/_all
    mkdir -p /tmp/harddisk/ados/_tmp
    mkdir -p /tmp/harddisk/ados/_log
    chmod 0777 /tmp/harddisk/ados/*
    wget http://www.studionr.ru/wl500/ados.sh -O /opt/etc/cron.1min/ados.sh
    chmod +x /opt/etc/cron.1min/ados.sh

    In the 53 line of the file / opt / bin / dlengine error string should look like this:
    while / opt / bin / true; do
    Then Download Engine runs and pumps the files normally.
    As I understood the instructions and error when you install all the same mount to shut down, as it is written here http://www.xtremecoders.org/forum/viewtopic.php?f=75&t=42 # p195. It is not those who were not corrected, all gone to the forum Lost_Animal.
    Rtorrent does not work, simply does not start and all.
    To set the normal (Automatic DOwnload System (ADOS) by DINI) can use this:
    echo-e "\ 033 [1mInstall Automatic DOwnload System (ADOS) by DINI \ 033 [0m"
    ipkg install libcurl
    ipkg install perl
    mkdir-p / opt / share / www / ados
    wget http://www.studionr.ru/wl500/ados.tar.gz-O ados.tar.gz
    tar-xzf ados.tar.gz-C / opt / share / www /
    sleep 10
    wget http://www.studionr.ru/wl500/axel.tgz-O axel.tgz
    tar-xzf axel.tgz-C / opt / bin /
    sleep 2
    chmod 0755 /opt/bin/axel
    mkdir -p /tmp/harddisk/ados
    mkdir -p /tmp/harddisk/ados/admin
    mkdir -p /tmp/harddisk/ados/admin/archives
    mkdir -p /tmp/harddisk/ados/admin/images
    mkdir -p /tmp/harddisk/ados/admin/music
    mkdir -p /tmp/harddisk/ados/admin/programs
    mkdir -p /tmp/harddisk/ados/admin/video
    mkdir -p /tmp/harddisk/ados/_all
    mkdir -p /tmp/harddisk/ados/_tmp
    mkdir -p /tmp/harddisk/ados/_log
    chmod 0777 /tmp/harddisk/ados/*
    wget http://www.studionr.ru/wl500/ados.sh-O / opt/etc/cron.1min/ados.sh
    chmod + x / opt/etc/cron.1min/ados.sh admin : router http://img59.imageshack.us/img59/7568/ados.png
    thanks valerakvb from forum http://wl500g.info
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice