FYI: WMP54G not compatible with ASUS P2B-F Mainboard...

Discussion in 'Other Linksys Equipment' started by Anonymous, May 12, 2004.

  1. Anonymous

    Anonymous Guest

    ...and probably other of the same type (P2B-*).

    I recently bought the WMP54G (and also the router WRT54G). The router - non-wireless part - worked great. Though, my happiness didn't last for long, because an installation of the PCI WLAN Adapter wasn't possible (under Win XP, W2K, Win 98SE). Windows hardware assistant continously asked for a driver (what should happen automatically after installing the monitor which includes the drivers I think), but didn't want to find one, when I pointed to the appropriate .inf file on the driver CD. The net[tm] as well as Linksys support couldn't help... they merely stated the incompatibility, but couldn't tell a reason. After some recherche maybe it's because of an old PCI Spec., I suppose.

    I would be happy to hear from other people with the same combination.

    Apud Helvetios longe nobilissimus fuit et ditissimus Orgetorix.
  2. Esquire

    Esquire Mesquire Staff Member Member

    I just came across a similar problem with a computer I was helping a friend to rebuild during the past week. Windows detected it as an ethernet controller, but couldn't read the INF file.

    I reseated it to another PCI slot and disabled the virus check in the BIOS, and the problem disappeared. Have you tried this?
  3. rotor

    rotor Network Guru Member

    Tried every single PCI Slot, with and without other cards and various BIOS settings (virus checking was never enabled).

    But no bad idea. What I didn't try till now is to set the default values of the BIOS. Maybe...

    Tnx anyway!
  4. I also could not get the wmp54gs to work with an old Gigabyte motherboard with intel 440bx chipset (PIII), running XP Pro.

    After installing the card, it would either:
    It would either:
    1. Hang on boot
    2. Only be recognized as ethernet controller, refusing to accept the driver
    3 Be rcogonized as a WMP54gs, but failing to start (error "Device cannot start (Code 10)".

    I tried ressetting bios to defraults and disabling virus protection in bios and XP, but nothing would work.

    I was hopping to try the latest driver, but toward the end of my effort, the machine would not boot with the card present.
  5. wavesailor

    wavesailor Network Guru Member

    Hi All,

    :?: I have the same problem. My PC (ASUS P2B-LS with Intel's 440BX chipset) with the WMP54GS wireless adapter will not boot - well it sounds like it might be booting by the video card does not display anything. When I install the card and boot up – the display adapter (ATI Rage Fury) stops working. I tried the farthest PCI slot from the AGP slot too – did not help. It does not even show the Bios 1st screen – does not even kick the monitor out of stand-by mode. Anyone had similar problems or can help? Please help – I just bought my WMP54GS to match my WRT54GS.


  6. rotor

    rotor Network Guru Member


    I don't think that you'll succeed. No chance with a 440BX.
  7. wavesailor

    wavesailor Network Guru Member

    FYI: here is a response I got back from Linksys. They say that they do not have issues with any mother boards or chipsets. What to do????


  8. Esquire

    Esquire Mesquire Staff Member Member


    I know this isn't gonna be helpful, but I have a WMP54G installed on Dell desktop with the same chipset without any problems.
  9. wavesailor

    wavesailor Network Guru Member

    No - It is definitely NOT helpful :) Did you do anything specific? On BIOS etc??

    I'm not sure what to do now ... Send it back or try and get them to at least try and solve it.

  10. Esquire

    Esquire Mesquire Staff Member Member

    Nothing specific.

    I placed it in the next available PCI slot on the motherboard. The BIOS is the latest available for this Dell model - a Dell-customized Phoenix BIOS. All the BIOS settings are at their defaults.

    I have another WMP54G working on an even older 440LX chipset motherboard too (with a P2 CPU).
  11. wavesailor

    wavesailor Network Guru Member

    Now I have not tried Nothing specific :D

    Jokes aside .... I'm pulling my hair out ... That is after pulling every PCI card out my box and trying the WMP54GS in every single slot. It just will not boot. Even tried with both BIOS Defaults set - both Setup and BIOS defaults. Not sure what to try next. Guess I just may have to send it back ... Ahgg (painful scream)

  12. rotor

    rotor Network Guru Member

    However, Linksys knows that there are compatibility issues with older ASUS Boards (resp. 440BX Chipsets).

  13. caplam

    caplam Guest

    I was told by the linksys french support center that pci port has to meet the 2.1 specifications.
    I've 2 motherboards from abit (vt6x4 and be6II) and I can't find the information anywhere.
  14. smvb

    smvb Network Guru Member

    Yes, I too just bought a WMP54GS for my computer that has a plain old P2B mainboard. It will not boot most of the time, but will sometimes get to Windows, and then shortly thereafter hang. And the last few times I tried to boot, it didn't even reach Windows--sounds exactly like wavesailor's symptoms. I wish I would have seen this thread before I bought it.... I hate wasting money (15% restocking fee).

    For the record, I checked the BIOS settings, and the virus checking was set to disabled already. As to PCI 2.1 as mentioned as a possible reason for the problems with other boards, there is an option in the BIOS settings that enables support for PCI 2.1 in my version of the BIOS, so I don't think that is the problem with my P2B.

    Now do I go and spend the extra money on a WET54G, or risk compatibility with the WUSB54GS? Hmmm....
  15. rotor

    rotor Network Guru Member

    Welcome to the club, smvb!

    If you have the possibility try the adapter before you buy it! Everything else is a waste of money...

  16. RITMaloney

    RITMaloney Network Guru Member

    O Man!

    My WMP54GS just arrived in the mail today from an ebay vendor. I tried putting it into my old IBM Aptiva from '99 that's barely running Windows XP with its Pentium II at 400 MGHz and 320MB of RAM. I figure hey, Windows XP, PCI slot, 400 MGHz, 320MB of RAM it ought to work. WRONG! Just like all of you it didn't even boot. I was furious. I thought the vendor had unloaded some short circuited hardware on me.

    After a while of trying different configurations I tried it in an older machine running Windows 2000 w/ 96 MB of RAM and it was detected as an ethernet controller. I didn't go any further, but I now knew the piece wasn't shorted. I tried it again in the Aptiva but it still didn't boot. So I called Linksys's 24/7 Tech Support (which was all the way around the world in India, I could tell by the accent and by the way the sound cut out every once in a while -VoIP isn't that great yet). I walked through all the idiot questions with the tech support guy, "is it pushed in... yadda yadda..." I finally got a chance to ask him if this was a problem linksys has heard of before or if maybe I had a bad machine. He went and checked offline and came back to say that they had never heard of this problem before. Obviously I had a bad card or a bad machine.

    Frustrated I fired up Google. Which I should have done all along! And I found you guys. I'm pissed, but at least I'm not alone.

    Here's my question, does linksys really know about this? Do they care? I didn't come across anything that could have warned me about this problem before I bought the product. My machine meets all the requirements as stated (

    Has anyone been able to overcome this?
  17. RITMaloney

    RITMaloney Network Guru Member

    What did you do? What has anyone else done to get thier machines on thier wireless lan?

    I had an ethernet cord dangling out three storries to connect this machine to the network. Now I just took that all down thinking my WMP54GS would work, but obviously not! Are there any wireless cards that will work with older machines!?
  18. After trying all the tricks I could I was also unable to get the WMP54GS card to be recognised as anything other than a network controller and that meant that I could not load the software. After 2 hours on what is supposed to be the UK Support line (actually somewhere 8 hours behind GMT) at a National Rate phone charge the support team (and I use the word support very loosely) told me that the card must be faulty. I have returned it to Linksys UK and over two weeks later still have not received a replacement as there is not one available in the UK. I will have to wait until one is shipped from Europe.
    I wish I had known that there were so many issues with this card before I bought it but you only start looking for support after it doesn,t work, not before. On the other hand the Linksys WRT54GS Router was totally flawless (my wired connections work fine) and I only bought the card to complement the router.
    I have temporarily solved my wireless connection problems by using a DLink USB adaptor. I wish I had gone for the USB option with Linksys as USB doesn't seem to have the problems associated with motherboards, chipsets etc. that PCI does.
  19. Tjeerd

    Tjeerd Guest


    Hey guys,

    please watch out to post e-mails from Supportdesks,
    because they have declaimers.
    I did this also on another post, and i had to pay a big amount from the judge, so if you all are smart, remove the post!!!

    This is from linksys
    ---This correspondence is considered confidential and any reproduction for the purpose of public disclosure is forbidden without written permission by the author signed above. If you are not the intended recipient, please immediately notify the sender and delete any copies.----
  20. RITMaloney

    RITMaloney Network Guru Member

    Get the WMP11 instead.

    Update on my situation:

    I went ahead and bought a WMP11 (the 802.11B Card) on ebay. It works in my old IMB Aptiva machine (the one I mentioned above). I'm a little dissapointed the WMP54GS didn't work, but 11mbs is still 10 times faster than my cable modem.

    I hope this information helps some people.
  21. jokach

    jokach Guest

    linksys wmp54gs-asus p2b

    Just to let you know, I don't believe that anyone has a defective card or motherboard. I was using my new wmp54gs card in a newer computer, but when I gave the computer away I kept the card. I put it in an older Asus P2b machine running Windows XP and could not get it to start (code 10). Windows would not recognize the driver. I tried it in all the pci slots, and upgraded my bios to the latest version, enabling pci 2.1 support...still no luck. If anyone gets it to work in a similar environment, please let me know.
  22. _Jeff_

    _Jeff_ Network Guru Member

    Digging up an old thread...

    I just bought this card yesterday to compliment my WRT54GS's and put it in an old ASUS P2B* board and it was recognized as a wireless card but could not see any signal or networks. Reading the Specifications on the box of the WMP54GS I noticed it it stated PCI 2.2 and PCI 2.3. No PCI 2.1 listed. So, it definitely appears that these cards won't work with < PCI 2.2. I put the card in my P4 system and it spun right up and I was able to connect with my wireless lan.

    I didn't find this thread until after I started googling.

    When I had the card in my P4 machine, I placed one WRT54GS at the opposite end of the house and I was able to connect just fine. It was slower something like 24 rather than the 54.

  23. stancatau

    stancatau Network Guru Member

    hey mate, try to update the bios of the motherboard to Beta version, sounds unstable but i did this for my CPU upgrade b4, u know, using new PIII on P2B tricks...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice