gaming problem with tomato (please help)

Discussion in 'Tomato Firmware' started by iXiCYNiKiXi, Apr 25, 2010.

  1. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    So before I type out this long post, I just want to introduce my post in one sentence:
    I have tried different routers, and different tomato builds (and custom builds as well), and different systems.

    So here we go!

    My gaming problem here is specifically with my PS3 and 360. When I setup my wifi and my router, I goto Internet Connection Test. When I do the test I get the following:
    Obtain IP Address: Succeeded
    Internet Connection: Succeeded
    Playstation Network: Succeeded
    UPnP: Succeeded
    NAT TYPE: Type 2
    Connection Speed (Download): - (never does this for some weird reason,though it works when i use DDWRT)
    Connection Speed (Upload): - (never does this for some weird reason,though it works when i use DDWRT)

    and on the bottom of the screen it says: "Your router may not support IP-fragments and communication features of some games may be restricted"

    Now im a HEAVY modern Warfare 2 player, in the game it says i have a STRICT NAT, so i have a hard time connecting to other players.
    on ps3, it says i have a strict nat
    on 360, it says OPEN
    on pc it says OPEN

    i have tried putting my ps3 in a DMZ, as well as forwarding the ports manually.

    The question is, how do i fix the "Your router may not support IP-fragments and communication features of some games may be restricted" error.

    This is what i have tried: (on both routers and ps3's)
    2 different routers (Asus WL-520GU and Buffalo WHR-G54S)
    Official Tomato Firmware (v 1.25, v 1.26, v 1.27) on both routers
    Other (unofficial) Tomato mods (hardc0re,Teddy Bear, and Victek)
    a different PS3
    Putting my ps3 in a DMZ
    Enabling UPnP
    Manually forwarding the ports needed for Modern Warfare 2 and the ps3
    Temporarily disabling all the firewall features of the router
    Changing the MTU

    if anyone could please help me, that would save me months of testing/configuring.

    the only thing i have tried that worked (on both routers, and ps3's) was DDWRT

    i dont really like DDWRT, and would rather have tomato, especially with my Asus WL-520GU router (tomato works great with the teddy bear mod)

    if there is any more information needed to help me out, i sure wont mind getting the info!

  2. Beast

    Beast Network Guru Member


    I dont know if this will help you, but like you I had problems with my PS3's NAT. After trying pretty much all that you did. In the end I resorted to restore all settings to the PS3 to default settings via the console menu. Then let the PS3 setup the network settings totally automatically across the board. And all worked fine after that. Of course you will need to go through and reset any other custom settings you may have had.

    BTW I rarely use my PS3 any more for online gaming. But I can confirm that my down loads still work as expected. Before I made the change, d/l speed was painfully slow. And I dont get that waring message anymore, when I run the network test.
  3. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member


    i have tried that today, and it did not work :(

    thanks for the help though ;]
  4. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    Ive pretty much narrowed it down, but cant find the solution...

    it has to be a difference between the tomato firmware and ddwrt
    because by logic, why don't I have this error when I use the ddwrt firmware but when i switch to tomato it give me the IP fragmentation error?

    unfortunately there is not a whole lot out there on the internet related to searching this problem [and i have been researching it for while, and have tried everything on different forums and sites to fix this] which is why i am here...
  5. Beast

    Beast Network Guru Member

    The MTU setting determines the largest ip packet that can be handled before it fragments. If you are on PPPOE it should be 1492. Also are you letting the router handle the PPPOE or the PS3 or is it handled by the modem? (I use the router and modem in bridge mode).
  6. felixkat

    felixkat Network Guru Member

    If it's any help my Ps3 work fine using Tomato. I do have an older version though, I only realised how old by reading your post.

    I use Tomato Firmware v1.22.1576

    I have a static IP on the PS3 and used that IP as the DMZ machine.

    I came here looking for another problem but will upgrade my firmware tomorrow to see if it fixes it. I'll try a test the PS3 to see if it still works.

    Oh and I use a cable connection as well, no wireless.
  7. FattysGoneWild

    FattysGoneWild LI Guru Member

    When using upnp. Give the PS3 a static ip.
  8. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    checked out command
    "ping -f -l 1472"
    and this worked for me, so i set the MTU to 1472 on my router, as well as ps3...and it still gave the fragmentation error.

    i will try to use v1.22, i never went back THAT far lol..but still let me know when you update your ps3!

    tried using automatic setup AS WELL as setting EVERY setting to manual (which is how i have ALWAYS had it setup) and it still did NOT make a difference...thanks though!

    thanks everyone!
  9. Azuse

    Azuse LI Guru Member

    Ask your isp what the MTU should be, if in doubt 1500, the ping google. If you dont get a fragmented reply stick with it, fi not reduce and repeat.
  10. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    i DO get a fragmented reply when i try 1500, so i set it to 1472 and its fine...the thing is is that ive set the MTU on my router, AND ps3 to 1472, and i STILL get the error... (which does not make sense)
  11. felixkat

    felixkat Network Guru Member

    I'm updating my router in the next couple of hours so I will let you know.

    Not sure where your based, if your in the UK, generally speaking Cable connections are MTU 1500 and ADSL are 1492, this is not gospel though.

    I think it's only the router you should be changing the MTU on and leaving the PS3 set to AUTO. Doesn't make sense to change them on both.

    I'll let you know the results of the firmware upgrade.
  12. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    ok ill try that tonight!
  13. felixkat

    felixkat Network Guru Member

    Okay, loaded Tomato Version 1.27.

    Put PS3 in the DMZ and the internet tests ran fine.

    I haven't touched MTU on PS3 and my router is set to 1500 but I'm on a cable connection, (Virgin Media), in the UK.

    I had a quick play on GTA and that seemed to work okay as well.

    Have you checked you Internet Cabling?
  14. iXiCYNiKiXi

    iXiCYNiKiXi Networkin' Nut Member

    if i use DDWRT, i DO NOT get this error, with the SAME exact cabling AND MTU settings (actually, the MTU settings on DDWRT are on 1500)

    i tried to set the MTU to 1500 on tomato, it worked, but i still received the error
  15. felixkat

    felixkat Network Guru Member

    Sorry, yeah forgot that it was working for you on DDWRT. Having said that though, you may have moved your modems & cables around a bit whilst doing the firmware upgrade. I once had what looked like a perfect cable until I noticed a small hole in it where it can snagged on a nail or screw, (caused me a small headache).

    There must be a logical reason somewhere why it's not working, we are both now using the same firmware on the routers and presumbly the same on PS3 as you have to update to go online. We are using different routers though, I'm using a Linksys WRT54G Ver 2.0.

    I think we can count the PS3 out if your having problems on the xbox as well. The modems we know are okay because you have tried two different ones and they worked on DDWRT.

    Have you tried a 30-30-30 reset before and after the firmware load? There's mixed opinions on doing this but I guess it's worth a go.

    Where are you based and who is your ISP provider? Have you tried running any speedtests etc just to see if there are any other usual events?

    Maybe you can connect the PS3 directly to you cable modem, (bypassing the routers), just as a final check that it is Tomato causing the issue. It's likely that it is but again worth checking.
  16. Dashiell

    Dashiell Network Guru Member

    I can confirm this issue is present in some of the latest builds. It goes away if you turn OFF QoS. I'm on an ASUS RT-N16, using TB's build 49. It's directly related to SOMETHING in QoS.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice