getting QuickVPN to work with a RV082

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Tomcat2k, Jan 7, 2005.

  1. Tomcat2k

    Tomcat2k Guest

    Hi all...

    I'd like to know if anyone of you've seen the same problem...
    when establishing a QuickVPN connection to a RV082
    I always got that damn messagebox saying more or less that something is wrong... (you know that box with the 4 items listed)

    Even when following all available instructions, I was not able to get the QuickVPN connection to work (not even IPSec)
    Even the Linksys helpdesk could not give me a hint where to search.

    Finally I've found out that the firewall setting for HTTPS was set to "Disable"
    I switched it to "enable" and QuickVPN said "Applying security.." and so on...
    While the Window "Verifying Network" was there for several minutes I tried to ping my remote network - and - it worked.

    Unfortunately the QuickVPN software is still saying "Verifying Network" but the connection is up and running, meaning I can work with thin the remote network.
    I cannot close this application as usual - I need to kick the process within Windows task manager in order to close my VPN connection.This behaviour is the same on several machines!

    So my question is...
    How do I get QuickVPN to fully work as expected???
    Is this something that I missed to configure, or is it a bug in the VPN client software?

    Thanks for your input...
  2. jorge98

    jorge98 Network Guru Member

    I got the Verifying Network message and then switched to using a NAT/firewall box that supported IPSEC passthrough. Once that happened, the unit managed to work fine for me.
  3. dbellard

    dbellard Guest

    Re: getting QuickVPN to work with a WRV54G

    Did you finally got it to work??

  4. ak-47

    ak-47 Network Guru Member

    I am also seeing this problem. Has anyone got the quickvpn client to work with a rv082?
  5. tareef

    tareef Guest


    I am having the same problem, only the firewall HTTPS setting was enabled. I have HTTPS being forwarded now to a server, I thought that might be the issue, but it wasn't. My quickvpn won't connect. Does a 'client-to-gateway' connection need to be setup?

    Linksys was no help and I am lost, any help would be appreciated.


  6. lurch

    lurch Network Guru Member

    QuickVPN worked fine on an XP Pro (Sp1) system connecting to an RV082 (firmware over DSL from behind a firewall (with Ipsec passthrough enabled) and even directly on a LAN. The only setup required on the RV082 is that you configure the user name, password etc. (no client-to-gateway VPN or anything else). In my experience, it only works if https is enabled as per the default firmware settings. Also, the user password must be at least six characters long. QuickVPN and the RV082 both accept shorter passwords without throwing an error message, but they won't set up a connection.
  7. dual_mon

    dual_mon Network Guru Member

    Quick VPN client software and RV042

    Does anyone know if Quick VPN can be downloaded? I searched all over the web, and while I will admit I am a bit past my bedtime, I think I would have found it on the LinkSys website, if they were making it easy.

    I must admit I didn't even open the CD that came with the RV042. Is it on there? Is is compatible with the 42? I would love to try it out. Configuring Windows for IPsec is a royal pain. The Greenbow IPSec client is nice, but it costs about $70+ per user (50 Eruos). Free is nice.
  8. dual_mon

    dual_mon Network Guru Member

    First rule of tech support. Always wait before you call back and 95% of the time the user answers theri own question :)

    First, it looks like this firmware adds support for the Quick VPN client:
    v1.3.3 2004/12/09
    1. Add the [VPN Client Access] page.
    2. Allow users to specify DMZ port as an IP range in the [Setup/Network] page.
    3. Fixed VPN tunnel can not be added after Group VPN connected by clients.
    4. Fixed Multicast over PPPoE.
    5. Fixed VPN IP Compression doesn’t work.
    6. Fixed the Netbios broadcast can not be over multiple VPN tunnel.

    (I found this in the fix list here):

    Second, the Quick VPN software is available for download from Linksys, just not anywhere obvious, especially if you are looking for it anywhere related to the fRV042.
    direct link:

    found on the RV082 firmware page:
  9. ohboy710

    ohboy710 Guest

    same problem

    I get to "verifying network" and then it says "the remote gateway is not responding" Any ideas?

    I have https enable, ipset enabled, and I can ping the remote network when I am connected while it says verifying network... then it disconnects me.
  10. chefybuck

    chefybuck Guest

    Remote gateway not responding w/ QuickVpn and RV082

    I am also getting "no response from remote gateway". I am trying to connect from behind an 8 port linksys cable/dsl router (BEFSR81) and keep getting this message. I have tried putting the PC in the DMZ with the same results. I have also pulled the PC out from the BEFSR81 and gave it a public IP via RoadRunner and still had the same results.

    Our RV082 is running the latest firmware publicly available from Linksys --v1.1.6.3.
    Any input on this would be greatly appreciated.

    Chad Buck
  11. redwolf3

    redwolf3 Guest

    Hi all...

    Well, I'm having much worse problems. I am running an RV082 trying to get the QuickVPN to connect. The RV082 side has a static IP, the Client side has a dynamic IP that changes regularly. I have tried every which way of configuring the RV082 to accept VPN, but I never get any response.

    I recently reset the RV082 to factory defaults (using Firmware I do not want to go through the reconfiguration process again until I can get the QuickVPN to connect, because this was 99% of the reason we got this router.

    Can anyone give me step by step instructions on exactly how to configure both the router and the client so that the client (a laptop) can access the local network? I have searched high and low and find tid bits here and there, but nothing that deals with my specific situation.

    Thanks in advance for any help you can give (and yes, I have used the Search function but have not found an answer to this question yet).
  12. xfag

    xfag Network Guru Member

    Problem with QuickVPN client software and RV082

    has anybody been able to connect a vpn to an RV082 using linksys quickvpn cliente software.
  13. xfag

    xfag Network Guru Member

  14. DocLarge

    DocLarge Super Moderator Staff Member Member

    For the record, quickvpn does work. This starter guide has been online for a few months now and even RV0XX users have connected following the steps:

    I'd make a guess that some of you have already seen this if not here it is. Also, look at "reasons quickvpn won't connect." As always, if you're getting "verifyng network" and it drops connection, it's just coming down to a setting or two that's off...

  15. xfag

    xfag Network Guru Member

    quickvpn client rv082

    The doc you sugested, as all the docs form linksys, posted how to configure the quickvpn client to work with a WRV54G, the point is, WITH THE RV082 IT DOES NOT WORK. If anybody got the Linksys QuickVPN Client software to work with an RV082, please let me know how?
  16. DocLarge

    DocLarge Super Moderator Staff Member Member

    Come ye of little faith (or persistence) :)

    I bestow upon you commentary from a user from the previous link posted by moi (please see below):

    Connected Client

    Joined: May 18, 2005
    Posts: 21
    Location: Sweden

    Status: Offline
    Posted: Sat May 21, 2005 12:36 pm Post subject:


    Hi Doc,

    Thanks to your excellent guide and work I have been able to connect with QuickVPN to the RV082 at the office. Without this guide I would still have been stumbling in the dark.
    So the settings on the router are also applicable for the RV082.
    Connection is stable for hours and I have been able to map drives and ping internal computers.

    Hey, I'm not one to say anything, but, ummm... maybe Perak has one of those special RV082's (hell if I know...). Again, all I can do is throw out a baseline. By all means, if you find another solution, please share :)

    If you're having trouble, I'd say shoot Perak a PM (this is just a suggestion on my part, of course).

  17. xfag

    xfag Network Guru Member

    ¨Hi Doc,

    Thanks to your excellent guide and work I have been able to connect with QuickVPN to the RV082 at the office. Without this guide I would still have been stumbling in the dark.
    So the settings on the router are also applicable for the RV082.¨

  18. DocLarge

    DocLarge Super Moderator Staff Member Member


    good god, man....stop hitting yourself.

    For the sake of posterity (and the conservation of keystrokes), here's a view of another person (thumbtack1349) who's now able to make quickvpn work with the RV082:

    I know what this is... All other RV082 owners have banded together against you to keep you in the dark to force you to think out of the box or higher Linksys tech support handle this (I think it might be a conspiracy) :rofl:

    Seriously, (again) PM RV082 users and see what they're doing to get quickvpn on track...
  19. johnvpn

    johnvpn Network Guru Member

    From another frustrated [rv042] owner:

    I can get quicklink to connect to the rv042 (had to disable XP's firewall to get past verifying network)

    But now the only IP I can see is the LAN IP of the rv042 itself. What I really want is to access the other hosts on the LAN subnet via http or ssh. Using IP addresses would be ok to start with. This seems to be a common problem for which I have found no solution.

    does not bode well for my chances as a nw noob.

    my config:
    <quickvnp/xp w dynamic IP> --- adsl --- internet--- adsl --- <fixed ip:rv042:LAN IP>
  20. johnvpn

    johnvpn Network Guru Member

    I've seen the LAN!

    turns out the LAN cannot see me...

    quickvpn connects ok , can access the RV042 LAN IP but apparently nothing else... seems to be a common problem, wonder if the same situation happens on RV082 and other WRV boxes.

    Have done a bit more sniffing around and found out the following.
    Pings from the remote quickvpn client are being sent out from the RV LAN port - with the source IP of the remote client. They do reach the target LAN host which tries to reply back to the remote client's IP via the LAN's default gw. In my case the RV is not the default gw, my LAN has its own internet gw.

    If I do a static route on the targeted LAN host specifying the RV LAN IP as the gateway, then packets will get back to the remote quickvpn client.

    If you have a packet sniffer on your LAN you could check if the same situation occurs for you.

    Now to think of a solution...
  21. morpheme

    morpheme Network Guru Member

    One suggestion

    This is a common problem...

    Can be solved with RIP, the RV082 will broadcast the route to its VPN connected hosts, and your default gateway will pick this up and forward packets on to the RV082.

    The other option is to set up a static route on the main internet gateway, which forwards VPN'd packets onto the RV082

    You shouldn't ever need to add static routes to the targetted LAN host.


  22. DocLarge

    DocLarge Super Moderator Staff Member Member

    I forgot to ask, do you have a user account created on the server you're trying to access?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice