Got Wireless network, no internet Can you help

Discussion in 'Cisco/Linksys Wireless Routers' started by GreenHornut, Sep 9, 2005.

  1. GreenHornut

    GreenHornut Network Guru Member

    I am looking for some help and possibly a point in the right direction. I have installed two other WRT54G’s in home settings and thought I knew my way around the box pretty good. I was trying to install a new WRT54G V3.0 in a apartment building with free high speed internet. The wireless network went up just fine and I soon had 4 computers talking to the WRT with a solid signal. But when I plugged in the internet cable the internet light lit up but I was unable to access the internet on any of the computers. The PC's all came from other places which did have linksys wireless products and worked fine. When I plug the cat5 directly into a NIC on any of the PC’s they are able to access the internet just fine. I talked to a fine foreign gentleman with poor English skills at Linksys support who ran me through all the rigmarole of “Is your power on? etc.†and finally told me that I was getting a private IP address and that the WRT can not handle it. I find it hard to believe since with netstumbler I see 6 other wireless networks, two which have not even changed the SSID from linksys. This is a large apartment complex and I am sure the networks are on the same floor. My DNS server is coming back with an address of 10.0.0.X which I know is a private range. I upgraded to the most current linksys firmware and then to HyperWRT but no joy. Spent at least 6 hours messing with the thing changing every setting I could in the box and still no luck. Any idea where to look next. All the apartment manager said is that the internet is working and they have no responsibility after that and he sees a lot of blue boxes in the apartments.
  2. 4Access

    4Access Network Guru Member

    When you connect a PC directly to the internet feed what IP adddress does it get? If it's getting an address in the 192.168.1.X range you'll need to change the LAN IP address of the WRT to or something similar.

    Good luck!
  3. GreenHornut

    GreenHornut Network Guru Member

    Thanks for the response. When I plug directly into the connection my network card has the address of or I would suspect that DHCP is assigning the address from a router in the building.
  4. 4Access

    4Access Network Guru Member

    The WRT shouldn't have any problems with that network... You made sure to configure the WRT to lease a DHCP address for the WAN port right? What does the Status page report when you connect the the WRT to the network?

    When connecting a PC directly to the network you aren't give a splash page that you have to enter a username and password on or agree to a terms of use agreement before surfing the web do you?
  5. GreenHornut

    GreenHornut Network Guru Member

    There is no network login or any password or username. Just plug it in and blast off. The status page says I have internet. I have Automatic Configuration DHCP and have a IP address and subnet mask. The default gateway is which is the same as when I use a direct connection. I only have one DNS address. All other times I have hooked up a WRT I had two but I figured that was just this network. Been working on this for the past couple of days, change a setting, boot the box, boot the computer. All sorts of combinations.
  6. jaysun

    jaysun Network Guru Member

    you should be able to connect your incoming line into one of the 4 LAN ports on the WRT, disable DHCP, change it from gateway mode into router mode, and it should work. that way, the apartment's router can assign each computer an address via DHCP, unless it limits you to one IP address. If you have to give the router a gateway address, connect one of your PCs directly to the incoming line and then in a command prompt type in "ipconfig /all" and write down the gateway address. Your DNS server should be the same address, thats why it only shows you one, it just goes from there out to the main router's DNS servers. I would guess that the reason it isnt working for you is that your DHCP server is conflicting with the apartments server. Let me know how that works out and good luck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice