Guide for Nocatplash setup

Discussion in 'DD-WRT Firmware' started by hchady, Sep 19, 2005.

  1. hchady

    hchady Network Guru Member

    This procedure works well with dd-wrt beta (15-09-05) on a wrt54g v2 unit

    1- activate jffs2, and clean jffs2 partition (router may not reponding, try to unplug it, then plug it again)
    2- create a splash file named splash.htm (or .html). many example can be found on the web for the splash page, my splash page is located at, feel free to copy the html code and personalize it.
    3- store your splash page on the router :
    an easy way to store it, is to put it in a location in the internet (like mine) and use wget command to download it to router

    first, log to your router by telnet (user : root, and then pasword)
    then type : mkdir /jffs/nocat, on some router model (v2 for example) you cannot create a new directory, so type the following command
    mkdir /jffs
    cd /jffs
    now you must be on /jffs directory (# /jffs), type
    wget http://yoursite/splash.htm (your site is the location of your splash page on the internet)
    if your page contains a pictures, you must download them all to your router (login buttom for example)
    once your file is on your router, go to nocat configuration and choose the directory of your downloaded files (/jffs in this case and not /jffs/nocat). keep splashURL empty.
    save your settings and it should works 30seconds after a reboot
    if not, telnet the router and activate it manually by typing : splashd
  2. bryanng

    bryanng Network Guru Member

    i have some doubts over your instructions:-

    1) when is the task of enabling nocatsplash feature take place?

    2) for v23 beta, i think after enabling jffs2, jffs folder shd have been created.

    pls advise, thx.

  3. hchady

    hchady Network Guru Member

    you can enable jffs before enabling nocat
  4. bryanng

    bryanng Network Guru Member

    i think having some problem for the firmware on my v3.1 wrt54g

    i manually run nocat by executing splashd and guess what

    it returned with **Error** Can't open /etc/nocat.conf No such file or > directory

    i m truly clueless now....i did numbers of reflash but still not working.....pretty easy in installation briefing but still got errors....wonder y? really not stable for having nocatsplash on v3.1?
  5. hchady

    hchady Network Guru Member

    i have the same problem also, reboot your router, wait 30 second and if it dosen't start automaticly, start it by telnet. splashd may not work from the first time, wait another 30sec
  6. BrainSlayer

    BrainSlayer Network Guru Member

    if you start it manually you have to give the configuration file manually too. it should be /tmp/nocat/nocat.conf (hopefully)
  7. jagboy

    jagboy Network Guru Member

    right now in my jffs i only have 60k is hter any way you can compress dd-wrt any further. please this is really needed!
  8. BrainSlayer

    BrainSlayer Network Guru Member

    sometimes i have to be a wizard to do this, but yes i always think about ways of downsizing. currently dd-wrt uses the best compressions methods available (lzma).
  9. bryanng

    bryanng Network Guru Member

    hchady, i did many reboot and 30 sec. waiting but still fruitless for this

    brainslayer, i was expecting auto start for nocat and not manual, when i enable nocat at first trial, it was empty content in nocat.conf ...may i know any sites can provide the content of configuration for nocat.conf? thx.
  10. hchady

    hchady Network Guru Member

    did you download correctly your splash file to your router ?
    in nocat settings document root is correct ?

    telnet your router and type : top and see if splashd process is running
  11. bryanng

    bryanng Network Guru Member

    hchady, i created the splash file by myself,
    i did use wget function in using wds to another AP which connected to internet, it did able to get but failed to work as well

    i defaulted factory settings again and again, enable jffs and activate nocatsplash, the top didn't show splashd in auto running what do u think by now?
  12. BrainSlayer

    BrainSlayer Network Guru Member

    it is running with a 15 second delay. additionally you can look into /tmp/services.out which is a logfile of splashd
  13. bryanng

    bryanng Network Guru Member

    brainslayer, could this b something wrong with the firmware or the machine itself?

    i typed TOP and viewed processes for more than 5 minutes, i didn't see a process named "splashd" in the list

    in the /tmp folder, there's only
    - action, cron.d, crontab, dnsmasq.conf, etc, hosts, resolv.conf, resolv.dnsmasq, root, udhcpc, udhcpc.expires, udhcpd.conf, udhcpd.leases, udhcpd.statics, var

    i never seen services.out as what u mentioned recently

    i m very sure that i flash the firmware with v23 beta for wrt54g....what do u think i left out o mistake i made since flashing the firmware, pls advise. Thanks
  14. BrainSlayer

    BrainSlayer Network Guru Member

    then nocat isnt enabled in the webgui. i know no other reason. if nocat is enabled in the interface splashd should start, also if it brings errors or something like that.
  15. hchady

    hchady Network Guru Member

    enable it by typing splashd in the command prompt.
    it's a bug with nocat, it happened many time to me, generally the first time i activate nocat, and sometime when i unplug the router
  16. bryanng

    bryanng Network Guru Member

    useless in doing so as i did mention that it returns statement -> **Error** Can't open /etc/nocat.conf No such file or > directory
    everytime i type splashd, brainslayer shd b confirmed that it shd b a bug despite of nocat has been activated in the webgui and not running in real process i guess.
  17. king_tuk

    king_tuk Network Guru Member

    What if I just want people to goto a website when they first connect? Do I have to create a splash page?
  18. rally1

    rally1 Network Guru Member

    "if not, telnet the router and activate it manually by typing : splashd"

    What is a "segmentation fault" because that's what I get when I type that.

    I have tried it on all 3 of my v3 routers, and it wont work, I must be doing something wrong.

    It's enabled in the gui, firmware v23 latest.

    "top" doesn't show it running.

    Would love to get it working.
  19. itsmeohmy

    itsmeohmy Network Guru Member

    7z for teh win!

    Method Description
    LZMA Improved and optimized version of LZ77 algorithm
    PPMD Dmitry Shkarin's PPMdH with small changes
    BCJ Converter for 32-bit x86 executables
    BCJ2 Converter for 32-bit x86 executables
    BZip2 Standard BWT algorithm
    Deflate Standard LZ77-based algorithm
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice