Has anyone tried the new WAG54G firmware??

Discussion in 'Other Linksys Equipment' started by saphuis, Jul 6, 2004.

  1. saphuis

    saphuis Network Guru Member

    Any experience with this new 1.02.3 version??

    What are the differences?
    Is is stable??
    Is it the release the last one should have been (1.02.2) but without all the problems?
  2. Toxic

    Toxic Administrator Staff Member

  3. md3v

    md3v Network Guru Member


    I just bought a WAG54G today and immediatley set about getting the latest firmware installed.

    Fixes I noted off the bat...

    Firmware Version: 1.02.3
    -Adds WDS
    -Adds Backup & Restore Feature
    -Adds Remote Upgrade
    -Mod to Internet Access menu

    I'm extremely dissapointed with the instability of the wireless component. My Intel Centrino equipt notebook dis-connects/reconnects and loses signal every ~5 minutes. It DID NOT do this with my WAP54G or WRT54G. I think i'll disable the wireless component in this WAG54G and piggy back the WAP54G into it.. since they stack so nice.

  4. Toxic

    Toxic Administrator Staff Member

    It is amazing that with linksys having an excellent WRT54G and WAP54G that they bring out a 2nd rate ADSL Modem/router.

    I suppose if the WAG54G was sold in the US the problems would be fixed overnight.

    I dont know who handles the firmware for this device but it would seem someone doesn't have their facts right.
  5. md3v

    md3v Network Guru Member

    Dissapointed .. WAG54G


    I am EXTREMELY dissapointed with this heap of junk. I would have never imagined Cisco/Linksys putting out such an unstable, unreliable unit. I am thoroughly disgusted.


    - Wifi link loses singal every ~5 minutes
    - ADSL modem drops link every ~10 minutes
    - HTTP Interface Locks up
    - Firmware Releases (up to WAG54G_AnnexA_ETSI_v1.02.3_02_code.bin) just make the unit more unstable.
    - Linksys Tech Support does not respond.

    I also own a WAP11, WAP54G, WRT54G - none of which have any of these sorts of issues.

    I'll return the unit promptly tomorrow... spend my money somewhere else.

    Bad show Linksys, bad show.

  6. md3v

    md3v Network Guru Member

    What next?

    Well, I'm not sure what to replace the WAG54G with. What ADSL modems are recommended? I'll just cross-over piggy-back it with my WRT54G, which is stable+++
  7. Toxic

    Toxic Administrator Staff Member

    if you look in most forums there are problems with ALL makes of devices these days.
  8. Toxic

    Toxic Administrator Staff Member

    Re: What next?

    if your just looking for a bog standard reilable adsl modem try the DLINK DSL-300T (Ethernet one NOT the USB one)
  9. unluckyluke

    unluckyluke Network Guru Member

    I tried 1.02.1 and 1.02.3, they have the same problem: adsl doesn't work. I'm now running 1.01.7, everything works ok. The upgrade to the 1.02.1/3 is ok, but adsl doesn't work. I have a pppoe connection, the router sincronizes the signal, but it doesn't make a connection. It gives this error: "Cannot connect to pppoe server" on administration page. I tried with a wrong password just for checking, it gives the same error. If i downgrade back to 1.01.7 adsl starts working again.

    Does anyone else have this problem?
  10. rjb02

    rjb02 Network Guru Member

    WAG54G firmware version 1.02.3

    Hi Guys,
    I'm running version 1.02.3 and am connecting to an Australian service provider with PPPoE no problem. Have also had no problems with the wireless side - am using a Linksys WPC54G wireless card and running WPA-PSK. Left a ping test running overnight and when checked in the morning had only dropped a handful of packets (less than 1%).

    Have read elsewhere that a hard reset back to factory defaults can be helpful when having problems moving from version 1.01.7 to the 1.02.x releases - have you given that a try yet? I did this as soon as I changed firmware version, and as mentioned above, no problems so far.
  11. corf

    corf Network Guru Member

    I can echo the post above.

    I have a wag54g that has run 1.01.06, 1.02.01 and is currently running 1.02.03 without issue.

    I have one desktop wired, and 2 laptops wirelessly, using mac filtering and 128bit wep. The desktop is static and the laptops dynamic ip. The upnp works fine for messenger and I can VPN into work but I am not sure what protocol that uses.

    I have transferred several gb across the network wireless and not had any problems.

    This is using PPPoA in the uk with pipex, i am not sure but i might get a lower signal strength with the latest firmware than previously.
  12. yonnage

    yonnage Network Guru Member

    Re: What next?

    The Dlink DSL300T has issues with just about every router I have seen, unless its a Dlink router
  13. yonnage

    yonnage Network Guru Member

    1.02.3 firmware no problems

    I've been running the 1.02.3 firmware for a week, I got it before the official release from Linksys. I have had no problems with it. everything works fine.

    Mind you, since i got the unit, the only problem I have ever had was with PPTP passthrough, hence the 1.02.3 firmware.

    I think its a great unit, just a shame that when you call the UK support number you speak to someone in Manilla, who doesnt know what a router does, or how to configure it
  14. unluckyluke

    unluckyluke Network Guru Member

    I contacted the Portuguese linksys support and they told me that they were awere of the problem and that it should be corrected in a future firmware version.
  15. md3v

    md3v Network Guru Member


    Ok, Linksys (via Ingram) gave me a new unit.

    Wireless is working fine now.

    The unit came with Firmware Version: 1.01.6.

    I'm not going to touch the firmware until I hear that there is a 100% working, non-buggy release. Grrr.

    Taps foot.
  16. md3v

    md3v Network Guru Member

    Firmware Version: 1.01.6.

    Does anyone know where the 1.01.6 can be downloaded? Its not listed anywhere on the Linksys FTP.
  17. corf

    corf Network Guru Member

    it is the version that mine came installed with and I havn't seen a download for it.
  18. md3v

    md3v Network Guru Member


    No one seems to know where to get it...

    BUT its stable++ compared to the newer firmware's.
  19. md3v

    md3v Network Guru Member


    I've spoken to ~6 different tech's in the last couple days and apparently the 1.01.6 is the most stable of the current builds BUT port forwarding etc. does not work correctly.

    Does anyone have port-forwarding setup through their WAG54G?

    Basically, I have NAT+Firewall enabled, I add a port forward of exterior 80 to interior 80 but it doesn't work... Based on the above, I suspect its a firmware issue.

    Any advise would be appreciated.
  20. yonnage

    yonnage Network Guru Member

    port forwarding

    I know what i'm gonna say sounds lame, but i use port forwarding i forward ranges 1025 ~ 8079 and 8081 ~65535. I use that many apps that I never know which port they use so forward the lot. Seems to work fine in 1.02.3

    Few questions what is this new wireless button on the firmware wda??? What is it what does it do? How can I use it? Do I need to use it? :?:

    Has anyone had issues with gnomemeeting and the wag? I find that I am having the same issues as with PPTP pass thorugh, in that I have to disable the firewall for it to work. This issue is apparent in fiirmwares 1.01.7, 1.01.9, 1.02.1, 1.02.2, 1.02.3. I havent tried any other firmwares.

    Linksys did say to me try the 1.01.6 firmware, and then said I had to speak to the UK technicians as they can email it out. Typical response from the outsourced helpline. I think I actually know more about Linksys operations than what they do. Anyway cant bitch about it, at least they *try* :roll:
  21. md3v

    md3v Network Guru Member


    If anyone on the forum can get a hold of 1.01.6, please PM me.

  22. aarghj

    aarghj Network Guru Member

    Re: 1.01.6

    i would also like to try that one out, it possible...

    md3v: you can use the port range forwarding as a workaround for the bug in the single port forwarding.

    say you want to forward port 80 - just put 80 on both the "start" and "end" fields in the port range forwarding configuration page. the only inconvenient is that you cannot forward to a different internal port... :(
  23. md3v

    md3v Network Guru Member

    Doesn't Work


    That 'fix' doesn't work in Firmware Version: 1.01.6.

    I setup a start=80, end=80 forwarding to an internal host running a web server but it doesn't work. I am leaving the firewall and NAT enabled.

    Any other ideas?
  24. aarghj

    aarghj Network Guru Member

    Re: Doesn't Work

    i've read in another forum that the single port forwarding only seems to work if the external and internal ports are different...

    you might want to try configuring your server to use a different port (8080, for example) and then configuring the external port to "80" and the internal to "8080".

    i wish linksys released yet another firmware upgrade and that they finally got it right...
  25. md3v

    md3v Network Guru Member


    Which forum did you read that on?

    Interesting stuff...

    The other possibility it/was that my ISP was filtering external port connections upstream but I ruled this out last night with a Dlink router.

  26. aarghj

    aarghj Network Guru Member

  27. yonnage

    yonnage Network Guru Member

    Re: 1.01.6

    I may still have it at work. Linksys uk sent me it
  28. md3v

    md3v Network Guru Member


    Any chance you can upload it somewhere?

  29. robinchee

    robinchee Network Guru Member

    Re: Firmware Version: 1.01.6.

    I wrote to Linksys .. its here


    I've tried 1.01.6, 1.01.7 and the latest 1.02.7. All are working with no problem so far. But then I only had my WAG54G for 3 days.

  30. Wild_Weasel

    Wild_Weasel Network Guru Member

    I've been running with 1.02.7 for about 3 weeks, very stable on both wired and wireless connections.
  31. shaamone

    shaamone Network Guru Member

    I've sent a copy of this to my gmail acct which I'll keep in-case it ever goes missing off the linksys ftp server. PM me if anyone needs a copy :)
  32. Fieldmarshall

    Fieldmarshall Network Guru Member

    3 weeks without a reset?

    I've tried out both the 1.2.5 and 1.2.7, but both sometimes lock-out the wireless component.

    The wireless firmware is (Status->Wireless) for the 1.2.7, but I'm not sure what it is for the 1.2.5 firmware (nevertheless I thought it was the same, but again, I'm not sure).

    So till now (I own the device for 2 days now and tried 3 firmware versions) 1.2.7 and 1.2.5 satisfy me, apart from the fact they sometimes locked out the Wireless connection and 1.2.5 sometimes disconnects me from MSN messenger... (although my correspondents notice this and I don't) The latest firmware on the product page isn't sufficient for my needs as I have also a WAP repeating the signal, so I need a firmware supporting WDS.

    To check if the wireless link is still active I could launch a continous ping to the WAP, and send some message to the router if the pings time, but does the router support some command to reboot it remotely?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice