Have I bricked my WRT54GS?

Discussion in 'DD-WRT Firmware' started by lencuff, Feb 6, 2007.

  1. lencuff

    lencuff LI Guru Member

    I have successfully upgraded 3 of these routers to DD-WRT but trying a fourth and I have major problems! I did the firmware upgrade step 1 to load the
    vxworks_prep_gs_v03 and all appeared fine. Powered cycled as instructed, router is now back on, PC connected , power light flashing(?). Open IE6 and
    go to and get the correct Management Mode Firmware Upgrade page. Navigate to the vxkillmac.bin file created with vximgtoolgui to include the correct MAC but when I hit Apply, after a couple of seconds I get the Message Upgrade Fail. Tried it a few times and also created a new bin file but still the same. Any ideas please? Obviously the router is functioning or I wouldn't get that page at all.

  2. lencuff

    lencuff LI Guru Member

    Quick update, while in the Management Mode Firmware Upgrade page I selected the vxworks prep file and I get Upgrade Success so obviously it doesn't like the vxkiller file??
  3. lencuff

    lencuff LI Guru Member

    At this point could I flash back to the Linksys firmware and start again?
  4. lencuff

    lencuff LI Guru Member

    As there are no replies yet (?) I bit the bullet and flashed it back to the linksys firmware. I now have the original Linksys firmware working again so no bricked router but I'd still like to have some advice on what to do to get success. I followed Scorpiontek's instructions to the letter and it's worked for the last upgrades so why not this one?
  5. Messerchmidt

    Messerchmidt LI Guru Member

    i did that too, managed to save it last night

    set your ip to

    subnet mask to, and gateway to

    load the killer file with tftp (no password) to it, let it sit for 5-10 mins

    then laod the mac address file you made, then the firmware

    should work - let it sit.

    if not, play around with it. above is what i did. you may have to load the killer/prep or prep/killer, then the mac addy file, then the firmware, etc

    you will get it to go eventually. remember to let it sit for awhile after flashing for it to reboot itself.
  6. lencuff

    lencuff LI Guru Member

    Thanks for the help. I managed to sort it myself in the end. I failed to change the radio button when creating the killer from WRT54G to GS !! All working fine now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice