Have PPPOE/DNS problem, need older firmware I think

Discussion in 'Other Firmware Projects' started by Elite_Master, Sep 6, 2004.

  1. Elite_Master

    Elite_Master Network Guru Member

    Ived got a WRT54G with SNET DSL and Win xp. I updated the firmware a few weeks ago and started having problems. Some websites dont seem to ever want to load, I can always get to google, but a site like nytimes.com or a search within google groups comes up with an error page. Ive searched around this site and found that there is a DNS and PPPOE problem with the newer firmware. Ive tried setting mtu to 1492 instead of whatever it was but that didnt fix it. I think I need to go back to the old firmware, but I dont see it on the linksys site, can someone provide a link or give me a solution. What version of the frimware should I use? Thanks
  2. Esquire

    Esquire Mesquire Staff Member Member

    When the pages fail to load, does it take a long time to time out? Do they behave as if they are try to load but behave as if the servers are not responding? Or does the error page appear instantly?

    Have you tried setting your client's TCP/IP to the matching/same MTU value?

    The problem could be due to a mismatch MTU value between router and client causing severe packet loss. I experienced this problem a few years ago when I was learning to set up my home network and connect to broadband. Once the clients and router were using the same MTU, everything was fine.

    BroadbandReports.com has a tool called DrTCP which helps you set your MTU value for your network card/adapter and other settings on your client. Give it a try.

    Good luck.
  3. Elite_Master

    Elite_Master Network Guru Member

    Yes my computer and linksys are both set to MTU value 1492. When the error occurs it does try to load for a few seconds then the "The page cannot be displayed" error page shows up. There is a thread about this somewhere on this site, its supposed to be a pppoe bug in the firmware and I think the solution is to go back to older firmware, but what I need is to find the older firmware, linksys seems to only have the newest version available for download.
  4. Elite_Master

    Elite_Master Network Guru Member

    actually they are both set to mtu 1490... I use dr tcpip.
  5. Esquire

    Esquire Mesquire Staff Member Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice