Have problem using Qos with my Xbox 360

Discussion in 'Tomato Firmware' started by hueyhy, Nov 29, 2010.

  1. hueyhy

    hueyhy Networkin' Nut Member

    I recently purchased a Asus WL520GU router, and flashed tomato firmware (teddy bear) into it.
    I set up Qos settings following this thread:

    It worked well for my computers. I have two computers, one is a HTPC. with the HTPC downloading using uTorrent and emule, the speed on the other computer is still good, and when I test on speedtest.net, the ping and bandwidth are both good.

    However, when I try to use my xbox 360, it is really laggy. it takes almost 15 seconds just to sign in. before using Qos, it signs in in less than one or two seconds.

    I tried to set the DMZ to the xbox IP(I set it a static one), and port forward 88 and 3074 to that IP address.
    I set Qos rule that all ports from xbox Mac address is set "high" in qos classification.

    But nothing works, it is still very laggy.
    I don't know if there's anything wrong with it.

    Here's my settings:
  2. Azuse

    Azuse LI Guru Member

    There should be no ports in you xbox rule, just udp traffic.
  3. hueyhy

    hueyhy Networkin' Nut Member

    thank you
    How do I set the rule? just choose UDP, and "any port"?
    or UDP, then src and dst port 1-65535 ?
    or, they are the same?
  4. hueyhy

    hueyhy Networkin' Nut Member

    Now I think maybe I solved the problem.
    I just deleted the MAC rule.
    only set the rules for TCP/UDP ports 3074 and 88, set them as high
    no MAC or IP rules. then it works. I don't know why. it seems strange.
  5. Azuse

    Azuse LI Guru Member

    Just all udp traffic from it's ip/mac.

    The gfwl port chages.
  6. hueyhy

    hueyhy Networkin' Nut Member

    I did that. I choose IP, and UDP ports, but still lags. and even worse, I cannot join game session in xbox live games, like in super street figher IV. while I can log into xbox live.

    I set DMZ also ,but still doesn't work.
  7. kardzzz

    kardzzz Addicted to LI Member

    i'm on Victeks v1.25.8515 .2RAF ND, so not sure if this works on teddybears.

    I had the same problem with games lagging and exiting xbox live sessions, hosting was next to impossible.
    The fix was:
    Port Forwarding > UPnP / NAT-PMP >
    - Enable UPnP {check}
    - Enable NAT-PMP {uncheck}

    For me, it seems NAT-PMP and XBOX live does not like each other.
  8. arlynrice

    arlynrice Guest

    I also found that {unchecking} the NAT-PMP fixed any lag or connection problems between the WRT54G (with tomato 1.27) and my xbox 360 slim.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice