having a problem flashing from dd-wrt to tomato on wrt-54g v3

Discussion in 'Tomato Firmware' started by robr, Feb 26, 2009.

  1. robr

    robr Network Guru Member

    I have a WRT-54G v3 currently running

    Firmware: DD-WRT v24 RC-5 (11/22/07) std

    I grabbed the http password as the docs said to do, then attempted to upgrade the firmware using this file:

    12/14/2008 06:11 AM 2,802,688 WRT54G_WRT54GL.bin

    The little progress bar flies to complete, I lose network connectivity for a moment, then reconnect to and I'm still running DD-WRT. I've even unplugged the router and it's still running DD-WRT. No errors were seen during the flash.

    Any ideas? Thanks!
  2. fyellin

    fyellin LI Guru Member

    Possibly stupid question. You're positive you're still running DD-WRT? You've flushed your browser cache to make sure the browser isn't feeding you an old copy of the page?

    Otherwise, I agree. This sounds really weird.

    Your next step may need to be copying the .bin file onto the router and running mtd-write directly. Maybe there will be some error message that's not making it back to the user.
  3. bogderpirat

    bogderpirat Network Guru Member

    i've had the exact same issue a day ago when i tried out dd-wrt's vdsl capabilities. i think it's a dd-wrt issue.
    try resetting the dd-wrt NVRAM contents, then re-flash, unplug and have it reboot. that's how i got back to my beloved vegetable.
  4. Low-WRT

    Low-WRT LI Guru Member

    In my experience, it's MUCH easier to restore to defaults before flashing a different firmware.

    Hold down reset for 30 sec. (root/admin)
    Flash tomato (root/admin)
  5. robr

    robr Network Guru Member

    I was trying to avoid restoring to defaults, i have too many settings changes to make. I run WDS with several routers connected, all my NAT stuff, I have no idea what my verizon PPPoE password is, though of course I could get it reset, the devices on the network all get assigned new IP addresses via DHCP, etc. I was just trying to make sure I wasn't missing something. I'll play with it a bit more I guess and perhaps try upgrading to the latest DD-WRT first.
  6. robr

    robr Network Guru Member

    bingo, it worked fine in IE. It did not work with firefox for some reason. FF also failed upgrading to a newer version of DD-WRT, so something's up with my FF apparently.
  7. bogderpirat

    bogderpirat Network Guru Member

    to get your verizon password from the box, just ssh to it and type nvram show | grep passwd, it should be among those results.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice