Having problem connection using WPA

Discussion in 'Cisco/Linksys Wireless Routers' started by phoenixa, Mar 7, 2006.

  1. phoenixa

    phoenixa Network Guru Member


    I can connect to my WRT54G when I use WEP encryption but when I want to use WPA encryption I can’t establish a connection with the WRT54G. The wireless adaptor sees the wireless network but can't connect! I'm using Windows XP SP2 with an Acer IPN2220 Wireless LAN card. The wireless adaptor driver is the most recent driver available and the Microsoft patch for supporting WPA network connection is not necessary to install since it is included in SP2. Does any one have an idea what I should do? Is there any update to install?

  2. -mb-

    -mb- Network Guru Member

    Have you verified your pass phrases?
  3. howardp6

    howardp6 Network Guru Member

  4. phoenixa

    phoenixa Network Guru Member


    I checked the phrases and retype them again to make sure it matches on the router and in the Wi-Fi network configuration but it didn’t help. I downloaded the Microsoft patch for SP2 and installed it but it didn’t help either. I can choose both encryption methods, AES and TKIP, on my wireless adaptor but not on my router because the firmware version that I have now does not support it. There is something weird though, when I activate WPA and TKIP on the router, after navigating to the page Status > Wireless on the router, I see that the encryption is Disabled! But Windows sees my network as a WPA secured network! I also enabled the broadcasting of SSID on the router but it didn’t help. I can only type the phrase in ASCII format on the router.

    I’m getting mad :( any idea?

    Thanks a lot everyone.
  5. howardp6

    howardp6 Network Guru Member

    Which firmware version do you have on your WRT54G? The latest has WPA2 Personal that is version 4.20.7 from the Linksys Support Site. Your Acer IPN2220 Wireless LAN card supports WPA2 if you can specify WPA AES/TKIP. Before flashing the router reset it to factory defaults, flash only from a wired connection to your computer and wait thirty seconds after you get a comfirmation of the update successful.
  6. phoenixa

    phoenixa Network Guru Member


    I updated the firmware of the router and configured it with WPA and for just a minute I could connect to it but soon I lost the connection! After that the wireless adaptor saw the network for a couple of times but sometimes it could not connect or sometimes it could not receive an IP address because the signal strength was not enough [I’m sitting at 0.5m from the router!]. After, I tried any possible configuration i.e. changing the channel, changing from TKIP to AES, enabling the SSID broadcasting, changing the Authentication Type from Auto to Shared key, changing the phrase etc. but the wireless adaptor still can't see the network. It’s strange! It seems the router is not sending any signal at all. I can’t detect my Wi-Fi network with Network Stumbler either! Do you have any idea?

    Thank you for your help!
  7. phoenixa

    phoenixa Network Guru Member


    When I set the Authentication type to Auto then the wireless adaptor sees the network and connects automatically but as soon as I change the Authenticatin type to Pre-Shared key then nor the adaptor neither Net Stumbler see the network!

    Any idea?
  8. Hondo314

    Hondo314 Guest

    WPA and Authentication on WRT54G w/ WPC54G


    I'm having the same problem. I can connect with WEP when Authentication Type is set to Shared Key, but not with WPA or WPA2, and I have all the Windows XP patches, latest drivers, and firmware from Linksys. I can only connect with WPA or WPA2 when Authentication Type is set to Auto. I know the encryption is working when set to Auto because when I change the passphrase on the router or on my adapter, I can't connect. It's probably something Linksys forgot about when they added WPA support, and the router still thinks that Shared Key Authentication is a WEP feature. Let me know if you discover anything.
  9. phoenixa

    phoenixa Network Guru Member


    I tried everything I could think of without any result. I tried different phrases [ASCII/Hex], changing from WPA to WPA2, trying to connect with another brand laptop with another wireless adaptor, but none of these helped. I'm sure now that it's my Linksys router that is causing the problem. I'm really disappointed :( the funny thing is that even Net Stumbler doesn't detect the router! Please let me know if you found a solution. I give up! :(

  10. 4EverGreen

    4EverGreen Network Guru Member

    Did you already consider the option to change your firmware to DD-WRT ? :thumb:
  11. phoenixa

    phoenixa Network Guru Member

    No I didn't because I don't know what that is! :( Could you please explain me what I should do? I appreciate your help.

  12. Thibor

    Thibor Super Moderator Staff Member Member

    when you set your "Authentication Type" to "Shared Key", that disabled WPA and enabled WEP only. Set it back to Auto
  13. Toxic

    Toxic Administrator Staff Member

    have you reset the router since the firmware upgrade?

    You will loose settings but this will default the router. press the reset button for 30 Seconds.

    then try setting up the router again.

    btw what version of WRT54G do you have?
  14. phoenixa

    phoenixa Network Guru Member

    I have WRT54G v2.2 with firmware version: v4.20.7.

    here is my configuration,
    Wireless network mode: G-only
    Wireless channel: 6 - 2.437Ghz
    SSID broadcast: disabled
    WPA algorithms: TKIP+AES
    Security mode: WPA2 Personal
    Authentication Type : Shared Key

    I reset the router and configured it again as I mentioned above but it didn't help. But, as soon as I change the Authentication Type: to Auto the wireless adaptor discovers the wireless network and connects to it. But with Authentication Type: set to Shared Key, nor the wireless adaptor neither Net Stumbler discovers the wireless router! :shock: Disabling or enabling the SSID broadcast doesn't change anything either. Do you have any idea why it is like this? Isn't it dangerous/risky to leave the Authentication Type: Auto? Why can't I connect while setting the Authentication Type: Shared Key? Have you ever encountered such problem? Is there any bug in the firmware version I have? Too many questions… I know but I’ve got mad... I’m really a big fan of Linksys and I hope I don’t have to buy another brand :(

    Thanks every one,

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice