HELP 1.18-> 1.19 upg fail on WRT54GL

Discussion in 'Tomato Firmware' started by help_1234, May 17, 2008.

  1. help_1234

    help_1234 Addicted to LI Member

    i got very similar problems like this guy had

    got MTD error while upgrading from 1.18 to 1.19 on my WRT54GL

    Web GUI doesnt work
    DHCP worked until i tried release/renew.
    ping works when i set static ip to and ping

    question is can i issue: tftp -i put WRT54G_WRT54GL.bin from the cmd prompt to load the firmware?
    or should i edit the wrt_install.bat to change the ip from to

    don't want to destroy it more than i have allready.

    Suggestions, help needed

    Edit: Solved!
    tftp -i put WRT54G_WRT54GL.bin worked and the router is up and running
  2. nvtweak

    nvtweak LI Guru Member

    Has the router been rebooted after upgrade failed?

    TFTP can only be used at boot time, which means you have to reboot the router which could brick it even worse (if you haven't already). Try telnetting into the router and flash it from there.

    If you've already rebooted the router and it is still responding to pings at boot time, then just tftp v1.19 to Make sure your computer has static IP in the same subnet as the router.

    After you get the router flashed and verify it works ok, go in the Admin -> Config section and erase the nvram (thorough). Then configure it as you please.

    Good luck!
  3. help_1234

    help_1234 Addicted to LI Member

    Thanks for the reply. i had allready rebooted the router after the failure so i tried to contact it with tftp.

    tftp -i put WRT54G_WRT54GL.bin worked!! i waited about 5min to be sure then i tried to contact the web GUI (SUCCESS!) and i erased nvram thouroughly.

    next time i upg my firmware is it wise to maybe restart the router before flashing to free up resources maybe?

    that "error writing to MTD device", what does MTD stand for?

    nevertheless im glad the router is working :)
  4. nvtweak

    nvtweak LI Guru Member

    Glad you got it fixed :)

    Yeah, I think rebooting before flash is normally a good idea. Or just use TFTP, which is apparently the safest way to flash a router.

    Memory Technology Device ?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice