Help! Brandnew wrt54GL 1.1 bricked

Discussion in 'Cisco/Linksys Wireless Routers' started by mchlor, Oct 22, 2006.

  1. mchlor

    mchlor Guest

    I tried to load alchemy final (Durrr). :(

    No ping, no nothing. Continual light blinkage. Tried shorting all the pins + power according to the debricking guide to no avail. Tried searching , no info on GL model.

    Tftt doesn't work. Linksys reset doesn't work.

    Anyone else wanna stab at it?

    2 day old wrt54GL for sale for cheap :( LOL.
  2. ursa_major

    ursa_major LI Guru Member

    Try this!

    I had the same problem. If you have the guts to try another method, radical, read further.

    The bad thing here is that you have to open the case. This will definitely void any warranty. The case just snaps off. It's made out of three separate pieces. Pull out the front. The PC board will slide out right away. Look for the flash chip. If you have problems in finding the chip just Google the names that you see on the chips. This way you will know exactly which one is it. GLs, as far as I know, have 2 chipsets used: one is an Intel and mine is an MX. Connect the router to your NIC. The NIC has to have a static IP, something like (not 0, 1 or 255). Open a DOS windows by typing into the RUN box CMD. Type PING -T There is no response from the router yet. Prepare another DOS window. Enter tftp -i PUT IMAGE.BIN (where IMAGE.BIN is the firmware file). Do not send yet the TFTP command. Get a magnifying glass (you will need it!) and find pins 15/16 for the Intel or pins 11/12 for the MX. Place a metal needle firmly between indicated pins. Take the power plug and connect it to the router while keeping the needle down. Give it 2 secs and then remove it. If everything is ok the ping on your screen will change to replies from the router. If you see this, send the TFTP command right away. The firmware would be loaded in just a couple of seconds. After this reset the router.

    Good luck!
  3. ursa_major

    ursa_major LI Guru Member

    Guess that everybody finds his own match...WRT54GL Bricked

    Definitely curiosity without care is dangerous! And it comes a moment of darkness, when just out of curiosity you want to experiment everything that your new toy can do.

    Just I downloaded a "free version" of something called FREEMAN (beware!!!). After successful download into the router, just the power light blinking steadily regardless of what I do. Waited 20mins, reset, long reset, combined reset, just plain vegetable...

    I already read everything that I could get my hands on, even my prior own successful procedure does not do anything. The only thing that I can do, with rigurous timing is to reflash the router. But, there is no result! Still sits and flashes at me...

    I am really tired of this, I exhausted all I could do. I am just fresh out of ideas...

    Who wants a brand new WRT54GL bricked?

    Any ideas would be greatly appreciated.
  4. PGalati

    PGalati Network Guru Member

    Give this a try, it worked for me.

    1 Obtain Linksys TFTP software downloads area. Maybe other TFTP software will work but have not tried.
    2 Obtain latest Linksys Firmware for said bricked router
    3 Assign your PC a static IP address in the 192.168.1.x range and plug your ethernet into any LAN port of Linksys
    4 Open TFTP software and load firmware binary file
    5 With Linksys OFF, start the upload of the Firmware
    6 After a couple seconds, plug in Linksys Router

    Hopefully, the Linksys will get caught by the TFTP software and begin loading the Linksys firmware into flash. You will know when the TFTP progress bar moves. If it does not work the first time, you may need to try again but power the router on sooner or later after pushing upload on the software.

    This may not work at all, but wanted to share since it worked for me.

    Good Luck.
  5. rickyschrieber

    rickyschrieber LI Guru Member

    Set static IP on PC 192.168.1.x/ (very important) !!
    Kill any internet tasks (browsers, aim, ms-messenger, etc)
    Flash with micro first using tftp then use GUI interface with final version!!!
    Linksys_TFTP IP=; no password; file=dd-wrt.v23_micro_generic.bin; try count to 255 (max allowed)
    Hold the reset button for 20 secs while power-on (defaults vnram)
    If TFTP doesn't say success power off/on router.
    If TFTP says success power off/on;
    Reset MAC address incrementing by 1 each time
    c:\> telnet (root/admin)
    > nvram set lan_hwaddr=00:14:BF:XX:XX:X1 <-- WAN MAC bottom of router
    > nvram set wan_hwaddr=00:14:BF:XX:XX:X2 <- LAN MAC (WAN MAC+1)
    > nvram set wl0_hwaddr=00:14:BF:XX:XX:X3 <- WLAN MAC (WAN MAC+2)
    > nvram commit
    > reboot
  6. brayl

    brayl LI Guru Member

    Just I downloaded a "free version" of something called FREEMAN (beware!!!). After successful download into the router, just the power light blinking steadily regardless of what I do. Waited 20mins, reset, long reset, combined reset, just plain vegetable...

    Thats exactly the same way I bricked a WRT54G V4. That free freeman software is bad.

    You'll need to erase the kernel part of the flash then tftp it with ddwrtmini. Here is how I debricked it. Debrick/index.htm
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice