Help! Can't connect to WRT54G!

Discussion in 'Networking Issues' started by rufiopan, Feb 24, 2007.

  1. rufiopan

    rufiopan LI Guru Member

    I've been experiencing this problem for the last few months off and on, and it's driving me insane. I have a Linksys WRT54G v4, and I'm absolutely unable to connect to it.

    All the connections to the router are fine, and connections from router to cable modem are fine as well. Connecting directly to the cable modem also works just fine. As soon as the router enters the equation, nada. My computer is unable to connect to the router, and ends up with the self-referencing 169.254.*.* IP address.

    In the past, I've tried re-flashing the firmware, but that has proven ineffective as the problem just comes back over time.

    The one clue that something is wrong is that the light for port 1 on the front is perpetually lit, whether a device is connected to that port or not. That port light just stays on, and I noticed this started happening when the problem first occurred.

    Any guesses as to what the problem might be? I am stumped and utterly frustrated as I thought Linksys was a quality brand. It's all the more frustrating since this is my 5th router in the last 6-7 years (I've tried them all... DLink, Belkin, Linksys, Netgear...)!

    Please help me! :)
  2. rufiopan

    rufiopan LI Guru Member

    I should also mention that the problem I've described only affects WIRED connections to the router. Wireless connections work just fine.
  3. Esquire

    Esquire Mesquire Staff Member Member

    What sort of TCP settings are you using on your Ethernet connection? (automatic/manual/static)
  4. rufiopan

    rufiopan LI Guru Member

    Which TCP settings? I'm not sure what you mean by that. I'm using the default configuration of the operating system. By the way, I've tried 3 different operating systems with the router (OSX, Windows XP, and Ubuntu Linux -- the last one is my current OS), and have experienced the problem with all three systems. I've also tried 3 different computers running different operating systems at different points in time (iMac, Dell XPS laptop, and a custom-built Athlon64 PC), and again, have had the issue with all 3.

    Is it safe to say the router is a goner? :(
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice