HELP! Connectivity issues with my WRT54GS v4 /w Thibor

Discussion in 'Cisco/Linksys Wireless Routers' started by kekelala, Dec 9, 2005.

  1. kekelala

    kekelala Network Guru Member

    I'm having the oddest issue and I'm unable to nail down exactly what is causing it. The router will hang and I will lose all upload/download speed and it'll drop to 0 for a second and sometimes as long as a few seconds and then it'll pick right up again like nothing ever happened. Never once have I had to hard reset the router after these crashes as it'll always immediately recover on its own. These drops occur at a random frequency of every 5-15ish minutes on the average, while sometimes it seems we can go half an hour or longer without a problem.

    I run a fair bit of Bittorrents and this can be seen clearly watching the Azureus window when it happens. The downloads will be cruising along at somewhere 50-150k down 10-20 up (which is not near my max up) and then it'll crash all the way down to 0d/0up and then slowly start to recover its speed. Though the crashing isn't limited just to just torrents. I'll be playing BF2 with another person on the same router, we'll both be in ventrillo in game and we'll get the same disconnects as we'll both get bumped quickly off ventrillo and the game server itself. These issues with internet gaming occur when no torrents are running on the network so it appears that this issue is not directly linked with torrents. Also, the router is using Static DHCP, for troubleshooting purposes I disabled it and went regular DHCP and still had these issues.

    I've got a new WRT54GS version 4 which I loaded (Firmware Version : v4.70.6 - HyperWRT 2.1b1 - Thibor) on to without a hitch (cleared the NVRAM and factory defaulted before and after). After I got the router and loaded up the firmware the router seemed to be operating fine for about 5-6 days fine without an disconnects (either during gaming or downloading) and then all the sudden the issues started popping up. One PC (mine) connects through a wired connection, and the other three PCs connect through wireless connection, and all four computers experience this same interuption in connectivity wireless or wired as it doesn't matter. All four PCs have been throughly scanned for virus/trojans/spyware and came up clean.

    At first thought my cable modem (a Dlink DCM-201) was the culprit because they are notorious for overheating. I didn't like the thing either way so I upgraded to the new DCM-202 model which has gotten stellar reviews everywhere I have looked, and I also flashed on the latest modem firmware that Dlink recommends you use if you're a comcast customer. I checked my SNR/signal power ect.. through comcast and though they are on the lower end of the spectrum comcast assured me that they're well within tolerances (33 SNR). Though the modem without a doubt improved my connection speed a bit I'm still getting these damned disconnects. Latest thing I've tried is setting that startup command that clears your dropped connections every 10 minutes as opposed to every 5 days, with no apparent change or improvement.

    So I'm at a loss, the router seems to me to be the culprit (though I haven't completely ruled out my cable modem provider just yet). But it seemed to be working fine for the first 5-6 days of its operation (with no disconnects) and then all the sudden without any major changes to the settings we're now getting these disconnects.

    Any help/suggestions/advice/solutions would be much appreciated.


    edit: found Azureus had a rather helpful logging utility with a nice graph which shows the severity of my connection instability. This graph represents about 30 minutes worth of logging to my best estimate.

    Everytime you see a sharp spike down in my download speed my upload speed is also going to zero as well though but the graph doesn't update quickly enough to display this drop in upload because it doesn't update fast enough. You can also see one of those more severe drops at the beginning of the log where the connection was completely out of order for about 15-20 seconds. None of these drops required me to reset the router. Any one of these drops would either drop me out of an internet game or lag me up quite a bit.
  2. danielhaden

    danielhaden Network Guru Member

    Maybe a memory cleaning?

    That would be a startup script of

    erase nvram; reboot

    then save it and press the reboot.
    Of course, you'll have to configure your router all over again as if it were new.

    One other possibility is that it might need a speed boost.
    Enter the following on the commands screen (one at a time on the command line).
    nvram set clkfreq=216
    nvram commit
  3. kekelala

    kekelala Network Guru Member

    Thanks for the suggestions daniel. I've already tried clearing the nvram with the command line on two seperate occasions without sucess.

    I'm curious to try overclocking the routers chip, but is that really all that safe with a V4 GS?

    Thanks again.

    edit: I went ahead and overclocked my router to 216 with no apparent change to my connection stability, and I'm beginning to think my ISP is the culprit as after a similar post on DSL reports a bunch of other Comcast users in my area are having the exact same problem. Though Comcast likes to play the blame game and point at your hardware but I have full confidence in my big beefy WRT54GS as it has yet to actually crash itself.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice