Help Firmware upgrading not taking

Discussion in 'Sveasoft Firmware' started by Anonymous, Jul 24, 2004.

  1. Anonymous

    Anonymous Guest

    Hello all,

    I'm new at this networking so if this questions has been asked before, please forgive me. I aplogize for this being so long.

    I have a WRT54g and I tried to do the satori 4.0 firmware update. I did download the proper version for my router which is a v1.0. I followed all the instruction from sveasoft to the letter. I got the message "failed upgrade" or something to the effect. Got the red diag light flashing and all. So then I tried to do a recover from failed upgrade attempt using sveasoft instuctions. Here is were I ran into problems:

    When it came time to ping the router it came up with the message no destenation or something. Basically could not ping the router. So I found out that if I changed the LAN settings to "static IP" and used this address: and subnet I could ping the router. However I had to do several pings at the same time activating the linksys firmware utilite to actually get the router to flash with the linksys firmware.

    Now everything is supposed to look right and operate the right way as if nothing ever happened. So I thought I would for good measure reflash the router with the same linksys firmware upgraded to make sure everything took. ( I also did a reset function several times) It didn't work so I had to do the whole above outline steps again. And now it won't take any firmware version unless it is the updated linksys and even that takes about 2 hours of fiddling to get it to work.

    What did I do wrong? Can I reflash with the same firmware? I hope you guys can help. I was looking foward to using the sveasoft firmware but as of right now it doesn't look good for the home team.

    Please help!
    Tankermax :?
  2. Toxic

    Toxic Administrator Staff Member

    What version of firmware (from linksys) did you have and now are upgraded. linksys did have a release version that once you upgraded you caould not go back but that was in the 1.30.9 or something like that.

    first of all download satori v4.0 again.

    for WRT54G =

    for WRT54GS =

    unzip the binary onto desktop.

    reset the router (press reset for 30 secs)

    logon to router again and reflash firmware. once it is updated do a hard reset again. give it ample time 30 secs (even after it says completed) to finish writing to flash ram.

    then you SHOULD have satori v4.0 loaded.
  3. Tankermax

    Tankermax Network Guru Member


    Thanks for the reply. The linksys had the orignal firware when it was shipped, router v1.0. I don't recall what the orignal firmware was. The router is currently on 2.02.7.

    I did try to reflash with satori but again it would fail to upgrade. I did download satori from this site and unzipped the firmware and again performed the correct steps as outlined in sveasoft instructions.

    I'm a little afraid to do it again since I tried again last night and it failed on me and it took me 2 hours trying to get the reflash done back to a linksys firmware. Any thoughts on what I should do?

    Can I also revert back to the linksys firmware if by some chance I did get a succsessful satori flash?

    Tankermax :?
  4. eric982

    eric982 Network Guru Member

    For sure you can go back to linksys original firmware after you flashed with sveasoft firmware. I have been switching between the linksys WRT54G, linksys WRT54GS, and sveasoft firmwares.

    BTW, when you said your router failed to update firmware, what error did you see and how did you flash your router?
  5. sounddrive

    sounddrive Network Guru Member

    I had the same plus after every change in the config I had to switch the router on/off and it works again.
  6. Tankermax

    Tankermax Network Guru Member

    I basically gave up on trying to flash the firmware. For some reason I can't flash it although I did everything by the book.

    The only way I can get the router to take the official firmware is to make an static IP address and a DNS address. Then I would ping the router for a response using the command function in ms-dos. After, it was finished I would then use the downloaded utility from linksys and flash the router.

    I even tried the power on and off cycle as well as the hard the reset. I haven't tried the latest upgrade from linksys because I heard that it cuts down on the wireless signal strength which is what I need the most hence the reason I wanted to upgrade to satori.

    Any more ideals that I might entertain?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice