Help: Forced to do hard reset after applying settings

Discussion in 'Tomato Firmware' started by funny909, Feb 18, 2014.

  1. funny909

    funny909 Reformed Router Member


    I have an ASUS RT-AC66U with AdvancedTomato 1.28.0000 MIPSR2-1.21.16 K26AC USB AIO-64K.

    My problem is that after applying settings (most of them, not all) I have to do a hard reset (using the power button to turn it off then on again).

    If not, the router is rebooting (lights blink on/off and I can see it starts the dhcp-server again (it serves ip's), but I can't access the web-interface or use ssh.

    After 95% of any changes I have to do this. Any changes to WAN PPTP or wireless settings, mac changes and so on.

    Is it supposed to be like this? Can I do anything to fix it?

    It's really frustrating to experiment with settings because I have to wait 1-2 mins for it to boot up again everytime.

    Thanks for your time!
  2. darkknight93

    darkknight93 Networkin' Nut Member

    Can you try to clear nvram and afterwards reboot, wait 5 minutes, reboot, apply just one setting e.g. DHCP scope and test whether this procedure kills your account?
  3. funny909

    funny909 Reformed Router Member

    I tried and it did not help. Well actually I did the DHCP thing, but I don't think that was the cause in the first place. I tried setting up PPTP; that went fine untill I tried to renew the ip, that's when it chrashed.

    EDIT: I suspected it was my stored config that was corrupted somehow, but not after the nvram-reset
  4. funny909

    funny909 Reformed Router Member

    Anything more I can do?
  5. fubdap

    fubdap LI Guru Member

    Go get a new copy of the same build from the website and re-flash. Do nvram erase and configure everything by hand. It is possible the copy you have is corrupted.
  6. funny909

    funny909 Reformed Router Member

    Thanks! I will try that:)
  7. funny909

    funny909 Reformed Router Member

    No change. Same thing happens. Still have to hard reset.
  8. koitsu

    koitsu Network Guru Member

    1a. Are you using Administration / Configuration / Backup Configuration and Restore Configuration?

    1b. If not: please provide your configuration adjustments -- yes, all of them. (You can "XXX" out things like passwords of course, but please do not "XXX" out MAC addresses or anything else; there has been some evidence in the past of syntax choices of the end user causing some problems in some features). Let me be clear: I don't want a binary file (ex. Backup Configuration; that'd contain passwords and other stuff anyway! Don't give that out!), I want a clear/concise write-up of every single configuration adjustment you make to the router from stock defaults ("thorough erase" of NVRAM). I can point you to another post of mine where I outline how I do this (I keep a .txt file around documenting them all).

    2. Are you using the Web Usage or IP Traffic features?

    3. Replace the router. It's very possible some portion of NVRAM flash block reallocation/remapping has failed and that the failure is transparent (i.e. no messages on console / in kernel log, although you haven't given any indication that you've looked there yet).
  9. funny909

    funny909 Reformed Router Member

    Thanks for your time!

    1a - Yes, and no. I usually do that after a firmware update, but as the post by fubdap stated I changed everything "manually" to no avail.

    1b - Ok, I will write it down and post it here asap.

    2 - I use the IP Traffic feature, but not Web Usage.

    3 - I have looked through the logs but there is nothing to identify the issue. I think the part of the log containing the error is not stored anyway cos the log is only saved to memory every hour.
  10. funny909

    funny909 Reformed Router Member

    Damn smileys=P

    I put everything in the text file for easier viewing

    Attached Files:

    Last edited: Feb 21, 2014
  11. koitsu

    koitsu Network Guru Member

    WARNING WARNING WARNING: I do not have familiarity with AdvancedTomato or AC-66U units. So take what I say below with a bit of caution.

    Things I've noticed:

    - Stop trying to use jumbo frames. Leave this off/default.
    - Try not adjusting anything relating to 5GHz. Stick with 2.4GHz with no other changes (just for testing)
    - Your Save History Location is incorrect; you're missing a / on the front of your path (/mnt not mnt)
    - Try disabling IP Traffic and Bandwidth Monitoring features
    - Completely cease with setting custom MAC addresses on your interfaces. Just stop this entirely. I wouldn't be surprised if this is somehow screwing up ARP on your local network and confusing all sorts of things. Those features really shouldn't be relied on, IMO (I've been advocating removing things like "Clone PC MAC" and etc. for years now; there is a brief period of time when the router reboots or certain settings change where the "Custom MAC" gets reverted to the stock factory default (especially when rebooting) -- just use the stock factory MACs)
    - I can't make heads or tails of your Wireless Settings, because all you've indicated is what the settings are at, not which you've changed *from stock defaults*. Thus I cannot speculate which of them might be causing you problems
    - If you are overclocking anything, stop doing it immediately. Again I can't tell because you aren't writing down the settings you change from stock defaults, you're just writing down every setting. That's not helpful for troubleshooting

    I would suggest trying something very very simple:

    - Reset the router to factory defaults (NVRAM thorough clear) and reboot it normally through the GUI
    - Wait until the router comes back up with stock defaults
    - Go into Basic / Network and change nothing. Just click Save
    - See if the problem happens
    - If it doesn't, adjust one setting, such as switching WAN type to PPTP and entering the information for that section only (NOT THE WIRELESS PART), click Save
    - See if the problem happens
    - Now move on to the wireless configuration part, etc..., click Save
    - See if the problem happens

    Rinse lather repeat in very very small increments until you figure out which adjustment or set of adjustments cause the problem. Yes this will probably take you an hour or more. There really isn't any other option; it's very possible your router is locking up or that this is a firmware (software) problem. I'm inclined to think software because you can power-cycle the unit and have it come up fine.
  12. funny909

    funny909 Reformed Router Member

    I appreciate the lengthy answer!

    First of all, I tried what you say about changing just a few settings from stock and go little by little. I only saved the PPTP settings before i tried to renew the ip and then the interface stopped responding. But i will try again, and ofc fix all the small errors.

    I am not overclocking, the option is not there (in the web-interface)
  13. funny909

    funny909 Reformed Router Member

    Hmm that didn't help. Main thing now is the restart part. With vanilla/stock-settings the router will not soft-reboot completely. It shuts down/starts up twice (i can see how the lights blink) and serves ips at the end of the cycle, but it's unavailable.

    ping: sendto: Host is down
    Request timeout for icmp_seq 80
    ping: sendto: Host is down
    Request timeout for icmp_seq 81

    But after i physically turn it off it starts up fine.
  14. funny909

    funny909 Reformed Router Member

    I loaded the newest firmware from asus: ASUS RT-AC66U Firmware version and there is no problem whatsoever during restart. The restart also seems faster. (I guess that is to be expected). So now what? :S

    EDIT: I tried "Firmware: DD-WRT v24-sp2 (02/07/14) kongac" as well. It would let me soft restart, but failed when i changed some settings.

    So this is definitely a firmware issue.
    Last edited: Feb 22, 2014
  15. funny909

    funny909 Reformed Router Member

    Anything more I can try?
  16. darkknight93

    darkknight93 Networkin' Nut Member

    seems that there's something wrong with nvram or accessing/writing to it. Can you contact your local dealer/seller and ask for an Exchange device?
  17. funny909

    funny909 Reformed Router Member

    Yes I did, they want me to send it to them so they can check the hardware. And they are saying that I have to pay for it if they don't find any errors. I will ofc reflash it to the stock firmware before sending it, but are ASUS accepting third-party firmware or is it by using it voiding the warranty? And it seemed like changing settings worked in the stock firmware. Maybe they'll just deny that there is something wrong? Just wanna be sure before sending it :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice